libbonobo-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. %define dbus_version 1.2.4
  2. %define dbus_glib_version 0.82
  3. %define libxml2_version 2.7.6
  4. %define orbit2_version 2.14.17
  5. %define po_package libbonobo-2.0
  6. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  7. Summary: Bonobo component system
  8. Summary(ja): Bonobo コンポーネントシステム
  9. Name: libbonobo
  10. Version: 2.24.3
  11. Release: 2%{?_dist_release}
  12. URL: http://ftp.gnome.org/
  13. Source0: %{name}-%{version}.tar.bz2
  14. Patch10: %{name}-2.14.0-i18n-help.patch
  15. License: LGPL
  16. Group: System Environment/Libraries
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: libxml2-devel >= %{libxml2_version}
  19. BuildRequires: ORBit2-devel >= %{orbit2_version}
  20. BuildRequires: dbus-devel >= %{dbus_version}
  21. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  22. BuildRequires: popt-devel
  23. BuildRequires: flex
  24. BuildRequires: byacc
  25. Obsoletes: bonobo-activation
  26. Provides: bonobo-activation
  27. %description
  28. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  29. %description -l ja
  30. Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
  31. システムです。
  32. %package devel
  33. Summary: Libraries and headers for libbonobo
  34. Summary: libbonobo のライブラリおよびヘッダ
  35. Group: Development/Libraries
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: ORBit2-devel >= %{orbit2_version}
  38. Requires: libxml2-devel >= %{libxml2_version}
  39. Obsoletes: bonobo-activation-devel
  40. Provides: bonobo-activation-devel
  41. Conflicts: bonobo-devel < 1.0.8
  42. %description devel
  43. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  44. This package contains header files used to compile programs that
  45. use Bonobo.
  46. %description devel -l ja
  47. Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
  48. システムです。
  49. このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
  50. ヘッダファイルが収録されています。
  51. # compat32
  52. %package -n compat32-%{name}
  53. Summary: Bonobo component system
  54. Summary(ja): Bonobo コンポーネントシステム
  55. Group: System Environment/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. %description -n compat32-%{name}
  58. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  59. %description -n compat32-%{name} -l ja
  60. Bonobo は GNUME デスクトップで使われている CORBA ベースのコンポーネント
  61. システムです。
  62. %package -n compat32-%{name}-devel
  63. Summary: Libraries and headers for libbonobo
  64. Summary: libbonobo のライブラリおよびヘッダ
  65. Group: Development/Libraries
  66. Requires: %{name}-devel = %{version}-%{release}
  67. Requires: compat32-%{name} = %{version}-%{release}
  68. Requires: compat32-ORBit2-devel >= %{orbit2_version}
  69. Requires: compat32-libxml2-devel >= %{libxml2_version}
  70. %description -n compat32-%{name}-devel
  71. Bonobo is a component system based on CORBA, used by the GNOME desktop.
  72. This package contains header files used to compile programs that
  73. use Bonobo.
  74. %description -n compat32-%{name}-devel -l ja
  75. Bonobo は GNOME デスクトップで使われている CORBA ベースのコンポーネント
  76. システムです。
  77. このパッケージは Bonobo を使うプログラムをコンパイルするために必要な
  78. ヘッダファイルが収録されています。
  79. %prep
  80. %setup -q -n %{name}-%{version}
  81. #patch1 -p1 -b .env-leak
  82. %patch10 -p1 -b .i18n-help
  83. %build
  84. %configure --disable-static
  85. make
  86. %install
  87. rm -rf $RPM_BUILD_ROOT
  88. %makeinstall
  89. ## just kill this wherever it lives
  90. rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo-2.0/samples/bonobo-echo-2
  91. rm -f $RPM_BUILD_ROOT%{_prefix}/lib/bonobo-2.0/samples/bonobo-echo-2
  92. ## kill other stuff
  93. rm $RPM_BUILD_ROOT%{_bindir}/echo-client-2
  94. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  95. rm $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.*a
  96. rm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.*a
  97. %find_lang %{po_package}
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %post -p /sbin/ldconfig
  101. %postun -p /sbin/ldconfig
  102. %post -n compat32-%{name} -p /sbin/ldconfig
  103. %postun -n compat32-%{name} -p /sbin/ldconfig
  104. %files -f %{po_package}.lang
  105. %defattr(-,root,root)
  106. %doc AUTHORS COPYING ChangeLog NEWS README
  107. %{_libdir}/lib*.so.*
  108. %{_libdir}/bonobo
  109. %{_libdir}/orbit-2.0/*.so*
  110. %{_bindir}*
  111. %{_libexecdir}/*
  112. %{_sbindir}/*
  113. %dir %{_sysconfdir}/bonobo-activation
  114. %config %{_sysconfdir}/bonobo-activation/*
  115. %{_mandir}/man*/*
  116. %files devel
  117. %defattr(-,root,root)
  118. #{_libdir}/lib*.a
  119. %{_libdir}/lib*.so
  120. %{_libdir}/pkgconfig/*.pc
  121. %{_includedir}/*
  122. %{_datadir}/idl
  123. %{_datadir}/gtk-doc
  124. # compat32
  125. %if %{build_compat32}
  126. %files -n compat32-%{name}
  127. %defattr(-,root,root)
  128. %{_libdir}/lib*.so.*
  129. %{_libdir}/bonobo
  130. %{_libdir}/orbit-2.0/*.so*
  131. %files -n compat32-%{name}-devel
  132. %defattr(-,root,root)
  133. #{_libdir}/lib*.a
  134. %{_libdir}/lib*.so
  135. %{_libdir}/pkgconfig/*.pc
  136. %endif
  137. %changelog
  138. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.3-2
  139. - build with rpm-4.8.1-1 for pkg-config file
  140. * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.3-1
  141. - new upstream release
  142. - add BuildRequires: dbus-devel, dbus-glib-devel, popt-devel, flex, byacc
  143. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.24.2-1
  144. - new upstream release
  145. * Sun Jul 19 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.24.1-2
  146. - added --disable-static configure option
  147. - added compat32 package for x86_64 arch support
  148. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  149. - new upstream release
  150. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  151. - new upstream release
  152. * Sun Jan 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.3-0vl1
  153. - new upstream release
  154. * Sat Nov 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
  155. - new upstream release
  156. * Mon Apr 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl2
  157. - add upstream patch1
  158. * Tue Apr 24 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-0vl1
  159. - new upstream release
  160. * Fri Jun 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl3
  161. - update Patch0 to fix more help message translation.
  162. * Fri May 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
  163. - add bindtextdomain_codeset in bonobo-activation initialize
  164. to fix corruption of help option message.(Patch0)
  165. * Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
  166. - new upstream release
  167. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.1-0vl1
  168. - new upstream release
  169. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  170. - new upstream release
  171. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  172. - new upstream release
  173. * Wed Mar 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  174. - new upstream release
  175. * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
  176. - new upstream release
  177. * Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  178. - new upstream release
  179. * Sat Jan 31 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.3-0vl1
  180. - new upstream release
  181. * Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
  182. - new upstream release
  183. - rebuild with new toolchains
  184. * Fri Oct 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  185. - new upstream release
  186. * Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  187. - new upstream release
  188. * Wed Aug 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.3-0vl1
  189. - new upstream release
  190. * Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  191. - new upstream release
  192. * Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  193. - new upstream release
  194. * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  195. - new upstream release
  196. * Sat Dec 14 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.0-0vl1
  197. - build for Vine Linux
  198. * Wed Jun 26 2002 Owen Taylor <otaylor@redhat.com>
  199. - Fix find_lang
  200. * Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
  201. - rebuild in different environment
  202. * Wed Jun 5 2002 Havoc Pennington <hp@redhat.com>
  203. - 2.0.0
  204. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  205. - automated rebuild
  206. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  207. - rebuild in different environment
  208. * Mon May 20 2002 Havoc Pennington <hp@redhat.com>
  209. - 1.117.0
  210. * Fri May 3 2002 Havoc Pennington <hp@redhat.com>
  211. - 1.116.0
  212. * Thu Apr 4 2002 Jeremy Katz <katzj@redhat.com>
  213. - 1.113.0
  214. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  215. - 1.111.0
  216. * Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
  217. - Version 1.110.0
  218. - Rebuild for dependencies
  219. - Intltoolize, the included version has problems with our Perl
  220. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  221. - automake-1.4
  222. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  223. - 1.108.0.90 cvs snap
  224. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  225. - 1.107.0, glib 1.3.11
  226. * Fri Oct 26 2001 Havoc Pennington <hp@redhat.com>
  227. - rebuild for new glib, new snap
  228. * Fri Oct 5 2001 Havoc Pennington <hp@redhat.com>
  229. - rebuild for new glib
  230. * Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
  231. - move to 1.103.0 tarball
  232. - call automake after patching Makefile.am
  233. - patch for parallel install
  234. * Fri Sep 21 2001 Havoc Pennington <hp@redhat.com>
  235. - add some requires
  236. * Tue Sep 18 2001 Havoc Pennington <hp@redhat.com>
  237. - conflict with bonobo < 1.0.8 to avoid header conflicts
  238. - update group
  239. * Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
  240. - moved IDL files into subdir
  241. - remove smp_mflags, libbonobo does not like those
  242. * Thu Sep 13 2001 Havoc Pennington <hp@redhat.com>
  243. - remove IDL files as temporary hack
  244. * Wed Sep 12 2001 Havoc Pennington <hp@redhat.com>
  245. - Initial build.