123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148 |
- Summary: A library implementing the SSH2 protocol
- Summary(ja): SSH2 プロトコルを実装するためのライブラリ
- Name: libssh2
- Version: 1.0
- Release: 1%{?_dist_release}
- Group: System Environment/Libraries
- License: BSD
- URL: http://www.libssh2.org/
- Source0: http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: openssl-devel
- BuildRequires: zlib-devel
- %description
- libssh2 is a library implementing the SSH2 protocol as defined by
- Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
- SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
- SECSH-DHGEX(04), and SECSH-NUMBERS(10).
- %package devel
- Summary: Development files for %{name}
- Summary(ja): %{name} の開発ファイル
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- The %{name}-devel package contains libraries and header files for
- developing applications that use %{name}.
- %package docs
- Summary: Documentation for %{name}
- Summary(ja): %{name} のドキュメント
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description docs
- The %{name}-docs package contains man pages and examples for
- developing applications that use %{name}.
- %prep
- %setup -q
- # make sure things are UTF-8...
- for i in ChangeLog NEWS ; do
- iconv --from=ISO-8859-1 --to=UTF-8 $i > new
- mv new $i
- done
- %build
- %configure --disable-static --enable-shared
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make install DESTDIR=%{buildroot} INSTALL="install -p"
- find %{buildroot} -name '*.la' -exec rm -f {} +
- # clean things up a bit for packaging
- ( cd example && make clean )
- rm -rf example/simple/.deps
- find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
- %check
- (cd tests && make check)
- %clean
- rm -rf %{buildroot}
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %doc AUTHORS ChangeLog COPYING README NEWS
- %{_libdir}/*.so.*
- %files docs
- %defattr(-,root,root,-)
- %doc COPYING HACKING example/
- %{_mandir}/man?/*
- %files devel
- %defattr(-,root,root,-)
- %doc COPYING
- %{_includedir}/*
- %{_libdir}/*.so
- %changelog
- * Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
- - initial build for Vine Linux
- * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
- - rebuilt with new openssl
- * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
- - update to 1.0
- * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
- - rebuild with new openssl
- * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
- - Autorebuild for GCC 4.3
- * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
- - rebuild for new openssl...
- * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
- - bump
- * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
- - add INSTALL arg to make install vs env. var
- * Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
- - run tests; don't package test
- * Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
- - split docs into -docs (they seemed... large.)
- * Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
- - update to 0.18
- * Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
- - update to 0.17
- - many spec file changes
- * Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
- - Fix release tag
- - Move manpages to -devel package
- - Add Examples dir to -devel package
- * Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
- - Initial build
|