texlive-common-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112
  1. ## -*- coding: utf-8-unix -*-
  2. %bcond_with firstbuild
  3. %define tex_destdir %{_datadir}
  4. %define texmf %{tex_destdir}/texmf
  5. %define texlive_src %{tex_destdir}/texlive-sources
  6. %define build_tex_destdir %{buildroot}%{tex_destdir}
  7. %define build_texmf %{buildroot}%{texmf}
  8. %define exec_mktexlsr [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
  9. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
  10. %define exec_updmap [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
  11. %define exec_fmtutil [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null
  12. %define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
  13. %define vartexfonts %{_var}/lib/texmf
  14. %define __find_provides %{nil}
  15. %define __find_requires %{nil}
  16. %define __perl_provides %{nil}
  17. %define __perl_requires %{nil}
  18. Autoreq: 0
  19. Summary: Common base for all TeX Live packages
  20. Summary(ja): TeX Live パッケージの共通ベース
  21. Name: texlive-common
  22. Version: 2009
  23. Release: 1%{?_dist_release}
  24. License: distributable
  25. Group: Applications/Publishing
  26. URL: http://www.tug.org/texlive/
  27. Requires: texlive-collection-basic = %{version}
  28. Requires: texlive-collection-latex = %{version}
  29. Requires: texlive-collection-latexrecommended = %{version}
  30. Requires: texlive-collection-fontsrecommended = %{version}
  31. #### $ pdftex -ini -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
  32. ## dehypht-x-2009-06-19.tex
  33. Requires: texlive-collection-langgerman = %{version}
  34. ## catkoi
  35. Requires: texlive-collection-langcyrillic = %{version}
  36. #### $ xetex -ini -jobname=xelatex -progname=xelatex -etex xelatex.ini
  37. ## unicode-letters
  38. Requires: texlive-collection-xetex = %{version}
  39. BuildArch: noarch
  40. Buildroot: %{_tmppath}/%{name}-%{version}-root
  41. Vendor: Project Vine
  42. Distribution: Vine Linux
  43. Packager: munepi
  44. %description
  45. The TeX Live software distribution offers a complete TeX system for a
  46. variety of Unix, Macintosh, Windows and other platforms. It
  47. encompasses programs for editing, typesetting, previewing and printing
  48. of TeX documents in many different languages, and a large collection
  49. of TeX macros and font libraries.
  50. The distribution includes extensive general documentation about TeX,
  51. as well as the documentation for the included software packages.
  52. This package is a virtual package
  53. to provide a common base for all TeX Live packages.
  54. %description -l ja
  55. TeX Live ソフトウェアディストリビューションは、
  56. さまざまな Unix, Macintosh, Windows、および
  57. 他のプラットホームに対して完全な TeX システムを提供します。
  58. 多くの異なった言語を含む TeX ドキュメントの
  59. 編集、組版、閲覧、印刷するためのプログラム、
  60. そして、TeX マクロやフォントライブラリの大きなコレクションを
  61. 同梱しています。
  62. このディストリビューションは
  63. 同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
  64. TeX に関するたくさんの一般的なドキュメントを含んでいます。
  65. このパッケージは TeX Live パッケージの共通ベースを
  66. 提供ための仮想パッケージです。
  67. %files
  68. %post
  69. %{exec_texhash}
  70. echo -n " "
  71. echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  72. echo -n " "
  73. echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  74. exit 0
  75. %postun
  76. %{exec_texhash}
  77. echo -n " "
  78. echo -n "Running updmap ... " && %{exec_updmap} >/dev/null 2>&1 && echo "done."
  79. # echo -n " "
  80. # echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
  81. exit 0
  82. %changelog
  83. * Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  84. - TeX Live 2009