texlive-sources-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. ## -*- coding: utf-8-unix -*-
  2. %define texlivesrcver 20091107
  3. %define texlivever 20091107
  4. %define texlivedir %{_datadir}/texlive
  5. %define build_texlive_src %{buildroot}%{texlivedir}-sources
  6. %define pkgname texlive
  7. %define __find_provides %{nil}
  8. %define __find_requires %{nil}
  9. %define __perl_provides %{nil}
  10. %define __perl_requires %{nil}
  11. Summary: A collection of sources for TeX Live packages
  12. Summary(ja): TeX Live のソース集
  13. Name: texlive-sources
  14. Version: 2009
  15. Release: 1%{?_dist_release}
  16. License: distributable
  17. Group: Applications/Publishing
  18. URL: http://www.tug.org/texlive/
  19. ## original TeX Live sources
  20. Source1: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivesrcver}-source.tar.xz
  21. Source2: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-texmf.tar.xz
  22. Source3: ftp://tug.org/historic/systems/texlive/2009/%{pkgname}-%{texlivever}-extra.tar.xz
  23. # Source4: ftp://tug.org/historic/systems/texlive/2009/%{name}-%{texlivever}-bin.tar.xz
  24. # ## from texlive2009.iso:/tlpkg/texlive.tlpdb
  25. # Source10: texlive2009.tlpdb
  26. %{?nosrc:NoSource: 1}
  27. %{?nosrc:NoSource: 2}
  28. %{?nosrc:NoSource: 3}
  29. BuildRequires: tar
  30. %if %{?_dist_release} == "vl6"
  31. BuildRequires: xz
  32. %endif
  33. %if %{?_dist_release} == "vl5"
  34. BuildRequires: lzma
  35. %endif
  36. BuildArch: noarch
  37. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: munepi
  41. %description
  42. This package is a collection of sources for TeX Live packages.
  43. It contains
  44. %{pkgname}-%{texlivesrcver}-source.tar.xz,
  45. %{pkgname}-%{texlivever}-texmf.tar.xz,
  46. %{pkgname}-%{texlivever}-extra.tar.xz
  47. on ftp://tug.org/historic/systems/texlive/2009/.
  48. This package is used to build texlive package and its related packages
  49. of Vine Linux.
  50. %description -l ja
  51. このパッケージは TeX Live のソース集です。
  52. ftp://tug.org/historic/systems/texlive/2009/ 上の
  53. %{pkgname}-%{texlivesrcver}-source.tar.xz,
  54. %{pkgname}-%{texlivever}-texmf.tar.xz,
  55. %{pkgname}-%{texlivever}-extra.tar.xz
  56. を含んでいます。
  57. このパッケージは Vine Linux の texlive パッケージやその関連パッケージを
  58. ビルドするために使われます。
  59. %prep
  60. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  61. %build
  62. %install
  63. [ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
  64. %__mkdir_p %{build_texlive_src}
  65. (cd %{build_texlive_src}
  66. %__mkdir_p source || exit 1
  67. %__install -m0644 %{SOURCE1} source/ || exit 1
  68. %__tar Jxf %{SOURCE2} || exit 1
  69. %__mv %{pkgname}-%{texlivever}-texmf/* . || exit 1
  70. %__tar Jxf %{SOURCE3} || exit 1
  71. %__mv %{pkgname}-%{texlivever}-extra/* . || exit 1
  72. # %__mkdir_p tlpkg || exit 1
  73. # %__install -m0644 %{SOURCE10} tlpkg/texlive.tlpdb || exit 1
  74. %__rm -r %{pkgname}-%{texlivever}-{texmf,extra} || exit 1
  75. )
  76. %clean
  77. %__rm -rf %{buildroot}
  78. %files
  79. %defattr(-,root,root)
  80. %{texlivedir}-sources
  81. %changelog
  82. * Sun May 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
  83. - TeX Live 2009