thunderbird-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 3.1
  3. %define tbversion %{tbmajor}.4
  4. %define tbrelease 1%{?_dist_release}
  5. # The tarball is pretty inconsistent with directory structure.
  6. # Sometimes there is a top level directory. That goes here.
  7. #
  8. # IMPORTANT: If there is no top level directory, this should be
  9. # set to the cwd, ie: '.'
  10. #%define tarballdir .
  11. %define tarballdir comm-1.9.2
  12. %define mozappdir %{_libdir}/%{name}-%{version_internal}
  13. %define moz_objdir objdir-tb
  14. %define version_internal 3.1
  15. %define thunderbird_app_id \{3550f703-e582-4d05-9a08-453d09bdfdc6\}
  16. %define desktop_file_utils_version 0.6
  17. %define nspr_version 4.8
  18. %define nss_version 3.12.6
  19. %define cairo_version 1.6.0
  20. %define freetype_version 2.1.9
  21. %define sqlite_version 3.6.14
  22. %define libnotify_version 0.4
  23. %define build_vineseed 0
  24. %define build_vine5 0
  25. %if "%{?_dist_release}" == "vl6"
  26. %define build_vineseed 1
  27. %endif
  28. %if "%{?_dist_release}" == "vl5"
  29. %define build_vine5 1
  30. %endif
  31. Summary: Thunderbird Community Edition, Mail/newsgroup client
  32. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  33. Name: thunderbird
  34. Version: %{tbversion}
  35. Release: %{tbrelease}
  36. URL: http://www.mozilla.org/projects/thunderbird/
  37. License: MPL
  38. Group: Applications/Internet
  39. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}.source.tar.bz2
  40. #Source1010: mozconfig-thunderbird-vine3
  41. #Source1020: mozconfig-thunderbird-vine4
  42. Source1030: mozconfig-thunderbird-vine5
  43. Source1040: mozconfig-thunderbird-vine6
  44. Source12: thunderbird-vine-default-prefs.js
  45. Source20: thunderbird.desktop
  46. Source21: thunderbird.vine.sh.in
  47. #Source22: thunderbird.png
  48. Source30: thunderbird-open-browser.sh
  49. Source40: thunderbird-unofficial-brandig-tb-brand.properties
  50. Source41: thunderbird-unofficial-brandig-tb-brand.dtd
  51. Source100: find-external-requires
  52. # locale sources
  53. %define MOZ_BUILD_LOCALES "ja"
  54. # get from mercurial repository with command,
  55. # mkdir l10n
  56. # hg clone http://hg.mozilla.org/releases/l10n-mozilla-1.9.2/ja l10n/ja
  57. Source1000: thunderbird-%{tbversion}-ja.tar.bz2
  58. # upstream patch
  59. # Fix for version issues
  60. Patch0: thunderbird-version.patch
  61. # Fix for jemalloc
  62. Patch1: mozilla-jemalloc.patch
  63. # Fix for installation fail when building with dynamic linked libraries
  64. Patch2: thunderbird-shared-error.patch
  65. # Fixes gcc complain that nsFrame::delete is protected
  66. Patch4: xulrunner-1.9.2.1-build.patch
  67. # customization patches
  68. #Patch22: firefox-1.0-psfonts.patch
  69. #Patch24: thunderbird-2.0-default-applications.patch
  70. #Patch25: thunderbird-1.1-software-update.patch
  71. Patch26: firefox-1.5-default-a4-paper.patch
  72. # font system fixes
  73. #Patch81: firefox-nopangoxft.patch
  74. ## Vine patch
  75. # http://bugzilla.mozilla.org/show_bug.cgi?id=179248
  76. Patch1000: thunderbird-3.1-sjisalias.patch
  77. # use /proc/net/netstat for random seed instead of netstat command.
  78. #Patch1010: firefox-nss-no_netstat.patch
  79. # workaround gcc visibility hidden bugs (see gcc#26905)
  80. Patch1020: firefox-2.0.0.3-visibility.patch
  81. # temporary fix for compilation error with PR_STATIC_ASSERT
  82. # refer http://bugs.gentoo.org/show_bug.cgi?id=336413
  83. Patch1030: thunderbird-3.1.3-fix-prlog-include-error.patch
  84. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  85. BuildRequires: pango-devel
  86. BuildRequires: cairo-devel >= %{cairo_version}
  87. %if %{build_vineseed}
  88. BuildRequires: nspr-devel >= %{nspr_version}
  89. BuildRequires: nss-devel >= %{nss_version}
  90. %endif
  91. BuildRequires: pixman-devel
  92. BuildRequires: libpng-devel
  93. BuildRequires: libjpeg-devel
  94. BuildRequires: gtk2-devel
  95. BuildRequires: zlib-devel, gzip, zip, unzip
  96. BuildRequires: libIDL-devel
  97. BuildRequires: freetype2-devel >= %{freetype_version}
  98. ## disabled libnotify support
  99. ## see related bug: https://bugzilla.mozilla.org/show_bug.cgi?id=478463
  100. #BuildRequires: libnotify-devel >= %{libnotify_version}
  101. BuildRequires: bzip2-devel
  102. BuildRequires: gnome-vfs2-devel
  103. BuildRequires: libgnome-devel
  104. BuildRequires: libgnomeui-devel
  105. BuildRequires: krb5-devel
  106. BuildRequires: pango-devel
  107. BuildRequires: libXt-devel
  108. BuildRequires: libXrender-devel
  109. # hunspell is in plus category for vine
  110. #BuildRequires: hunspell-devel
  111. BuildRequires: sqlite3-devel >= %{sqlite_version}
  112. BuildRequires: startup-notification-devel
  113. BuildRequires: desktop-file-utils
  114. BuildRequires: alsa-lib-devel
  115. Requires: sqlite3 >= %{sqlite_version}
  116. Requires(post): desktop-file-utils >= %{desktop_file_utils_version}
  117. Requires(postun): desktop-file-utils >= %{desktop_file_utils_version}
  118. Obsoletes: MozillaThunderbird
  119. Provides: MozillaThunderbird = %{version}
  120. Packager: daisuke, ryoichi, kazutaka
  121. AutoProv: 0
  122. %define _use_internal_dependency_generator 0
  123. %define __find_requires %{SOURCE100}
  124. %description
  125. Thunderbird is a standalone mail and newsgroup client.
  126. %description -l ja
  127. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  128. #===============================================================================
  129. %prep
  130. %setup -q %{name}-%{version} -c -b 1000
  131. cd %{tarballdir}
  132. # Fix for version issue
  133. sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' %{P:%%PATCH0} \
  134. > version.patch
  135. %{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
  136. %patch1 -p0 -b .jemalloc
  137. %patch2 -p1 -b .shared-error
  138. %patch4 -p1 -b .protected
  139. cd mozilla
  140. #%patch22 -p1
  141. #%patch24 -p1
  142. #%patch25 -p0
  143. %patch26 -p1 -b .default-a4
  144. %patch1000 -p1 -b .sjis-alias
  145. %patch1030 -p3 -b .prlog-fix
  146. cd -
  147. %{__rm} -f .mozconfig
  148. %if %{build_vine5}
  149. %{__cp} %{SOURCE1030} .mozconfig
  150. %endif
  151. %if %{build_vineseed}
  152. %{__cp} %{SOURCE1040} .mozconfig
  153. # cannot build with xulrunner (yet)
  154. # see tracking bugs.
  155. # https://bugzilla.mozilla.org/show_bug.cgi?id=306324
  156. # https://bugzilla.mozilla.org/show_bug.cgi?id=377319
  157. #echo "ac_add_options --with-libxul-sdk=`pkg-config --variable=sdkdir libxul`" >> .mozconfig
  158. %endif
  159. # setup unofficial branding name
  160. %{__cp} %{SOURCE40} mail/branding/unofficial/locales/en-US/brand.properties
  161. %{__cp} %{SOURCE41} mail/branding/unofficial/locales/en-US/brand.dtd
  162. #===============================================================================
  163. %build
  164. cd %{tarballdir}
  165. INTERNAL_GECKO=%{version_internal}
  166. MOZ_APP_DIR=%{mozappdir}
  167. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  168. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  169. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  170. export CFLAGS="$RPM_OPT_FLAGS"
  171. export CXXFLAGS="$CFLAGS"
  172. export MOZ_APP_DISPLAYNAME="Tb for Vine Linux"
  173. %ifarch ppc ppc64 s390 s390x
  174. %define moz_make_flags -j1
  175. %else
  176. %define moz_make_flags %{?_smp_mflags}
  177. %endif
  178. export PREFIX='%{_prefix}'
  179. export LIBDIR='%{_libdir}'
  180. export LDFLAGS="-Wl,-rpath,%{mozappdir}"
  181. export MAKE="gmake %{moz_make_flags}"
  182. %{__make} -f client.mk build
  183. # build locales
  184. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  185. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  186. for dir in $LOCALEDIRS
  187. do
  188. for lang in %{MOZ_BUILD_LOCALES} ; do
  189. make -C $dir/locales AB_CD=$lang
  190. done
  191. done
  192. #===============================================================================
  193. %install
  194. %{__rm} -rf $RPM_BUILD_ROOT
  195. cd %{tarballdir}
  196. INTERNAL_GECKO=%{version_internal}
  197. INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
  198. MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
  199. cd %{moz_objdir}
  200. DESTDIR=$RPM_BUILD_ROOT make install
  201. # install unofficial icons
  202. cd -
  203. %{__cp} mail/branding/unofficial/mailicon16.png \
  204. $RPM_BUILD_ROOT/%{mozappdir}/icons/
  205. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps
  206. %{__cp} mail/branding/unofficial/mailicon16.png \
  207. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  208. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps
  209. %{__cp} mail/branding/unofficial/mailicon22.png \
  210. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  211. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps
  212. %{__cp} mail/branding/unofficial//mailicon24.png \
  213. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  214. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps
  215. %{__cp} mail/branding/unofficial/mailicon32.png \
  216. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  217. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
  218. %{__cp} mail/branding/unofficial/mailicon48.png \
  219. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  220. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps
  221. %{__cp} mail/branding/unofficial/mailicon256.png \
  222. $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  223. desktop-file-install --vendor vine \
  224. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  225. --add-category Application \
  226. --add-category Network \
  227. %{SOURCE20}
  228. # set up the thunderbird start script
  229. rm -f $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  230. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{mozappdir},g' > \
  231. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  232. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  233. install -Dm755 %{SOURCE30} $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  234. %{__sed} -i -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{mozappdir}/open-browser.sh
  235. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  236. -e 's,COMMAND,%{mozappdir}/open-browser.sh,g' > \
  237. $RPM_BUILD_ROOT/vine-default-prefs
  238. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/greprefs/all-vine.js
  239. %{__install} -D $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{mozappdir}/defaults/pref/all-vine.js
  240. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  241. %{__rm} -f $RPM_BUILD_ROOT%{_bindir}/thunderbird-config
  242. # own mozilla plugin dir (#135050)
  243. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  244. # own extension directories
  245. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/mozilla/extensions/%{thunderbird_app_id}
  246. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/extensions/%{thunderbird_app_id}
  247. # install locales
  248. for lang in %{MOZ_BUILD_LOCALES} ; do
  249. %{__install} -p -D -m 664 %{moz_objdir}/mozilla/dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{mozappdir}/chrome/
  250. done
  251. %clean
  252. %{__rm} -rf $RPM_BUILD_ROOT
  253. #===============================================================================
  254. %post
  255. update-desktop-database &> /dev/null || :
  256. touch --no-create %{_datadir}/icons/hicolor
  257. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  258. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  259. fi
  260. %postun
  261. update-desktop-database &> /dev/null || :
  262. touch --no-create %{_datadir}/icons/hicolor
  263. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  264. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  265. fi
  266. %files
  267. %defattr(-,root,root,-)
  268. %attr(755,root,root) %{_bindir}/thunderbird
  269. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  270. %{_datadir}/icons/hicolor/16x16/apps/thunderbird.png
  271. %{_datadir}/icons/hicolor/22x22/apps/thunderbird.png
  272. %{_datadir}/icons/hicolor/24x24/apps/thunderbird.png
  273. %{_datadir}/icons/hicolor/256x256/apps/thunderbird.png
  274. %{_datadir}/icons/hicolor/32x32/apps/thunderbird.png
  275. %{_datadir}/icons/hicolor/48x48/apps/thunderbird.png
  276. %{mozappdir}
  277. #===============================================================================
  278. %changelog
  279. * Sun Sep 19 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.4-1
  280. - new upstream release
  281. * Thu Sep 09 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.3-1
  282. - new upstream release with security fix
  283. - add Patch1030 to fix compilation error
  284. * Sat Aug 07 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-2
  285. - change mozconfig (Source1030 & 1040): add --enable-jsd
  286. * Fri Aug 06 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.2-1
  287. - new upstream release
  288. * Wed Jul 21 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1.1-1
  289. - new upstream release with security fix
  290. - add Patch0 from fedora development: fix version issue
  291. - remove BuildRequires: hunspell-devel
  292. - update mozconfig (Source1030 & Source1040): set --disable-system-hunspell
  293. * Sat Jul 03 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-2
  294. - add BuildRequires: alsa-lib-devel
  295. - remove BuildRequires: libnotify-devel
  296. (workaround for known bug)
  297. - update mozconfig to add --disable-libnotify option
  298. * Tue Jun 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 3.1-1
  299. - new upstream release
  300. - update spec entirely
  301. - import patches from fedora (Patch1, 2 & 4)
  302. - drop outdated patches (Patch22, 24)
  303. - update Sources:
  304. - mozconfig (Source1030 & Source1040)
  305. - default prefs.js (Source12)
  306. - unofficial branding (Source40 & Source41)
  307. - japanese translation (Source1000)
  308. - update Patch1000 (sjis-alias)
  309. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  310. - new upstream release
  311. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  312. - new upstream release
  313. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  314. - don't install official branding logos
  315. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  316. - add necessary icons in %%{tbdir}/chrome/icons/default
  317. - add Packager tag
  318. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  319. - new upstream release
  320. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  321. - new upstream release
  322. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  323. - new upstream release
  324. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  325. - new upstream release
  326. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  327. - rebuilt for VineSeed
  328. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  329. - new upstream release
  330. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  331. - new upstream release
  332. - built for Vine Linux 4.x
  333. - dropped Patch1020 (merged into upstream)
  334. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  335. - added Patch1020 for workaround gcc visibility hidden bugs
  336. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  337. - build with new environment/toolchain
  338. - add build options to build with external nss/nspr libraries
  339. ac_add_options --with-system-nspr
  340. ac_add_options --with-system-nss
  341. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  342. - new upstream release
  343. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  344. - new upstream release
  345. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  346. - new upstream release
  347. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  348. - new upstream release
  349. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  350. - new upstream release
  351. - merge changes from firefox
  352. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  353. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  354. - new upstream release
  355. - build en-US locale
  356. - merge changes from firefox
  357. - add upstream patches
  358. - disable pango rendering by default
  359. (workaround fix slow rendering in some page)
  360. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  361. - initial build for Vine Linux based on FC package
  362. - update to 1.5RC2
  363. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  364. - Fix issue with popup dialogs and other actions causing lockups
  365. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  366. - Update to 1.5 rc1
  367. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  368. - Update to 1.5 beta2
  369. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  370. - Update to 1.5 beta1
  371. - Bring the install phase of the spec file up to speed
  372. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  373. - Rebuild
  374. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  375. - Add patch to make file chooser dialog modal
  376. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  377. - Update to 1.0.6
  378. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  379. - 1.0.6 Release Candidate
  380. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  381. - Use system NSPR
  382. - Fix crash on 64bit platforms (#160330)
  383. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  384. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  385. references, fixing the "no fonts" problem.
  386. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  387. - Change the Exec line in the desktop file to `thunderbird`
  388. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  389. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  390. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  391. - Add temporary workaround to not create files in the user's $HOME (#149664)
  392. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  393. - Don't have downloads "disappear" when downloading to desktop (#139015)
  394. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  395. - Add upstream patch to fix bidi justification of pango
  396. - Add patch to fix launching of helper applications
  397. - Add patch to properly link against libgfxshared_s.a
  398. - Fix multilib conflicts
  399. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  400. - correct confusing PANGO vars in startup script
  401. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  402. - Thunderbird 1.0.2
  403. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  404. - Add patch to compile against new fortified glibc macros
  405. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  406. - Rebuild against GCC 4.0
  407. - Add execshield patches
  408. - Minor specfile cleanup
  409. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  410. - Rebuild
  411. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  412. - Add RPM version to useragent
  413. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  414. - Port over pango patches from firefox
  415. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  416. - Thunderbird 1.0
  417. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  418. - Fix advanced prefs
  419. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  420. - Make this run on s390(x) now for real
  421. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  422. - Update to 1.0 rc1
  423. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  424. - Add patches to build and run on s390(x)
  425. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  426. - Rebuild to fix file chooser
  427. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  428. - Update to 0.9
  429. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  430. - Prevent inlining of stack direction detection (#135255)
  431. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  432. - More file chooser fixes (same as in firefox)
  433. - Fix for upstream 28327.
  434. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  435. - Update the pango patch
  436. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  437. - Pull over patches from firefox build:
  438. - disable default application dialog
  439. - don't include software update since it doesn't work
  440. - make external app support work
  441. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  442. - Use pango for rendering
  443. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  444. - Fix for 64 bit crash at startup (b.m.o #256603)
  445. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  446. - Add patches to fix xremote (#135036)
  447. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  448. - Add patch to fix button focus issues (#133507)
  449. - Add patch for fix IMAP race issues (bmo #246439)
  450. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  451. - filter out library Provides: and internal Requires:
  452. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  453. - Backport the GTK+ File Chooser.
  454. - Add fix for JS math on x86_64 systems
  455. - Add pkgconfig patch
  456. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  457. - Update to 0.8.0
  458. - Remove enigmail
  459. - Update BuildRequires
  460. - Remove gcc34 and extension manager patches -- they are upstreamed.
  461. - Fix for gnome-vfs2 error at component registration
  462. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  463. - Build with --disable-xprint
  464. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  465. - remove all Xvfb-related hacks
  466. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  467. - actually apply psfonts
  468. - add mozilla gnome-uriloader patch to prevent build failure
  469. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  470. - rawhide import
  471. - apply NetBSD's freetype 2.1.8 patch
  472. - apply psfonts patch
  473. - remove BR on /usr/bin/ex, breaks beehive
  474. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  475. - oops, fix %%install
  476. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  477. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  478. - remove XUL.mfasl on startup, add Debian enigmail patches
  479. - add Xvfb hack for -install-global-extension
  480. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  481. - update to 0.7.2, just because it's there
  482. - update gcc-3.4 patch (Kaj Niemi)
  483. - add EM registration patch and remove instdir hack
  484. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  485. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  486. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  487. - update to 0.7.1
  488. - remove Enigmail
  489. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  490. - re-enable Enigmail 0.84.1
  491. - add gcc-3.4 patch (Kaj Niemi)
  492. - use official branding (with permission)
  493. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  494. - update to 0.7
  495. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  496. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  497. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  498. - temporary workaround for enigmail skin "modern" bug
  499. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  500. - update to Enigmail 0.84.0
  501. - update launch script
  502. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  503. - installation directory now versioned
  504. - allow root to run the program (for installing extensions)
  505. - remove unnecessary %%pre and %%post
  506. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  507. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  508. - include Enigmail, re-add release notes
  509. - delete %{_libdir}/thunderbird in %%pre
  510. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  511. - update to Thunderbird 0.6
  512. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  513. - update to Thunderbird 0.6 RC1
  514. - add new icon, remove release notes
  515. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  516. - update to latest CVS, update mozconfig and %%build accordingly
  517. - update to Enigmail 0.83.6
  518. - remove x-remote and x86_64 patches
  519. - build with -Os
  520. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  521. - update x-remote patch
  522. - more startup script fixes
  523. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  524. - startup script fixes, and a minor cleanup
  525. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  526. - Minor cleanups
  527. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  528. - minor improvements to open-browser.sh and startup script
  529. - update to latest version of Blizzard's x-remote patch
  530. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  531. - update open-browser.sh, startup script, and BuildRequires
  532. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  533. - update open-browser script, modify BuildRequires (Warren)
  534. - add Blizzard's x-remote patch
  535. - initial attempt at x-remote-enabled startup script
  536. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  537. - refuse to run with excessive privileges
  538. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  539. - add Mozilla x86_64 patch (Oliver Sontag)
  540. - Enigmail source filenames now include the version
  541. - modify BuildRoot
  542. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  543. - use the updated official tarball
  544. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  545. - fix %%prep script
  546. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  547. - update Enigmail to 0.83.3
  548. - use official source tarball (after removing the CRLFs)
  549. - package renamed to thunderbird
  550. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  551. - update to 0.5
  552. - check for lockfile before launching
  553. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  554. - update to latest cvs
  555. - update to Enigmail 0.83.2
  556. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  557. - update to Enigmail 0.83.1
  558. - removed Mozilla/Firebird script patching
  559. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  560. - add startup notification to .desktop file
  561. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  562. - open-browser.sh release 3
  563. - patch broken /usr/bin/mozilla script during install
  564. - dir ownership
  565. - XXX: Source fails build on x86_64... fix later
  566. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  567. - update to Enigmail 0.82.5
  568. - add Warren's open-browser.sh (#1113)
  569. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  570. - use Thunderbird's mozilla-xremote-client to launch browser
  571. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  572. - update to 0.4
  573. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  574. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  575. - update to 0.4rc2
  576. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  577. - update to 0.4rc1 and Enigmail 0.82.4
  578. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  579. - update to latest CVS and Enigmail 0.82.3
  580. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  581. - update to latest CVS (0.4a)
  582. - update Enigmail to 0.82.2
  583. - alter mozconfig for new build requirements
  584. - add missing BuildReq (#987)
  585. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  586. - update to 0.3
  587. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  588. - update to 0.3rc3
  589. - update Enigmail to 0.81.7
  590. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  591. - update to 0.3rc2
  592. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  593. - simplify startup script
  594. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  595. - add GPG support (Enigmail 0.81.6)
  596. - specfile fixes (#679)
  597. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  598. - update to 0.2
  599. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  600. - initial RPM
  601. (based on the fedora MozillaFirebird-0.6.1 specfile)