curl-vl.spec 9.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  3. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  4. Name: curl
  5. Version: 7.20.1
  6. Release: 4%{?_dist_release}
  7. License: MIT/X
  8. Group: Applications/Internet
  9. Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
  10. URL: http://curl.haxx.se/
  11. # Security
  12. Patch100: curl-7.19.6_CVE-2011-2192.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: openssl-devel libidn-devel zlib-devel
  15. BuildRequires: openldap-devel gnutls-devel
  16. Requires: openssl libidn zlib
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. %description
  20. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  21. Dict servers, using any of the supported protocols. cURL is designed
  22. to work without user interaction or any kind of interactivity. cURL
  23. offers many useful capabilities, like proxy support, user
  24. authentication, FTP upload, HTTP post, and file transfer resume.
  25. %package devel
  26. Summary: Files needed for building applications with libcurl.
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: openssl-devel libidn-devel zlib-devel
  30. %description devel
  31. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  32. Dict servers, using any of the supported protocols. The curl-devel
  33. package includes files needed for developing applications which can
  34. use cURL's capabilities internally.
  35. #'
  36. ## to build compat32 for x86_64 architecture support
  37. %package -n compat32-%{name}
  38. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  39. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  40. Group: System Environment/Libraries
  41. %description -n compat32-%{name}
  42. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  43. Dict servers, using any of the supported protocols. cURL is designed
  44. to work without user interaction or any kind of interactivity. cURL
  45. offers many useful capabilities, like proxy support, user
  46. authentication, FTP upload, HTTP post, and file transfer resume.
  47. %package -n compat32-%{name}-devel
  48. Summary: Files needed for building applications with libcurl.
  49. Group: Development/Libraries
  50. %description -n compat32-%{name}-devel
  51. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  52. Dict servers, using any of the supported protocols. The curl-devel
  53. package includes files needed for developing applications which can
  54. use cURL's capabilities internally.
  55. #'
  56. %prep
  57. %setup -q
  58. %patch100 -p1 -b .CVE-2011-2192
  59. %build
  60. %configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
  61. %ifarch alpha
  62. make %{?_smp_mflags} CFLAGS=""
  63. %else
  64. make %{?_smp_mflags}
  65. %endif
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make DESTDIR=$RPM_BUILD_ROOT install
  69. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %post -p /sbin/ldconfig
  73. %postun -p /sbin/ldconfig
  74. %files
  75. %defattr(-,root,root)
  76. %doc CHANGES COPYING README
  77. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  78. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  79. %doc docs/TheArtOfHttpScripting docs/TODO
  80. %{_bindir}/curl
  81. #{_datadir}/curl/*
  82. %{_libdir}/*.so.*
  83. %{_mandir}/man1/curl.1*
  84. %files devel
  85. %defattr(-,root,root)
  86. %{_bindir}/curl-config
  87. %{_includedir}/curl
  88. %{_libdir}/*.so
  89. %{_libdir}/pkgconfig/*.pc
  90. %{_mandir}/man1/curl-config.1*
  91. %{_mandir}/man3/*
  92. ## to build compat32 for x86_64 architecture support
  93. %if %{build_compat32}
  94. %files -n compat32-%{name}
  95. %defattr(-,root,root)
  96. %{_libdir}/*.so.*
  97. %files -n compat32-%{name}-devel
  98. %defattr(-,root,root)
  99. %{_libdir}/*.so
  100. %{_libdir}/pkgconfig/*.pc
  101. %endif
  102. %changelog
  103. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  104. - add patch100 for fix CVE-2011-2192 (gssapi)
  105. - add Vendor/Distri tags
  106. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  107. - rebuild with openssl-1.0.0c
  108. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  109. - rebuilt with rpm-4.8.1 for pkg-config
  110. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  111. - new upstream release
  112. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  113. - new upstream release with security fix
  114. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  115. - added compat32 subpackages
  116. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  117. - new upstream release
  118. - use "_smp_mflags" flag
  119. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  120. - rebuild with openldap-2.4.11
  121. - add BR: openldap-devel
  122. - remove static library
  123. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  124. - new upstream release with security fix (CVE-2009-0037)
  125. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  126. - new upstream release
  127. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  128. - new upstream release
  129. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  130. - new upstream release
  131. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  132. - new upstream release
  133. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  134. - new upstream release
  135. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  136. - rebuilt with openssl-0.9.8e
  137. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  138. - new upstream release
  139. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  140. - new upstream release
  141. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  142. - new upstream release
  143. - add pkgconfig file to devel package
  144. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  145. - new upstream release
  146. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  147. - new upstream release
  148. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  149. - new upstream release
  150. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  151. - added libidn, zlib in Requires
  152. - added libidn-devel, zlib-devel in BuildPrereq
  153. - added zlib-devel in curl-devel's Requires
  154. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  155. - added openssl-devel, libidn-devel in curl-devel's Requires
  156. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  157. - new upstream release
  158. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  159. - new upstream release
  160. - rebuild with openssl-0.9.7d
  161. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  162. - upstream release
  163. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  164. - add %%{_datadir}/curl/* to %%files section
  165. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  166. - source upgrade
  167. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  168. - source upgrade
  169. - add PreReq: ldconfig
  170. - add %%{_libdir}/*.la to %%files devel section
  171. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  172. - build for VineSeed
  173. - add Requires: openssl
  174. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  175. - automated rebuild
  176. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  177. - 7.9.2
  178. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  179. - include curl-config in curl-devel
  180. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  181. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  182. - added openssl-devel build req
  183. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  184. - built for the distro
  185. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  186. - upgrade to curl-7.7.2.
  187. - enable IPv6.
  188. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  189. - rebuilt against openssl-0.9.6-1
  190. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  191. - fixed mising ldconfigs
  192. - updated to 7.5.2, bug fixes
  193. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  194. - updated to 7.5.1
  195. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  196. - update to 7.4.1 to fix bug #20337, problems with curl -c
  197. - not using patch anymore, it's included in the new source. Keeping
  198. for reference
  199. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  200. - fix bogus req in -devel package
  201. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  202. - devel package needed defattr so that root owns the files
  203. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  204. - update to 7.3
  205. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  206. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  207. - enable SSL support
  208. - fix packager tag
  209. - move buildroot to %%{_tmppath}
  210. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  211. - fixed vendor tag for bug #15028
  212. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  213. - rebuilt
  214. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  215. - workaround alpha build problems with optimizations
  216. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  217. - rebuilt
  218. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  219. - put man pages in correct place
  220. - use %%makeinstall
  221. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  222. - updated to 6.5.2
  223. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  224. - updated sources to 6.2
  225. - gzip man page
  226. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  227. - changed group
  228. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  229. - changelog started
  230. - general cleanups, changed prefix to /usr, added manpage to files section
  231. - including in Powertools