git-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900
  1. %bcond_with arch
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  4. # Pass --without docs to rpmbuild if you don't want the documentation
  5. Name: git
  6. Version: 2.15.1
  7. Release: 1%{?_dist_release}
  8. Summary: Core git tools
  9. Summary(ja): Core git ツール
  10. License: GPLv2
  11. Group: Development/Tools
  12. URL: http://git-scm.com/
  13. Source0: https://www.kernel.org/pub/software/scm/git/%{name}-%{version}.tar.xz
  14. Source1: vine-default-git.el
  15. Source2: git.xinetd
  16. Source3: git.conf.httpd
  17. Source4: gitweb.conf.in
  18. Source10: %{name}-install.sh
  19. Source11: %{name}-remove.sh
  20. Source12: git-init.el
  21. Patch0: git-1.5-gitweb-home-link.patch
  22. # Security
  23. # none
  24. BuildRequires: zlib-devel >= 1.2, openssl-devel, curl-devel
  25. BuildRequires: expat-devel, gettext, asciidoc
  26. BuildRequires: pcre-devel
  27. BuildRequires: xmlto
  28. # git-credential-gnome-keyring
  29. BuildRequires: glib2-devel libgnome-keyring-devel
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  31. Requires: perl-Git = %{version}-%{release}
  32. Requires: zlib
  33. Provides: git-core = %{version}-%{release}
  34. Obsoletes: git-core <= 1.5.4.3
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. Packager: iwaim
  38. %description
  39. Git is a fast, scalable, distributed revision control system with an
  40. unusually rich command set that provides both high-level operations
  41. and full access to internals.
  42. The git rpm installs the core tools with minimal dependencies. To
  43. install all git packages, including tools for integrating with other
  44. SCMs, install the git-all meta-package.
  45. %package all
  46. Summary: Meta-package to pull in all git tools
  47. Summary(ja): すべての git ツール
  48. Group: Development/Tools
  49. Requires: git = %{version}-%{release}
  50. Requires: git-svn = %{version}-%{release}
  51. Requires: git-cvs = %{version}-%{release}
  52. %if "%{?_dist_release}" != "vl4" && %{with arch}
  53. Requires: git-arch = %{version}-%{release}
  54. %endif
  55. Requires: git-email = %{version}-%{release}
  56. Requires: gitk = %{version}-%{release}
  57. Requires: git-gui = %{version}-%{release}
  58. Requires: perl-Git = %{version}-%{release}
  59. Requires: emacs-git = %{version}-%{release}
  60. Requires: git-contrib = %{version}-%{release}
  61. Obsoletes: git <= 1.5.4.3
  62. %description all
  63. Git is a fast, scalable, distributed revision control system with an
  64. unusually rich command set that provides both high-level operations
  65. and full access to internals.
  66. This is a dummy package which brings in all subpackages.
  67. %package daemon
  68. Summary: Git protocol daemon
  69. Summary(ja): Git プロトコルデーモン
  70. Group: Development/Tools
  71. Requires: git = %{version}-%{release}
  72. %description daemon
  73. The git daemon for supporting git:// access to git repositories
  74. %package -n gitweb
  75. Summary: Simple web interface to git repositories
  76. Summary(ja): git リポジトリへのシンプルな Web インタフェース
  77. Group: Development/Tools
  78. Requires: git = %{version}-%{release}
  79. %description -n gitweb
  80. Simple web interface to track changes in git repositories
  81. %package svn
  82. Summary: Git tools for importing Subversion repositories
  83. Summary(ja): Subversion リポジトリを git へインポートするためのツール
  84. Group: Development/Tools
  85. Requires: git = %{version}-%{release}, subversion, perl(Term::ReadKey)
  86. Requires: perl(SVN::Core)
  87. %description svn
  88. Git tools for importing Subversion repositories.
  89. %package cvs
  90. Summary: Git tools for importing CVS repositories
  91. Summary(ja): CVS リポジトリを git へインポートするためのツール
  92. Group: Development/Tools
  93. Requires: git = %{version}-%{release}, cvs, cvsps
  94. %description cvs
  95. Git tools for importing CVS repositories.
  96. %package contrib
  97. Summary: Git contrib tools
  98. Group: Development/Tools
  99. Requires: git = %{version}-%{release}
  100. %description contrib
  101. Git contrib tools
  102. %if "%{?_dist_release}" != "vl4" && %{with arch}
  103. %package arch
  104. Summary: Git tools for importing Arch repositories
  105. Summary(ja): Arch リポジトリを git へインポートするためのツール
  106. Group: Development/Tools
  107. Requires: git = %{version}-%{release}, tla
  108. %description arch
  109. Git tools for importing Arch repositories.
  110. %endif
  111. %package email
  112. Summary: Git tools for sending email
  113. Summary(ja): Eメールを送るための git ツール
  114. Group: Development/Tools
  115. Requires: git = %{version}-%{release}, perl-Git = %{version}-%{release}
  116. %description email
  117. Git tools for sending email.
  118. %package gui
  119. Summary: Git GUI tool
  120. Summary(ja): Git の GUI ツール
  121. Group: Development/Tools
  122. Requires: git = %{version}-%{release}, tk
  123. %description gui
  124. Git GUI tool.
  125. %package -n gitk
  126. Summary: Git revision tree visualiser
  127. Summary(ja): Git リビジョンツリー可視化ツール
  128. Group: Development/Tools
  129. Requires: git = %{version}-%{release}, tk
  130. %description -n gitk
  131. Git revision tree visualiser.
  132. %package -n perl-Git
  133. Summary: Perl interface to Git
  134. Summary(ja): Git の perl インタフェース
  135. Group: Development/Libraries
  136. Requires: git = %{version}-%{release}, perl(Error)
  137. %if "%{?_dist_release}" == "vl4"
  138. Requires: perl = %(rpm -q --qf '%%{epoch}:%%{version}' perl)
  139. %else
  140. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  141. %endif
  142. #BuildRequires: perl(Error), perl(ExtUtils::MakeMaker)
  143. %description -n perl-Git
  144. Perl interface to Git.
  145. %package -n emacs-git
  146. Summary: Git version control system support for Emacs
  147. Summary(ja): Emacs の Git サポート
  148. Group: Applications/Editors
  149. Requires: git = %{version}-%{release}, emacsen-common
  150. %description -n emacs-git
  151. %{summary}.
  152. %package devel
  153. Summary: Header files for git-core
  154. Summary(ja): git-core 用ヘッダファイル
  155. Group: Development/Libraries
  156. %description devel
  157. Header files for git-core.
  158. %prep
  159. %setup -q
  160. %patch0 -p1
  161. # for pcre-8.12
  162. %if %{?_dist_release} == "vl6"
  163. %{__perl} -pi -e "s|#include <pcre.h>|#include <pcre/pcre.h>|" grep.h
  164. %endif
  165. %__mv contrib/diff-highlight/README contrib/diff-highlight/README.diff-highlight
  166. # Filter bogus perl requires
  167. cat << \EOF > %{name}-req
  168. #!/bin/sh
  169. %{__perl_requires} $* |\
  170. sed -e '/perl(packed-refs)/d'
  171. EOF
  172. %global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
  173. chmod +x %{__perl_requires}
  174. %build
  175. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS -I%{_includedir/pcre}" \
  176. ETC_GITCONFIG=/etc/gitconfig \
  177. USE_LIBPCRE=1 \
  178. GITWEB_PROJECTROOT=/var/lib/git \
  179. gitwebdir=/var/www/git \
  180. prefix=%{_prefix} all %{!?_without_docs: doc}
  181. pushd contrib/diff-highlight
  182. make diff-highlight
  183. popd
  184. %install
  185. rm -rf $RPM_BUILD_ROOT
  186. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS" DESTDIR=$RPM_BUILD_ROOT \
  187. prefix=%{_prefix} mandir=%{_mandir} \
  188. ETC_GITCONFIG=/etc/gitconfig \
  189. USE_LIBPCRE=1 \
  190. NO_PYTHON=1 \
  191. GITWEB_PROJECTROOT=/var/lib/git \
  192. gitwebdir=/var/www/git \
  193. INSTALLDIRS=vendor install %{!?_without_docs: install-doc}
  194. pushd contrib/credential/gnome-keyring
  195. make %{_smp_mflags} CFLAGS="$RPM_OPT_FLAGS"
  196. popd
  197. # perl-Git
  198. # Error.pm provide by perl-Error package
  199. rm -rf $RPM_BUILD_ROOT%{perl_vendorlib}/Error.pm
  200. # emacs-git
  201. mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git
  202. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
  203. #mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
  204. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
  205. mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
  206. # install el files
  207. install -m644 contrib/emacs/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  208. # install vine-default file
  209. install -m644 %{SOURCE1} %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/git/
  210. # install script( bytecompile el and install elc , remove )
  211. %_installemacsenscript git %{SOURCE10}
  212. %_removeemacsenscript git %{SOURCE11}
  213. mkdir -p $RPM_BUILD_ROOT/%{_var}/lib/git
  214. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d
  215. install -m 644 %SOURCE2 $RPM_BUILD_ROOT/%{_sysconfdir}/xinetd.d/git
  216. perl -p \
  217. -e "s|\@GITCOREDIR\@|%{_libexecdir}/git-core|g;" \
  218. -e "s|\@BASE_PATH\@|%{_var}/lib/git|g;" \
  219. %{SOURCE3} > %{buildroot}%{_sysconfdir}/xinetd.d/git
  220. ## for gitweb sub package
  221. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d
  222. install -m 0644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/httpd/conf.d/git.conf
  223. sed "s|@PROJECTROOT@|%{_var}/lib/git|g" \
  224. %{SOURCE4} > %{buildroot}%{_sysconfdir}/gitweb.conf
  225. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  226. find $RPM_BUILD_ROOT -type f -name '*.bs' -empty -exec rm -f {} ';'
  227. find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
  228. (find $RPM_BUILD_ROOT%{_libexecdir} -type f | grep -vE "archimport|svn|cvs|email|gitk|git-gui|git-citooli|git-daemon" | sed -e s@^$RPM_BUILD_ROOT@@) > bin-man-doc-files
  229. (find $RPM_BUILD_ROOT%{perl_vendorlib} -type f | sed -e s@^$RPM_BUILD_ROOT@@) >> perl-files
  230. %if %{!?_without_docs:1}0
  231. (find $RPM_BUILD_ROOT%{_mandir} $RPM_BUILD_ROOT/Documentation -type f | grep -vE "archimport|svn|git-cvs|email|gitk|git-gui|git-citool" | sed -e s@^$RPM_BUILD_ROOT@@ -e 's/$/*/' ) >> bin-man-doc-files
  232. %else
  233. rm -rf $RPM_BUILD_ROOT%{_mandir}
  234. %endif
  235. mkdir -p $RPM_BUILD_ROOT/srv/git
  236. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
  237. install -m 644 -T contrib/completion/git-completion.bash $RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d/git
  238. install -m 755 contrib/diff-highlight/diff-highlight $RPM_BUILD_ROOT%{_bindir}/
  239. # header files and lib
  240. install -d $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  241. install *.h $RPM_BUILD_ROOT%{_includedir}/%{name}
  242. install xdiff/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}/xdiff
  243. install libgit.a $RPM_BUILD_ROOT%{_libdir}
  244. install xdiff/lib.a $RPM_BUILD_ROOT%{_libdir}/libgit_xdiff.a
  245. # git-credential-gnome-keyring
  246. pushd contrib/credential/gnome-keyring
  247. %__install -m0755 git-credential-gnome-keyring $RPM_BUILD_ROOT%{_libexecdir}/git-core
  248. popd
  249. %find_lang %{name}
  250. %clean
  251. rm -rf $RPM_BUILD_ROOT
  252. %post -n emacs-git
  253. # bytecompile and install
  254. if [ "$1" = 2 ]; then
  255. %_emacsenPackageRemove git
  256. fi
  257. %_addemacsenlist git
  258. %_emacsenPackageInstall git
  259. %preun -n emacs-git
  260. if [ "$1" = 0 ]; then
  261. %_emacsenPackageRemove git
  262. %_removeemacsenlist git
  263. fi
  264. %files -f bin-man-doc-files -f %{name}.lang
  265. %defattr(-,root,root)
  266. %{_bindir}/git
  267. %{_bindir}/git-receive-pack
  268. %{_bindir}/git-upload-archive
  269. %{_bindir}/git-upload-pack
  270. %{_bindir}/git-shell
  271. %{_datadir}/git-core/
  272. %exclude %{_libexecdir}/git-core/git-credential-gnome-keyring
  273. %doc README.md COPYING Documentation/*.txt contrib/hooks
  274. %{!?_without_docs: %doc Documentation/*.html Documentation/docbook-xsl.css}
  275. %{!?_without_docs: %doc Documentation/howto Documentation/technical}
  276. %{_sysconfdir}/bash_completion.d
  277. %files svn
  278. %defattr(-,root,root)
  279. %{_libexecdir}/git-core/*svn*
  280. %doc Documentation/*svn*.txt
  281. %{!?_without_docs: %{_mandir}/man1/*svn*.1*}
  282. %{!?_without_docs: %doc Documentation/*svn*.html }
  283. %files cvs
  284. %defattr(-,root,root)
  285. %doc Documentation/*git-cvs*.txt
  286. %{_bindir}/git-cvsserver
  287. %{_libexecdir}/git-core/*cvs*
  288. %{!?_without_docs: %{_mandir}/man1/*cvs*.1*}
  289. %{!?_without_docs: %doc Documentation/*git-cvs*.html }
  290. %files contrib
  291. %defattr(-,root,root)
  292. %doc contrib/diff-highlight/README.diff-highlight
  293. %{_bindir}/diff-highlight
  294. %{_libexecdir}/git-core/git-credential-gnome-keyring
  295. %if "%{?_dist_release}" != "vl4" && %{with arch}
  296. %files arch
  297. %defattr(-,root,root)
  298. %doc Documentation/git-archimport.txt
  299. %{_libexecdir}/git-core/git-archimport
  300. %{!?_without_docs: %{_mandir}/man1/git-archimport.1*}
  301. %{!?_without_docs: %doc Documentation/git-archimport.html }
  302. %endif
  303. %files email
  304. %defattr(-,root,root)
  305. %doc Documentation/*email*.txt
  306. %{_libexecdir}/git-core/*email*
  307. %{!?_without_docs: %{_mandir}/man1/*email*.1*}
  308. %{!?_without_docs: %doc Documentation/*email*.html }
  309. %files gui
  310. %defattr(-,root,root)
  311. %{_libexecdir}/git-core/git-gui*
  312. %{_libexecdir}/git-core/git-citool
  313. %{_datadir}/git-gui/
  314. %{!?_without_docs: %{_mandir}/man1/git-gui.1*}
  315. %{!?_without_docs: %doc Documentation/git-gui.html}
  316. %{!?_without_docs: %{_mandir}/man1/git-citool.1*}
  317. %{!?_without_docs: %doc Documentation/git-citool.html}
  318. %files -n gitk
  319. %defattr(-,root,root)
  320. %doc Documentation/*gitk*.txt
  321. %{_bindir}/gitk
  322. %{_datadir}/gitk
  323. %{!?_without_docs: %{_mandir}/man1/*gitk*.1*}
  324. %{!?_without_docs: %doc Documentation/*gitk*.html }
  325. %files -n perl-Git -f perl-files
  326. %defattr(-,root,root)
  327. %files -n emacs-git
  328. %defattr(-,root,root)
  329. %{_datadir}/emacs/site-lisp/git
  330. #%{_libdir}/emacsen-common/packages/install/git
  331. #%{_libdir}/emacsen-common/packages/remove/git
  332. %{emacsen_pkgdir}/install/git
  333. %{emacsen_pkgdir}/remove/git
  334. %files daemon
  335. %defattr(-,root,root)
  336. %{_var}/lib/git
  337. %{_libexecdir}/git-core/git-daemon
  338. %config(noreplace)%{_sysconfdir}/xinetd.d/git
  339. /srv/git
  340. %files -n gitweb
  341. %defattr(-,root,root)
  342. %doc gitweb/README
  343. /var/www/git/
  344. %config(noreplace)%{_sysconfdir}/gitweb.conf
  345. %config(noreplace)%{_sysconfdir}/httpd/conf.d/git.conf
  346. %files devel
  347. %defattr(644,root,root,755)
  348. %{_includedir}/git
  349. %{_libdir}/libgit.a
  350. %{_libdir}/libgit_xdiff.a
  351. %files all
  352. # No files for you!
  353. %changelog
  354. * Wed Jan 17 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 2.15.1-1
  355. - update to 2.15.1
  356. * Tue Aug 15 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.14.1-1
  357. - update to 2.14.1
  358. * Sun Jul 9 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.2-1
  359. - update to 2.13.2
  360. * Thu May 18 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.13.0-1
  361. - update to 2.13.0
  362. * Sun Mar 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.12.0-1
  363. - update to 2.12.0
  364. * Sat Feb 25 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.1-1
  365. - update to 2.11.1
  366. * Tue Dec 20 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.11.0-1
  367. - update to 2.11.0
  368. * Fri Nov 18 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2.10.2-2
  369. - include git-credential-gnome-keyring in contrib subpackage
  370. * Mon Nov 14 2016 Toshiaki Ara <ara_t@384.jp> 2.10.2-1
  371. - update to 2.10.2
  372. - fix build error using pcre-8.12 (Vine6)
  373. * Sun May 8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.2-1
  374. - update to 2.8.2.
  375. * Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.6-1
  376. - update to 2.6.6.
  377. * Thu Dec 31 2015 IWAI Masaharu <iwaim.sub@gmail.com> 2.6.4-1
  378. - update to 2.6.4
  379. - add locale files
  380. * Mon Dec 29 2014 IWAI Masaharu <iwaim.sub@gmail.com> 2.2.1-1
  381. - update to 2.2.1
  382. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-2
  383. - build with Perl 5.16
  384. * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.0.1-1
  385. - update to 2.0.1
  386. - add "%%bcond_with arch": no create git-arch sub package by default
  387. * Fri Apr 18 2014 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
  388. - update to 1.9.2
  389. * Sun Dec 29 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.5.2-1
  390. - update to 1.8.5.2
  391. * Thu Nov 28 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.8.4.4-1
  392. - update to 1.8.4.4
  393. - new sub package: contrib
  394. * Fri Feb 8 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.3-1
  395. - new upstream release
  396. * Tue Jan 29 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.2-1
  397. - new upstream release
  398. * Thu Jan 17 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1.1-1
  399. - new upstream release
  400. * Thu Jan 3 2013 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
  401. - new upstream release
  402. * Wed Dec 12 2012 IWAI, Masaharu <iwai@alib.jp> 1.8.0.2-1
  403. - new upstream release
  404. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0.1-1
  405. - new upstream release
  406. * Mon Oct 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  407. - new upstream release
  408. - enable libpcre support, add BR: pcre-devel
  409. - add /etc/gitweb.conf
  410. - add /var/lib/git for PROJECTROOT
  411. * Mon Sep 3 2012 IWAI, Masaharu <iwai@alib.jp> 1.7.12-1
  412. - new upstream release
  413. * Fri May 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.2-1
  414. - new upstream release
  415. * Sat May 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.10.1-1
  416. - new upstream release
  417. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.4.2-1
  418. - new upstream release
  419. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-2vl6
  420. - build with perl 5.12.3
  421. * Mon Jan 10 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.5-1
  422. - new upstream release
  423. - build with openssl 1.0.0c for VineSeed
  424. * Sat Jan 1 2011 IWAI, Masaharu <iwai@alib.jp> 1.7.3.4-1
  425. - new upstream release: include security fix: CVE-2010-3906
  426. * Fri Oct 1 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.3.1-1
  427. - new upstream release
  428. - drop CVE-2010-2542 patch (Patch100): upstream fixed
  429. - apply vine-default
  430. - rename Source1: git-init.el -> vine-default-git.el
  431. - add new git-init.el file (Source12)
  432. - update git-install.sh
  433. - update %%build and %%install section for gitweb subpackage
  434. - add README in gitweb subpackage
  435. * Tue Sep 28 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.1-2
  436. - add Patch100 for fix CVE-2010-2542 (BOF in is_git_directory)
  437. * Wed Jun 9 2010 IWAI, Masaharu <iwai@alib.jp> 1.7.1-1
  438. - new upstream release
  439. - fix git-daemon path in git.xinetd: <BTS:VineLinux:919>
  440. - disable building of unused python remote helper libs
  441. * Mon Jun 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.3-1
  442. - new upstream release with security fix
  443. - drop patch10 (included in new release)
  444. * Tue Jun 16 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.6.3.2-1
  445. - new upstream release
  446. - add patch10 git daemon extra arg parsing fix
  447. * Thu Apr 16 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-2
  448. - fix install script for Emacs Lisp: <BTS:VineLinux:685>
  449. - update git-install.sh (Source10) using contributed patch
  450. * Tue Apr 14 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.2.3-1
  451. - new upstream release
  452. * Sun Feb 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-3
  453. - delete arch sub package for Vine Linux 4.2: <BTS:VineLinux:667>
  454. - spec in EUC-JP for Vine Linux 4.2: <BTS:VineLinux:668>
  455. - fix summary and description in daemon sub package
  456. * Sun Feb 1 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-2
  457. - drop Error.pm: provide by perl-Error package
  458. * Thu Jan 29 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1.2-1
  459. - new upstream relase
  460. - update URL tag
  461. - add Requires: perl(SVN::Core) for svn subpackage
  462. * Thu Jan 22 2009 IWAI, Masaharu <iwai@alib.jp> - 1.6.1-3
  463. - add git-shell in git package
  464. - do not require perl(:MODULE_COMPAT_x.y.z) on Vine Linux 4.x
  465. * Mon Jan 5 2009 Shu KONNO <owa@bg.wakwak.com> - 1.6.1-2
  466. - added BuildRequires: xmlto
  467. * Mon Jan 5 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-1
  468. - new upstream release
  469. - add devel subpackage (see [wishes:0165])
  470. * Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.3-1
  471. - new upstream release
  472. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.2-1
  473. - new upstream release
  474. * Tue Aug 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0.1-1
  475. - new upstream release
  476. * Mon Aug 25 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.0-2
  477. - use %%emacsen_pkgdir macro
  478. * Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  479. - new upstream release
  480. * Wed Aug 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6.4-1
  481. - initial build for Vine Linux
  482. * Thu Jul 24 2008 James Bowes <jbowes@redhat.com> 1.5.6-4
  483. - git-1.5.6.4
  484. * Thu Jun 19 2008 James Bowes <jbowes@redhat.com> 1.5.6-1
  485. - git-1.5.6
  486. * Tue Jun 3 2008 Stepan Kasal <skasal@redhat.com> 1.5.5.3-2
  487. - use tar.bz2 instead of tar.gz
  488. * Wed May 28 2008 James Bowes <jbowes@redhat.com> 1.5.5.3-1
  489. - git-1.5.5.3
  490. * Mon May 26 2008 James Bowes <jbowes@redhat.com> 1.5.5.2-1
  491. - git-1.5.5.2
  492. * Mon Apr 21 2008 James Bowes <jbowes@redhat.com> 1.5.5.1-1
  493. - git-1.5.5.1
  494. * Wed Apr 09 2008 James Bowes <jbowes@redhat.com> 1.5.5-1
  495. - git-1.5.5
  496. * Fri Apr 04 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-3
  497. - Remove the last two requires on git-core.
  498. * Wed Apr 02 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-2
  499. - Remove a patch that's already upstream.
  500. * Fri Mar 28 2008 James Bowes <jbowes@redhat.com> 1.5.4.5-1
  501. - git-1.5.4.5
  502. * Wed Mar 26 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-4
  503. - Own /etc/bash_completion.d in case bash-completion isn't installed.
  504. * Tue Mar 25 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-3
  505. - Include the sample hooks from contrib/hooks as docs (bug 321151).
  506. - Install the bash completion script from contrib (bug 433255).
  507. - Include the html docs in the 'core' package again (bug 434271).
  508. * Wed Mar 19 2008 James Bowes 1.5.4.4-2
  509. - Obsolete git <= 1.5.4.3, to catch going from F8 to rawhide/F9
  510. * Thu Mar 13 2008 James Bowes <jbowes@redhat.com> 1.5.4.4-1
  511. - git-1.5.4.4
  512. * Mon Mar 3 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4.3-3
  513. - rebuild for new perl (again)
  514. * Sun Feb 24 2008 Bernardo Innocenti <bernie@codewiz.org> 1.5.4.3-2
  515. - Do not silently overwrite /etc/httpd/conf.d/git.conf
  516. * Sat Feb 23 2008 James Bowes <jbowes@redhat.com> 1.5.4.3-1
  517. - git-1.5.4.3
  518. - Include Kristian Høgsberg's changes to rename git-core to
  519. git and git to git-all.
  520. * Sun Feb 17 2008 James Bowes <jbowes@redhat.com> 1.5.4.2-1
  521. - git-1.5.4.2
  522. * Mon Feb 11 2008 Jeremy Katz <katzj@redhat.com> - 1.5.4.1-2
  523. - Add upstream patch (e62a641de17b172ffc4d3a803085c8afbfbec3d1) to have
  524. gitweb rss feeds point be commitdiffs instead of commit
  525. * Sun Feb 10 2008 James Bowes <jbowes@redhat.com> 1.5.4.1-1
  526. - git-1.5.4.1
  527. * Tue Feb 05 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.5.4-3
  528. - rebuild for new perl
  529. * Sun Feb 03 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  530. - Add BuidRequires on gettext.
  531. * Sat Feb 02 2008 James Bowes <jbowes@redhat.com> 1.5.4-1
  532. - git-1.5.4
  533. * Tue Jan 08 2008 James Bowes <jbowes@redhat.com> 1.5.3.8-1
  534. - git-1.5.3.8
  535. * Fri Dec 21 2007 James Bowes <jbowes@redhat.com> 1.5.3.7-2
  536. - Have git metapackage require explicit versions (bug 247214)
  537. * Mon Dec 03 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.7-1
  538. - git-1.5.3.7
  539. * Tue Nov 27 2007 Josh Boyer <jwboyer@gmail.com> 1.5.3.6-1
  540. - git-1.5.3.6
  541. - git-core requires perl(Error) (bug 367861)
  542. - git-svn requires perl(Term:ReadKey) (bug 261361)
  543. - git-email requires perl-Git (bug 333061)
  544. * Wed Oct 24 2007 Lubomir Kundrak <lkundrak@redhat.com> 1.5.3.4-2
  545. - git-Perl requires Error package
  546. * Tue Oct 09 2007 James Bowes <jbowes@redhat.com> 1.5.3.4-1
  547. - git-1.5.3.4
  548. * Sun Sep 30 2007 James Bowes <jbowes@redhat.com> 1.5.3.3-1
  549. - git-1.5.3.3
  550. * Wed Sep 26 2007 James Bowes <jbowes@redhat.com> 1.5.3.2-1
  551. - git-1.5.3.2
  552. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-2
  553. - Include git-gui and git-citool docs
  554. * Thu Sep 06 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.3.1-1
  555. - git-1.5.3.1-1
  556. * Thu Aug 23 2007 James Bowes <jbowes@redhat.com> 1.5.2.5-1
  557. - git-1.5.2.5-1
  558. * Fri Aug 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.4-1
  559. - git-1.5.2.4-1
  560. * Tue Jul 03 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-3
  561. - Add git-daemon and gitweb packages
  562. * Thu Jun 21 2007 Josh Boyer <jwboyer@jdub.homelinux.org> 1.5.2.2-2
  563. - Add emacs-git package (#235431)
  564. * Mon Jun 18 2007 James Bowes <jbowes@redhat.com> 1.5.2.2-1
  565. - git-1.5.2.2
  566. * Fri Jun 08 2007 James Bowes <jbowes@redhat.com> 1.5.2.1-1
  567. - git-1.5.2.1
  568. * Sun May 13 2007 Quy Tonthat <qtonthat@gmail.com>
  569. - Added lib files for git-gui
  570. - Added Documentation/technical (As needed by Git Users Manual)
  571. * Tue May 8 2007 Quy Tonthat <qtonthat@gmail.com>
  572. - Added howto files
  573. * Fri Mar 30 2007 Chris Wright <chrisw@redhat.com> 1.5.0.6-1
  574. - git-1.5.0.6
  575. * Mon Mar 19 2007 Chris Wright <chrisw@redhat.com> 1.5.0.5-1
  576. - git-1.5.0.5
  577. * Tue Mar 13 2007 Chris Wright <chrisw@redhat.com> 1.5.0.3-1
  578. - git-1.5.0.3
  579. * Fri Mar 2 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-2
  580. - BuildRequires perl-devel as of perl-5.8.8-14 (bz 230680)
  581. * Mon Feb 26 2007 Chris Wright <chrisw@redhat.com> 1.5.0.2-1
  582. - git-1.5.0.2
  583. * Tue Feb 13 2007 Nicolas Pitre <nico@cam.org>
  584. - Update core package description (Git isn't as stupid as it used to be)
  585. * Mon Feb 12 2007 Junio C Hamano <junkio@cox.net>
  586. - Add git-gui and git-citool.
  587. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-2
  588. - no need to install manpages executable (bz 216790)
  589. - use bytes for git-cvsserver
  590. * Sun Dec 10 2006 Chris Wright <chrisw@redhat.com> 1.4.4.2-1
  591. - git-1.4.4.2
  592. * Mon Nov 6 2006 Jindrich Novy <jnovy@redhat.com> 1.4.2.4-2
  593. - rebuild against the new curl
  594. * Tue Oct 17 2006 Chris Wright <chrisw@redhat.com> 1.4.2.4-1
  595. - git-1.4.2.4
  596. * Wed Oct 4 2006 Chris Wright <chrisw@redhat.com> 1.4.2.3-1
  597. - git-1.4.2.3
  598. * Fri Sep 22 2006 Chris Wright <chrisw@redhat.com> 1.4.2.1-1
  599. - git-1.4.2.1
  600. * Mon Sep 11 2006 Chris Wright <chrisw@redhat.com> 1.4.2-1
  601. - git-1.4.2
  602. * Thu Jul 6 2006 Chris Wright <chrisw@redhat.com> 1.4.1-1
  603. - git-1.4.1
  604. * Tue Jun 13 2006 Chris Wright <chrisw@redhat.com> 1.4.0-1
  605. - git-1.4.0
  606. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.3-1
  607. - git-1.3.3
  608. - enable git-email building, prereqs have been relaxed
  609. * Thu May 4 2006 Chris Wright <chrisw@redhat.com> 1.3.2-1
  610. - git-1.3.2
  611. * Fri Apr 28 2006 Chris Wright <chrisw@redhat.com> 1.3.1-1
  612. - git-1.3.1
  613. * Wed Apr 19 2006 Chris Wright <chrisw@redhat.com> 1.3.0-1
  614. - git-1.3.0
  615. * Mon Apr 10 2006 Chris Wright <chrisw@redhat.com> 1.2.6-1
  616. - git-1.2.6
  617. * Wed Apr 5 2006 Chris Wright <chrisw@redhat.com> 1.2.5-1
  618. - git-1.2.5
  619. * Wed Mar 1 2006 Chris Wright <chrisw@redhat.com> 1.2.4-1
  620. - git-1.2.4
  621. * Wed Feb 22 2006 Chris Wright <chrisw@redhat.com> 1.2.3-1
  622. - git-1.2.3
  623. * Tue Feb 21 2006 Chris Wright <chrisw@redhat.com> 1.2.2-1
  624. - git-1.2.2
  625. * Thu Feb 16 2006 Chris Wright <chrisw@redhat.com> 1.2.1-1
  626. - git-1.2.1
  627. * Mon Feb 13 2006 Chris Wright <chrisw@redhat.com> 1.2.0-1
  628. - git-1.2.0
  629. * Wed Feb 1 2006 Chris Wright <chrisw@redhat.com> 1.1.6-1
  630. - git-1.1.6
  631. * Tue Jan 24 2006 Chris Wright <chrisw@redhat.com> 1.1.4-1
  632. - git-1.1.4
  633. * Sun Jan 15 2006 Chris Wright <chrisw@redhat.com> 1.1.2-1
  634. - git-1.1.2
  635. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.1-1
  636. - git-1.1.1
  637. * Tue Jan 10 2006 Chris Wright <chrisw@redhat.com> 1.1.0-1
  638. - Update to latest git-1.1.0 (drop git-email for now)
  639. - Now creates multiple packages:
  640. - git-core, git-svn, git-cvs, git-arch, gitk
  641. * Mon Nov 14 2005 H. Peter Anvin <hpa@zytor.com> 0.99.9j-1
  642. - Change subpackage names to git-<name> instead of git-core-<name>
  643. - Create empty root package which brings in all subpackages
  644. - Rename git-tk -> gitk
  645. * Thu Nov 10 2005 Chris Wright <chrisw@osdl.org> 0.99.9g-1
  646. - zlib dependency fix
  647. - Minor cleanups from split
  648. - Move arch import to separate package as well
  649. * Tue Sep 27 2005 Jim Radford <radford@blackbean.org>
  650. - Move programs with non-standard dependencies (svn, cvs, email)
  651. into separate packages
  652. * Tue Sep 27 2005 H. Peter Anvin <hpa@zytor.com>
  653. - parallelize build
  654. - COPTS -> CFLAGS
  655. * Fri Sep 16 2005 Chris Wright <chrisw@osdl.org> 0.99.6-1
  656. - update to 0.99.6
  657. * Fri Sep 16 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  658. - Linus noticed that less is required, added to the dependencies
  659. * Sun Sep 11 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  660. - Updated dependencies
  661. - Don't assume manpages are gzipped
  662. * Thu Aug 18 2005 Chris Wright <chrisw@osdl.org> 0.99.4-4
  663. - drop sh_utils, sh-utils, diffutils, mktemp, and openssl Requires
  664. - use RPM_OPT_FLAGS in spec file, drop patch0
  665. * Wed Aug 17 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.99.4-3
  666. - use dist tag to differentiate between branches
  667. - use rpm optflags by default (patch0)
  668. - own %{_datadir}/git-core/
  669. * Mon Aug 15 2005 Chris Wright <chrisw@osdl.org>
  670. - update spec file to fix Buildroot, Requires, and drop Vendor
  671. * Sun Aug 07 2005 Horst H. von Brand <vonbrand@inf.utfsm.cl>
  672. - Redid the description
  673. - Cut overlong make line, loosened changelog a bit
  674. - I think Junio (or perhaps OSDL?) should be vendor...
  675. * Thu Jul 14 2005 Eric Biederman <ebiederm@xmission.com>
  676. - Add the man pages, and the --without docs build option
  677. * Thu Jul 7 2005 Chris Wright <chris@osdl.org>
  678. - initial git spec file