xorg-x11-utils-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233
  1. %define pkgname utils
  2. Summary: X.Org X11 X client utilities
  3. Summary(ja): X.Org X11 X クライアントユーティリティ
  4. Name: xorg-x11-%{pkgname}
  5. Version: 7.6
  6. Release: 3%{?_dist_release}
  7. License: MIT/X11
  8. Group: User Interface/X
  9. URL: http://www.x.org
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  11. Source0: ftp://ftp.x.org/pub/individual/app/xdpyinfo-1.3.0.tar.bz2
  12. Source1: ftp://ftp.x.org/pub/individual/app/xdriinfo-1.0.4.tar.bz2
  13. Source2: ftp://ftp.x.org/pub/individual/app/xev-1.2.0.tar.bz2
  14. Source3: ftp://ftp.x.org/pub/individual/app/xfd-1.1.1.tar.bz2
  15. Source4: ftp://ftp.x.org/pub/individual/app/xfontsel-1.0.3.tar.bz2
  16. Source5: ftp://ftp.x.org/pub/individual/app/xlsatoms-1.1.0.tar.bz2
  17. Source6: ftp://ftp.x.org/pub/individual/app/xlsclients-1.1.2.tar.bz2
  18. Source7: ftp://ftp.x.org/pub/individual/app/xlsfonts-1.0.3.tar.bz2
  19. Source8: ftp://ftp.x.org/pub/individual/app/xprop-1.2.1.tar.bz2
  20. Source9: ftp://ftp.x.org/pub/individual/app/xvinfo-1.1.1.tar.bz2
  21. Source10: ftp://ftp.x.org/pub/individual/app/xwininfo-1.1.2.tar.bz2
  22. Source100: edid-decode-20100205.tar.xz
  23. Source101: make-edid-decode-snapshot.sh
  24. BuildRequires: pkgconfig
  25. BuildRequires: libdmx-devel
  26. BuildRequires: libGL-devel
  27. BuildRequires: libXaw-devel >= 1.0.5
  28. BuildRequires: libXext-devel
  29. BuildRequires: libXft-devel
  30. BuildRequires: libXi-devel
  31. BuildRequires: libXinerama-devel
  32. BuildRequires: libXpm-devel
  33. BuildRequires: libXrandr-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: libXtst-devel
  36. BuildRequires: libXv-devel
  37. BuildRequires: libXxf86dga-devel
  38. BuildRequires: libXxf86misc-devel
  39. BuildRequires: libXxf86vm-devel
  40. BuildRequires: xcb-util-devel
  41. BuildRequires: xz
  42. # FIXME: check if still needed for X11R7
  43. Requires(pre): filesystem
  44. Provides: xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo
  45. Vendor: Project Vine
  46. Distribution: Vine Linux
  47. %description
  48. A collection of client utilities which can be used to query the X server
  49. for various information, view and select fonts, etc.
  50. %prep
  51. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a100
  52. %build
  53. # Build all apps
  54. {
  55. for app in * ; do
  56. pushd $app
  57. if [ -e ./configure ]; then
  58. %configure
  59. fi
  60. make
  61. popd
  62. done
  63. }
  64. %install
  65. rm -rf $RPM_BUILD_ROOT
  66. # Install all apps
  67. {
  68. for app in * ; do
  69. pushd $app
  70. make install DESTDIR=$RPM_BUILD_ROOT
  71. popd
  72. done
  73. }
  74. %clean
  75. rm -rf $RPM_BUILD_ROOT
  76. %files
  77. %defattr(-,root,root,-)
  78. %doc
  79. %{_bindir}/edid-decode
  80. %{_bindir}/xdpyinfo
  81. %{_bindir}/xdriinfo
  82. %{_bindir}/xev
  83. %{_bindir}/xfd
  84. %{_bindir}/xfontsel
  85. %{_bindir}/xlsatoms
  86. %{_bindir}/xlsclients
  87. %{_bindir}/xlsfonts
  88. %{_bindir}/xprop
  89. %{_bindir}/xvinfo
  90. %{_bindir}/xwininfo
  91. %dir %{_datadir}/X11
  92. %{_datadir}/X11/app-defaults/XFontSel
  93. %{_datadir}/X11/app-defaults/Xfd
  94. %{_mandir}/man1/xdpyinfo.1*
  95. %{_mandir}/man1/xdriinfo.1*
  96. %{_mandir}/man1/xev.1*
  97. %{_mandir}/man1/xfd.1*
  98. %{_mandir}/man1/xfontsel.1*
  99. %{_mandir}/man1/xlsatoms.1*
  100. %{_mandir}/man1/xlsclients.1*
  101. %{_mandir}/man1/xlsfonts.1*
  102. %{_mandir}/man1/xprop.1*
  103. %{_mandir}/man1/xvinfo.1*
  104. %{_mandir}/man1/xwininfo.1*
  105. %changelog
  106. * Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
  107. - xev-1.2.0
  108. - xfd-1.1.1
  109. - add BuildRequires: libXrandr-devel
  110. * Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
  111. - xdpyinfo-1.3.0
  112. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
  113. - xlsclients-1.1.2
  114. - xprop-1.2.1
  115. - xwininfo-1.1.2
  116. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
  117. - xdpyinfo-1.2.0
  118. - xdriinfo-1.0.4
  119. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
  120. - xev-1.1.0
  121. - xfd-1.1.0
  122. - xprop-1.2.0
  123. - xwininfo-1.1.1
  124. - xfontsel-1.0.3
  125. - xlsatoms-1.1.0
  126. - xlsclients-1.1.1
  127. - xlsfonts-1.0.3
  128. - xvinfo-1.1.1
  129. - add BuildRequires: xcb-utils-devel, xz
  130. * Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-2
  131. - add edid-decode snapshot
  132. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
  133. - xdpyinfo-1.1.0
  134. - xdriinfo-1.0.3
  135. - xev-1.0.4
  136. - xlsatoms-1.0.2
  137. - xlsclient-1.0.2
  138. - xprop-1.1.0
  139. - xvinfo-1.1.0
  140. - xwininfo-1.0.5
  141. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
  142. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  143. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
  144. - xdpyinfo 1.0.3
  145. - xev 1.0.3
  146. - xprop 1.0.4
  147. - xwininfo 1.0.4
  148. * Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
  149. - initial build for Vine Linux
  150. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.3-2
  151. - Autorebuild for GCC 4.3
  152. * Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
  153. - xdriinfo 1.0.2
  154. - xwininfo 1.0.3
  155. - Bump to 7.3
  156. * Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 7.2-1
  157. - xfontsel 1.0.2, xlsfonts 1.0.2, xvinfo 1.0.2, xprop 1.0.3
  158. * Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 7.1-4
  159. - xdpyinfo 1.0.2
  160. * Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-3
  161. - Fix man page glob and rebuild for FC7.
  162. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
  163. - Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
  164. - Add 'dist' tag to package release string.
  165. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
  166. - rebuild
  167. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
  168. - Bump package version to 7.1 to reflect the X11 release the utilities
  169. are aggregated from.
  170. - Updated to xdriinfo-1.0.1, xev-1.0.2, xwininfo-1.0.2 from X11R7.1
  171. * Wed May 31 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
  172. - Fix BuildRequires (#191966)
  173. * Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
  174. - Remove a spurious Xprint dependency from xdpyinfo.
  175. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  176. - bump again for double-long bug on ppc(64)
  177. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  178. - rebuilt for new gcc4.1 snapshot and glibc changes
  179. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  180. - Updated all tarballs to versions from X11R7.0
  181. * Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  182. - Updated all tarballs to version 1.0.0 from X11R7 RC4.
  183. - Changed manpage dir from man1x to man1 to match upstream RC4 default.
  184. - Moved all app-defaults files from _libdir to _datadir
  185. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
  186. - require newer filesystem package (#172610)
  187. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-2
  188. - rebuild
  189. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  190. - Initial build, with all apps taken from X11R7 RC2
  191. - Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
  192. some packages.