libesmtp-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231
  1. %define plugindir %{_libdir}/esmtp-plugins
  2. Summary: SMTP client library
  3. SUmmary(ja): SMTP クライアントライブラリ
  4. Name: libesmtp
  5. Version: 1.0.6
  6. Release: 2%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.stafford.uklinux.net/libesmtp/
  10. Source: http://www.stafford.uklinux.net/libesmtp/%{name}-%{version}.tar.bz2
  11. Patch1: libesmtp-build.patch
  12. Patch2: libesmtp-1.0.4-ssl.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: openssl-devel
  15. BuildRequires: pkgconfig
  16. %description
  17. LibESMTP is a library to manage posting (or submission of) electronic
  18. mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
  19. Exim. It may be used as part of a Mail User Agent (MUA) or another
  20. program that must be able to post electronic mail but where mail
  21. functionality is not the program's primary purpose.
  22. %package devel
  23. Summary: Headers and development libraries for libESMTP
  24. # example file is under the GPLv2+
  25. License: LGPLv2+ and GPLv2+
  26. Group: Development/Libraries
  27. Requires: %{name} = %{version}-%{release}
  28. Requires: openssl-devel
  29. %description devel
  30. LibESMTP is a library to manage posting (or submission of) electronic
  31. mail using SMTP to a preconfigured Mail Transport Agent (MTA) such as
  32. Exim.
  33. The libesmtp-devel package contains headers and development libraries
  34. necessary for building programs against libesmtp.
  35. #'
  36. %prep
  37. %setup -q
  38. %patch1 -p1 -b .build
  39. #patch2 -p1 -b .571817
  40. # Keep rpmlint happy about libesmtp-debuginfo...
  41. chmod a-x htable.c
  42. %build
  43. if pkg-config openssl ; then
  44. export CFLAGS="$CFLAGS $RPM_OPT_FLAGS `pkg-config --cflags openssl`"
  45. export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
  46. fi
  47. %configure \
  48. --with-auth-plugin-dir=%{plugindir} \
  49. --enable-pthreads \
  50. --enable-require-all-recipients \
  51. --enable-debug \
  52. --enable-etrn \
  53. --disable-isoc \
  54. --disable-more-warnings \
  55. --disable-static
  56. make %{?_smp_mflags}
  57. cat << "EOF" > libesmtp.pc
  58. prefix=%{_prefix}
  59. exec_prefix=%{_prefix}
  60. libdir=%{_libdir}
  61. includedir=%{_includedir}
  62. Name: libESMTP
  63. Version: %{version}
  64. Description: SMTP client library.
  65. Requires: openssl
  66. Libs: -pthread -L${libdir} -lesmtp
  67. Cflags:
  68. EOF
  69. cat << "EOF" > libesmtp-config
  70. #! /bin/sh
  71. exec pkg-config "$@" libesmtp
  72. EOF
  73. %install
  74. rm -rf $RPM_BUILD_ROOT
  75. make DESTDIR=$RPM_BUILD_ROOT install INSTALL='install -p'
  76. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  77. rm -f $RPM_BUILD_ROOT/%{_libdir}/esmtp-plugins/*.la
  78. install -p -m644 -D libesmtp.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/libesmtp.pc
  79. %clean
  80. rm -rf $RPM_BUILD_ROOT
  81. %post -p /sbin/ldconfig
  82. %postun -p /sbin/ldconfig
  83. %files
  84. %defattr(-,root,root,-)
  85. %doc AUTHORS COPYING.LIB NEWS Notes README
  86. %{_libdir}/libesmtp.so.*
  87. %{plugindir}
  88. %files devel
  89. %defattr(-,root,root,-)
  90. %doc examples COPYING
  91. %{_bindir}/libesmtp-config
  92. %{_prefix}/include/*
  93. %{_libdir}/libesmtp.so
  94. %{_libdir}/pkgconfig/libesmtp.pc
  95. %changelog
  96. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.6-2
  97. - rebuild with openssl-1.0.2
  98. * Thu Jan 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.0.6-1
  99. - updated to 1.0.6
  100. - dropt Patch2
  101. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-3
  102. - rebuild with openssl-1.0.0d
  103. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
  104. - rebuild with rpm-4.8.1 for pkg-config file
  105. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  106. - new upstream release
  107. - fix bug 599428: use 'version' macro instead of '_version'.
  108. - Use SSL patch by Ludwig Nussel of SUSE (bugzilla att id 399130).
  109. * Tue Mar 9 2010 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-13
  110. - fix CVE-2009-2408 (#571817).
  111. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.4-12
  112. - rebuilt with new openssl
  113. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-11
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  115. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-10
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  117. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.4-9
  118. - rebuild with new openssl
  119. * Sat Nov 1 2008 Manuel "lonely wolf" Wolfshant <wolfy@fedoraproject.org> - 1.0.4-8
  120. - do not package libtool files from the plugin directory
  121. * Fri Apr 4 2008 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-7
  122. - attempt at multilib support (#342011).
  123. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.4-6
  124. - Autorebuild for GCC 4.3
  125. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.0.4-5
  126. - Rebuild for deps
  127. * Sun Nov 18 2007 Patrice Dumas <pertusus@free.fr> - 1.0.4-4
  128. - use --disable-static
  129. * Thu Nov 15 2007 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-3
  130. - drop static libs as suggested in bug 377731.
  131. * Mon Sep 11 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-2
  132. - rebuild for FC6.
  133. * Fri Mar 24 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.4-1
  134. - Update to 1.0.4 - redo build and ssl patches.
  135. * Wed Mar 1 2006 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-8
  136. - Rebuild for Fedora Extras 5
  137. * Sun Dec 4 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-7
  138. - Fix bug 173332 completely, including licence issues.
  139. * Thu Nov 17 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-6
  140. - fix #173332.
  141. * Tue Nov 15 2005 Dan Williams <dcbw@redhat.com> - 1.0.3r1-5
  142. - rebuild against newer crypto libs
  143. * Wed Oct 19 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-4
  144. - fix crashes on certificates with subjectAltName extension. Fix #166844.
  145. * Sun Jun 12 2005 Pawel Salek <pawsa@theochem.kth.se> - 1.0.3r1-3
  146. - Add libesmtp-build.patch - fix building under FC4.
  147. * Thu Sep 30 2004 Miloslav Trmac <mitr@redhat.com> - 1.0.3r1-2
  148. - Include libesmtp-config in libesmtp-devel (#125426, patch by Robert Scheck)
  149. * Tue Jul 13 2004 John Dennis <jdennis@redhat.com> 1.0.3r1-1
  150. - bring up to latest upstream release
  151. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  152. - rebuilt
  153. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  154. - rebuilt
  155. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  156. - rebuilt
  157. * Thu Jan 29 2004 Bill Nottingham <notting@redhat.com> 1.0.2-1
  158. - upgrade to 1.0.2 (#113894)
  159. * Fri Oct 3 2003 Bill Nottingham <notting@redhat.com> 1.0.1-1
  160. - update to 1.0.1, rebuild to fix some broken 64-bit libs
  161. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  162. - rebuilt
  163. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  164. - rebuilt
  165. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 0.8.12-4
  166. - include compilation flags for openssl as defined for pkg-config
  167. - don't blow up on compile because key schedules aren't arrays
  168. * Tue Nov 5 2002 Bill Nottingham <notting@redhat.com> 0.8.12-3
  169. - build on various platforms
  170. * Tue Jul 23 2002 Bill Nottingham <notting@redhat.com> 0.8.12-2
  171. - fix broken lib (no pthread dependency)