libgit2-vl.spec 2.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. Summary: C implementation of the Git core methods as a library with a solid API
  2. Name: libgit2
  3. Version: 0.24.1
  4. Release: 1%{?_dist_release}
  5. License: GPLv2
  6. Group: System Environment/Libraries
  7. URL: https://libgit2.github.com/
  8. # https://github.com/libgit2/libgit2/archive/v0.23.3.tar.gz
  9. Source0: %{name}-%{version}.tar.gz
  10. BuildRequires: cmake
  11. BuildRequires: openssl-devel
  12. BuildRequires: http-parser-devel
  13. BuildRequires: libssh2-devel
  14. BuildRequires: zlib-devel
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. Vendor: Project Vine
  17. Distribution: Vine Linux
  18. Packager: Takemikaduchi
  19. %description
  20. libgit2 is a portable, pure C implementation of the Git core methods
  21. provided as a re-entrant linkable library with a solid API, allowing
  22. you to write native speed custom Git applications in any language
  23. which supports C bindings.
  24. %package devel
  25. Summary: Development tools for %{name}
  26. Summary(ja): %{name} の開発環境
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: pkgconfig
  30. Requires: openssl-devel
  31. Requires: http-parser-devel
  32. Requires: libssh2-devel
  33. Requires: zlib-devel
  34. %description devel
  35. Header files and libraries for building a extension library for the %{name}.
  36. %prep
  37. %setup -q
  38. %build
  39. rm -rf build && mkdir build && pushd build
  40. %cmake -DINSTALL_DOCS=OFF \
  41. ../
  42. make %{?_smp_mflags}
  43. popd
  44. %install
  45. rm -rf ${RPM_BUILD_ROOT}
  46. pushd build
  47. make install DESTDIR=${RPM_BUILD_ROOT}
  48. popd
  49. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
  50. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  51. %clean
  52. %{__rm} -rf ${RPM_BUILD_ROOT}
  53. %post -p /sbin/ldconfig
  54. %postun -p /sbin/ldconfig
  55. %files
  56. %defattr(-,root,root,-)
  57. %doc COPYING CHANGELOG.md README.md
  58. %{_libdir}/%{name}.so.*
  59. %files devel
  60. %defattr(-,root,root,-)
  61. %{_includedir}/git2/
  62. %{_includedir}/git2.h
  63. %{_libdir}/%{name}.so
  64. %{_libdir}/pkgconfig/%{name}.pc
  65. %changelog
  66. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.24.1-1
  67. - new upstream release
  68. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.23.3-1
  69. - new upstream release
  70. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-2
  71. - add BuildRequires: openssl-devel, http-parser-devel, libssh2-devel, zlib-devel
  72. * Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.22.2-1
  73. - initial build