openssh-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786
  1. %define ver 5.5p1
  2. %define rel 1%{_dist_release}
  3. # SELinux
  4. %define WITH_SELINUX 0
  5. # OpenSSH privilege separation requires a user & group ID
  6. %define sshd_uid 74
  7. %define sshd_gid 74
  8. # Version of ssh-askpass
  9. %define aversion 1.2.4.1
  10. # Do we want to disable building of x11-askpass? (1=yes 0=no)
  11. %define no_x11_askpass 0
  12. # Do we want to disable building of gnome-askpass? (1=yes 0=no)
  13. %define no_gnome_askpass 0
  14. # Use GTK2 for gnome-ssh-askpass
  15. %define gtk2 1
  16. # Build position-independent executables (requires toolchain support)?
  17. %define pie 1
  18. # Do we want to link against a static libcrypto? (1=yes 0=no)
  19. %define static_libcrypto 0
  20. # Do we want smartcard support (1=yes 0=no)
  21. %define scard 0
  22. # Disable IPv6 (avoids DNS hangs on some glibc versions)
  23. %define noip6 0
  24. # Do we want kerberos5 support (1=yes 0=no)
  25. %define kerberos5 0
  26. # Reserve options to override askpass settings with:
  27. # rpm -ba|--rebuild --define 'skip_xxx 1'
  28. %{?skip_x11_askpass:%define no_x11_askpass 1}
  29. %{?skip_gnome_askpass:%define no_gnome_askpass 1}
  30. # Options for static OpenSSL link:
  31. # rpm -ba|--rebuild --define "static_openssl 1"
  32. %{?static_openssl:%define static_libcrypto 1}
  33. # Options for Smartcard support: (needs libsectok and openssl-engine)
  34. # rpm -ba|--rebuild --define "smartcard 1"
  35. %{?smartcard:%define scard 1}
  36. # Option to disable ipv6
  37. # rpm -ba|--rebuild --define "noipv6 1"
  38. %{?noipv6:%define noip6 1}
  39. # Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
  40. %define rescue 0
  41. %{?build_rescue:%define rescue 1}
  42. # Turn off some stuff for resuce builds
  43. %if %{rescue}
  44. %define kerberos5 0
  45. %endif
  46. Summary: The OpenSSH implementation of SSH.
  47. Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
  48. Name: openssh
  49. Version: %{ver}
  50. Release: %{rel}
  51. URL: http://www.openssh.com/portable.html
  52. Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
  53. Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
  54. Patch0: openssh-5.5p1-vine.patch
  55. Patch2: openssh-5.3p1-skip-initial.patch
  56. Patch4: openssh-5.2p1-vendor.patch
  57. Patch5: openssh-3.9p1-noinitlog.patch
  58. Patch12: openssh-selinux.patch
  59. Patch20: openssh-3.9p1-gssapimitm.patch
  60. Patch21: openssh-3.9p1-safe-stop.patch
  61. Patch24: openssh-4.3p1-fromto-remote.patch
  62. Patch26: openssh-5.2p1-pam-no-stack.patch
  63. Patch27: openssh-5.1p1-log-in-chroot.patch
  64. Patch30: openssh-4.0p1-exit-deadlock.patch
  65. # Patch31: openssh-3.9p1-skip-used.patch
  66. Patch35: openssh-4.2p1-askpass-progress.patch
  67. # Vine Patch
  68. Patch100: openssh-norootlogin.patch
  69. Patch120: openssh-4.7p1-sshd.init.patch
  70. License: BSD
  71. Group: Applications/Internet
  72. BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
  73. Obsoletes: ssh
  74. PreReq: initscripts >= 5.20
  75. BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
  76. BuildRequires: util-linux
  77. BuildRequires: db4-devel
  78. BuildRequires: pam-devel
  79. BuildRequires: zlib-devel
  80. %if ! %{no_x11_askpass}
  81. BuildRequires: libX11-devel, libSM-devel, libXt-devel, libICE-devel
  82. %endif
  83. %if ! %{no_gnome_askpass}
  84. BuildRequires: libX11-devel
  85. BuildRequires: gtk2-devel
  86. %endif
  87. Vendor: Project Vine
  88. Distribution: Vine Linux
  89. Packager: daisuke
  90. %package clients
  91. Summary: OpenSSH clients.
  92. Summary(ja): OpenSSH Secure Shell プロトコルクライアント
  93. Requires: openssh = %{version}-%{release}
  94. Group: Applications/Internet
  95. Obsoletes: ssh-clients
  96. %package server
  97. Summary: The OpenSSH server daemon.
  98. Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
  99. Group: System Environment/Daemons
  100. Obsoletes: ssh-server
  101. PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
  102. Requires: pam
  103. %package askpass
  104. Summary: A passphrase dialog for OpenSSH and X.
  105. Summary(ja): OpenSSH X11 パスフレーズ入力ダイアログ
  106. Group: Applications/Internet
  107. Requires: openssh = %{version}-%{release}
  108. Obsoletes: ssh-extras
  109. %package askpass-gnome
  110. Summary: A passphrase dialog for OpenSSH, X, and GNOME.
  111. Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
  112. Group: Applications/Internet
  113. Requires: openssh = %{version}-%{release}
  114. Obsoletes: ssh-extras
  115. %package contrib
  116. Summary: addons for OpenSSH
  117. Summary(ja): OpenSSH のためのアドオン
  118. Group: Applications/Internet
  119. Requires: openssh-clients = %{version}-%{release}
  120. %description
  121. SSH (Secure SHell) is a program for logging into and executing
  122. commands on a remote machine. SSH is intended to replace rlogin and
  123. rsh, and to provide secure encrypted communications between two
  124. untrusted hosts over an insecure network. X11 connections and
  125. arbitrary TCP/IP ports can also be forwarded over the secure channel.
  126. OpenSSH is OpenBSD's version of the last free version of SSH, bringing
  127. it up to date in terms of security and features, as well as removing
  128. all patented algorithms to separate libraries.
  129. This package includes the core files necessary for both the OpenSSH
  130. client and server. To make this package useful, you should also
  131. install openssh-clients, openssh-server, or both.
  132. #'
  133. %description -l ja
  134. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  135. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  136. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  137. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  138. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  139. な通信路の中を通すことができます。
  140. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  141. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  142. アルゴリズムは分割したライブラリにわかれています。
  143. このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
  144. コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
  145. openssh-clients および/または openssh-server が必要です。
  146. %description clients
  147. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  148. into and executing commands on a remote machine. This package includes
  149. the clients necessary to make encrypted connections to SSH servers.
  150. You'll also need to install the openssh package on OpenSSH clients.
  151. #'
  152. %description -l ja clients
  153. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  154. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  155. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  156. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  157. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  158. な通信路の中を通すことができます。
  159. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  160. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  161. アルゴリズムは分割したライブラリにわかれています。
  162. このパッケージは OpenSSH をクライアントとして使用する場合に
  163. 必要なものを含んでいます。
  164. %description server
  165. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  166. into and executing commands on a remote machine. This package contains
  167. the secure shell daemon (sshd). The sshd daemon allows SSH clients to
  168. securely connect to your SSH server. You also need to have the openssh
  169. package installed.
  170. %description -l ja server
  171. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  172. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  173. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  174. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  175. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  176. な通信路の中を通すことができます。
  177. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  178. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  179. アルゴリズムは分割したライブラリにわかれています。
  180. このパッケージは OpenSSH をサーバとして使用する場合に必要な
  181. デーモンなどを含んでいます。
  182. %description askpass
  183. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  184. into and executing commands on a remote machine. This package contains
  185. an X11 passphrase dialog for OpenSSH.
  186. %description -l ja askpass
  187. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  188. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  189. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  190. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  191. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  192. な通信路の中を通すことができます。
  193. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  194. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  195. アルゴリズムは分割したライブラリにわかれています。
  196. このパッケージは Jim Knoble <jmknoble@jmknoble.cx> による X11 上の
  197. パスフレーズ入力ダイアログを含んでいます。
  198. %description askpass-gnome
  199. OpenSSH is a free version of SSH (Secure SHell), a program for logging
  200. into and executing commands on a remote machine. This package contains
  201. an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
  202. environment.
  203. %description -l ja askpass-gnome
  204. OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
  205. Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
  206. するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
  207. ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
  208. 可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
  209. な通信路の中を通すことができます。
  210. OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
  211. 最新のセキュリティと機能を提供しています。またすべての特許がからむ
  212. アルゴリズムは分割したライブラリにわかれています。
  213. このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
  214. %description contrib
  215. addons for OpenSSH
  216. %description -l ja contrib
  217. OpenSSH のためのアドオン
  218. %prep
  219. %if ! %{no_x11_askpass}
  220. %setup -q -a 1
  221. %else
  222. %setup -q
  223. %endif
  224. %patch0 -p1 -b .vine
  225. %patch2 -p1 -b .skip-initial
  226. %patch4 -p1 -b .vendor
  227. %patch5 -p1 -b .noinitlog
  228. %if %{WITH_SELINUX}
  229. #SELinux
  230. %patch12 -p1 -b .selinux
  231. %endif
  232. %patch21 -p1 -b .safe-stop
  233. %patch24 -p1 -b .fromto-remote
  234. %patch26 -p1 -b .stack
  235. %patch27 -p1 -b .log-chroot
  236. %patch30 -p1 -b .exit-deadlock
  237. %patch35 -p1 -b .progress
  238. %patch100 -p1 -b .norootlogin
  239. %patch120 -p1 -b .localtime
  240. autoreconf
  241. %build
  242. CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
  243. %if %{rescue}
  244. CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
  245. %endif
  246. %if %{pie}
  247. %ifarch s390 s390x sparc sparc64
  248. CFLAGS="$CFLAGS -fPIE"
  249. %else
  250. CFLAGS="$CFLAGS -fpie"
  251. %endif
  252. export CFLAGS
  253. LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
  254. %endif
  255. %configure \
  256. --sysconfdir=%{_sysconfdir}/ssh \
  257. --libexecdir=%{_libexecdir}/openssh \
  258. --datadir=%{_datadir}/openssh \
  259. --with-tcp-wrappers \
  260. --with-rsh=%{_bindir}/rsh \
  261. --with-default-path=/usr/local/bin:/bin:/usr/bin \
  262. --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
  263. --with-privsep-path=%{_var}/empty/sshd \
  264. --enable-vendor-patchlevel="VL-%{version}-%{release}" \
  265. %if %{scard}
  266. --with-smartcard \
  267. %endif
  268. %if %{noip6}
  269. --with-ipv4-default \
  270. %endif
  271. %if %{rescue}
  272. --without-pam --with-md5-passwords
  273. %else
  274. --with-pam
  275. %endif
  276. %if %{static_libcrypto}
  277. perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
  278. %endif
  279. make
  280. %if ! %{no_x11_askpass}
  281. pushd x11-ssh-askpass-%{aversion}
  282. %configure --libexecdir=%{_libexecdir}/openssh
  283. xmkmf -a
  284. make
  285. popd
  286. %endif
  287. %if %{gtk2}
  288. gtk2=yes
  289. %else
  290. gtk2=no
  291. %endif
  292. %if ! %{no_gnome_askpass}
  293. pushd contrib
  294. if [ $gtk2 = yes ]; then
  295. make gnome-ssh-askpass2
  296. mv gnome-ssh-askpass2 gnome-ssh-askpass
  297. else
  298. make gnome-ssh-askpass1
  299. mv gnome-ssh-askpass1 gnome-ssh-askpass
  300. fi
  301. popd
  302. %endif
  303. %install
  304. rm -rf $RPM_BUILD_ROOT
  305. mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
  306. mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
  307. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
  308. mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
  309. make install DESTDIR=$RPM_BUILD_ROOT
  310. touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
  311. install -d $RPM_BUILD_ROOT/etc/pam.d/
  312. install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
  313. install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
  314. install -m644 contrib/redhat/sshd.pam $RPM_BUILD_ROOT/etc/pam.d/sshd
  315. install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
  316. %if ! %{no_x11_askpass}
  317. install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
  318. ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
  319. %endif
  320. %if ! %{scard}
  321. rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
  322. %endif
  323. %if ! %{no_gnome_askpass}
  324. install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
  325. install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  326. install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
  327. %endif
  328. %if %{no_gnome_askpass}
  329. rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
  330. %endif
  331. # for contrib package
  332. install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
  333. install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
  334. mv contrib/README contrib/README.contrib
  335. perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
  336. %clean
  337. rm -rf $RPM_BUILD_ROOT
  338. %triggerun server -- ssh-server
  339. if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
  340. touch /var/run/sshd.restart
  341. fi
  342. %triggerun server -- openssh-server < 2.5.0p1
  343. # Count the number of HostKey and HostDsaKey statements we have.
  344. gawk 'BEGIN {IGNORECASE=1}
  345. /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
  346. END {exit sawhostkey}' /etc/ssh/sshd_config
  347. # And if we only found one, we know the client was relying on the old default
  348. # behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
  349. # specified. Now that HostKey is used for both SSH1 and SSH2 keys, specifying
  350. # one nullifies the default, which would have loaded both.
  351. if [ $? -eq 1 ] ; then
  352. echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
  353. echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
  354. fi
  355. %triggerpostun server -- ssh-server
  356. if [ "$1" != 0 ] ; then
  357. /sbin/chkconfig --add sshd
  358. if test -f /var/run/sshd.restart ; then
  359. rm -f /var/run/sshd.restart
  360. # /sbin/service sshd start > /dev/null 2>&1 || :
  361. /sbin/service sshd start
  362. fi
  363. fi
  364. %pre server
  365. %{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
  366. %{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
  367. -g sshd -M -r sshd 2>/dev/null || :
  368. %post server
  369. /sbin/chkconfig --add sshd
  370. %postun server
  371. # /sbin/service sshd condrestart > /dev/null 2>&1 || :
  372. /sbin/service sshd condrestart
  373. %preun server
  374. if [ "$1" = 0 ]
  375. then
  376. /sbin/service sshd stop > /dev/null 2>&1 || :
  377. /sbin/chkconfig --del sshd
  378. fi
  379. %files
  380. %defattr(-,root,root)
  381. %doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
  382. %attr(0755,root,root) %{_bindir}/scp
  383. %attr(0644,root,root) %{_mandir}/man1/scp.1*
  384. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  385. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
  386. %attr(644,root,root) %{_mandir}/man5/moduli.5*
  387. %if ! %{rescue}
  388. %attr(0755,root,root) %{_bindir}/ssh-keygen
  389. %attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
  390. %attr(0755,root,root) %dir %{_libexecdir}/openssh
  391. %attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
  392. %attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
  393. %endif
  394. %if %{scard}
  395. %attr(0755,root,root) %dir %{_datadir}/openssh
  396. %attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
  397. %endif
  398. %files clients
  399. %defattr(-,root,root)
  400. %attr(0755,root,root) %{_bindir}/ssh
  401. %attr(0644,root,root) %{_mandir}/man1/ssh.1*
  402. %attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
  403. %attr(0644,root,root) %{_mandir}/man1/slogin.1*
  404. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
  405. %attr(-,root,root) %{_bindir}/slogin
  406. %if ! %{rescue}
  407. %attr(0755,root,root) %{_bindir}/ssh-agent
  408. %attr(0755,root,root) %{_bindir}/ssh-add
  409. %attr(0755,root,root) %{_bindir}/ssh-keyscan
  410. %attr(0755,root,root) %{_bindir}/sftp
  411. %attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
  412. %attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
  413. %attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
  414. %attr(0644,root,root) %{_mandir}/man1/sftp.1*
  415. %endif
  416. %if ! %{rescue}
  417. %files server
  418. %defattr(-,root,root)
  419. %dir %attr(0711,root,root) %{_var}/empty/sshd
  420. %dir %attr(0755,root,root) %{_var}/empty/sshd/etc
  421. %ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
  422. %attr(0755,root,root) %{_sbindir}/sshd
  423. %attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
  424. %attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
  425. %attr(0644,root,root) %{_mandir}/man8/sshd.8*
  426. %attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
  427. %attr(0755,root,root) %dir %{_sysconfdir}/ssh
  428. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
  429. %attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
  430. %attr(0755,root,root) %config /etc/rc.d/init.d/sshd
  431. %endif
  432. %if ! %{no_x11_askpass}
  433. %files askpass
  434. %defattr(-,root,root)
  435. %doc x11-ssh-askpass-%{aversion}/README
  436. %doc x11-ssh-askpass-%{aversion}/ChangeLog
  437. %doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
  438. %attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
  439. %attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
  440. %endif
  441. %if ! %{no_gnome_askpass}
  442. %files askpass-gnome
  443. %defattr(-,root,root)
  444. %attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
  445. %attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
  446. %endif
  447. %files contrib
  448. %defattr(-,root,root)
  449. %doc contrib/README.contrib
  450. %{_bindir}/ssh-copy-id
  451. %{_mandir}/man1/ssh-copy-id.1*
  452. %changelog
  453. * Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
  454. - new upstream release
  455. - update patch0,2
  456. - drop patch3,22
  457. * Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
  458. - new upstream release
  459. * Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
  460. - new upstream release
  461. * Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
  462. - rebuild with xorg-x11-7.3
  463. * Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
  464. - new upstream release with security fix (CVE-2008-1483)
  465. - drop patch31 which is included in new release (This was for CVE-2008-1483)
  466. * Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
  467. - new upstream release with security fix ("ForceCommand" Directive)
  468. - turn on daemon restart message
  469. - new versioning policy
  470. * Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
  471. - add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
  472. * Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
  473. - new upstream release
  474. * Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
  475. - build with -fpie/-pie by default.
  476. - enable ipv6 by default.
  477. * Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
  478. - new upstream release
  479. * Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
  480. - new upstream release
  481. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
  482. - new upstream release
  483. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
  484. - new upstream release
  485. * Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
  486. - new upstream release
  487. - remove build6x stuff
  488. - remove libgnome-devel from BuildRequires
  489. - cleanup BuildRequires
  490. - drop Patch200, it is merged in upstream.
  491. - import patches(25-35) from FC-devel
  492. * Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
  493. - SECURITY FIX: CVE-2006-0225
  494. - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
  495. - update BuildPreReq: s/XFree86-devel/XOrg-devel/
  496. - fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
  497. - When GNOME2 is used, using libgnome-devel
  498. - add BuildPreReq: gtk2-devel for GNOME2
  499. * Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
  500. - rebuild with gtk+-2.8 final
  501. * Sun Sep 4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
  502. - new upstream release
  503. - build with gtk+-2.7
  504. * Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
  505. - new upstream release
  506. * Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
  507. - cleanup obsolete patches and added patches from fedora
  508. * Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
  509. - new upstream release
  510. * Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
  511. - new upstream release
  512. * Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
  513. - new upstream release
  514. * Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
  515. - rebuild with openssl-0.9.7d
  516. * Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
  517. - new upstream release
  518. * Thu Oct 2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
  519. - create contrib package
  520. * Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
  521. - new upstream release
  522. - fix security issue: http://www.openssh.com/txt/sshpam.adv
  523. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
  524. - new upstream release
  525. - fix security issue: http://www.openssh.com/txt/buffer.adv
  526. * Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
  527. - new upstream release
  528. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
  529. - rebuild with gtk2
  530. * Thu May 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
  531. - new upstream release
  532. * Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
  533. - rebuild with new tool chain
  534. * Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
  535. - new upstream release
  536. - merge with upstream spec (drop anonymous mmap patch, suid of ssh)
  537. * Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
  538. - change some defines in spec files
  539. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
  540. - add patch110 ( 3.4p1 does not include mmap-fallback patch )
  541. * Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
  542. - new upstream release
  543. - security fix
  544. - drop patch10
  545. * Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
  546. - add patch from Solar Designer to make privsep work with a 2.2 kernel.
  547. * Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
  548. - new upstream release
  549. - add {sshd,ssh}_config.5 manpages
  550. - add ssh-keysign
  551. * Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
  552. - new upstream release
  553. * Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
  554. - new upstream release
  555. - drop patch1
  556. * Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
  557. - new upstream release
  558. - merged with rawhide release.
  559. - drop Patch101 (merged in upstream)
  560. * Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
  561. - seurity patch for off-by-one bug
  562. * Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
  563. - merged with Rawhide 3.0.2p1-2
  564. * Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
  565. - updated to 3.0.2p1
  566. * Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
  567. - updated to 3.0.1p1
  568. * Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
  569. - updated to 3.0p1
  570. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
  571. - add japanese summery and descriptions.
  572. - update x11-askpass 1.2.5
  573. * Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
  574. - update to openssh-2.9.9p2
  575. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
  576. - rebuilt with openssl-0.9.6b
  577. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
  578. - do not Permit RootLogin
  579. * Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
  580. - update to openssh-2.5.2p2
  581. * Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
  582. - update to openssh-2.5.2p1
  583. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  584. - update to openssh-2.5.1p2
  585. * Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
  586. - update to openssh-2.5.1p1
  587. * Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
  588. - update to openssh-2.5.1p1
  589. * Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
  590. - remove suid bit from ssh
  591. * Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
  592. - moved man dir to /usr/share/man
  593. * Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
  594. - fixed askpass's link in ssh-add
  595. - partially used rpmmacros
  596. * Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
  597. - update to 2.3.0p1
  598. - update x11-askpass 1.0.3
  599. * Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
  600. - Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
  601. Redhat 7.0 spec file
  602. * Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
  603. - rebuild for Vine Linux
  604. * Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
  605. - Use RPM configure macro
  606. * Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
  607. - Some surgery to sshd.init (generate keys at runtime)
  608. - Cleanup of groups and removal of keygen calls
  609. * Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
  610. - Make building of X11-askpass and gnome-askpass optional
  611. * Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
  612. - Glob manpages to catch compressed files
  613. * Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
  614. - Updated for new location
  615. - Updated for new gnome-ssh-askpass build
  616. * Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
  617. - Added Jim Knoble's <jmknoble@pobox.com> askpass
  618. * Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
  619. - Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
  620. * Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
  621. - Added 'Obsoletes' directives
  622. * Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
  623. - Use make install
  624. - Subpackages
  625. * Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
  626. - Added links for slogin
  627. - Fixed perms on manpages
  628. * Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
  629. - Renamed init script
  630. * Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
  631. - Back to old binary names
  632. * Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
  633. - Use autoconf
  634. - New binary names
  635. * Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
  636. - Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.