tinyxml-vl.spec 3.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108
  1. %define underscore_version 2_6_1
  2. Name: tinyxml
  3. Version: 2.6.1
  4. Release: 1%{?_dist_release}
  5. Summary: A simple, small, C++ XML parser
  6. Summary(ja): シンプルで小さな C++ XML パーサー
  7. Group: System Environment/Libraries
  8. License: zlib
  9. URL: http://www.grinninglizard.com/tinyxml/
  10. Source0: http://downloads.sourceforge.net/%{name}/%{name}_%{underscore_version}.tar.gz
  11. Patch0: tinyxml-2.5.3-stl.patch
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. %description
  14. TinyXML is a simple, small, C++ XML parser that can be easily integrating
  15. into other programs. Have you ever found yourself writing a text file parser
  16. every time you needed to save human readable data or serialize objects?
  17. TinyXML solves the text I/O file once and for all.
  18. (Or, as a friend said, ends the Just Another Text File Parser problem.)
  19. %package devel
  20. Summary: Development files for %{name}
  21. Summary(ja): %{name} の開発ファイル
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. %description devel
  25. The %{name}-devel package contains libraries and header files for
  26. developing applications that use %{name}.
  27. %prep
  28. %setup -q -n %{name}
  29. %patch0 -p1 -b .stl
  30. touch -r tinyxml.h.stl tinyxml.h
  31. %build
  32. # Not really designed to be build as lib, DYI
  33. for i in tinyxml.cpp tinystr.cpp tinyxmlerror.cpp tinyxmlparser.cpp; do
  34. g++ $RPM_OPT_FLAGS -fPIC -o $i.o -c $i
  35. done
  36. g++ $RPM_OPT_FLAGS -shared -o lib%{name}.so.0.%{version} \
  37. -Wl,-soname,lib%{name}.so.0 *.cpp.o
  38. %install
  39. rm -rf $RPM_BUILD_ROOT
  40. # Not really designed to be build as lib, DYI
  41. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  42. mkdir -p $RPM_BUILD_ROOT%{_includedir}
  43. install -m 755 lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}
  44. ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so.0
  45. ln -s lib%{name}.so.0.%{version} $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
  46. install -p -m 644 %{name}.h $RPM_BUILD_ROOT%{_includedir}
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %post -p /sbin/ldconfig
  50. %postun -p /sbin/ldconfig
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc changes.txt readme.txt
  54. %{_libdir}/*.so.*
  55. %files devel
  56. %defattr(-,root,root,-)
  57. %doc docs/*
  58. %{_includedir}/*
  59. %{_libdir}/*.so
  60. %changelog
  61. * Tue Mar 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.1-1
  62. - new upstream release
  63. * Mon Mar 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.6.0-1
  64. - new upstream release
  65. - applied new naming policy to spec
  66. - added summary(ja)
  67. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.5.3-3
  68. - rebuilt with new toolchain
  69. * Sat May 9 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-2vl5
  70. - fixed %BuildRoot
  71. - spec in UTF-8
  72. * Wed Jan 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.3-1vl5
  73. - initial build for VineSeed
  74. - import Fedora's 2.5.3-3
  75. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.5.3-3
  76. - Autorebuild for GCC 4.3
  77. * Fri Dec 14 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-2
  78. - Various improvements from review (bz 407571)
  79. * Fri Nov 30 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.5.3-1
  80. - Initial Fedora Package