xlockmore-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. %define orgname xlockmore
  2. # if you want to make kterm_plus version,
  3. # uncomment below line, or rpm --define withgl:1
  4. # % define withgl 1
  5. %define name %{orgname}%{?withgl:_gl}
  6. %define version 5.29.1
  7. %define release 2%{?_dist_release}
  8. Summary: An X terminal locking program.
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. License: MIT
  13. Group: Amusements/Graphics
  14. Url: http://www.tux.org/~bagleyd/xlockmore.html
  15. Source0: ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/xlockmore-%{version}.tar.bz2
  16. Source1: m-redhat.xpm
  17. Source2: m-redhat.xbm
  18. Source3: s-redhat.xpm
  19. Source4: s-redhat.xbm
  20. Source5: xlock.pamd
  21. Patch0: xlockmore-5.02-sounddir.patch
  22. BuildPrereq: esound-devel, audiofile-devel
  23. Requires: pam >= 0.59, esound, audiofile, fortune-mod
  24. BuildRequires: flex
  25. BuildRequires: pam-devel
  26. BuildRequires: libX11-devel
  27. BuildRequires: libXt-devel
  28. BuildRequires: libXinerama-devel
  29. BuildRequires: libXext-devel
  30. %{?withgl:Requires: Mesa, gle}
  31. %{?withgl:BuildPreReq: Mesa-devel, gle-devel}
  32. %{?withgl:Provides: xlockmore}
  33. Conflicts: %{orgname}%{!?withgl:_gl}
  34. Buildroot: %{_tmppath}/%{name}-%{version}-root
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. %define gldesc %{?withgl:This package has MesaGL feature.}
  38. %define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
  39. %description
  40. The xlockmore utility is an enhanced version of the standard xlock
  41. program, which allows you to lock an X session so that other users
  42. can't access it. Xlockmore runs a provided screensaver until you type
  43. in your password.
  44. Install the xlockmore package if you need a locking program to secure
  45. X sessions.
  46. %{gldesc}
  47. %description
  48. xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
  49. X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
  50. セスできないようにします.
  51. %{gldescja}
  52. %prep
  53. %setup -q -n %{orgname}-%{version}
  54. %patch0 -p1 -b .sounddir
  55. cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
  56. cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
  57. cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
  58. cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
  59. cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
  60. cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
  61. %build
  62. #autoconf-2.13
  63. %define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
  64. %define glflag %{?withgl:--with-mesa --with-gltt}
  65. #%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
  66. # --mandir=/usr/X11R6/man/man1 --without-motif --without-gtk --enable-pam \
  67. # --with-esound %{glflag} %{nglflag}
  68. %configure --without-motif --without-gtk --without-gtk2 --enable-pam --with-esound %{glflag} %{nglflag}
  69. make
  70. # recompile xlockgen for each architecture
  71. make -C etc/genlauncher xlockgen
  72. %install
  73. rm -rf %{buildroot}
  74. mkdir -p %{buildroot}/etc/pam.d
  75. #%%makeinstall \
  76. # exec_prefix=%{buildroot}/usr/X11R6/ \
  77. # bindir=%{buildroot}/usr/X11R6/bin \
  78. # mandir=%{buildroot}/usr/X11R6/man/man1 \
  79. # xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/ \
  80. # INSTPGMFLAGS="-m 755"
  81. %makeinstall \
  82. mandir=%{buildroot}%{_mandir}/man1 \
  83. xapploaddir=%{buildroot}%{_datadir}/X11/app-defaults/ \
  84. INSTPGMFLAGS="-m 755"
  85. install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
  86. mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
  87. install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
  88. (cd etc
  89. sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
  90. mv xlock.tcl.new xlock.tcl
  91. # chmod +x xlock.tcl
  92. )
  93. # eliminate executable bit in %doc
  94. find etc/ -type f -perm +111 | xargs -r chmod -x
  95. %clean
  96. rm -rf %{buildroot}
  97. %files
  98. %defattr(-,root,root)
  99. %doc README docs/ etc/
  100. %attr(4111,root,root)%{_bindir}/xlock
  101. %config %{_sysconfdir}/pam.d/xlock
  102. %config %{_datadir}/X11/app-defaults/XLock
  103. %{_datadir}/sounds/xlockmore/
  104. %{_mandir}/man1/xlock.*
  105. %changelog
  106. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-2
  107. - add BuildRequires: libXinerama-devel, libXext-devel (for Vine Linux 5.0)
  108. - fix xlock.pamd (required pam_unix.so -> include system-auth)
  109. * Sat Jan 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-1
  110. - new upstream release
  111. - add configure option: --without-gtk2
  112. - add BuildRequires: flex, pam-devel, libX11-devel, libXt-devel
  113. - fixed xlock.pamd (pam_stack.so -> pam_unix.so)
  114. - comment out: autoconf-2.13
  115. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 5.03-1vl5
  116. - applied new versioning policy, spec in utf-8
  117. - fixed autoconf version
  118. - modified install directories
  119. * Tue Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
  120. - updated to current stable release 5.03
  121. - use %%configure, %%makeinstall
  122. - added patch for DEFALUT_SOUND_DIR
  123. * Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
  124. - typo fixed: --without-mesagl -> --without-mesa
  125. * Sun Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  126. - add Conflicts tag
  127. * Fri Aug 17 2001 <sagami@vinelinux.org>
  128. - 5.01.2-0vl1: bump up release
  129. * Wed Jul 18 2001 <sagami@vinelinux.org>
  130. - 5.01.2-0vl0: updated to current stable release 5.01.2
  131. * Mon Apr 2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
  132. - bug fix for withgl option
  133. * Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
  134. - bug fix in Provides for withgl
  135. - build with gle
  136. * Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
  137. - added switch withgl
  138. * Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
  139. - recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
  140. for each architecture (to resolve unmet dependency)
  141. * Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
  142. - 4.17.2-0vl4
  143. - eliminate executable bit in %doc (requierment for /bin/ksh etc.)
  144. * Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
  145. - build on gcc-2.95.3
  146. - partialy used rpmmacros
  147. * Tue Nov 7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
  148. - change filedepend to package name depend
  149. * Sat Sep 2 2000 Jun Nishii <jun@vinelinux.org>
  150. - 4.17.2-0vl1
  151. * Fri Sep 1 2000 Jun Nishii <jun@vinelinux.org>
  152. - 4.17.1-0vl1
  153. - upgrade and build without GL
  154. - added docs etc
  155. * Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
  156. - wmconfig gone.
  157. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  158. - handle compressed man pages
  159. * Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
  160. - fun with GL
  161. * Tue Nov 9 1999 Bill Nottingham <notting@redhat.com>
  162. - update to 4.15
  163. * Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
  164. - update to 4.13.1
  165. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  166. - auto rebuild in the new build environment (release 2)
  167. * Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
  168. - update to 4.12
  169. * Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
  170. - take out some modules to avoid TMv
  171. * Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
  172. - turned PAM support on in ./configure
  173. * Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
  174. - Upgraded to 4.11
  175. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  176. - translations modified for de, fr, tr
  177. * Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
  178. - upgraded to 4.09
  179. - removed Michael's PAM patch (it's now available in the sources)
  180. * Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
  181. - upgrade to 4.05
  182. - add wmconfig
  183. * Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
  184. - Upgraded to 4.04
  185. - Changed pam to new conventions
  186. - Use configure instead of imake
  187. - buildroot
  188. * Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
  189. - built against glibc
  190. * Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
  191. - moved from pam.conf to pam.d