docker-ce-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. %bcond_with build_nosrc
  2. %if !%{with build_nosrc}
  3. %global _disable_source_fetch 0
  4. %endif
  5. Name: docker-ce
  6. Version: 19.03.8
  7. Release: 1%{?_dist_release}
  8. Summary: The open-source application container engine
  9. Group: Development/Tools
  10. License: ASL 2.0
  11. URL: https://www.docker.com
  12. Source0: https://download.docker.com/linux/static/stable/x86_64/docker-%{version}.tgz
  13. Source1: https://github.com/docker/docker-ce/raw/v%{version}/README.md
  14. Source2: https://github.com/docker/docker-ce/raw/v%{version}/components/cli/LICENSE
  15. Source10: docker.init
  16. Source11: docker.sysconfig
  17. Source12: docker.conf
  18. %if %{with build_nosrc}
  19. NoSource: 0
  20. NoSource: 1
  21. NoSource: 2
  22. %endif
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: tomop
  26. # required packages on install
  27. Requires: /bin/sh
  28. Requires: libcgroup
  29. Requires: docker-ce-cli = %{version}-%{release}
  30. Conflicts: docker-ee
  31. Conflicts: docker-ee-cli
  32. %description
  33. Docker is is a product for you to build, ship and run any application as a
  34. lightweight container.
  35. Docker containers are both hardware-agnostic and platform-agnostic. This means
  36. they can run anywhere, from your laptop to the largest cloud compute instance and
  37. everything in between - and they don't require you to use a particular
  38. language, framework or packaging system. That makes them great building blocks
  39. for deploying and scaling web apps, databases, and backend services without
  40. depending on a particular stack or provider.
  41. %package cli
  42. Summary: clients for Docker
  43. Group: Development/Tools
  44. %description cli
  45. Docker is is a product for you to build, ship and run any application as a
  46. lightweight container.
  47. Docker containers are both hardware-agnostic and platform-agnostic. This means
  48. they can run anywhere, from your laptop to the largest cloud compute instance and
  49. everything in between - and they don't require you to use a particular
  50. language, framework or packaging system. That makes them great building blocks
  51. for deploying and scaling web apps, databases, and backend services without
  52. depending on a particular stack or provider.
  53. %prep
  54. %setup -q -c -n docker
  55. %build
  56. # %check
  57. # cli/build/docker -v
  58. %install
  59. # install binary
  60. install -d %{buildroot}%{_bindir}
  61. install -d %{buildroot}%{_localstatedir}/lib/docker
  62. install -d %{buildroot}%{_localstatedir}/run/docker
  63. install -d %{buildroot}%{_initdir}
  64. install -d %{buildroot}%{_sysconfdir}/sysconfig
  65. install -d %{buildroot}%{_sysconfdir}/rsyslog.d
  66. for f in docker/*; do
  67. install -p -m 755 $f %{buildroot}%{_bindir}/
  68. done
  69. install -p -m 755 %{SOURCE10} %{buildroot}%{_initdir}/docker
  70. install -p -m 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/docker
  71. install -p -m 644 %{SOURCE12} %{buildroot}%{_sysconfdir}/rsyslog.d/docker
  72. install -p -m 644 %{SOURCE1} ./
  73. install -p -m 644 %{SOURCE2} ./
  74. %clean
  75. rm -rf %{buildroot}
  76. %post
  77. if ! getent group docker > /dev/null; then
  78. groupadd --system docker
  79. fi
  80. if [ $1 -eq 1 ]; then
  81. /sbin/chkconfig --add docker
  82. fi
  83. %preun
  84. if [ $1 -eq 0 ]; then
  85. /sbin/chkconfig docker off
  86. /sbin/chkconfig --del docker
  87. fi
  88. # list files owned by the package here
  89. %files
  90. %defattr(-,root,root,-)
  91. %license LICENSE
  92. %doc README.md
  93. %{_bindir}/containerd
  94. %{_bindir}/containerd-shim
  95. %{_bindir}/ctr
  96. %{_bindir}/docker-init
  97. %{_bindir}/docker-proxy
  98. %{_bindir}/dockerd
  99. %dir %{_localstatedir}/run/docker
  100. %dir %{_localstatedir}/lib/docker
  101. %{_initdir}/docker
  102. %config(noreplace) %{_sysconfdir}/sysconfig/docker
  103. %config(noreplace) %{_sysconfdir}/rsyslog.d/docker
  104. %files cli
  105. %defattr(-,root,root,-)
  106. %license LICENSE
  107. %doc README.md
  108. %{_bindir}/docker
  109. %{_bindir}/runc
  110. %changelog
  111. * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.08-1
  112. - new upstream release.
  113. * Thu Oct 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.03-1
  114. - new upstream release.
  115. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-2
  116. - updated initscript: added syslog support.
  117. * Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-1
  118. - initial build for Vine Linux.