nginx-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.16.0
  26. Release: 3%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.4.3
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  48. %define nginx_accept_language_module_version 2f69842
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. ## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
  51. %define passenger_version 6.0.2
  52. Source1020: passenger-%{passenger_version}.tar.gz
  53. %define upstream_fair_version a18b409
  54. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  55. %define mod_wsgi_version 6975f0ec7eeb
  56. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  57. %define nginx_dav_ext_module_version 3.0.0
  58. Source2010: https://github.com/arut/nginx-dav-ext-module/archive/v%{nginx_dav_ext_module_version}.tar.gz#/nginx-dav-ext-module-%{nginx_dav_ext_module_version}.tar.gz
  59. %global naxsi_version untagged-afabfc163946baa8036f
  60. Source2020: https://github.com/nbs-system/naxsi/archive/untagged-afabfc163946baa8036f.tar.gz#/naxsi-%{naxsi_version}.tar.gz
  61. Source2021: naxsi_params
  62. # removes -Werror in upstream build scripts. -Werror conflicts with
  63. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  64. Patch0: nginx-auto-cc-gcc.patch
  65. # to fix https://svn.boost.org/trac/boost/ticket/8731
  66. Patch100: boost-changeset_84950.diff
  67. # to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
  68. Patch101: gnosek-nginx-upstream-fair-pull-23.patch
  69. # to fix compile error with C++11.
  70. Patch1000: passenger-5.0.28-boost.patch
  71. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  72. %if "%{_dist_release}" > "vl6"
  73. BuildRequires: libboost-devel
  74. %endif
  75. BuildRequires: libxcrypt-devel
  76. BuildRequires: libnsl2-devel
  77. BuildRequires: pcre-devel
  78. BuildRequires: zlib-devel
  79. BuildRequires: openssl-devel
  80. BuildRequires: gd-devel
  81. BuildRequires: perl
  82. BuildRequires: perl(ExtUtils::Embed)
  83. BuildRequires: libxml2-devel
  84. BuildRequires: libxslt-devel
  85. BuildRequires: curl-devel
  86. %if %{with geoip}
  87. BuildRequires: GeoIP-devel
  88. %endif
  89. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  90. # for /usr/sbin/useradd
  91. Requires(pre): shadow-utils
  92. Requires(post): chkconfig
  93. # for /sbin/service
  94. Requires(preun): chkconfig, initscripts
  95. Requires(postun): initscripts
  96. %if "%{_dist_release}" > "vl6"
  97. Requires(pre): www-common
  98. %endif
  99. Provides: webserver
  100. Vendor: Project Vine
  101. Distribution: Vine Linux
  102. Packager: daisuke
  103. %description
  104. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  105. proxy server written by Igor Sysoev.
  106. %description -l ja
  107. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  108. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  109. - HTTP(S) サーバ
  110. - HTTP(S) リバースプロキシサーバ
  111. - IMAP/POP3 プロキシサーバ
  112. %package passenger
  113. Summary: Nginx with mod_passenger support
  114. Summary(ja): Passenger サポート入りの Nginx
  115. Group: System Environment/Daemons
  116. BuildRequires: ruby, rubygem-rake
  117. Requires: ruby, rubygem-rake
  118. %if "%{_dist_release}" >= "vl7"
  119. BuildRequires: ruby-devel, ruby-rubygems
  120. Requires: ruby-rubygems
  121. %else
  122. BuildRequires: rubygems
  123. Requires: rubygems
  124. %endif
  125. Requires: nginx
  126. %description passenger
  127. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  128. This package contains nginx server with passenger support.
  129. %description -l ja passenger
  130. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  131. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  132. - HTTP(S) サーバ
  133. - HTTP(S) リバースプロキシサーバ
  134. - IMAP/POP3 プロキシサーバ
  135. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  136. %prep
  137. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000} -a 2010 -a 2020
  138. %patch0 -p0
  139. # pushd passenger-%{passenger_version}/ext/
  140. # %patch100 -p2
  141. # popd
  142. pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
  143. %patch101 -p1
  144. popd
  145. %if %{?_dist_release} == "vl7"
  146. pushd passenger-%{passenger_version}
  147. #% patch1000 -p1
  148. popd
  149. %endif
  150. %build
  151. # nginx does not utilize a standard configure script. It has its own
  152. # and the standard configure options cause the nginx configure script
  153. # to error out. This is is also the reason for the DESTDIR environment
  154. # variable. The configure script(s) have been patched (Patch1 and
  155. # Patch2) in order to support installing into a build environment.
  156. export DESTDIR=%{buildroot}
  157. CONFIGOPTS="\
  158. --user=%{nginx_user} \
  159. --group=%{nginx_group} \
  160. --prefix=%{nginx_datadir} \
  161. --sbin-path=%{_sbindir}/%{name} \
  162. --conf-path=%{nginx_confdir}/%{name}.conf \
  163. --error-log-path=%{nginx_logdir}/error.log \
  164. --http-log-path=%{nginx_logdir}/access.log \
  165. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  166. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  167. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  168. --pid-path=%{_localstatedir}/run/%{name}.pid \
  169. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  170. --with-file-aio \
  171. --with-ipv6 \
  172. --with-http_ssl_module \
  173. --with-http_v2_module \
  174. --with-http_realip_module \
  175. --with-http_addition_module \
  176. --with-http_xslt_module \
  177. --with-http_image_filter_module \
  178. %if %{with geoip}
  179. --with-http_geoip_module \
  180. %endif
  181. --with-http_sub_module \
  182. --with-http_dav_module \
  183. --with-http_flv_module \
  184. --with-http_mp4_module \
  185. --with-http_gunzip_module \
  186. --with-http_gzip_static_module \
  187. --with-http_auth_request_module \
  188. --with-http_random_index_module \
  189. --with-http_secure_link_module \
  190. --with-http_degradation_module \
  191. --with-http_stub_status_module \
  192. --with-http_perl_module \
  193. --with-mail \
  194. --with-mail_ssl_module \
  195. --with-stream \
  196. --with-stream_ssl_preread_module \
  197. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  198. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  199. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  200. %if %{with wsgi}
  201. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  202. %endif
  203. --add-module=nginx-dav-ext-module-%{nginx_dav_ext_module_version} \
  204. --add-module=naxsi-%{naxsi_version}/naxsi_src \
  205. %ifarch i686
  206. --with-cpu-opt=pentiumpro \
  207. --with-zlib-asm=pentiumpro \
  208. --with-md5-asm \
  209. --with-sha1-asm \
  210. %endif
  211. "
  212. ## build with passenger
  213. ./configure \
  214. $CONFIGOPTS \
  215. --with-cc-opt="%{optflags}" \
  216. --add-module=passenger-%{passenger_version}/src/nginx_module
  217. make %{?_smp_mflags}
  218. mv objs/nginx objs/nginx.passenger
  219. ## build without passenger
  220. ./configure \
  221. $CONFIGOPTS \
  222. --with-cc-opt="%{optflags}"
  223. make %{?_smp_mflags}
  224. %install
  225. rm -rf %{buildroot}
  226. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  227. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  228. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  229. find %{buildroot} -type f -empty -exec rm -f {} \;
  230. find %{buildroot} -type f -exec chmod 0644 {} \;
  231. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  232. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  233. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  234. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  235. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  236. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  237. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  238. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  239. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  240. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  241. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  242. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  243. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  244. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  245. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  246. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  247. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  248. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  249. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  250. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  251. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  252. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  253. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  254. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  255. %if %{with wsgi}
  256. %{__install} -p -m 0644 \
  257. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  258. %{buildroot}%{nginx_confdir}
  259. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  260. %endif
  261. # upstream fair module document
  262. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  263. # document for nginx-dav-ext-module
  264. cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/LICENSE LICENSE.dav-ext-module
  265. cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/README.rst README.dav-ext-module.rst
  266. # NAXSI module
  267. cp -f naxsi-%{naxsi_version}/LICENSE LICENSE.naxsi
  268. cp -f naxsi-%{naxsi_version}/README.md README.naxsi.md
  269. install -p -m0644 naxsi-%{naxsi_version}/naxsi_config/naxsi_core.rules %{buildroot}%{nginx_confdir}/
  270. install -p -m0644 %{SOURCE2021} %{buildroot}%{nginx_confdir}/naxsi_params
  271. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  272. # convert to UTF-8 all files that give warnings.
  273. for textfile in CHANGES
  274. do
  275. mv $textfile $textfile.old
  276. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  277. rm -f $textfile.old
  278. done
  279. %clean
  280. rm -rf %{buildroot}
  281. %post
  282. if [ $1 == 1 ]; then
  283. /sbin/chkconfig --add %{name}
  284. fi
  285. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  286. %post passenger
  287. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  288. %preun
  289. if [ $1 = 0 ]; then
  290. /sbin/service %{name} stop >/dev/null 2>&1
  291. /sbin/chkconfig --del %{name}
  292. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  293. fi
  294. %preun passenger
  295. if [ $1 = 0 ]; then
  296. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  297. fi
  298. %postun
  299. if [ $1 == 2 ]; then
  300. /sbin/service %{name} upgrade || :
  301. fi
  302. %files
  303. %defattr(-,root,root,-)
  304. %doc LICENSE CHANGES README LICENSE.dav-ext-module LICENSE.naxsi
  305. %doc README.upstream_fair
  306. %doc README.dav-ext-module.rst
  307. %doc README.naxsi.md
  308. %doc %{?with_wsgi:README.mod_wsgi}
  309. %{nginx_datadir}/
  310. %{_sbindir}/%{name}.normal
  311. %{_mandir}/man3/%{name}.3pm.gz
  312. %{_initrddir}/%{name}
  313. %dir %{nginx_confdir}
  314. %dir %{nginx_confdir}/conf.d
  315. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  316. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  317. %config(noreplace) %{nginx_confdir}/sites.d/*
  318. %config(noreplace) %{nginx_confdir}/win-utf
  319. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  320. %config(noreplace) %{nginx_confdir}/mime.types.default
  321. %config(noreplace) %{nginx_confdir}/fastcgi_params
  322. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  323. %config(noreplace) %{nginx_confdir}/koi-win
  324. %config(noreplace) %{nginx_confdir}/koi-utf
  325. %config(noreplace) %{nginx_confdir}/%{name}.conf
  326. %config(noreplace) %{nginx_confdir}/mime.types
  327. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  328. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  329. %config(noreplace) %{nginx_confdir}/scgi_params
  330. %config(noreplace) %{nginx_confdir}/scgi_params.default
  331. %config(noreplace) %{nginx_confdir}/uwsgi_params
  332. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  333. %if %{with wsgi}
  334. %config(noreplace) %{nginx_confdir}/wsgi_vars
  335. %endif
  336. %config(noreplace) %{nginx_confdir}/naxsi_params
  337. %config(noreplace) %{nginx_confdir}/naxsi_core.rules
  338. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  339. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  340. %dir %{perl_vendorarch}/auto/%{name}
  341. %{perl_vendorarch}/%{name}.pm
  342. %{perl_vendorarch}/auto/%{name}/%{name}.so
  343. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  344. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  345. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  346. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  347. %files passenger
  348. %defattr(-,root,root,-)
  349. %doc passenger-%{passenger_version}/doc/*.md
  350. %doc passenger-%{passenger_version}/doc/*.txt
  351. %doc passenger-%{passenger_version}/doc/*.html
  352. %doc passenger-%{passenger_version}/doc/templates
  353. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  354. %doc passenger-%{passenger_version}/doc/images
  355. %{_sbindir}/%{name}.passenger
  356. %changelog
  357. * Wed Aug 07 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-3
  358. - added NAXSI module.
  359. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-2
  360. - rebuilt with perl-5.26.
  361. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  362. - updated to 1.16.0.
  363. - updated passenger to 6.0.2.
  364. - updated nginx-dav-ext-module to 3.0.0.
  365. - dropped Patch1001: fixed in upstream.
  366. * Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
  367. - updated to 1.15.5.
  368. - updated passenger to 5.3.6.
  369. - updated ngx_fancyindex_version to 0.4.3.
  370. * Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.9-1
  371. - updated to 1.13.9.
  372. - updated ngx-fancyindex to 0.4.2.
  373. - updated nginx-accept_language_module to git HEAD.
  374. - updated nginx-upstream-fair to git HEAD.
  375. - updated passenger to 5.2.1.
  376. - added Source2010 (nginx-dav-ext-module).
  377. - enabled --with-stream and --with-stream_ssl_preread_module.
  378. * Fri Sep 8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.5-1
  379. - updated to 1.13.5
  380. - updated passenger to 5.1.8
  381. * Fri Aug 11 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.4-1
  382. - updated to 1.13.4
  383. - updated passenger to 5.1.7
  384. * Fri Jul 14 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.3-1
  385. - updated to 1.13.3
  386. * Sat Jul 1 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.2-1
  387. - updated to 1.13.2
  388. * Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.1-1
  389. - updated to 1.13.1
  390. - updated passenger to 5.1.5
  391. * Wed Apr 26 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.0-1
  392. - updated to 1.13.0
  393. * Wed Apr 5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
  394. - updated to 1.11.13
  395. * Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
  396. - updated to 1.11.12
  397. * Tue Mar 7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
  398. - updated to 1.11.10
  399. - updated passenger to 5.1.2
  400. * Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
  401. - updated to 1.11.9
  402. * Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
  403. - updated to 1.11.8
  404. * Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
  405. - updated to 1.11.6
  406. - applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
  407. * Mon Sep 5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
  408. - updated to 1.11.3
  409. - updated passenger to 5.0.30
  410. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
  411. - rebuild with gcc-5.4.0
  412. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  413. - updated to 1.10.1.
  414. - updated passenger to 5.0.28.
  415. * Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
  416. - updated to 1.9.15
  417. * Thu Apr 7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
  418. - updated to 1.9.14
  419. - updated passenger to 5.0.27
  420. * Wed Apr 6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
  421. - new upstream release
  422. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
  423. - updated to 1.9.12.
  424. - updated passenger to 5.0.26.
  425. * Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
  426. - new upstream release
  427. * Wed Feb 3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
  428. - update to 1.9.10
  429. - update passenger to 5.0.24
  430. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
  431. - update passenger to 5.0.23
  432. * Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
  433. - new upstream release
  434. * Sat Dec 5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
  435. - new upstream release
  436. * Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
  437. - new upstream release
  438. * Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
  439. - new upstream release
  440. * Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
  441. - update to 1.9.3
  442. - update passenger to 5.0.11
  443. * Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
  444. - updated Source4 (ssl.conf).
  445. * Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
  446. - update to 1.9.2
  447. - update passenger to 5.0.10
  448. - update ngx-fancyindex to 0.3.5
  449. * Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
  450. - update to 1.6.2
  451. - update passenger to 4.0.52
  452. * Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
  453. - new upstream release
  454. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
  455. - rebuild with new environment
  456. * Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
  457. - update passenger to 4.0.45
  458. * Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  459. - update to 1.6.0 (stable)
  460. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  461. - update fancyindex to 0.3.3
  462. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  463. - update to 1.5.10
  464. - update passenger to 4.0.37
  465. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  466. - rebuilt with GeoIP-1.6.0.
  467. - added Patch100.
  468. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  469. - update to 1.5.6
  470. - update passenger to 4.0.21
  471. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  472. - rebuilt with gd-2.1.0.
  473. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  474. - update to 1.4.1
  475. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  476. - update to 1.4.0
  477. - enable SPDY module
  478. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  479. - new upstream release
  480. - update passenger to 3.0.19
  481. - update ngx-fancyindex to upstream git master
  482. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  483. - new upstream release
  484. - update passenger to 3.0.17
  485. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  486. - rebuild with pcre-8.31
  487. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  488. - added http_geoip_module.
  489. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  490. - update to 1.2.4
  491. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  492. - update to 1.2.2
  493. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  494. - update to 1.2.1
  495. - change nginx user from nginx to www-data
  496. - R(pre): www-common
  497. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  498. - update to 1.2.0
  499. - update passenger to 3.0.12
  500. - drop http_upstream_keepalive
  501. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  502. - new upstream release
  503. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  504. - update to 1.0.12
  505. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  506. - update to 1.0.11
  507. - update passenger to 3.0.11
  508. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  509. - update to 1.0.10
  510. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  511. - update passenger to 3.0.9
  512. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  513. - update to 1.0.6
  514. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  515. - update to 1.0.4
  516. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  517. - add gnosek-nginx-upstream-fair module
  518. - add ngx_http_upstream_keepalive module
  519. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  520. - add nginx-passenger sub pakckage
  521. - use alternatives to choose nginx with or without passenger
  522. - add BR: ruby, rubygems, rubygem-rake
  523. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  524. - update to 1.0.2
  525. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  526. - update to 1.0.1
  527. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  528. - add bcond_with wsgi for mod_wsgi
  529. - add bcond_with passenger
  530. - you need to install rake.gem to build with this option.
  531. - add Provides: webserver
  532. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  533. - new upstream release 1.0.0!
  534. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  535. - rebuild with perl-5.12.3
  536. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  537. - update to 0.8.54
  538. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  539. - update to 0.8.53
  540. - add nginx_accept_language_module
  541. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  542. - update to 0.8.50
  543. - update ngx-fancyindex to 0.3
  544. - add BR: libxml2-devel, libxslt-devel
  545. - add scgi_params* and uwsgi_params* to %%files
  546. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  547. - update to 0.8.35 (development version)
  548. - add sites.d/ to store vitualhost settings
  549. - split out default server settings to sites.d/default
  550. - add fancyindex module
  551. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  552. - new upstream release
  553. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  554. - update to 0.7.62 (included security fix: VU#180065)
  555. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  556. - fix typo
  557. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  558. - add translated descriptions
  559. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  560. - update 404.html/50x.html to use powered by vine logo.
  561. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  562. - initial build for Vine Linux
  563. - update to 0.7.61
  564. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  565. - init script updates from Gena Makhomed
  566. - remove nginx-upstream-fair
  567. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  568. - update to 0.6.36
  569. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  570. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  571. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  572. - rebuild
  573. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  574. - update to 0.6.35
  575. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  576. - rebuild with new openssl
  577. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  578. - update to 0.6.34
  579. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  580. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  581. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  582. - update to 0.6.33
  583. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  584. - update to 0.6.32
  585. - nginx now supports DESTDIR so removed the patches that enabled it
  586. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  587. - init script fixes
  588. - resolve 'listen 80 default' [#447873]
  589. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  590. - update to 0.6.31
  591. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  592. - upate to new upstream stable branch 0.6
  593. - added 3rd party module nginx-upstream-fair
  594. - added default webpages
  595. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  596. - update init script to match recommended guidelines
  597. - add /etc/nginx/conf.d support [#443280]
  598. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  599. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  600. - add Requires for versioned perl (libperl.so)
  601. - drop silly file Requires
  602. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  603. - Autorebuild for GCC 4.3
  604. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  605. - update to 0.5.35
  606. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  607. - update to 0.5.34
  608. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  609. - Rebuild for deps
  610. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  611. - update to 0.5.33
  612. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  613. - updated to 0.5.32
  614. - fixed rpmlint UTF-8 complaints.
  615. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  616. - added --with-http_stub_status_module build option.
  617. - added --with-http_sub_module build option.
  618. - added use of pcre-config --cflags
  619. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  620. - Update to 0.5.31
  621. - specify license is BSD
  622. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  623. - Add BuildRequires: perl-devel - fixing rawhide build
  624. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  625. - Update to 0.5.30
  626. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  627. - Update to 0.5.29
  628. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  629. - Update to 0.5.28
  630. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  631. - Update to 0.5.27
  632. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  633. - Update to 0.5.26
  634. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  635. - Update to 0.5.19
  636. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  637. - Update to 0.5.17
  638. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  639. - Update to 0.5.16
  640. - add ownership of /usr/share/nginx/html (#233950)
  641. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  642. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  643. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  644. - fixed package review bugs (#233522) given by kevin@tummy.com
  645. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  646. - create patches to assist with building for Fedora
  647. - initial packaging for Fedora