icu-vl.spec 6.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: International Components for Unicode
  3. Summary(ja): ユニコード用国際化コンポーネント
  4. Name: icu
  5. Version: 69.1
  6. Release: 1%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. %define sover %(echo %{version} | cut -d . -f 1)
  11. %define minorver %(echo %{version} | cut -d . -f 2)
  12. License: MIT
  13. URL: http://icu-project.org/
  14. Source0: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-src.tgz
  15. Source1: https://github.com/unicode-org/icu/releases/download/release-%{sover}-%{minorver}/icu4c-%{sover}_%{minorver}-docs.zip
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: gcc-c++
  18. BuildRequires: unzip perl
  19. Requires: libicu%{sover} = %{version}-%{release}
  20. %description
  21. ICU is a C++ and C library that provides robust and full-featured Unicode
  22. support. This package contains the Unicode character database and derived
  23. properties, along with converters and time zones data.
  24. %package -n libicu%{sover}
  25. Summary: International Components for Unicode (library)
  26. Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
  27. Group: system
  28. Provides: libicu = %{version}-%{release}
  29. %description -n libicu%{sover}
  30. ICU is a C++ and C library that provides robust and full-featured Unicode
  31. support. This package contains the runtime libraries for ICU. It does not
  32. contain any of the data files needed at runtime.
  33. %package -n libicu-devel
  34. Summary: Header files, libraries and development documentation for libicu
  35. Summary(ja): libicu 用のヘッダファイル、ライブラリおよび開発用ドキュメント
  36. Group: programming
  37. Requires: libicu%{sover} = %{version}-%{release}
  38. %description -n libicu-devel
  39. This package contains the header files, static libraries for %{name}.
  40. If you like to develop programs using %{name}, you will need to install
  41. %{name}-devel.
  42. %package -n libicu-doc
  43. Summary: Documentation for International Components for Unicode
  44. Summary(ja): ユニコード用国際化コンポーネントのドキュメント
  45. Group: documentation
  46. Requires: libicu%{sover} = %{version}-%{release}
  47. %description -n libicu-doc
  48. This package contains the development documentation for %{name}.
  49. # compat32
  50. %if %{build_compat32}
  51. %package -n compat32-libicu%{sover}
  52. Summary: International Components for Unicode (library)
  53. Summary(ja): ユニコード用国際化コンポーネント (ライブラリ)
  54. Group: system,legacy
  55. Provides: compat32-libicu = %{version}-%{release}
  56. %description -n compat32-libicu%{sover}
  57. ICU is a C++ and C library that provides robust and full-featured Unicode
  58. support. This package contains the runtime libraries for ICU. It does not
  59. contain any of the data files needed at runtime.
  60. %endif
  61. %debug_package
  62. %prep
  63. %setup -q -n icu
  64. find . -name CVS -o -name .cvsignore | xargs -r rm -rf
  65. perl -pi -e 's/^(HAVE_DOT\b.*=).*$/$1 YES/' source/Doxyfile.in
  66. mkdir docs
  67. pushd docs
  68. unzip %{SOURCE1}
  69. popd
  70. %build
  71. cd source
  72. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  73. export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  74. %configure --disable-static --with-data-packaging=library --disable-samples
  75. make %{?_smp_mflags}
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. make -C source install DESTDIR=$RPM_BUILD_ROOT
  79. cp -pR ./source/tools/ctestfw/libicutest.so* $RPM_BUILD_ROOT/%{_libdir}
  80. chmod +x $RPM_BUILD_ROOT%{_libdir}/*.so.*
  81. %ifarch x86_64
  82. %check
  83. %make_build -C source check
  84. %endif
  85. %clean
  86. rm -rf $RPM_BUILD_ROOT
  87. %files
  88. %defattr(-, root, root, 0755)
  89. %license LICENSE
  90. %doc license.html readme.html
  91. %{_bindir}/derb
  92. %{_bindir}/genbrk
  93. %{_bindir}/gencfu
  94. %{_bindir}/gencnval
  95. %{_bindir}/gendict
  96. %{_bindir}/genrb
  97. %{_bindir}/icuinfo
  98. %{_bindir}/makeconv
  99. %{_bindir}/pkgdata
  100. %{_bindir}/uconv
  101. %{_sbindir}/*
  102. %{_mandir}/man?/*
  103. %exclude %{_mandir}/man1/icu-config.1*
  104. %files -n libicu%{sover}
  105. %license LICENSE
  106. %defattr(-, root, root, 0755)
  107. %{_libdir}/*.so.*
  108. %files -n libicu-devel
  109. %license LICENSE
  110. %defattr(-, root, root, 0755)
  111. %{_bindir}/icu-config
  112. %{_includedir}/unicode
  113. %{_libdir}/*.so
  114. %{_libdir}/%{name}
  115. %{_libdir}/pkgconfig/*.pc
  116. %{_mandir}/man1/icu-config.1*
  117. %{_datadir}/%{name}
  118. %files -n libicu-doc
  119. %license LICENSE
  120. %defattr(-,root,root,-)
  121. %doc docs/*
  122. %if %{build_compat32}
  123. %files -n compat32-libicu%{sover}
  124. %license LICENSE
  125. %defattr(-, root, root, 0755)
  126. %{_libdir}/*.so.*
  127. %endif
  128. %changelog
  129. * Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 69.1-1
  130. - updated to 69.1.
  131. - dropped ldconfig scriptlets.
  132. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 67.1-1
  133. - updated to 67.1.
  134. * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 66.1-1
  135. - updated to 66.1.
  136. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-2
  137. - made to build compat32-* package.
  138. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 65.1-1
  139. - updated to 65.1.
  140. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.3-1
  141. - updated to 60.3.
  142. - disabled tests on i686.
  143. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 60.2-1
  144. - updated to 60.2.
  145. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-2
  146. - rebuild with gcc-5.4.0
  147. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 56.1-1
  148. - update to 56.1
  149. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 54.1-1
  150. - update to 54.1
  151. * Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 52.1-1
  152. - new upstream release
  153. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 51.2-1
  154. - update to 51.2
  155. * Tue Apr 13 2010 Shu KONNO <owa@bg.wakwak.com> 4.4-2
  156. - install libicutest.so*
  157. * Sat Apr 10 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4-1
  158. - new upstream release
  159. - built with new toolchain
  160. * Sun Mar 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.1-1vl5
  161. - new upstream release
  162. - updated URL
  163. * Sun Sep 28 2008 Shu KONNO <owa@bg.wakwak.com> 3.6-1vl5
  164. - applied new versioning policy, spec in utf-8
  165. * Tue Sep 4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.6-0vl1
  166. - updated to 3.6
  167. - removed ".so ver" from libicu package name
  168. - changed Group to Development/Tools
  169. - changed libicu-doc Group to Applications/Documentation
  170. * Tue Mar 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.4.1-0vl1
  171. - updated to 3.4.1
  172. * Sun Jul 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.2-3vl1
  173. - updated to 3.2 based on Fedora extra
  174. - new subpackage libicu-doc for API document
  175. * Sat Oct 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 3.0-0vl1
  176. - Build for Vine Linux
  177. - add developers document to devel package
  178. - add Japanese summary
  179. * Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-1
  180. - Fixed a typo in the dependencies "libuci" should be "libicu". (Daniel Demus)
  181. * Wed Feb 25 2004 Dag Wieers <dag@wieers.com> - 2.6.2-0
  182. - Initial package. (using DAR)