python-pyudev-vl.spec 9.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241
  1. %bcond_with systemd
  2. %global srcname pyudev
  3. Summary: A libudev binding
  4. Name: python-%{srcname}
  5. Version: 0.22.0
  6. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: https://pypi.org/project/pyudev/
  12. Source0: https://pypi.io/packages/source/p/%{srcname}/%{srcname}-%{version}.tar.gz
  13. BuildArch: noarch
  14. %description
  15. pyudev is a LGPL licensed, pure Python binding for libudev, the device
  16. and hardware management and information library for Linux. It supports
  17. almost all libudev functionality, you can enumerate devices, query device
  18. properties and attributes or monitor devices, including asynchronous
  19. monitoring with threads, or within the event loops of Qt, Glib or wxPython.
  20. The binding supports CPython 2 (2.6 or newer) and 3 (3.1 or newer), and
  21. PyPy 1.5 or newer. It is tested against udev 151 or newer, earlier
  22. versions of udev as found on dated Linux systems may work, but are not
  23. officially supported.
  24. %package -n python3-%{srcname}
  25. Summary: A libudev binding
  26. Group: programming
  27. %{?python_provide:%python_provide python3-%{srcname}}
  28. BuildRequires: python3-devel
  29. BuildRequires: python3-setuptools
  30. BuildRequires: python3-rpm-macros
  31. # Needed for libudev, loaded through ctypes
  32. %if %{with systemd}
  33. Requires: systemd-libs
  34. %endif
  35. # Used for python2/3 compatibility
  36. Requires: python3-six
  37. %description -n python3-%{srcname}
  38. pyudev is a LGPL licensed, pure Python binding for libudev, the device
  39. and hardware management and information library for Linux. It supports
  40. almost all libudev functionality, you can enumerate devices, query device
  41. properties and attributes or monitor devices, including asynchronous
  42. monitoring with threads, or within the event loops of Qt, Glib or wxPython.
  43. The binding supports CPython 2 (2.6 or newer) and 3 (3.1 or newer), and
  44. PyPy 1.5 or newer. It is tested against udev 151 or newer, earlier
  45. versions of udev as found on dated Linux systems may work, but are not
  46. officially supported.
  47. %prep
  48. %autosetup -n %{srcname}-%{version}
  49. rm -rf pyudev.egg-info
  50. %build
  51. %py3_build
  52. %install
  53. %py3_install
  54. %files -n python3-%{srcname}
  55. %license COPYING
  56. %doc README.rst CHANGES.rst
  57. %{python3_sitelib}/pyudev
  58. %{python3_sitelib}/pyudev-%{version}-*.egg-info
  59. %exclude %{python3_sitelib}/pyudev/glib.py
  60. %exclude %{python3_sitelib}/pyudev/__pycache__/glib.*
  61. %exclude %{python3_sitelib}/pyudev/pyside.py
  62. %exclude %{python3_sitelib}/pyudev/__pycache__/pyside.*
  63. %exclude %{python3_sitelib}/pyudev/wx.py
  64. %exclude %{python3_sitelib}/pyudev/__pycache__/wx.*
  65. %changelog
  66. * Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.22.0-2
  67. - added systemd support (disabled as default).
  68. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.22.0-1
  69. - new upstream release.
  70. * Mon Sep 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.21.0-13
  71. - initial build for Vine Linux.
  72. - dropped qt4/qt5 stuff.
  73. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 0.21.0-12
  74. - Rebuilt for Python 3.8
  75. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-11
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  77. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-10
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  79. * Thu Oct 11 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 0.21.0-9
  80. - Python2 binary package has been removed
  81. See https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
  82. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-8
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  84. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.21.0-7
  85. - Rebuilt for Python 3.7
  86. * Fri Mar 23 2018 Iryna Shcherbina <ishcherb@redhat.com> - 0.21.0-6
  87. - Update Python 2 dependency declarations to new packaging standards
  88. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  89. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-5
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  91. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-4
  92. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  93. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.21.0-3
  94. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  95. * Wed Dec 21 2016 Kevin Fenzi <kevin@scrye.com> - 0.21.0-2
  96. - Rebuild for Python 3.6
  97. * Fri Jul 29 2016 mulhern <amulhern@redhat.com> - 0.21.1
  98. - Deprecate use of Device object as mapping from udev property names to values
  99. - Add a Properties class and a Device.properties() method for udev properties
  100. - Fix places where Device object was incorrectly used in a boolean context
  101. - Return an empty string, not None, if the property value is an empty string
  102. - Exceptions re-raised from libudev calls now have a message string
  103. - Insert a warning about using a Device in a boolean context in docs
  104. - Infrastructure for vagrant tests is removed
  105. - Various internal refactorings
  106. - Extensive test improvements
  107. - Numerous documentation fixes
  108. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20.0-3
  109. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  110. * Mon May 2 2016 mulhern <amulhern@redhat.com> - 0.20.0
  111. - Remove parsing code added in previous release
  112. - No longer do CI for Python 2.6
  113. - Eliminate all wildcard imports and __all__ statements
  114. - No longer use deprecated Device.from_sys_path() method
  115. - Minor pylint induced changes
  116. - Documentation fixes
  117. * Mon Feb 08 2016 mulhern <amulhern@redhat.com> - 0.19.0
  118. - Never raise a DeviceNotFoundError when iterating over a device enumeration
  119. - Device.subsystem() now returns None if device has no subsystem
  120. - Add DeprecationWarnings to deprecated Device methods
  121. - Replace "/" with "!" in Device.from_name() sys_name parameter
  122. - Add some unstable classes for parsing some kinds of values
  123. - Make version info more like Python's including micro numbers and levels
  124. - Refactor some internal modules into subdirectories
  125. - Work on tests and reproducers
  126. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.18.1-5
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  128. * Mon Dec 21 2015 mulhern <amulhern@redhat.com> - 0.18.1
  129. - Restore raising KeyError in astring, asint, asbool methods in Attributes
  130. - Add dependency on six package
  131. - pyudev sources now in src directory
  132. - Added support for pyqt5 monitor observer
  133. - Added discover module, which looks up a device on limited information
  134. - DeviceNotFoundError is no longer a subtype of LookupError
  135. - Attributes class no longer extends Mapping class
  136. - Attributes class no longer inherits [] operator and other Mapping methods
  137. - Attributes class object are no longer iterable or indexable and have no length
  138. - Attributes.available_attributes property added
  139. - Attributes.get() method, with usual semantics explicitly defined
  140. - Device.from_* methods are deprecated, use Devices.from_* methods instead
  141. - Device.from_device_number() now raises DeviceNotFoundByNumberError
  142. - Devices.from_interface_index() method added
  143. - Devices.from_kernel_device() method added
  144. * Thu Dec 3 2015 David Shea <dshea@redhat.com> - 0.17-4
  145. - Add requires for things that are required
  146. - Split the main-loop integration modules into separate packages
  147. * Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 0.17-3
  148. - Rebuilt for Python3.5 rebuild
  149. * Tue Sep 15 2015 David Shea <dshea@redhat.com> - 0.17.1-2
  150. - Fix a typo in the python3-pyudev Provides
  151. * Mon Sep 14 2015 David Shea <dshea@redhat.com> - 0.17.1-1
  152. - Really start the monitor on pyudev.Monitor.poll()
  153. - Force non-blocking IO in pyudev.Monitor to avoid blocking on receiving the device
  154. - Set proper flags on pipe fs
  155. - Handle irregular polling events properly
  156. - Rename MonitorObserver GUI classes and deprecate the old ones
  157. - Remove patches for #1170337 and #1230773 that are now part of upstream
  158. - Switch to new packaging guidelines which renames python-pyudev to python2-pyudev
  159. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.16.1-4
  160. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  161. * Fri Jun 12 2015 David Shea <dshea@redhat.com> - 0.16.1-3
  162. - Retry interrupted system calls (#1230773)
  163. - Rearrange the build process to match current packaging recommendations
  164. * Wed Jan 28 2015 David Shea <dshea@redhat.com> - 0.16.1-2
  165. - Use %%license for the license file
  166. * Wed Dec 10 2014 David Shea <dshea@redhat.com> - 0.16.1-1
  167. - Update to pyudev-0.16.1 (#880644)
  168. - Apply a patch from upstream to remove a global reference to libudev (#1170337)
  169. * Wed Dec 10 2014 David Shea <dshea@redhat.com> - 0.15-7
  170. - Fix license tag (LGPL -> LGPLv2+) (#990579)
  171. - Remove rst tags from description
  172. - Remove unnecessary requires and buildrequires (#1095459)
  173. - Avoid packaging upstream egg-info files
  174. - Add a python3 package
  175. - Drop the Group tag which wasn't even the right group
  176. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-6
  177. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  178. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-5
  179. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  180. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-4
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  182. * Mon Jul 23 2012 Chris Lockfort <clockfort@redhat.com> 0.15-3
  183. - Reflect rawhide merging udev into systemd
  184. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-2
  185. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  186. * Mon Jun 18 2012 Chris Lockfort <clockfort@redhat.com> 0.15-1
  187. - initial package