tracker-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469
  1. %bcond_with systemd
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: An object database, tag/metadata database, search tool and indexer
  4. Summary(ja): オブジェクト/タグ/メタデータデータベースおよび検索ツール
  5. Name: tracker
  6. Version: 3.1.1
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. Group: desktop-gnome,accesories
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPL
  12. URL: https://gnome.pages.gitlab.gnome.org/tracker/
  13. %define major_minor %(echo %{version} | cut -d . -f 1-2)
  14. Source0: https://download.gnome.org/sources/tracker/%{major_minor}/tracker-%{version}.tar.xz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: asciidoc
  17. BuildRequires: gettext
  18. BuildRequires: gtk-doc
  19. BuildRequires: meson
  20. BuildRequires: vala
  21. BuildRequires: dbus-devel
  22. BuildRequires: pkgconfig(gobject-introspection-1.0)
  23. BuildRequires: pkgconfig(icu-i18n)
  24. BuildRequires: pkgconfig(icu-uc)
  25. BuildRequires: pkgconfig(json-glib-1.0)
  26. BuildRequires: pkgconfig(libsoup-2.4)
  27. BuildRequires: pkgconfig(libxml-2.0)
  28. BuildRequires: pkgconfig(sqlite3)
  29. BuildRequires: /bin/dbus-run-session
  30. %if %{with systemd}
  31. BuildRequires: systemd
  32. %endif
  33. %if %{with systemd}
  34. %global systemd_units tracker-xdg-portal-3
  35. %{?systemd_requires}
  36. %endif
  37. Obsoletes: %{name}-libs < 2.0.0
  38. Obsoletes: %{name}-search-tool < 2.0.0
  39. Provides: %{name}-libs = %{version}-%{release}
  40. Provides: %{name}-search-tool = %{version}-%{release}
  41. %description
  42. Tracker is a powerful desktop-neutral first class object database,
  43. tag/metadata database, search tool and indexer.
  44. It consists of a common object database that allows entities to have an
  45. almost infinte number of properties, metadata (both embedded/harvested as
  46. well as user definable), a comprehensive database of keywords/tags and
  47. links to other entities.
  48. It provides additional features for file based objects including context
  49. linking and audit trails for a file object.
  50. It has the ability to index, store, harvest metadata. retrieve and search
  51. all types of files and other first class objects
  52. %package devel
  53. Summary: Headers for developing programs that will use %{name}
  54. Group: programming
  55. Requires: %{name} = %{version}-%{release}
  56. %description devel
  57. This package contains the static libraries and header files needed for
  58. developing with tracker
  59. %package -n libtracker-sparql
  60. Summary: Tracker SPARQL library
  61. Group: system
  62. License: LGPLv2+
  63. Recommends: %{name}%{?_isa} = %{version}-%{release}
  64. %description -n libtracker-sparql
  65. This package contains the libtracker-sparql library.
  66. %package docs
  67. Summary: Documentation for tracker
  68. Group: documentation
  69. BuildArch: noarch
  70. Obsoletes: %{name}-doc < 0.15.0
  71. Provides: %{name}-doc = 0.15.0
  72. %description docs
  73. This package contains documentation for tracker.
  74. %debug_package
  75. %prep
  76. %setup -q
  77. %build
  78. %meson \
  79. -Dunicode_support=icu \
  80. -Dstemmer=disabled \
  81. %if %{with systemd}
  82. -Dsystemd_user_services=true \
  83. %else
  84. -Dsystemd_user_services=false \
  85. %endif
  86. -Ddocs=true
  87. %meson_build
  88. %install
  89. rm -rf %{buildroot}
  90. export LANG=ja_JP.UTF-8
  91. %meson_install
  92. %find_lang %{name}3
  93. %if !%{with systemd}
  94. rm -rf %{buildroot}/usr/lib/systemd
  95. %endif
  96. %clean
  97. rm -rf %{buildroot}
  98. %if %{with systemd}
  99. %post
  100. %systemd_user_post %{systemd_units}
  101. %endif
  102. %if %{with systemd}
  103. %preun
  104. %systemd_user_preun %{systemd_units}
  105. %endif
  106. %if %{with systemd}
  107. %postun
  108. %systemd_user_postun_with_restart %{systemd_units}
  109. %endif
  110. %files -f %{name}3.lang
  111. %defattr(-, root, root, -)
  112. %license COPYING COPYING.LGPL
  113. %doc AUTHORS NEWS README.md
  114. %{_bindir}/tracker3
  115. %{_libexecdir}/tracker3/
  116. %{_libexecdir}/tracker-xdg-portal-3
  117. %dir %{_datadir}/bash-completion
  118. %dir %{_datadir}/bash-completion/completions
  119. %{_datadir}/bash-completion/completions/tracker3
  120. %{_datadir}/dbus-1/services/org.freedesktop.portal.Tracker.service
  121. %{_mandir}/man1/tracker*.1*
  122. %if %{with systemd}
  123. %{_userunitdir}/tracker-xdg-portal-3.service
  124. %endif
  125. %files -n libtracker-sparql
  126. %license COPYING COPYING.LGPL
  127. %dir %{_libdir}/girepository-1.0
  128. %{_libdir}/girepository-1.0/Tracker-3.0.typelib
  129. %{_libdir}/libtracker-sparql-3.0.so.0*
  130. %{_datadir}/tracker3/
  131. %files devel
  132. %defattr(-, root, root, -)
  133. %{_includedir}/tracker-3.0/
  134. %{_libdir}/libtracker-sparql-3.0.so
  135. %{_libdir}/pkgconfig/*.pc
  136. %dir %{_libdir}/tracker-3.0
  137. %{_libdir}/tracker-3.0/trackertestutils/
  138. %dir %{_datadir}/vala
  139. %dir %{_datadir}/vala/vapi
  140. %{_datadir}/vala/vapi/tracker-sparql-3.0.*
  141. %dir %{_datadir}/gir-1.0
  142. %{_datadir}/gir-1.0/Tracker-3.0.gir
  143. %files docs
  144. %license docs/reference/COPYING
  145. %dir %{_datadir}/gtk-doc
  146. %dir %{_datadir}/gtk-doc/html
  147. %{_datadir}/gtk-doc/html/libtracker-sparql-3/
  148. %{_datadir}/gtk-doc/html/ontology-3/
  149. %changelog
  150. * Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
  151. - new upstream release.
  152. - built with icu69.
  153. * Mon Mar 29 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.0-1
  154. - new upstream release.
  155. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
  156. - new upstream release.
  157. - built with icu-67.
  158. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-3
  159. - rebuilt with icu-66.
  160. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-2
  161. - rebuilt with icu-65.
  162. * Sun Sep 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.2-1
  163. - new upstream release.
  164. - dropped Patch0.
  165. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
  166. - new upstream release.
  167. - dropped all patches.
  168. - added Patch0.
  169. - dropped subpackages "libs" and "search-tool".
  170. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.4-1
  171. - new upstream release.
  172. * Sun Jul 17 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
  173. - new upstream release
  174. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  175. - new upstream release
  176. * Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
  177. - new upstream release
  178. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  179. - new upstream release
  180. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-2
  181. - remove *.la files
  182. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
  183. - new upstream release
  184. - add BuildRequires: libmediaart-devel, libvorbis-devel, flac-devel
  185. * Mon Dec 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.5-1
  186. - new upstream release
  187. * Sun Nov 09 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.4-1
  188. - new upstream release
  189. - add Patch1 (tracker-1.2.3-revert-error_message.patch)
  190. * Sun Sep 21 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-2
  191. - rebuild with upower-0.99.1
  192. * Sun Sep 14 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.4-1
  193. - new upstream release
  194. * Sun Aug 31 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
  195. - new upstream release
  196. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-3
  197. - rebuild with poppler-0.26.2
  198. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-2
  199. - rebuild with libarchive-3.1.2
  200. * Fri May 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1-1
  201. - new upstream release
  202. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-2
  203. - rebuild with poppler-0.24.5
  204. * Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0-1
  205. - new upstream release
  206. * Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-2
  207. - rebuild with VineSeed environment
  208. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.4-1
  209. - new upstream release
  210. * Sat Nov 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.3-1
  211. - new upstream release
  212. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-2
  213. - rebuild with icu-51.2
  214. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.2-1
  215. - new upstream release
  216. * Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.1-1
  217. - new upstream release
  218. * Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.16.0-1
  219. - new upstream release
  220. - remove BuildRequires: gnome-panel-devel, gnome-applets
  221. - change BuildRequires: gstreamer1-devel instead of gstreamer-devel
  222. - add BuildRequires: libjpeg-turbo-devel, giflib-devel, libtiff-devel, exempi-devel, enca-devel, taglib-devel, libgxps-devel
  223. - change BuildRequires: gstreamer1-plugins-base-devel instead of gstreamer-plugins-base-devel
  224. - change to %%{name}-docs subpackage from %%{name}-docs
  225. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.5-1
  226. - new upstream release
  227. * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.4-1
  228. - new upstream release
  229. * Fri Oct 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.3-1
  230. - new upstream release
  231. * Sat Sep 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-2
  232. - create -libs subpackage
  233. - add BuildRequires: firefox, thunderbird
  234. * Sun Jul 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.2-1
  235. - new upstream release
  236. * Sun May 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
  237. - new upstream release
  238. * Wed Apr 18 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
  239. - new upstream release
  240. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.9-1
  241. - new upstream release
  242. * Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.7-1
  243. - new upstream release
  244. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.4-1
  245. - new upstream release
  246. - create %%{name}-doc sub package
  247. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.3-1
  248. - new upstream release
  249. - add Patch0 (tracker-0.12.3-sched.patch)
  250. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.2-1
  251. - new upstream release
  252. - add BuildRequires: gstreamer-devel, gstreamer-plugins-base-devel, NetworkManager-glib-devel
  253. - drop Patch0
  254. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.25-1
  255. - new upstream release
  256. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.23-1
  257. - new upstream release
  258. * Wed Jul 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.22-1
  259. - new upstream release
  260. - add BuildRequires: libicu-devel
  261. * Thu May 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.18-1
  262. - new upstream release
  263. - add Patch0 (tracker-0.8.18-tracker_spawn.patch)
  264. - delete Patch1
  265. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.16-3
  266. - rebuilt with poppler-0.16.3
  267. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-2
  268. - rebuild with poppler-0.14.2
  269. * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.16-1
  270. - new upstream release
  271. - add BuildRequires: glib2-devel, gtk2-devel, gnome-panel-devel, libgee-devel
  272. - add configure option (--enable-tracker-search-bar)
  273. * Sun Jul 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.15-1
  274. - new upstream release
  275. * Sat Jun 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.13-1
  276. - new upstream release
  277. - fix URL of Source0
  278. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.12-1
  279. - new upstream release
  280. * Sun Jun 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.11-1
  281. - new upstream release
  282. * Sun May 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.9-1
  283. - new upstream release
  284. - fix %install and %files (make /etc/ld.so.conf.d/tracker-%{_arch}.conf)
  285. * Sun May 16 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  286. - new upstream release
  287. * Sun Apr 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3-1
  288. - new upstream release
  289. - add BuildRequires: upower-devel, gnome-applets
  290. - change BuildRequires: dbus-glib -> dbus-glib-devel
  291. * Sun Mar 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
  292. - new upstream release
  293. - add BuildRequires: libgnome-devel, libgnomeui-devel, libSM-devel, libnotify-devel, libuuid-devel, libgee-devel
  294. - fix BuildRequires: gmime-devel >= 2.4
  295. - add configure option (--enable-tracker-search-tool)
  296. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.91-1
  297. - new upstream release
  298. * Sun Dec 14 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-2
  299. - rebuild with poppler-0.10.2
  300. - spec in UTF-8
  301. * Mon Mar 31 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.6.6-1
  302. - new upstream release
  303. - update Patch1
  304. - drop Patch10 (no more necessary)
  305. - add %%{_sysconfdir}/xdg/autostart/tracker-applet.desktop
  306. - remove --enable-external-sqlite option (no more bundled sqlite exist)
  307. - apply new versioning policy
  308. * Mon Sep 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
  309. - new upstream release
  310. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
  311. - add Patch10 to fix selecting video-extractor
  312. - use external video extractor(totem) instead of gstreamer/xine
  313. * Sun Apr 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
  314. - initial build for Vine Linux
  315. * Fri Mar 30 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-6
  316. - Ship both autostart desktop files in the main package (BZ #233323)
  317. * Tue Feb 13 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-3
  318. - Package the deskbar plugin properly (BZ #228308)
  319. * Mon Jan 29 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-2
  320. - Split out tracker-search-tool sub-packages, for the GUI facility
  321. - Add proper requires for the -devel subpackage
  322. - Deal with the rpmlint complaints on rpath
  323. * Sat Jan 27 2007 Deji Akingunola <dakingun@gmail.com> - 0.5.4-1
  324. - Update to 0.5.4
  325. * Tue Dec 26 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.3-1
  326. - Update to 0.5.3
  327. * Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-2
  328. - Apply patch on Makefile.am instead of Makefile.in
  329. - Add libtool to BR
  330. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.2-1
  331. - Update to 0.5.2
  332. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.1-1
  333. - Update to new version
  334. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-7
  335. - Have the devel subpackage require pkgconfig
  336. - Make the description field not have more than 76 characters on a line
  337. - Fix up the RPM group
  338. * Mon Nov 06 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-6
  339. - Explicitly require dbus-devel and dbus-glib (needed for FC < 6)
  340. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-5
  341. - Remove unneeded BRs (gnome-utils-devel and openssl-devel)
  342. * Sun Nov 05 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-4
  343. - Add autostart desktop file.
  344. - Edit the package description as suggested in review
  345. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-3
  346. - More cleaups to the spec file.
  347. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-2
  348. - Add needed BRs
  349. * Sat Nov 04 2006 Deji Akingunola <dakingun@gmail.com> - 0.5.0-1
  350. - Initial packaging for Fedora Extras