webkitgtk4-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378
  1. %bcond_with systemd
  2. %bcond_with clang
  3. ## NOTE: Lots of files in various subdirectories have the same name (such as
  4. ## "LICENSE") so this short macro allows us to distinguish them by using their
  5. ## directory names (from the source tree) as prefixes for the files.
  6. %global add_to_license_files() \
  7. mkdir -p _license_files ; \
  8. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  9. Summary: GTK+ Web content engine library
  10. Name: webkitgtk4
  11. Version: 2.32.0
  12. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  13. Group: system
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: LGPLv2
  17. URL: http://www.webkitgtk.org/
  18. Source0: https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  19. Patch1: webkitgtk-2.32.0-icu69.patch
  20. %if %{with clang}
  21. BuildRequires: clang
  22. BuildRequires: lld
  23. %endif
  24. BuildRequires: at-spi2-core-devel
  25. BuildRequires: bison
  26. BuildRequires: bubblewrap
  27. BuildRequires: cairo-devel
  28. BuildRequires: cmake
  29. BuildRequires: enchant2-devel
  30. BuildRequires: flex
  31. BuildRequires: fontconfig-devel
  32. BuildRequires: freetype-devel
  33. BuildRequires: geoclue2-devel
  34. BuildRequires: gettext
  35. BuildRequires: glib2-devel
  36. BuildRequires: gobject-introspection-devel
  37. BuildRequires: gperf
  38. BuildRequires: gstreamer1-devel
  39. BuildRequires: gstreamer1-plugins-base-devel
  40. BuildRequires: gtk2-devel
  41. BuildRequires: gtk3-devel
  42. BuildRequires: harfbuzz-icu-devel
  43. BuildRequires: libicu-devel
  44. BuildRequires: libjpeg-turbo-devel
  45. BuildRequires: libpng-devel
  46. BuildRequires: libseccomp-devel
  47. BuildRequires: libsecret-devel
  48. BuildRequires: libsoup-devel
  49. BuildRequires: libwebp-devel
  50. BuildRequires: libxslt-devel
  51. BuildRequires: libXt-devel
  52. BuildRequires: ninja
  53. BuildRequires: mesa-libGL-devel
  54. BuildRequires: pcre-devel
  55. BuildRequires: python3-devel
  56. BuildRequires: ruby
  57. BuildRequires: sqlite3-devel
  58. BuildRequires: libnotify-devel
  59. BuildRequires: hyphen-devel
  60. BuildRequires: woff2-devel
  61. BuildRequires: xdg-dbus-proxy
  62. %if %{with systemd}
  63. BuildRequires: systemd-devel
  64. %endif
  65. Requires: geoclue2
  66. # for sandbox
  67. Requires: bubblewrap
  68. Requires: xdg-dbus-proxy
  69. # Require the jsc subpackage
  70. Requires: %{name}-jsc = %{version}-%{release}
  71. # Obsolete libwebkit2gtk from the webkitgtk3 package
  72. Obsoletes: libwebkit2gtk < 2.4.5-3
  73. Provides: libwebkit2gtk = %{version}-%{release}
  74. # Filter out provides for private libraries
  75. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  76. %description
  77. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  78. GTK+ platform.
  79. This package contains WebKitGTK+ for GTK+ 3.
  80. %package devel
  81. Summary: Development files for %{name}
  82. Group: programming
  83. Requires: %{name} = %{version}-%{release}
  84. Requires: %{name}-jsc-devel = %{version}-%{release}
  85. %description devel
  86. The %{name}-devel package contains libraries, build data, and header
  87. files for developing applications that use %{name}.
  88. %package jsc
  89. Summary: JavaScript engine from %{name}
  90. Group: system
  91. %description jsc
  92. This package contains JavaScript engine from %{name}.
  93. %package jsc-devel
  94. Summary: Development files for JavaScript engine from %{name}
  95. Group: programming
  96. Requires: %{name}-jsc = %{version}-%{release}
  97. %description jsc-devel
  98. The %{name}-jsc-devel package contains libraries, build data, and header
  99. files for developing applications that use JavaScript engine from %{name}.
  100. %debug_package
  101. %prep
  102. %setup -q -n webkitgtk-%{version}
  103. %autopatch -p1
  104. # Remove bundled libraries
  105. rm -rf Source/ThirdParty/leveldb/
  106. rm -rf Source/ThirdParty/gtest/
  107. rm -rf Source/ThirdParty/qunit/
  108. %build
  109. %ifnarch x86_64
  110. %define cflags_add --rtlib=compiler-rt
  111. %endif
  112. %if %{with clang}
  113. export CC=clang
  114. export CXX=clang++
  115. export LD=ld.lld
  116. %ifnarch x86_64
  117. %define cflags_add --rtlib=compiler-rt
  118. %endif
  119. %global optflags %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
  120. %global build_ldflags %{build_ldflags}
  121. %else
  122. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  123. %endif
  124. %cmake \
  125. -GNinja \
  126. %if %{with clang}
  127. -DCOMPILER_IS_CLANG=ON \
  128. -DCMAKE_CXX_COMPILER=clang++ \
  129. %endif
  130. -DPORT=GTK \
  131. -DCMAKE_BUILD_TYPE=Release \
  132. -DUSER_AGENT_BRANDING="Vine Linux" \
  133. -DENABLE_JIT=OFF \
  134. -DENABLE_LLINT_C_LOOP=ON \
  135. -DUSE_GSTREAMER_GL=OFF \
  136. -DUSE_OPENJPEG=OFF \
  137. -DENABLE_GTKDOC=OFF \
  138. -DUSE_WPE_RENDERER=OFF \
  139. -DENABLE_GAMEPAD=NO \
  140. %if %{with systemd}
  141. -DUSE_SYSTEMD=ON \
  142. %else
  143. -DUSE_SYSTEMD=OFF \
  144. %endif
  145. # Show the build time in the status
  146. export NINJA_STATUS="[%f/%t][%e] "
  147. %cmake_build
  148. %install
  149. %cmake_install
  150. %find_lang WebKit2GTK-4.0
  151. # Finally, copy over and rename various files for %%license inclusion
  152. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  153. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  154. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  155. %add_to_license_files Source/WebCore/LICENSE-APPLE
  156. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  157. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  158. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  159. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  160. %add_to_license_files Source/WTF/icu/LICENSE
  161. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  162. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  163. %files -f WebKit2GTK-4.0.lang
  164. %license _license_files/*
  165. %{_libdir}/libwebkit2gtk-4.0.so.*
  166. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  167. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  168. %{_libdir}/webkit2gtk-4.0/
  169. %{_libexecdir}/webkit2gtk-4.0/*
  170. %exclude %{_libexecdir}/webkit2gtk-4.0/jsc
  171. %{_bindir}/WebKitWebDriver
  172. %files jsc
  173. %license _license_files/*JavaScriptCore*
  174. %dir %{_libexecdir}/webkit2gtk-4.0/
  175. %{_libexecdir}/webkit2gtk-4.0/jsc
  176. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  177. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  178. %files devel
  179. %{_includedir}/webkitgtk-4.0/*
  180. %exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  181. %{_libdir}/libwebkit2gtk-4.0.so
  182. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  183. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  184. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  185. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  186. %files jsc-devel
  187. %dir %{_includedir}/webkitgtk-4.0
  188. %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  189. %{_libdir}/libjavascriptcoregtk-4.0.so
  190. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  191. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  192. %changelog
  193. * Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.32.0-2
  194. - rebuilt with icu69.
  195. - added Patch1 to build with icu69.
  196. * Thu Apr 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.32.0-1
  197. - new upstream release.
  198. - dropped ldconfig scriptlets.
  199. * Tue Mar 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.30.5-1
  200. - new upstream release.
  201. * Tue Dec 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.30.3-1
  202. - new upstream release.
  203. - added systemd support (disabled as default).
  204. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.4-1
  205. - new upstream release.
  206. * Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.3-1
  207. - new upstream release.
  208. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
  209. - new upstream release.
  210. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
  211. - new upstream release.
  212. - rebuilt with libicu67.
  213. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
  214. - rebuilt with libicu66.
  215. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
  216. - new upstream release.
  217. - dropped Patch1: fixed in upstream.
  218. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
  219. - new upstream release.
  220. - built with icu-65.
  221. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
  222. - new upstream release.
  223. - switched build-system to ninja.
  224. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
  225. - new upstream release.
  226. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
  227. - new upstream release.
  228. * Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
  229. - new upstream release.
  230. - added subpackages webkitgtk4-jsc{,-devel}.
  231. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
  232. - new upstream release.
  233. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
  234. - rebuilt with new toolchain.
  235. * Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
  236. - new upstream release
  237. (including security fix for CVE-2016-1856,1857)
  238. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
  239. - new upstream release
  240. - remove Patch0
  241. - add BuildRequires: libnotify-devel, hyphen-devel
  242. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
  243. - rebuild with gnutls-3.4.7
  244. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
  245. - rebuild with icu-56.1
  246. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
  247. - new upstream release
  248. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
  249. - new upstream release
  250. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
  251. - new upstream release
  252. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  253. - new upstream release
  254. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  255. - new upstream release
  256. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  257. - new upstream release
  258. - update Patch0
  259. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  260. - new upstream release
  261. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  262. - add Group tag
  263. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  264. - new upstream release
  265. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  266. - new upstream release
  267. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  268. - initial build for Vine Linux
  269. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  270. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  271. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  272. - Update to 2.6.0
  273. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  274. - Update to 2.5.90
  275. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  276. - Obsolete libwebkit2gtk from the webkitgtk3 package
  277. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  278. - rebuild for ICU 53.1
  279. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  280. - Add support for secondary arches
  281. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  282. - Add webkitgtk-2.5.3-toggle-buttons.patch
  283. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  284. - More package review fixes (#1131284)
  285. - Correct the license tag to read LGPLv2
  286. - Filter out provides for private libraries
  287. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  288. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  289. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  290. - Update to 2.5.3
  291. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  292. - Initial Fedora packaging, based on the webkitgtk3 package