TrueType-sazanami-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390
  1. # Command macros
  2. %define __mkfontdir umask 133;/usr/bin/mkfontdir
  3. %define __mkfontscale umask 133;/usr/bin/mkfontscale
  4. # Use this macro to call fc-cache throughout the specfile.
  5. %define __fccache umask 133;which fc-cache &> /dev/null && fc-cache -f
  6. %define version 4.2
  7. %define release 1%{?_dist_release}
  8. %define sazanami_date 20040629-vl-20061231
  9. %define ttfjp_version 6.0
  10. %define xfontdir %{_datadir}/fonts/TrueType-sazanami
  11. %define fontpathdir %{_sysconfdir}/X11/fontpath.d
  12. Summary: Free Japanese True Type Font (Sazanami)
  13. Summary(ja): フリーの日本語 True Type フォント(さざなみ明朝/さざなみゴシック)
  14. Name: TrueType-sazanami
  15. Version: %{version}
  16. Release: %{release}
  17. BuildArch: noarch
  18. PreReq: TrueType-base >= 4.4.1
  19. Requires: TrueType-base >= 4.4.1
  20. Provides: TrueTypeFonts_jp = %{ttfjp_version}
  21. Obsoletes: TrueTypeFonts_jp < 4.1
  22. Obsoletes: TrueType-kochi <= 4.4.1
  23. Provides: TrueType-kochi = %{ttfjp_version}
  24. Requires: %{name}-mincho = %{version}-%{release}
  25. Requires: %{name}-gothic = %{version}-%{release}
  26. # This is not really required, but usefull to upgrade.
  27. Requires: TrueType-vlgothic
  28. Source: %{name}.tar.bz2
  29. Source10: 60-sazanami-mincho.conf
  30. Source11: 60-sazanami-gothic.conf
  31. Source20: cidfmap.ja.sazanami-mincho
  32. Source21: cidfmap.ja.sazanami-gothic
  33. # Sazanami Font Family
  34. Source4: sazanami-%{sazanami_date}.tar.bz2
  35. License: distributable
  36. Group: User Interface/X
  37. Buildroot: %{_tmppath}/%{name}-root
  38. Distribution: Vine Linux
  39. Vendor: Project Vine
  40. %description
  41. This is meta package for Free Japanese True Type Font 'Sazanami Font'
  42. - Sazanami-Mincho
  43. - Sazanami-Gothic
  44. %description -l ja
  45. このパッケージはフリーの日本語 True Type フォント「さざなみフォント」
  46. の明朝、ゴシック両書体をインストールするためのメタパッケージです。この
  47. パッケージで以下のフォントがインストールされます。
  48. - さざなみ明朝
  49. - さざなみゴシック
  50. %package mincho
  51. Summary: Sazanami Mincho TrueType Fonts
  52. Summary(ja): さざなみ明朝 True Type フォント
  53. Group: User Interface/X
  54. Requires(post,postun): mktcapdir >= 0.5.4
  55. Requires(post,postun): fontconfig, xorg-x11-font-utils
  56. %description mincho
  57. This package includes Sazanami Mincho TrueType fonts.
  58. %description -l ja mincho
  59. このパッケージにはさざなみ明朝フォントが含まれています。
  60. %package gothic
  61. Summary: Sazanami Gothic TrueType Fonts
  62. Summary(ja): さざなみゴシック 日本語 True Type フォント
  63. Group: User Interface/X
  64. Requires(post,postun): mktcapdir >= 0.5.4
  65. Requires(post,postun): fontconfig, xorg-x11-font-utils
  66. %description gothic
  67. This package includes Sazanami Gothic TrueType fonts.
  68. %description -l ja gothic
  69. このパッケージにはさざなみゴシックフォントがふくまれています。
  70. %prep
  71. rm -rf ${RPM_BUILD_ROOT}
  72. %setup -n %{name} -a 4
  73. mv sazanami-%{sazanami_date}/* .
  74. %install
  75. # mkdir fontdirs
  76. mkdir -p $RPM_BUILD_ROOT/%{xfontdir}-{mincho,gothic}
  77. # install ttfconf
  78. install -m644 *-mincho.ttfconf *-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho
  79. install -m644 *-gothic.ttfconf *-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic
  80. # install fonts
  81. ln -sf sazanami-mincho.ttf $RPM_BUILD_ROOT/%{xfontdir}-mincho/kochi-mincho.ttf
  82. ln -sf sazanami-gothic.ttf $RPM_BUILD_ROOT/%{xfontdir}-gothic/kochi-gothic.ttf
  83. # install fontpath.d symlink
  84. mkdir -p $RPM_BUILD_ROOT/%{fontpathdir}
  85. ln -sf %{xfontdir}-mincho $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-mincho
  86. ln -sf %{xfontdir}-gothic $RPM_BUILD_ROOT/%{fontpathdir}/%{name}-gothic
  87. # install fontconfig files
  88. mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.{avail,d}
  89. install -m644 %{SOURCE10} %{SOURCE11} $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/
  90. for i in $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.avail/*.conf
  91. do
  92. ln -sf ../conf.avail/$(basename $i) $RPM_BUILD_ROOT/%{_sysconfdir}/fonts/conf.d/
  93. done
  94. # install ghostscript8 cidfmap
  95. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
  96. install -m644 %{SOURCE20} %{SOURCE21} $RPM_BUILD_ROOT%{_datadir}/ghostscript/conf.d
  97. %post mincho
  98. %{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
  99. ( %__fccache %{xfontdir}-mincho ) ||:
  100. %post gothic
  101. %{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
  102. ( %__fccache %{xfontdir}-gothic ) ||:
  103. %postun mincho
  104. %{_bindir}/mktcapdir %{xfontdir}-mincho %{xfontdir}-mincho/*.ttfconf
  105. ( %__fccache %{xfontdir}-mincho ) ||:
  106. %postun gothic
  107. %{_bindir}/mktcapdir %{xfontdir}-gothic %{xfontdir}-gothic/*.ttfconf
  108. ( %__fccache %{xfontdir}-gothic ) ||:
  109. %clean
  110. rm -rf $RPM_BUILD_ROOT
  111. %files
  112. %defattr(-,root,root)
  113. %doc README doc/
  114. %files mincho
  115. %defattr(-,root,root)
  116. %{xfontdir}-mincho/*
  117. %{fontpathdir}/%{name}-mincho
  118. %{_sysconfdir}/fonts/conf.avail/60-sazanami-mincho.conf
  119. %config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-mincho.conf
  120. %config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-mincho
  121. %files gothic
  122. %defattr(-,root,root)
  123. %{xfontdir}-gothic/*
  124. %{fontpathdir}/%{name}-gothic
  125. %{_sysconfdir}/fonts/conf.avail/60-sazanami-gothic.conf
  126. %config(missingok,noreplace) %{_sysconfdir}/fonts/conf.d/60-sazanami-gothic.conf
  127. %config %{_datadir}/ghostscript/conf.d/cidfmap.ja.sazanami-gothic
  128. %changelog
  129. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2-1
  130. - add gs8 cidfmap for sazanami
  131. * Sat Jun 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1-1
  132. - split mincho and gothic to its own fontdir
  133. - add fontpath.d symlink
  134. * Thu May 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-1
  135. - build for xorg-x11-7.3
  136. - change font location to %{_datadir}/fonts/TrueType-sazanami
  137. - require(post,postun) fontconfig and xorg-x11-font-utils
  138. - split to TrueType-sazanami-mincho and TrueType-sazanami-gothic
  139. * Sat Sep 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0-0vl1
  140. - split out VLGothic to TrueType-vlgothic package.
  141. * Sat Sep 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10-0vl1
  142. - update VLGothic to 20070901
  143. - update some kanji glyphs
  144. * Thu Aug 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-0vl1
  145. - update VLGothic to 20070830
  146. - update M+1C/M+1M to CVS head
  147. - update some kanji glyphs
  148. * Mon Jul 31 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8-0vl1
  149. - update VLGothic to 20070731
  150. - update M+1C/M+1M to CVS head
  151. - add new glyphs to VL-PGothic/VL-Gothic
  152. - add Roman Numeral Glyphs (some part of Number Forms)
  153. - update some glyphs
  154. * Mon May 07 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-0vl1
  155. - update VLGothic to 20070507
  156. - add new glyphs to VL-Gothic
  157. - add ISO8859-1 Glyphs (Latin-1 Supplement)
  158. - add ISO8859-15 Glyphs (some part of Latin Extended-A)
  159. * Sun May 06 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6-0vl1
  160. - update VLGothic to 20070506
  161. - add new glyphs to VL-PGothic
  162. - add ISO8859-1 Glyphs (Latin-1 Supplement)
  163. - add ISO8859-15 Glyphs (some part of Latin Extended-A)
  164. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5-0vl1
  165. - update VLGothic to 20070503
  166. - update M+1C/1M to CVS head
  167. * Wed Mar 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4-0vl1
  168. - update VLGothic to 20070328
  169. - update M+1C/1M to CVS head
  170. - fix embolden problem on freetype-2.2
  171. * Sat Mar 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3-0vl1
  172. - update VLGothic to 20070317
  173. - update M+1C/1M to CVS head
  174. - include M+ Kanji glyphs
  175. - update some glyphs
  176. - add some special sign characters
  177. - fix broken glyphs
  178. * Mon Jan 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2-0vl1
  179. - update VLGothic to 20070101
  180. - fix embolden problem on freetype-2.2
  181. * Sun Dec 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-0vl1
  182. - update VLGothic to 20061231
  183. - update M+1C/M+1M to cvs head 20061231
  184. - update kanji glyphs
  185. - update Sazanami to 20040629-vl-20061231
  186. - fix broken glyphs of sazanami-mincho
  187. * Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-0vl1
  188. - bump up version to 2.0
  189. - update VLGothic to 20061026
  190. - update greek letter glyphs
  191. - split license information file from README.
  192. - add english version of license.
  193. * Sat Oct 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.29-0vl1
  194. - update VLGothic to 20061021
  195. * Fri Oct 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.28-0vl1
  196. - update VLGothic to 20061020 (<BTS:221>)
  197. - update M+1C/M+1M to TESTFILGHT012
  198. - update some glyphs
  199. - fix outline direction
  200. - remove overlap path
  201. * Thu Oct 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.27-0vl1
  202. - update VLGothic to 20061005 (<BTS:221>)
  203. - update some glyphs
  204. - fix outline direction
  205. - remove overlap path
  206. * Sat Sep 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26-0vl1
  207. - update VLGothic to 20060930 (<BTS:221>)
  208. - fix outline direction
  209. - remove overlap path
  210. * Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.25-0vl1
  211. - update VLGothic to 20060929
  212. - update some glyphs
  213. - fix outline direction
  214. - remove overlap path
  215. * Mon Sep 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24-0vl1
  216. - update VLGothic to 20060925
  217. - update some glyphs
  218. - add minimum gsub table for vertical writing
  219. * Thu Sep 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.23-0vl1
  220. - update VLGothic to 20060921
  221. - update few glyphs
  222. - update M+1C/M+1M to cvs head 2006/09/21
  223. * Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-0vl1
  224. - update VLGothic to 20060913
  225. - update some glyphs
  226. - fix half width space
  227. * Mon Sep 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-0vl1
  228. - update VLGothic to 20060911
  229. - update M+1C/M+1M to cvs head 2006/09/11
  230. - use VL-PGothic for -alias-gothic-p- (legacy core font)
  231. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-0vl1
  232. - update VLGothic to 20060831
  233. - add VL-Gothic-Regular.ttf for
  234. - use M+1C for VLPGothic instead of M+1P
  235. * Mon Aug 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.19-0vl1
  236. - fix sazanami.ttfconf
  237. * Tue Aug 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18-0vl1
  238. - change the fontname to VLPGothic
  239. - update VLPGothic
  240. - TODO:
  241. - split VLGothic family to new package.
  242. - add M+1M based VLGothic for monospace font.
  243. * Wed Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17-0vl1
  244. - update M+1P+Sazanami.ttf
  245. - refine more glyphs
  246. * Wed Aug 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16-0vl1
  247. - update M+1P+Sazanami.ttf
  248. - refine more glyphs
  249. - add some glyphs for windows compatibility
  250. - update sazanami.ttfconf
  251. - add -fake-kochi gothic-, -fake-kochi mincho- without TTCap
  252. for Flash Plugin. (<BTS:0100>)
  253. * Fri Aug 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.15-0vl1
  254. - update M+1P+Sazanami.ttf
  255. - refine more glyphs
  256. - add new full-width alphabets and numeric letters based on M+1P
  257. * Mon Jul 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
  258. - update M+1P+Sazanami.ttf
  259. - refine more glyphs
  260. * Sun Jul 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13-0vl1
  261. - update M+1P+Sazanami.ttf
  262. - refine more glyphs
  263. - redesign greek letter based on M+ 1P fonts
  264. * Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12-0vl1
  265. - update M+1P+Sazanami.ttf
  266. - refine more glyphs
  267. * Sun Jul 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11-0vl1
  268. - update M+1P+Sazanami.ttf
  269. - refine more glyphs
  270. * Fri Jul 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10-0vl1
  271. - update M+1P+Sazanami.ttf
  272. - refine more glyphs
  273. - fix encoding
  274. * Thu Jul 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-0vl1
  275. - update M+1P+Sazanami.ttf
  276. - refine more glyphs
  277. - fix outline direction (fix corruption on emboldening)
  278. * Wed Jul 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8-0vl1
  279. - update M+1P+Sazanami.ttf
  280. - refine more glyphs
  281. - fix broken glyph
  282. - refine greek letters
  283. * Tue Jul 18 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7-0vl1
  284. - update M+1P+Sazanami.ttf
  285. - refine more glyphs
  286. - TODO: should rename the fontname?
  287. * Sun Jul 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6-0vl1
  288. - update M+1P+Sazanami.ttf
  289. - fix outline direction (fix corruption of some glyphs)
  290. - refine more glyphs
  291. * Wed Jul 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl1
  292. - update M+1P+Sazanami.ttf
  293. - refine some glyphs.. (modified 200 or more)
  294. - update sazanami.ttfconf to use M+1P+Sazanami for alias-{sans,gothic}-p
  295. * Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4-0vl1
  296. - update M+1P+Sazanami.ttf
  297. - refine some glyphs.. (modified 100 or more)
  298. * Mon Jul 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-0vl1
  299. - update M+1P-Sazanami.ttf
  300. - fix corruption of some glyphs
  301. - refine some glyphs to make it more usable..
  302. * Thu May 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
  303. - add M+1P+Sazanami.ttf (Mplus 1P Font + Sazanami Gothic)
  304. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1-0vl1
  305. - new upstream release
  306. * Wed Jun 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-0vl1
  307. - initial build for Vine Linux based on TrueType-kochi-subst package
  308. - Provides TrueType-kochi, TrueTypeFonts_jp
  309. - include Kochi-{mincho,gothic}.ttf symlinks for compatibility