gedit-plugins-vl.spec 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. Name: gedit-plugins
  2. Version: 2.32.0
  3. Release: 1%{?_dist_release}
  4. Summary: A collection Official Plugins for gedit
  5. Summary: gedit の公式プラグイン集
  6. Group: Applications/Editors
  7. License: GPLv2+
  8. URL: http://live.gnome.org/GeditPlugins
  9. Source0: ftp://ftp.gnome.org/pub/gnome/sources/gedit-plugins/2.32/%{name}-%{version}.tar.bz2
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: intltool >= 0.35.0
  12. BuildRequires: perl >= 5.8.1
  13. BuildRequires: perl-XML-Parser
  14. BuildRequires: gettext
  15. BuildRequires: glib2-devel >= 2.24.0
  16. BuildRequires: gtk2-devel >= 2.20.0
  17. BuildRequires: GConf2-devel
  18. BuildRequires: gtksourceview2-devel >= 2.5.1
  19. BuildRequires: gedit-devel >= 2.30.0
  20. BuildRequires: gucharmap-devel >= 2.30.0
  21. BuildRequires: gnome-doc-utils
  22. BuildRequires: vte-devel
  23. BuildRequires: pygtk2-devel >= 2.12.0
  24. BuildRequires: pygtksourceview-devel >= 2.2.0
  25. BuildRequires: pygobject-devel >= 2.15.4
  26. BuildRequires: python-devel
  27. Requires: gedit
  28. Requires: pygtk2
  29. Requires: pygtksourceview
  30. Requires: pygobject
  31. Requires(pre): GConf2
  32. Requires(post): GConf2
  33. Requires(preun): GConf2
  34. %description
  35. A collection of Official plugins for gedit.
  36. * Bookmarks: Easy document navigation with bookmarks
  37. * Bracket Completion: Automatically adds closing brackets.
  38. * Character Map: Insert special characters just by clicking on them.
  39. * Code comment: Comment out or uncomment a selected block of code.
  40. * Color Picker: Pick a color from a dialog and insert its hexadecimal representation.
  41. * Draw Spaces: Draw Spaces and Tabs
  42. * Join/Split Lines: Join several lines or split long ones
  43. * Session Saver: Save and restore your working sessions
  44. * Show/Hide Tabbar: Add a menu entry to show/hide the tabbar.
  45. * Smart Spaces: Forget you're not using tabulations.
  46. * Embedded Terminal: Embed a terminal in the bottom pane.
  47. %description -l ja
  48. gedit の公式プラグイン集です。
  49. * ブックマーク: ブックマークを使って簡単にドキュメントを閲覧できるようにします。
  50. * 括弧の補完: 対応する閉じ括弧を自動的に追加します。
  51. * 文字マップ: 特殊な文字をクリックしながら挿入していきます。
  52. * コードのコメント: 選択した範囲をコメントアウトしたり解除します。
  53. * 色の取得: 色選択ダイアログから色を取得して 16進形式の文字列として挿入します。
  54. * 空白文字の表示: 空白やタブ文字を描画します。
  55. * 行の結合・分割: 複数の行と結合したり一行を分割したりします。
  56. * セッションの保存: 現在、作業中のセッションを保存したりリストアします。
  57. * タブバーの表示/非表示: タブバーの表示切り替えエントリをメニューに追加します。
  58. * スマート・スペース: 作表を使っていないことを忘れて下さい。
  59. * 埋め込み式の端末: ボトム・ペインに端末を埋め込みます。
  60. %prep
  61. %setup -q
  62. grep '"import vte' configure && sed \
  63. -i "s!import vte!import imp; imp.find_module('vte')!" configure
  64. %build
  65. %configure --disable-schemas-install --enable-python
  66. #--with-plugins=bracketcompletion,charmap,codecomment,colorpicker,drawspaces,joinlines,showtabbar,smartspaces,terminal,bookmarks
  67. make %{?_smp_mflags}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make install DESTDIR=$RPM_BUILD_ROOT
  71. %find_lang %{name}
  72. find $RPM_BUILD_ROOT/%{_libdir}/gedit-2/plugins -name "*.la" -exec rm {} \;
  73. %clean
  74. rm -rf $RPM_BUILD_ROOT
  75. %pre
  76. if [ "$1" -gt 1 ]; then
  77. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  78. gconftool-2 --makefile-uninstall-rule \
  79. %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas >/dev/null || :
  80. fi
  81. %post
  82. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  83. gconftool-2 --makefile-install-rule \
  84. %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
  85. %preun
  86. if [ "$1" -eq 0 ]; then
  87. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  88. gconftool-2 --makefile-uninstall-rule \
  89. %{_sysconfdir}/gconf/schemas/gedit-show-tabbar-plugin.schemas > /dev/null || :
  90. fi
  91. %check
  92. [ -f ${RPM_BUILD_ROOT}%{_libdir}/gedit-2/plugins/terminal.py ]
  93. %files -f %{name}.lang
  94. %defattr(-,root,root,-)
  95. %doc README NEWS AUTHORS COPYING
  96. %config(noreplace) %{_sysconfdir}/gconf/schemas/*.schemas
  97. %{_libdir}/gedit-2/plugins/*
  98. %{_datadir}/gedit-2/plugins/*
  99. %changelog
  100. * Tue Oct 05 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.32.0-1
  101. - new upstream release
  102. * Sun Apr 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.30.0-1
  103. - new upstream release
  104. - add BuildRequires: python-devel
  105. * Tue Dec 1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.28.0-2
  106. - added BuildRequires: gedit-devel
  107. * Tue Nov 3 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.0-1
  108. - new upstream release
  109. * Sun Aug 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.3-1
  110. - Update to upstream release
  111. * Fri Jun 5 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.2-1
  112. - Update to upstream release
  113. * Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.26.1-1
  114. - initial build for VineSeed
  115. * Sat Apr 11 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.1-1
  116. - Update to upstream release 2..26.1
  117. - Fixes GNOME bugzilla bug #576766 - Crash when Configuring "Draw Spaces"
  118. - Make sure to remove all *.la files
  119. - Remove BuildRequire libgnomeui-devel as needless now
  120. * Fri Apr 10 2009 Dodji Seketeli <dodji@redhat.org> - 2.26.0-1
  121. - Update to upstream release (2.26.1)
  122. - Add plugin files from %%{_datadir}
  123. - Don't check for vte anymore, the package checks it pkg-config
  124. - Add 'bookmarks' to the plugin set
  125. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.22.3-4
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  127. * Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.22.3-3
  128. - Rebuild for Python 2.6
  129. * Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-2
  130. - Fixed buildrequires
  131. * Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.3-1
  132. - Updated to 2.22.3
  133. * Mon Sep 29 2008 Rakesh Pandit <rakesh@fedoraproject.org> - 2.22.0-2
  134. - rebuild to pick latest gucharmap
  135. * Tue Mar 18 2008 Trond Danielsen <trond.danielsen@gmail.com> - 2.22.0-1
  136. - Updated.
  137. * Mon Apr 30 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-2
  138. - Disable buggy session saver plugin.
  139. - Removed static libraries.
  140. * Sun Apr 01 2007 Trond Danielsen <trond.danielsen@gmail.com> - 2.18.0-1
  141. - Initial version.