gnome-bluetooth-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426
  1. Summary: GNOME Bluetooth Subsystem
  2. Summary(ja): GNOME Bluetooth サブシステム
  3. Name: gnome-bluetooth
  4. Version: 2.32.0
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Libraries
  8. URL: http://live.gnome.org/GnomeBluetooth
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/2.32/%{name}-%{version}.tar.bz2
  10. Source1: 61-gnome-bluetooth-rfkill.rules
  11. #----------------------------------------------------------------------------
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. #----------------------------------------------------------------------------
  14. #BuildRequires: autoconf >= 2.57
  15. BuildRequires: bluez-libs-devel >= 2.8
  16. #BuildRequires: bluez-utils
  17. BuildRequires: libbonobo-devel >= 2.32.0
  18. BuildRequires: libbonoboui-devel >= 2.24.4
  19. BuildRequires: GConf2-devel >= 2.32
  20. BuildRequires: hal-devel
  21. BuildRequires: unique-devel
  22. BuildRequires: libnotify-devel
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: intltool, automake, libtool, gettext
  25. Requires: %{name}-libs = %{version}-%{release}
  26. Requires(pre): GConf2
  27. Requires(post): GConf2
  28. Requires(preun): GConf2
  29. Requires: bluez >= 4.42
  30. Requires: obexd
  31. Requires(post): desktop-file-utils
  32. Requires(postun): desktop-file-utils
  33. ExcludeArch: s390 s390x
  34. ## Patch1: gnome-bluetooth-0.8.0-desktop.patch
  35. #----------------------------------------------------------------------------
  36. %description
  37. This package contains a library with widgets for Bluetooth applications.
  38. %description -l ja
  39. このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
  40. ライブラリが含まれます。
  41. #----------------------------------------------------------------------------
  42. %package libs
  43. Summary: Libraries for applications, which use gnome-bluetooth
  44. Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
  45. Group: Development/Libraries
  46. %description libs
  47. This package contains the libraries for applications,
  48. which use gnome-bluetooth.
  49. %description libs -l ja
  50. このパッケージには Gnome-bluetoothを使用するアプリケーション用の
  51. ライブラリが含まれています。
  52. #----------------------------------------------------------------------------
  53. %package devel
  54. Summary: Files for the development of applications, which use gnome-bluetooth
  55. Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
  56. Group: Development/Libraries
  57. License: LGPLv2+
  58. Requires: %{name}-libs = %{version}-%{release}
  59. Requires: gtk-doc pkgconfig
  60. Requires: glib2-devel
  61. Requires: libbtctl-devel
  62. %description devel
  63. This package contains the files for the development of applications,
  64. which will use gnome-bluetooth.
  65. %description devel -l ja
  66. このパッケージにはGnome-bluetoothを使用するアプリケーションを
  67. 開発するためのヘッダーファイルなどが含まれています(develパッケージ)
  68. #----------------------------------------------------------------------------
  69. %prep
  70. %setup -q -n gnome-bluetooth-%{version}
  71. ## %patch1 -p1 -b .dfix
  72. %build
  73. %configure --disable-desktop-update --disable-icon-update --disable-nautilus-sendto --enable-introspection=yes
  74. make %{?_smp_mflags}
  75. #----------------------------------------------------------------------------
  76. %install
  77. rm -rf $RPM_BUILD_ROOT
  78. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  79. make DESTDIR=$RPM_BUILD_ROOT install
  80. # we do not want .la files
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
  82. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
  83. rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
  84. rm -f $RPM_BUILD_ROOT/%{_libdir}/nautilus-sendto/plugins/*.la
  85. install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  86. # Remove the gnome-obex-server
  87. # rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
  88. %find_lang gnome-bluetooth2
  89. %find_lang %{name} --with-gnome
  90. cat %{name}.lang >> gnome-bluetooth2.lang
  91. # save space by linking identical images in translated docs
  92. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  93. for f in $helpdir/C/figures/*.png; do
  94. b="$(basename $f)"
  95. for d in $helpdir/*; do
  96. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  97. g="$d/figures/$b"
  98. if [ -f "$g" ]; then
  99. if cmp -s $f $g; then
  100. rm "$g"; ln -s "../../C/figures/$b" "$g"
  101. fi
  102. fi
  103. fi
  104. done
  105. done
  106. %clean
  107. rm -rf $RPM_BUILD_ROOT
  108. %pre
  109. #if [ "$1" -gt 1 ]; then
  110. # export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  111. # if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  112. # gconftool-2 --makefile-uninstall-rule \
  113. # %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
  114. # fi
  115. #fi
  116. if [ "$1" -gt 1 ]; then
  117. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  118. if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  119. gconftool-2 --makefile-uninstall-rule \
  120. %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
  121. fi
  122. if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
  123. gconftool-2 --makefile-uninstall-rule \
  124. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  125. >& /dev/null || :
  126. fi
  127. fi
  128. %post
  129. update-desktop-database -q
  130. %posttrans
  131. glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
  132. %preun
  133. #if [ "$1" -eq 0 ]; then
  134. # export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  135. # if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  136. # gconftool-2 --makefile-uninstall-rule \
  137. # %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
  138. # fi
  139. #fi
  140. if [ "$1" -eq 0 ]; then
  141. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  142. if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  143. gconftool-2 --makefile-uninstall-rule \
  144. %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
  145. fi
  146. if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
  147. gconftool-2 --makefile-uninstall-rule \
  148. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  149. >& /dev/null || :
  150. fi
  151. fi
  152. %postun
  153. update-desktop-database -q
  154. glib-compile-schemas %{_datadir}/glib-2.0/schemas || :
  155. if [ $1 -eq 0 ] ; then
  156. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  157. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  158. fi
  159. %post libs
  160. /sbin/ldconfig
  161. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  162. %posttrans libs
  163. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  164. %postun libs
  165. /sbin/ldconfig
  166. if [ $1 -eq 0 ] ; then
  167. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  168. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  169. fi
  170. #----------------------------------------------------------------------------
  171. %files -f %{name}.lang
  172. %defattr(-, root, root)
  173. %doc README NEWS COPYING
  174. %{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
  175. %{_bindir}/bluetooth-*
  176. %{_libdir}/gnome-bluetooth/
  177. %{_datadir}/applications/*.desktop
  178. %{_datadir}/gnome-bluetooth/
  179. %{_datadir}/locale/*
  180. %{_datadir}/GConf/gsettings/gnome-bluetooth
  181. %{_datadir}/glib-2.0/schemas/org.gnome.Bluetooth.gschema.xml
  182. %{_mandir}/man1/*
  183. /lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  184. %files libs
  185. %defattr(-,root,root,-)
  186. %doc COPYING.LIB
  187. %{_libdir}/libgnome-bluetooth.so.*
  188. %{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
  189. %{_datadir}/icons/hicolor/*/apps/*
  190. %{_datadir}/icons/hicolor/*/status/*
  191. %files devel
  192. %defattr(-,root,root,-)
  193. %{_includedir}/gnome-bluetooth/
  194. %{_libdir}/libgnome-bluetooth.so
  195. %{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
  196. %{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
  197. %{_datadir}/gtk-doc/html/gnome-bluetooth/
  198. #----------------------------------------------------------------------------
  199. # Maintainers: babasaki@mindgear.org
  200. #
  201. #----------------------------------------------------------------------------
  202. %changelog
  203. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  204. - new upstream release
  205. - remove BuildRequires: gir-repository-devel
  206. - add Requires(post) and Requires(postun): desktop-file-utils
  207. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
  208. - rebuild with rpm-4.8.1 for pkg-config file
  209. * Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  210. - new upstream release
  211. - add BuildRequires: gir-repository-devel
  212. - add configure option (--disable-nautilus-sendto)
  213. * Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  214. - new upstream release
  215. - merge spec file from FC package
  216. * Fri Oct 24 2008 Seiichirou Babasaki 0.11.0-6
  217. - Update to 0.11.0 (VineSeed)
  218. - added "# Maintainers: " comments.
  219. - changed UTF-8 encode at gnome-bluetooth.vsc.spec
  220. - FedoraCore - LOGS
  221. -- 0.11.0-5
  222. -- Rebuild against new bluez-libs
  223. -- 0.11.0-4
  224. -- Changed name of icon file(#444811)
  225. -- 0.11.0-3
  226. -- Remove gnome-obex-server, we should use gnome-user-share now
  227. -- 0.11.0-1
  228. -- gcc43 rebuild
  229. -- 0.11.0 - Update to 0.11.0
  230. -- 0.10.0 - Update to 0.10.0
  231. -- 0.9.1-4
  232. -- marked gnome-obex-server.schemas as config file
  233. -- changed upstream URL
  234. -- 0.9.1-3
  235. -- fixed wrong source URL
  236. -- 0.9.1-2
  237. -- rebuilt for F8
  238. -- changed license tag to GPLv2 and LGPLv2+
  239. -- 0.9.1-1
  240. -- Upgrade to 0.9.1 to fix a crasher in the server
  241. -- 0.9.0-1
  242. -- Update for 0.9.0
  243. -- Fix installation of the python bindings
  244. -- 0.8.0-4
  245. -- Remove unncessary gconfd killing from scripts (#224561)
  246. -- 0.8.0-3
  247. -- corrected BuildRoot
  248. -- smp flags added
  249. -- specfile cleanup
  250. -- fixed desktop file
  251. - Updated specfile
  252. * Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
  253. - Updated specfile
  254. * Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
  255. - Import gnome-bluetooth - Packager: Babasaki
  256. - Updated specfile (downgrade -> 0.8.0-0vl1)
  257. #----------------------------------------------------------------------------
  258. * Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
  259. - version 0.8.0
  260. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
  261. - rebuild
  262. * Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
  263. - bump for new openobex
  264. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
  265. - Missing automake, libtool, gettext BR
  266. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
  267. - Bump for new libbluetooth
  268. * Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
  269. - add dependency on bluez-utils, cosmetic tweaks (bug #190280)
  270. * Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
  271. - install schemata correctly (bug #193518)
  272. * Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
  273. - more build requires (bug #193374)
  274. * Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
  275. - pydir fixes for lib64
  276. * Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
  277. - version 0.7.0
  278. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
  279. - bump again for double-long bug on ppc(64)
  280. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
  281. - rebuilt for new gcc4.1 snapshot and glibc changes
  282. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  283. - rebuilt
  284. * Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
  285. - Fix relative path for the icons in desktop files which no longer works
  286. with the icon cache.
  287. * Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
  288. - new version 0.6.0
  289. * Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
  290. - rebuild for new cairo
  291. * Thu Jul 7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
  292. - Minor spec file cleanups.
  293. - Fix relative path for the icons in desktop files which no longer works
  294. with the icon cache.
  295. - Remove useless zero epochs.
  296. - Remove explicit python abi requirement, it's automatic for FC4 and up.
  297. * Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
  298. - removed base requirement from libs
  299. * Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
  300. - devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
  301. * Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
  302. - rebuilt
  303. * Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
  304. - added gnome hbox patch for bug rh#149215
  305. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
  306. - added requires for python-abi
  307. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
  308. - split package into app, libs and devel
  309. * Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
  310. - fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
  311. * Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
  312. - buildrequire pygtk2-devel (bug 135032)
  313. - fixed gnome-bluetooth-manager script for 64bit (bug 134864)
  314. - fixed segfault on file receive (bug 133041)
  315. * Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
  316. - buildrequire libbtctl-devel
  317. - buildrequire openobex-devel >= 1.0.1
  318. - pythondir -> pyexecdir
  319. * Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
  320. - added build dependency for librsvg2-devel
  321. * Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
  322. - added pydir patch
  323. * Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
  324. - version 0.5.1
  325. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  326. - rebuilt
  327. * Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
  328. - corrected BuildRequires
  329. * Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
  330. - added EggToolBar patch for gcc34
  331. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  332. - rebuilt
  333. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  334. - rebuilt
  335. * Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
  336. - added autofoo patch
  337. * Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
  338. - add .so to gnome-vfs module, if libtool does not!
  339. * Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
  340. - call libtool finish
  341. * Wed Aug 6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
  342. - new version 0.4.1
  343. * Wed Jun 5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
  344. - initial RPM