kdevplatform-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193
  1. %if %{?_dist_release} != "vl5"
  2. %define kde KDE
  3. %else
  4. %define kde KDE4
  5. %endif
  6. Name: kdevplatform
  7. Summary: Libraries for use by %{kde} development tools
  8. Summary(ja): %{kde} 開発ツールが使用するライブラリ
  9. Version: 1.2.0
  10. Release: 1%{?_dist_release}
  11. Group: Development/Tools
  12. License: GPLv2
  13. URL: http://www.kdevelop.org/
  14. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.2.0/src/kdevplatform-%{version}.tar.bz2
  15. Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.2.0/src/kdevplatform-%{version}.md5sum
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: libboost-devel
  18. BuildRequires: gettext
  19. BuildRequires: kdelibs4-devel >= 4.6
  20. BuildRequires: kdesdk4-devel >= 4.6
  21. BuildRequires: pcre-devel
  22. BuildRequires: subversion-devel
  23. BuildRequires: apr-util-devel
  24. Requires: %{name}-libs = %{version}-%{release}
  25. Requires(postun): gtk2
  26. Requires(posttrans): gtk2
  27. %description
  28. %{kde} Development platform, the foundations upon which
  29. KDevelop and Quanta are built.
  30. %package libs
  31. Summary: Runtime libraries for %{name}
  32. Summary(ja): %{name} のランタイムライブラリ
  33. Group: System Environment/Libraries
  34. Requires: kdelibs4
  35. %description libs
  36. %{summary}.
  37. %package devel
  38. Summary: Developer files for %{name}
  39. Summary(ja): %{name} の開発用ファイル
  40. Group: Development/Libraries
  41. Requires: %{name}-libs = %{version}-%{release}
  42. Requires: libboost-devel
  43. Requires: commoncpp2-devel
  44. Requires: kdelibs4-devel
  45. Requires: subversion-devel
  46. %description devel
  47. %{summary}.
  48. %prep
  49. %setup -q -n kdevplatform-%{version}
  50. %build
  51. mkdir -p %{_target_platform}
  52. pushd %{_target_platform}
  53. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  54. %cmake \
  55. -DCMAKE_BUILD_TYPE=release \
  56. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  57. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  58. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  59. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  60. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  61. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  62. ..
  63. popd
  64. make %{?_smp_mflags} -C %{_target_platform}
  65. %install
  66. rm -rf %{buildroot}
  67. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  68. %find_lang %{name} --all-name --with-kde
  69. %clean
  70. rm -rf %{buildroot}
  71. %post
  72. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  73. %posttrans
  74. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  75. %postun
  76. if [ $1 -eq 0 ] ; then
  77. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  78. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  79. fi
  80. %post libs -p /sbin/ldconfig
  81. %postun libs -p /sbin/ldconfig
  82. %files -f %{name}.lang
  83. %defattr(-,root,root,-)
  84. %doc COPYING.PLUGINS COPYING.SRC
  85. %{_datadir}/kde4/apps/kdev*/
  86. %{_datadir}/kde4/services/*.desktop
  87. %{_datadir}/kde4/servicetypes/*.desktop
  88. %{_datadir}/icons/hicolor/*/*/*
  89. %files libs
  90. %defattr(-,root,root,-)
  91. %{_libdir}/lib*.so.*
  92. %{_libdir}/kde4/*.so
  93. %files devel
  94. %defattr(-,root,root,-)
  95. %{_libdir}/lib*.so
  96. %{_includedir}/kde4/kdevplatform/
  97. %{_libdir}/cmake/kdevplatform/
  98. %changelog
  99. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-1
  100. - new upstream release
  101. * Thu Jan 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.1.2-1
  102. - new upstream release
  103. - added Japanese summary
  104. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
  105. - removed R: kdevplatform from libs package
  106. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  107. - Initial build for Vine Linux
  108. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
  109. - kdevplatform-1.0.0
  110. * Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
  111. - kdevplatform-0.10.2
  112. * Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
  113. - kdevplatform-0.10.0
  114. * Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
  115. - kdevplatform-0.9.99
  116. * Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
  117. - kdevplatform-0.9.98
  118. * Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
  119. - rebuild (boost)
  120. - BR: kdelibs4-devel
  121. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
  122. - kdevplatform-0.9.97
  123. - kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
  124. * Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
  125. - rebuild (fc13+, qt-4.6.0-rc1)
  126. * Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
  127. - New snapshot
  128. * Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
  129. - Fix finding Kompare includes
  130. * Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
  131. - Use official release
  132. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
  133. - Add icon scriptlets
  134. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
  135. - Update tarball
  136. * Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
  137. - 1.0 Beta 3
  138. * Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
  139. - Post KDevplatform 1.0 Beta 1 snapshot
  140. * Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
  141. - 0.9.85 snapshot