nspluginwrapper-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. # Compile as a debug package
  3. %define make_debug_package 0
  4. # What gecko we use
  5. %define gecko_flavour "mozilla"
  6. %define plugin_config_version 1.9
  7. %define plugin_config_name plugin-config-%{plugin_config_version}
  8. %define plugin_config_binary plugin-config
  9. # Excluded plugins (separated by ':')
  10. %define exclude_list "libtotem*:libjavaplugin*:gecko-mediaplayer*:mplayerplug-in*:librhythmbox*:packagekit*"
  11. # Target defines
  12. %if "%{_target_cpu}" == "i386"
  13. %define target_bits 32
  14. %endif
  15. %if "%{_target_cpu}" == "i586"
  16. %define target_bits 32
  17. %endif
  18. %if "%{_target_cpu}" == "i686"
  19. %define target_bits 32
  20. %endif
  21. %if "%{_target_cpu}" == "ppc"
  22. %define target_bits 32
  23. %endif
  24. %if "%{_target_cpu}" == "x86_64"
  25. %define target_bits 64
  26. %endif
  27. %if "%{_target_cpu}" == "ppc64"
  28. %define target_bits 64
  29. %endif
  30. # Define libraries for 32/64 arches
  31. %define lib32 lib
  32. %define lib64 lib64
  33. %define libdir32 /usr/lib
  34. %define libdir64 /usr/lib64
  35. # define nspluginswrapper libdir (invariant, including libdir)
  36. %define pkgdir32 %{libdir32}/%{name}
  37. %define pkgdir64 %{libdir64}/%{name}
  38. # define mozilla plugin dir and back up dir for 32-bit browsers
  39. %define pluginsourcedir32 %{libdir32}/mozilla/plugins
  40. %define plugindir32 %{libdir32}/mozilla/plugins-wrapped
  41. # define mozilla plugin dir and back up dir for 64-bit browsers
  42. %define pluginsourcedir64 %{libdir64}/mozilla/plugins
  43. %define plugindir64 %{libdir64}/mozilla/plugins-wrapped
  44. %define build_dir objs-%{target_bits}
  45. %if "%{target_bits}" == "32"
  46. %define lib %{lib32}
  47. %define libdir %{libdir32}
  48. %define pkgdir %{pkgdir32}
  49. %define plugindir %{plugindir32}
  50. %define pluginsourcedir %{pluginsourcedir32}
  51. %else
  52. %define lib %{lib64}
  53. %define libdir %{libdir64}
  54. %define pkgdir %{pkgdir64}
  55. %define plugindir %{plugindir64}
  56. %define pluginsourcedir %{pluginsourcedir64}
  57. %endif
  58. Summary: A compatibility layer for Netscape 4 plugins
  59. Name: nspluginwrapper
  60. Version: 1.3.0
  61. Release: 3%{?_dist_release}
  62. Source0: %{name}-%{version}%{?svndate:-%{svndate}}.tar.bz2
  63. Source1: %{plugin_config_name}.tar.gz
  64. Source2: plugin-config.sh.in
  65. Source3: %{name}.sh.in
  66. Patch1: nspluginwrapper-1.3.0-make.patch
  67. Patch2: nspluginwrapper-1.3.0-configure.patch
  68. Patch3: nspluginwrapper-1.3.0-directory.patch
  69. Patch4: nspluginwrapper-20090625-fix-npident-array-sending.patch
  70. Patch5: nspluginwrapper-1.3.0-inst.patch
  71. Patch6: nspluginwrapper-1.3.0-compiz.patch
  72. Patch7: nspluginwrapper-1.3.0-comp.patch
  73. Patch8: nspluginwrapper-1.3.0-silent.patch
  74. Patch9: nspluginwrapper-1.3.0-timeout.patch
  75. Patch100: plugin-config-setuid.patch
  76. Patch101: plugin-config-umask.patch
  77. Patch102: plugin-config-print.patch
  78. Patch103: plugin-config-native.patch
  79. Patch104: plugin-config-time-check.patch
  80. License: GPLv2+
  81. Group: Applications/Internet
  82. URL: http://gwenole.beauchesne.info/projects/nspluginwrapper/
  83. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  84. Provides: %{name} = %{version}-%{release}
  85. #Requires: mozilla-filesystem
  86. %ifarch x86_64
  87. Requires: compat32-%{name} = %{version}-%{release}
  88. %endif
  89. BuildRequires: pkgconfig gtk2-devel glib2-devel nspr-devel
  90. BuildRequires: libX11-devel libXt-devel cairo-devel pango-devel curl-devel
  91. BuildRequires: gecko-devel
  92. ExclusiveArch: %{ix86} x86_64 ppc
  93. %description
  94. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  95. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  96. This package consists in:
  97. * npviewer: the plugin viewer
  98. * npwrapper.so: the browser-side plugin
  99. * nspluginplayer: stand-alone NPAPI plugin player
  100. * mozilla-plugin-config: a tool to manage plugins installation and update
  101. ## to build compat32 for x86_64 architecture support
  102. %package -n compat32-%{name}
  103. Summary: A compatibility layer for Netscape 4 plugins
  104. Group: System Environment/Libraries
  105. %description -n compat32-%{name}
  106. nspluginwrapper makes it possible to use Netscape 4 compatible plugins
  107. compiled for %{_arch} into Mozilla for another architecture, e.g. x86_64.
  108. This package consists in:
  109. * npviewer: the plugin viewer
  110. * npwrapper.so: the browser-side plugin
  111. * nspluginplayer: stand-alone NPAPI plugin player
  112. * mozilla-plugin-config: a tool to manage plugins installation and update
  113. %prep
  114. %setup -q -a 1
  115. # Installation & build patches
  116. %patch1 -p1 -b .make
  117. %patch2 -p1 -b .conf
  118. %patch3 -p1 -b .dir
  119. %patch4 -p0 -b .array
  120. %patch5 -p1 -b .inst
  121. %patch6 -p1 -b .compiz
  122. %patch7 -p1 -b .comp
  123. %patch8 -p1 -b .silent
  124. %patch9 -p1 -b .timeout
  125. # Plugin-config patches
  126. pushd %plugin_config_name
  127. %patch100 -p2
  128. %patch101 -p2 -b .umask
  129. %patch102 -p2 -b .print
  130. %patch103 -p2 -b .native
  131. %patch104 -p2 -b .time
  132. popd
  133. %build
  134. # Build wrapper
  135. # set the propper built options
  136. %if %{make_debug_package}
  137. %if "%{target_bits}" == "64"
  138. export CFLAGS="-g -m64 -DDEBUG"
  139. %else
  140. export CFLAGS="-g -m32 -DDEBUG"
  141. %endif
  142. %else
  143. export CFLAGS="$RPM_OPT_FLAGS"
  144. %endif
  145. # set the propper built options
  146. %if "%{target_bits}" == "64"
  147. export LDFLAGS="-m64 -L%{libdir64}"
  148. %else
  149. export LDFLAGS="-m32 -L%{libdir32}"
  150. %endif
  151. mkdir %{build_dir}
  152. pushd %{build_dir}
  153. ../configure \
  154. --prefix=%{_prefix} \
  155. --target-cpu=%{_target_cpu} \
  156. --pkgdir=%{name} \
  157. --pkglibdir=%{pkgdir} \
  158. --with-lib32=%{lib32} \
  159. --with-lib64=%{lib64} \
  160. --with-base-lib=%{lib} \
  161. --with-base-libdir=%{libdir} \
  162. --viewer-paths=%{pkgdir} \
  163. --with-x11-prefix=/usr \
  164. --with-gecko=%{gecko_flavour} \
  165. --enable-viewer \
  166. --viewer-paths="%{pkgdir32}:%{pkgdir64}"\
  167. --disable-biarch
  168. %__make
  169. popd
  170. #Build plugin configuration utility
  171. pushd %{plugin_config_name}
  172. ./configure --prefix=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
  173. %__make
  174. popd
  175. %install
  176. %__rm -rf $RPM_BUILD_ROOT
  177. %__mkdir_p $RPM_BUILD_ROOT%{_bindir}
  178. %__mkdir_p $RPM_BUILD_ROOT%{plugindir}
  179. %__mkdir_p $RPM_BUILD_ROOT%{pluginsourcedir}
  180. %__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
  181. %__make -C %{build_dir} install DESTDIR=$RPM_BUILD_ROOT
  182. ln -s %{pkgdir}/npwrapper.so $RPM_BUILD_ROOT/%{plugindir}/npwrapper.so
  183. # Install plugin-config utility
  184. pushd %{plugin_config_name}
  185. DESTDIR=$RPM_BUILD_ROOT %__make install
  186. popd
  187. cd $RPM_BUILD_ROOT%{_bindir}
  188. %__mv %{plugin_config_binary} $RPM_BUILD_ROOT/%{pkgdir}
  189. cd -
  190. %__rm -rf $RPM_BUILD_ROOT/usr/doc/plugin-config
  191. cat %{SOURCE2} > $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  192. chmod 755 $RPM_BUILD_ROOT%{_bindir}/mozilla-plugin-config
  193. cat %{SOURCE3} | %{__sed} -e "s|EXCLUDE_LIST|%{exclude_list}|g" \
  194. > $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  195. chmod 644 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/%{name}
  196. # set up nsplugin player starting script
  197. %{__cat} > $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer << EOF
  198. export MOZ_PLUGIN_PATH=%{pluginsourcedir}
  199. %{pkgdir}/npplayer "$@"
  200. EOF
  201. chmod 755 $RPM_BUILD_ROOT%{pkgdir}/nspluginplayer
  202. # Remove conflicting files
  203. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginplayer
  204. %__rm -rf $RPM_BUILD_ROOT%{_bindir}/nspluginwrapper
  205. ## <mozilla-filesystem>
  206. %__mkdir_p $RPM_BUILD_ROOT/usr/{lib,%{_lib}}/mozilla/{plugins,extensions}
  207. %__mkdir_p $RPM_BUILD_ROOT/%{_datadir}/mozilla/extensions
  208. %__mkdir_p $RPM_BUILD_ROOT/etc/skel/.mozilla/{plugins,extensions}
  209. ## </mozilla-filesystem>
  210. %clean
  211. %__rm -rf $RPM_BUILD_ROOT
  212. %post
  213. /usr/bin/mozilla-plugin-config -i -f > /dev/null 2>&1 || :
  214. %preun
  215. if [ "$1" == "0" ]; then
  216. /usr/bin/mozilla-plugin-config -r > /dev/null 2>&1 || :
  217. fi;
  218. %files
  219. %defattr(-,root,root)
  220. %doc README COPYING NEWS
  221. %dir %{pkgdir}
  222. %dir %{plugindir}
  223. %{pkgdir}/%{plugin_config_binary}
  224. %{pkgdir}/npconfig
  225. %{pkgdir}/npwrapper.so
  226. %{pkgdir}/npviewer.bin
  227. %{pkgdir}/npviewer.sh
  228. %{pkgdir}/npviewer
  229. %{pkgdir}/npplayer
  230. %{pkgdir}/libxpcom.so
  231. %{pkgdir}/libnoxshm.so
  232. %{pkgdir}/nspluginplayer
  233. %{plugindir}/npwrapper.so
  234. %{_bindir}/mozilla-plugin-config
  235. %config %{_sysconfdir}/sysconfig/%{name}
  236. ## <mozilla-filesystem>
  237. /usr/lib*/mozilla
  238. %{_datadir}/mozilla
  239. /etc/skel/.mozilla
  240. ## </mozilla-filesystem>
  241. ## to build compat32 for x86_64 architecture support
  242. %if %{build_compat32}
  243. %files -n compat32-%{name}
  244. %defattr(-,root,root)
  245. %dir %{pkgdir}
  246. %dir %{plugindir}
  247. %{pkgdir}/%{plugin_config_binary}
  248. %{pkgdir}/npconfig
  249. %{pkgdir}/npwrapper.so
  250. %{pkgdir}/npviewer.bin
  251. %{pkgdir}/npviewer.sh
  252. %{pkgdir}/npviewer
  253. %{pkgdir}/npplayer
  254. %{pkgdir}/libxpcom.so
  255. %{pkgdir}/libnoxshm.so
  256. %{pkgdir}/nspluginplayer
  257. %{plugindir}/npwrapper.so
  258. %endif
  259. %changelog
  260. * Mon Nov 15 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.0-3
  261. - applied some improvement patches from Fedora rawhide
  262. * Wed Jun 30 2010 Martin Stransky <stransky@redhat.com> 1.3.0-14
  263. - fixed patch for rhbz#523273
  264. * Tue Jun 29 2010 Martin Stransky <stransky@redhat.com> 1.3.0-13
  265. - Changed RPM timeout to 10 second, should prevent
  266. long browser hangs.
  267. - Disabled debug outputs in normal build.
  268. * Mon Jun 28 2010 Martin Stransky <stransky@redhat.com> 1.3.0-12
  269. - Fixed rhbz#523273 - wrapped plugins not getting updated
  270. * Fri Dec 4 2009 Martin Stransky <stransky@redhat.com> 1.3.0-10
  271. - added Compiz workaround (#542424)
  272. * Tue Nov 10 2009 Martin Stransky <stransky@redhat.com> 1.3.0-9
  273. - added NULL check (#531669)
  274. * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-7
  275. - NPIdentifiers fix by Tristan Schmelcher (Google)
  276. * Wed Jul 15 2009 Martin Stransky <stransky@redhat.com> 1.3.0-6
  277. - Package kit plugin is ignored now (#511385)
  278. * Sat Aug 28 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.0-2
  279. - changed Group to System Environment/Libraries
  280. * Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.3.0-1
  281. - initial release
  282. - ported from Fedora development package
  283. * Tue Mar 03 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-5
  284. - Really Fix x86 32bit build (#488308)
  285. * Sun Mar 01 2009 Warren Togami <wtogami@redhat.com> - 1.3.0-4
  286. - Fix x86 32bit build
  287. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.0-3
  288. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  289. * Thu Jan 9 2009 Martin Stransky <stransky@redhat.com> 1.3.0-2
  290. - Fixed multilib conflicts
  291. * Thu Jan 8 2009 Martin Stransky <stransky@redhat.com> 1.3.0-1
  292. - Updated to 1.3.0 and removed some fedora build patches
  293. * Tue Dec 02 2008 Warren Togami <wtogami@redhat.com> 1.1.8-2
  294. - fix-invalid-RPC-after-NPP_Destroy fixes a crasher
  295. * Mon Dec 1 2008 Martin Stransky <stransky@redhat.com> 1.1.8-1
  296. - Updated to 1.1.8
  297. - Removed already upstreamed patches
  298. * Wed Nov 12 2008 Martin Stransky <stransky@redhat.com> 1.1.4-1
  299. - Updated to 1.1.4
  300. - Consolidated build patches
  301. * Wed Oct 22 2008 Martin Stransky <stransky@redhat.com> 1.1.2-4
  302. - Fixed #449338 - mozilla-plugin-config segfaults with -v argument
  303. * Tue Oct 21 2008 Martin Stransky <stransky@redhat.com> 1.1.2-3
  304. - Removed event patch, it blocks X events and breaks Adobe pdf plugin
  305. - Removed event limit in xt_event_polling_timer_callback
  306. * Fri Oct 17 2008 Martin Stransky <stransky@redhat.com> 1.1.2-2
  307. - added umask to plugin config (#463736)
  308. * Thu Oct 16 2008 Martin Stransky <stransky@redhat.com> 1.1.2-1
  309. - updated to 1.1.12
  310. - added librhythmbox* to ignored plugins (#467187)
  311. - removed debug prints (#467090)
  312. * Mon Oct 06 2008 Warren Togami <wtogami@redhat.com> 1.1.0-11
  313. - Unrevert patch from -7 because Warren was wrong
  314. - Concurrent rpc_method_invoke() patch
  315. * Fri Oct 03 2008 Warren Togami <wtogami@redhat.com> 1.1.0-10
  316. - Revert libcurl requires because it was done in an incorrect way
  317. - Revert patch from -7 because it made things worse
  318. * Tue Sep 30 2008 Martin Stransky <stransky@redhat.com> 1.1.0-7
  319. - Updated fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  320. * Wed Sep 17 2008 Martin Stransky <stransky@redhat.com> 1.1.0-6
  321. - Added libcurl to requires (#460988)
  322. * Mon Aug 04 2008 Martin Stransky <stransky@redhat.com> 1.1.0-5
  323. - Added fix for #456432 -(Windowless Crash) Flash 10 w/ Firefox 3
  324. * Mon Jul 21 2008 Martin Stransky <stransky@redhat.com> 1.1.0-4
  325. - Removed gecko-libs from requieres (it's not needed now)
  326. * Tue Jul 18 2008 Martin Stransky <stransky@redhat.com> 1.1.0-3
  327. - Enabled experimental stand-alone plugin player
  328. * Tue Jul 15 2008 Martin Stransky <stransky@redhat.com> 1.1.0-2
  329. - Fixed build warnings in our patches
  330. * Tue Jul 8 2008 Martin Stransky <stransky@redhat.com> 1.1.0-1
  331. - update to latest upstream version (1.1.0)
  332. * Mon May 5 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-28
  333. - link pluginwrapper with stdc++ lib
  334. * Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 0.9.91.5-27
  335. - mozilla-filesystem now owns the plugin source dir
  336. * Tue Mar 11 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-26
  337. - /etc/sysconfig/nspluginwrapper marked as config file
  338. - exclude some player plugins
  339. * Mon Mar 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-25
  340. - updated the sleep patch
  341. * Thu Mar 06 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-24
  342. - added experimental patch for #426968 - nspluginwrapper wakes up too much
  343. * Tue Feb 26 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-23
  344. - merged exclude patch with main tarball
  345. - fixed #431095 - Typo in mozilla-plugin-config verbose output
  346. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.91.5-22
  347. - Autorebuild for GCC 4.3
  348. * Mon Jan 21 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-21
  349. - fixed #426618 - gcjwebplugin error: Failed to run
  350. (added to ignored plugins)
  351. * Mon Jan 14 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-20
  352. - fixed #426176 - Orphaned npviewer.bin processes
  353. * Thu Jan 10 2008 Martin Stransky <stransky@redhat.com> 0.9.91.5-19
  354. - xulrunner rebuild
  355. - fixed build script, added gthread-2.0
  356. * Mon Dec 24 2007 Warren Togami <wtogami@redhat.com> 0.9.91.5-18
  357. - Make nsviewer.bin initialized for multithreading, fixes #360891
  358. * Tue Dec 20 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-17
  359. - disabled xpcom support - it causes more troubles than advantages
  360. * Tue Dec 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-16
  361. - spec fixes
  362. - fixed xulrunner support
  363. * Mon Dec 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-15
  364. - updated configure script - gecko selection
  365. * Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-14
  366. - enabled xpcom support
  367. - added fix for #393541 - scripts will never fail
  368. * Fri Nov 23 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-13
  369. - rebuilt against xulrunner
  370. * Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-12
  371. - more fixes from review by security standards team
  372. * Wed Oct 31 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-11
  373. - added fixes from review by security standards team
  374. * Fri Oct 26 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-10
  375. - mozilla-plugin-config can be run by normal user now
  376. * Wed Oct 24 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-9
  377. - Updated config utility - removes dangling symlinks and
  378. wrapped plugins
  379. * Tue Oct 23 2007 Jeremy Katz <katzj@redhat.com> 0.9.91.5-8
  380. - Rebuild against new firefox
  381. * Mon Oct 15 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-7
  382. - added a fix for #281061 - gnash fails when wrapped, works when native
  383. * Wed Oct 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-6
  384. - removed possibble deadlock during plugin restart
  385. * Tue Oct 9 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-5
  386. - fixed browser crashes (#290901)
  387. * Mon Oct 1 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-4
  388. - quit the plugin when browser crashes (#290901)
  389. * Fri Sep 21 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-3
  390. - added original plugin dir to the package
  391. * Mon Sep 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-2
  392. - added upstream patches - RPC error handling and plugin restart
  393. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.5-1
  394. - update to the latest upstream
  395. * Mon Aug 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-19
  396. - converted rpc error handling code to a thread-safe variant
  397. - added a time limit to plugin restart
  398. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-18
  399. - implemented plugin restart (#251530)
  400. * Tue Aug 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-17
  401. - fixed an installation script (#251698)
  402. * Mon Aug 13 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-16
  403. - fixed plugins check
  404. - minor spec fixes
  405. * Fri Aug 10 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-15
  406. - removed mozembeded dependency
  407. - excluded totem plugins from wrapping
  408. - xpcom support is optional now
  409. * Thu Aug 9 2007 Christopher Aillon <caillon@redhat.com> 0.9.91.4-14
  410. - Rebuild against newer gecko
  411. * Wed Aug 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-13
  412. - removed unsafe plugins probe
  413. - added agruments to mozilla-plugin-config
  414. * Tue Aug 7 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-12
  415. - removed fake libxpcom
  416. * Mon Aug 6 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-11
  417. - added gecko dependency
  418. - added plugin configuration utility
  419. * Fri Aug 3 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-10
  420. - fixed totem-complex plugin wrapping
  421. * Mon Jul 30 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-9
  422. - added plugin dirs
  423. * Fri Jul 27 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-8
  424. - added switch for creating debug packages
  425. * Thu Jul 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-7
  426. - integrated with firefox / seamonkey
  427. * Tue Jul 11 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-6
  428. - added new options to the configuration utility
  429. - modified along new plug-ins concept
  430. * Thu Jun 19 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-5
  431. - updated nspluginsetup script
  432. - added support for x86_64 plug-ins
  433. * Thu Jun 14 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-4
  434. - added ppc arch
  435. - silenced installation scripts
  436. - moved configuration to /etc/sysconfig
  437. * Thu Jun 12 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-3
  438. - updated nspluginsetup script and package install/uninstall scripts
  439. - added cross-compilation support
  440. - removed binaries stripping
  441. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-2
  442. - added BuildRequires - pkgconfig, gtk2-devel, glib, libXt-devel
  443. * Fri Jun 8 2007 Martin Stransky <stransky@redhat.com> 0.9.91.4-1
  444. - initial build