perl-HTML-Template-vl.spec 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105
  1. %define perl_vendorlib %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
  2. %define rel 2
  3. Summary: a Perl module to use HTML Templates
  4. Name: perl-HTML-Template
  5. Version: 2.9
  6. Release: %{rel}%{?_dist_release}
  7. License: GPL/Artistic
  8. Group: Development/Libraries
  9. Source0: http://www.cpan.org/authors/id/S/SA/SAMTREGAR/HTML-Template-%{version}.tar.gz
  10. Url: http://search.cpan.org/search?dist=HTML-Template
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: perl >= 5.004
  13. Requires: perl >= 5.004
  14. BuildArch: noarch
  15. AutoReq: false
  16. %description
  17. This module attempts make using HTML templates simple and natural.
  18. It extends standard HTML with a few new HTML-esque tags - <TMPL_VAR>,
  19. <TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF> and <TMPL_ELSE>. The file
  20. written with HTML and these new tags is called a template. It is
  21. usually saved separate from your script - possibly even created by
  22. someone else! Using this module you fill in the values for the
  23. variables, loops and branches declared in the template. This allows
  24. you to seperate design - the HTML - from the data, which you generate
  25. in the Perl script.
  26. %description -l ja
  27. このモジュールは HTML テンプレートを使うことを簡単に、自然にしようとし
  28. ます。これは標準の HTML をいくつかの新しいHTML風のタグ - <TMPL_VAR>,
  29. <TMPL_LOOP>, <TMPL_INCLUDE>, <TMPL_IF>, <TMPL_ELSE>, <TMPL_UNLESS> で拡
  30. 張します。 HTML とこれらの新しいタグで書かれたファイルはテンプレートと
  31. 呼ばれます。これは通常スクリプトとは別に保存されます - もしかしたら他の
  32. 誰かによって作成されることさえあるかもしれません! このモジュールを使っ
  33. て、変数のための値を埋めたり、テンプレートで宣言されたループや分岐をお
  34. こないます。これにより Perl スクリプトで作成されるデータからデザイン
  35. - HTML - を分けることが出来ます。
  36. %prep
  37. %setup -q -n HTML-Template-%{version}
  38. %build
  39. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  40. #PREFIX=%{buildroot}%{_prefix}
  41. make
  42. %install
  43. rm -rf $RPM_BUILD_ROOT
  44. mkdir -p $RPM_BUILD_ROOT%{_prefix}
  45. make DESTDIR=$RPM_BUILD_ROOT install
  46. [ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
  47. find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
  48. find $RPM_BUILD_ROOT%{_prefix} -type f -print |
  49. sed "s@^$RPM_BUILD_ROOT@@g" |
  50. grep -v ^%{_mandir} |
  51. grep -v perllocal.pod |
  52. grep -v "\.packlist" > %{name}.files
  53. if [ "$(cat %{name}.files)X" = "X" ] ; then
  54. echo "ERROR: EMPTY FILE LIST"
  55. exit -1
  56. fi
  57. %check
  58. make test
  59. %clean
  60. rm -rf $RPM_BUILD_ROOT
  61. %files -f %{name}.files
  62. %defattr(-,root,root)
  63. %doc ANNOUNCE Changes FAQ README scripts templates
  64. %{_mandir}/*/*
  65. %dir %{perl_vendorlib}/HTML
  66. %changelog
  67. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.06-2
  68. - spec in utf-8
  69. * Mon Apr 28 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 4.06-1
  70. - rebuild with perl-5.10.0-1
  71. * Tue Jul 24 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.9-0vl1
  72. - new upstream release
  73. - changed Group to Development/Libraries
  74. * Sun Jul 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.7-0vl2
  75. - added Japanese description from VinePlus/3.2 package
  76. - added Autoreq: false
  77. - installed perl modules to vendor_perl
  78. * Mon Jan 10 2005 Satoshi MACHINO <machino@vinelinux.org> 2.7-0vl1
  79. - new upstream release
  80. - built with perl-5.8.6
  81. * Thu Apr 24 2003 IWAI Masaharu <iwai@alib.jp> 2.6-0vl1
  82. - build with perl-5.8.0
  83. - version up to 2.6
  84. * Mon Apr 29 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 2.5-0vl1
  85. - first build for Vine Linux