rail-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1 | grep -v "is not")
  3. %define origver 1.2.5
  4. %define origname rail
  5. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  6. Name: %{origname}
  7. Version: %{origver}
  8. Release: 1%{?_dist_release}
  9. Summary: rail - Replace Agent-string Internal Library for emacsen
  10. Summary(ja): rail - emacsen 用 Agent 名変換ライブラリ
  11. Source0: ftp://ftp.fan.gr.jp/pub/elisp/rail/rail-%{version}.tar.bz2
  12. Source1: semi-1.14.6-VERSION
  13. Source2: flim-1.14.9-VERSION
  14. Source10: %{origname}-install.sh
  15. Source11: %{origname}-remove.sh
  16. Source12: %{origname}-init.el
  17. License: GPL
  18. Group: Applications/Editors/Emacs
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildArch: noarch
  21. PreReq: emacsen
  22. %prereq_ge emacsen-common
  23. %prereq_ge semi
  24. Obsoletes: rail-xemacs
  25. Conflicts: %{origname}-el
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  29. %description
  30. rail is a nifty elisp, that translates codenames with latin chars
  31. of flim/semi/XEmacs/UTF-2000-Mule/Meadow to Japanese characters.
  32. It also provides a function compatible with genjis.el (a part
  33. of tm, that converts mule-version to Japanese characters).
  34. %description -l ja
  35. rail は,flim/semi/XEmacs/UTF-2000-Mule/Meadow のコードネームを
  36. 日本語化し,User-Agent: フィールドに適用するための elsp です.
  37. tm の genjis.el 互換機能 (mule-version の日本語化) も備えています.
  38. %prep
  39. %setup -n %{origname}-%{version}
  40. ## install newer codename file for semi
  41. cp %{SOURCE1} contrib/SEMI_VERSION
  42. cp %{SOURCE2} contrib/FLIM_VERSION
  43. %install
  44. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  45. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  46. mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  47. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/install
  48. #mkdir -p ${RPM_BUILD_ROOT}/%{_libdir}/emacsen-common/packages/remove
  49. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/install
  50. mkdir -p ${RPM_BUILD_ROOT}/%{emacsen_pkgdir}/remove
  51. ## install el files
  52. cp -a Makefile contrib *.el \
  53. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  54. # 2004.12.13 add Irokawa
  55. cp -a %{SOURCE12} \
  56. ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{origname}
  57. ## install script (bytecompile el and install elc, remove elc)
  58. %_installemacsenscript %{origname} %{SOURCE10}
  59. %_removeemacsenscript %{origname} %{SOURCE11}
  60. %clean
  61. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  62. %post
  63. ## bytecompile el and install elc
  64. if [ "$1" = 2 ] ; then
  65. %_emacsenPackageRemove %{origname}
  66. fi
  67. %_addemacsenlist %{origname}
  68. %_emacsenPackageInstall %{origname}
  69. %preun
  70. if [ "$1" = 0 ] ; then
  71. %_emacsenPackageRemove %{origname}
  72. %_removeemacsenlist %{origname}
  73. fi
  74. %files
  75. %defattr(-,root,root)
  76. %doc 00README 00FAQ CHANGELOG contrib
  77. %{_datadir}/emacs/site-lisp/%{origname}
  78. #%{_libdir}/emacsen-common/packages/install/%{origname}
  79. #%{_libdir}/emacsen-common/packages/remove/%{origname}
  80. %{emacsen_pkgdir}/install/%{origname}
  81. %{emacsen_pkgdir}/remove/%{origname}
  82. %changelog
  83. * Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5-1vl5
  84. - applied new versioning policy, spec in utf-8
  85. - added macro %%emacsen_pkgdir
  86. * Fri Dec 7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl12
  87. - added %%{SOURCE2} for flim-1.14.9
  88. * Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl11
  89. - added %%{SOURCE2} for flim-1.14.8
  90. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-0vl10
  91. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  92. * Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl9
  93. - added %%{SOURCE2} for flim-1.14.7
  94. - added %%{SOURCE12} for use /etc/$FLAVOR/site-start.d/
  95. * Wed Dec 24 2003 MATSUBAYASHI <shaolin@vinelinux.org> 1.2.5-0vl8
  96. - added %%{SOURCE1} and %%{SOURCE2} for flim-1.14.6 / semi-1.14.6
  97. * Wed May 21 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.2.5-0vl7
  98. - Modded %%{SOURCE2} for flim-1.14.5
  99. * Sat Dec 07 2002 MATSUBAYASHI <shaolin@vinelinux.org> 1.2.5-0vl6
  100. - added %%{SOURCE1} for semi-1.14.5
  101. * Mon Jun 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl5
  102. - added Source2 (for flim-1.14.4)
  103. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl4
  104. - package name changed rail-el -> rail again
  105. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.5-0vl3
  106. - rail is now rail-el, thus emacsen-common aware :)
  107. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  108. - 1.2.5-0vl2
  109. - added %%{SOURCE1} for semi-1.14.3
  110. * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  111. - 1.2.5-0vl1
  112. - updated to 1.2.5 release
  113. - now rail-xemacs is a sub-package
  114. - use better macros (%%{_tmppath})
  115. * Tue Mar 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  116. - 1.2.4-0vl1
  117. - updated in sync with 1.2.4 release
  118. * Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  119. - 1.0.2-2
  120. - Requires: apel, flim removed
  121. * Tue Nov 16 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  122. - 1.0.2-1
  123. - updated in sync wih 1.0.2 release
  124. * Tue Oct 26 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  125. - 0.8-1
  126. - updated in sync wih 0.8 release
  127. - added newer FLIM_VERSION file for newest CLIME release
  128. * Wed Oct 13 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  129. - 0.7-1
  130. - updated in sync wih 0.7 release
  131. * Mon Oct 4 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  132. - 0.6-1
  133. - updated in sync wih 0.6 release
  134. * Fri Oct 1 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  135. - 0.5-2
  136. - added newer FLIM_VERSION file for newest CLIME release
  137. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
  138. - 0.5-1
  139. - first rpm release