telnet-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284
  1. %define telnet_version 0.17
  2. Summary: The client program for the telnet remote login protocol.
  3. Summary(ja): リモートログインプロトコル telnet のクライアントプログラム
  4. Name: telnet
  5. Version: %{telnet_version}.x
  6. Release: 31%{?_dist_release}
  7. License: BSD
  8. Group: Applications/Internet
  9. Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-%{telnet_version}.tar.gz
  10. Source2: telnet-client.tar.gz
  11. Source3: telnet-xinetd
  12. Source4: telnet.wmconfig
  13. Patch1: telnet-client-cvs.patch
  14. Patch5: telnetd-0.17.diff
  15. Patch6: telnet-0.17-env.patch
  16. Patch7: telnet-0.17-issue.patch
  17. Patch8: telnet-0.17-sa-01-49.patch
  18. Patch9: telnet-0.17-env-5x.patch
  19. Patch10: telnet-0.17-pek.patch
  20. Patch11: telnet-0.17-8bit.patch
  21. Patch12: telnet-0.17-argv.patch
  22. Patch13: telnet-0.17-conf.patch
  23. Patch50: telnet-0.17-CAN-2005-468_469.patch
  24. BuildPreReq: ncurses-devel
  25. Buildroot: %{_tmppath}/%{name}-%{version}-root
  26. %description
  27. Telnet is a popular protocol for logging into remote systems over the
  28. Internet. The telnet package provides a command line telnet client.
  29. Install the telnet package if you want to telnet to remote machines.
  30. This version has support for IPv6.
  31. %description -l ja
  32. Telnet はインターネット越しにリモートシステムへログインするための非常に
  33. ポピュラーなプロトコルです。telnet パッケージは telnet のコマンドライン
  34. クライアントを提供しています。
  35. リモートマシンへ telnet したい場合は telnet パッケージをインストールして
  36. ください。
  37. このバージョンは IPv6 をサポートしています。
  38. %package server
  39. Summary: The server program for the telnet remote login protocol.
  40. Summary(ja): リモートログインプロトコル telnet サーバトプログラム
  41. Requires: xinetd
  42. Group: System Environment/Daemons
  43. %description server
  44. Telnet is a popular protocol for logging into remote systems over the
  45. Internet. The telnet-server package a telnet daemon, which will
  46. support remote logins into the host machine. The telnet daemon is
  47. enabled by default. You may disable the telnet daemon by editing
  48. /etc/xinet.d/telnet
  49. Install the telnet-server package if you want to support remote logins
  50. to your own machine.
  51. %description -l ja server
  52. Telnet はインターネット越しにリモートシステムへログインするための非常に
  53. ポピュラーなプロトコルです。telnet-server パッケージにはホストマシンにリ
  54. モートログインの機能を提供する telnet デーモンが含まれています。
  55. xinetd または inetd の設定を編集することで telnet デーモンを停止すること
  56. ができます。
  57. あなたのマシンに外部から telnet でリモートログインできるようにするために
  58. は telnet-server パッケージをインストールしてください。
  59. %prep
  60. %setup -q -n netkit-telnet-%{telnet_version}
  61. mv telnet telnet-NETKIT
  62. %setup -T -D -q -a 2 -n netkit-telnet-%{telnet_version}
  63. %patch1 -p0 -b .cvs
  64. %patch5 -p0 -b .fix
  65. %patch6 -p1 -b .env
  66. %patch10 -p0 -b .pek
  67. %patch7 -p1 -b .issue
  68. %patch8 -p1 -b .sa-01-49
  69. %patch11 -p1 -b .8bit
  70. %patch12 -p1 -b .argv
  71. %patch13 -p1 -b .confverb
  72. %patch50 -p1 -b .CAN-2005-468_469
  73. %build
  74. sh configure --with-c-compiler=gcc
  75. perl -pi -e '
  76. s,^CC=.*$,CC=cc,;
  77. s,-O2,\$(RPM_OPT_FLAGS),;
  78. s,^BINDIR=.*$,BINDIR=%{_bindir},;
  79. s,^MANDIR=.*$,MANDIR=%{_mandir},;
  80. s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
  81. ' MCONFIG
  82. make
  83. %install
  84. rm -rf ${RPM_BUILD_ROOT}
  85. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  86. mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
  87. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  88. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man5
  89. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  90. make INSTALLROOT=${RPM_BUILD_ROOT} install
  91. mkdir -p ${RPM_BUILD_ROOT}/etc/xinetd.d
  92. install -m644 %SOURCE3 ${RPM_BUILD_ROOT}/etc/xinetd.d/telnet
  93. %clean
  94. rm -rf ${RPM_BUILD_ROOT}
  95. %files
  96. %defattr(-,root,root)
  97. %{_bindir}/telnet
  98. %{_mandir}/man1/telnet.1*
  99. %{!?b5x:%files server}
  100. %defattr(-,root,root)
  101. %config(noreplace) /etc/xinetd.d/telnet
  102. %{_sbindir}/in.telnetd
  103. %{_mandir}/man5/issue.net.5*
  104. %{_mandir}/man8/in.telnetd.8*
  105. %{_mandir}/man8/telnetd.8*
  106. %changelog
  107. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-31
  108. - Requires: xinetd instead of inetd
  109. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.17.x-30vl5
  110. - applied new versioning policy, spec in utf-8
  111. * Thu Jul 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.x-30vl2
  112. - rebuilt for VineSeed
  113. * Fri Apr 01 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.17.x-30vl1.1
  114. - added a security patch for CAN-2005-0468 and CAN-2005-0469 from Fedora.
  115. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-30vl1
  116. - import patches from Fedora package
  117. - add Japanese summaries and desctiptions.
  118. - add xinetd config files.
  119. - remove old applnk files.
  120. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.6x-23vl1
  121. - merged with redhat package (patch10 for errata)
  122. * Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
  123. - 0.17.6x-18vl1: from RedHat updates
  124. * Tue Jul 31 2001 Harald Hoyer <harald@redhat.de>
  125. - fixed security issues (#50335)
  126. - patched the patches to fit the 5x version
  127. - one world -> one spec file for all versions ;)
  128. * Sat Jul 21 2001 Tim Powers <timp@redhat.com>
  129. - no applnk file, it's clutrtering the menus
  130. * Wed Jul 17 2001 Bill Nottingham <notting@redhat.com>
  131. - apply the patch, duh (and fix it while we're here)
  132. * Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
  133. - make /etc/issue.net parsing match the various gettys
  134. * Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
  135. - merged Jakubs and Pekka's patches
  136. * Wed Apr 4 2001 Jakub Jelinek <jakub@redhat.com>
  137. - don't let configure to guess compiler, it can pick up egcs
  138. * Fri Mar 9 2001 Pekka Savola <pekkas@netcore.fi>
  139. - update to 0.17
  140. - apply latest changes from CVS to telnet client, enable IPv6
  141. - BuildPreReq ncurses-devel
  142. * Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
  143. - added swedish & german translation to .desktop-file (#15332)
  144. * Sat Dec 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  145. - mark the xinetd config file as config(noreplace)
  146. * Fri Dec 01 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  147. - make sure the server is turned off by default
  148. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  149. - add description & default to xinetd file
  150. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  151. - automatic rebuild
  152. * Mon Jun 19 2000 Jeff Johnson <jbj@redhat.com>
  153. - FHS packaging.
  154. - update to 0.17-pre20000412.
  155. * Tue May 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  156. - moved the xinet entry to the server
  157. * Mon May 22 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  158. - add an entry to /etc/xinetd.d
  159. * Tue May 16 2000 Jeff Johnson <jbj@redhat.com>
  160. - permit telnet queries only for exported variables.
  161. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  162. - 0.17
  163. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  164. - rebuild for sparc baud rates > 38400.
  165. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  166. - fix description
  167. * Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
  168. - wmconfig gone
  169. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  170. - man pages are compressed
  171. - fix description
  172. * Tue Jan 4 2000 Bill Nottingham <notting@redhat.com>
  173. - split client and server
  174. * Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
  175. - update to 0.16.
  176. * Sun Oct 10 1999 Matt Wilson <msw@redhat.com>
  177. - corrected the Terminal setting of the .desktop (needs to be 'true' not '1')
  178. * Sat Sep 24 1999 Preston Brown <pbrown@redhat.com>
  179. - red hat .desktop entry
  180. * Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
  181. - rebuild for 6.1.
  182. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  183. - don't trust random TERM variables in telnetd (#4560)
  184. * Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
  185. - fix (#3098).
  186. * Thu May 27 1999 Antti Andreimann <Antti.Andreimann@mail.ee>
  187. - fixed the problem with escape character (it could not be disabled)
  188. - changed the spec file to use %setup macro for unpacking telnet-client
  189. * Thu Apr 15 1999 Jeff Johnson <jbj@redhat.com>
  190. - use glibc utmp routines.
  191. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  192. - fix the fix (wrong way memcpy).
  193. * Wed Apr 7 1999 Jeff Johnson <jbj@redhat.com>
  194. - fix "telnet localhost" bus error on sparc64 (alpha?).
  195. * Tue Apr 6 1999 Jeff Johnson <jbj@redhat.com>
  196. - use OpenBSD telnet client (and fix minor core dump with .telnetrc #247)
  197. * Thu Mar 25 1999 Erik Troan <ewt@redhat.com>
  198. - use openpty in telnetd
  199. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  200. - auto rebuild in the new build environment (release 22)
  201. * Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
  202. - compile for 6.0.
  203. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  204. - translations modified for de, fr, tr
  205. * Fri Apr 24 1998 Cristian Gafton <gafton@redhat.com>
  206. - compile C++ code using egcs
  207. * Tue Apr 14 1998 Erik Troan <ewt@redhat.com>
  208. - built against new ncurses
  209. * Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
  210. - added wmconfig entry
  211. * Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
  212. - initial build