aspell-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. Summary: A spelling checker.
  4. Summary(ja): スペルチェッカ
  5. Name: aspell
  6. Version: 0.50.5
  7. Release: 1%{?_dist_release}
  8. License: LGPL
  9. Group: Applications/Text
  10. URL: http://aspell.net/
  11. Source0: ftp://ftp.gnu.org/gnu/aspell/aspell-%{version}.tar.gz
  12. Source2: ftp://ftp.gnu.org/gnu/aspell/aspell-en-0.51-0.tar.bz2
  13. Source10: %{name}-install.sh
  14. Source11: %{name}-remove.sh
  15. Source12: %{name}-init.el
  16. Source100: aspell.conf
  17. Patch0: aspell-0.50.5.prefix.patch
  18. Patch1: aspell-compress-bug.patch
  19. Buildrequires: gcc-c++
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Provides: pspell
  22. Obsoletes: ispell, pspell
  23. %description
  24. GNU Aspell is a spell checker designed to eventually replace Ispell. It can
  25. either be used as a library or as an independent spell checker. Its main
  26. feature is that it does a much better job of coming up with possible
  27. suggestions than just about any other spell checker out there for the
  28. English language, including Ispell and Microsoft Word. It also has many
  29. other technical enhancements over Ispell such as using shared memory for
  30. dictionaries and intelligently handling personal dictionaries when more
  31. than one Aspell process is open at once.
  32. %package devel
  33. Summary: Static libraries and header files for Aspell development.
  34. Group: Development/Libraries
  35. Requires: aspell = %{version}-%{release}
  36. Obsoletes: pspell-devel
  37. %description devel
  38. Aspell is a spelling checker. The aspell-devel package includes the
  39. static libraries and header files needed for Aspell development.
  40. %package el
  41. Summary: Emacs lisp for aspell
  42. Group: Applications/Editors/Emacs
  43. Requires: aspell = %{version}-%{release}
  44. PreReq: emacsen-common
  45. %description el
  46. Aspell is a spelling checker. The aspell-el package includes the
  47. elisp for using aspell within emacsen.
  48. %prep
  49. rm -rf $RPM_BUILD_ROOT
  50. %setup -q -n aspell-%{version} -a 2
  51. %patch0 -p1 -b .prefix
  52. %patch1 -p0 -b .compress
  53. %build
  54. %configure
  55. make
  56. pushd aspell-en-0.51-0
  57. echo "ASPELL = ../prog/aspell --data-dir=../data" > Makefile
  58. echo "DEST_DIR = $RPM_BUILD_ROOT" >> Makefile
  59. echo "WORD_LIST_COMPRESS = ../prog/word-list-compress" >> Makefile
  60. echo "dictdir = ${RPM_BUILD_ROOT}%{_libdir}/aspell" >> Makefile
  61. echo "datadir = ${RPM_BUILD_ROOT}%{_datadir}/aspell" >> Makefile
  62. cat Makefile.pre >> Makefile
  63. make
  64. popd
  65. %install
  66. %makeinstall
  67. mv ${RPM_BUILD_ROOT}%{_datadir}/aspell/ispell ${RPM_BUILD_ROOT}%{_bindir}
  68. mv ${RPM_BUILD_ROOT}%{_datadir}/aspell/spell ${RPM_BUILD_ROOT}%{_bindir}
  69. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libaspell.la
  70. rm -f ${RPM_BUILD_ROOT}%{_libdir}/libpspell.la
  71. # Add by H.Irokawa(2004.02.23)
  72. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}
  73. install -m 644 %{SOURCE100} $RPM_BUILD_ROOT%{_sysconfdir}/aspell.conf
  74. mkdir -p $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/aspell
  75. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/install
  76. mkdir -p ${RPM_BUILD_ROOT}%{_prefix}/lib/emacsen-common/packages/remove
  77. install -m 644 %{SOURCE12} $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{name}
  78. # install script( bytecompile el and install elc , remove )
  79. %_installemacsenscript %{name} %{SOURCE10}
  80. %_removeemacsenscript %{name} %{SOURCE11}
  81. rm -f $RPM_BUILD_ROOT/usr/share/doc/aspell/manual.aux
  82. pushd aspell-en-0.51-0
  83. make install
  84. popd
  85. %post
  86. /sbin/ldconfig
  87. %post el
  88. if [ "$1" = 2 ]; then
  89. %_emacsenPackageRemove %{name}
  90. fi
  91. %_addemacsenlist %{name}
  92. %_emacsenPackageInstall %{name}
  93. %postun
  94. /sbin/ldconfig
  95. %preun el
  96. if [ "$1" = 0 ]; then
  97. %_emacsenPackageRemove %{name}
  98. %_removeemacsenlist %{name}
  99. fi
  100. %clean
  101. rm -rf $RPM_BUILD_ROOT
  102. %files
  103. %defattr(-,root,root)
  104. %config %{_sysconfdir}/aspell.conf
  105. %doc README TODO
  106. %doc %{_docdir}/aspell/*
  107. %{_bindir}/*
  108. %{_libdir}/lib*.so.*
  109. %{_libdir}/aspell/*
  110. %{_datadir}/aspell/*
  111. %files devel
  112. %defattr(-,root,root)
  113. /usr/include/aspell.h
  114. /usr/include/pspell/pspell.h
  115. %{_libdir}/lib*spell.so
  116. %files el
  117. %{_datadir}/emacs/site-lisp/%{name}/
  118. %{_prefix}/lib/emacsen-common/packages/install/%{name}
  119. %{_prefix}/lib/emacsen-common/packages/remove/%{name}
  120. %changelog
  121. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.50.5-1vl5
  122. - applied new versioning policy, spec in utf-8
  123. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl3
  124. - rebuilt with new toolchain
  125. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.5-0vl2
  126. - changed aspell-el Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  127. * Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.50.5-0vl1
  128. - upgrade to new upstream
  129. - drop aspell-0.50.3-gcc33.patch
  130. - update prefix.patch
  131. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl8
  132. - merged with errata package
  133. * Wed Oct 6 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.50.3-0vl5.1
  134. - added aspell-compress-bug.patch (CAN-2004-0548).
  135. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl7
  136. - fixed typo (s/%postun el/%preun el/)
  137. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.50.3-0vl6
  138. - split elisp-related files into the aspell-el subpackage
  139. * Thu Mar 4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl5
  140. - add PreReq: emacsen-common
  141. * Mon Feb 23 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.50.3-0vl4
  142. - add /etc/aspell.conf
  143. - modded aspell-init.el(Japanese blended English spell check)
  144. * Wed Feb 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl3
  145. - add %{_bindir}/{ispell,spell} for compatibility script
  146. - enable site-start.d stuff
  147. * Mon Nov 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.50.3-0vl2
  148. - fixed spec file character code to EUC-JP
  149. * Wed Jun 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50.3-0vl1
  150. - build for Vine Linux
  151. - merge aspell-en
  152. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  153. - rebuilt
  154. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-10
  155. - rebuild again to fix libpspell deps
  156. * Fri May 30 2003 Joe Orton <jorton@redhat.com> 7:0.50.3-9
  157. - remove ExcludeArch
  158. * Thu May 22 2003 Jeremy Katz <katzj@redhat.com> 7:0.50.3-8
  159. - fix build with gcc 3.3
  160. * Wed May 22 2003 Adrian Havill <havill@redhat.com> 0.50.3-7
  161. - require aspell-en for upgrades
  162. * Sun May 11 2003 Jeremy Katz <katzj@redhat.com> 6:0.50.3-6
  163. - -devel should obsolete pspell-devel
  164. * Tue May 6 2003 Joe Orton <jorton@redhat.com> 0.50.3-5
  165. - include libpspell.so in devel package
  166. * Wed May 1 2003 Adrian Havill <havill@redhat.com> 0.50.3-4
  167. - removed .la files
  168. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-3
  169. - Changed the header for provides, obsoletes, epoch
  170. - fixed config prefix in dirs.h
  171. * Wed Apr 16 2003 Adrian Havill <havill@redhat.com> 0.50.3-1
  172. - upgrade to 0.50.3
  173. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  174. - rebuilt
  175. * Fri Nov 8 2002 Tim Powers <timp@redhat.com>
  176. - fix broken pspell epoch dep
  177. - create $RPM_BUILD_ROOT/usr/bin by hand
  178. - remove /usr/doc
  179. - fix hardcoding of /usr/lib so that we can build on x86_64
  180. * Tue Aug 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.33.7.1-16
  181. - require pspell and pspell-devel using the proper epoch
  182. * Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
  183. - rebuilt with gcc-3.2 (we hope)
  184. * Mon Jul 22 2002 Tim Powers <timp@redhat.com> 0.33.7.1-14
  185. - rebuild using gcc-3.2-0.1
  186. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 0.33.7.1-13
  187. - automated rebuild
  188. * Thu Jun 13 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-12
  189. - Rebuild to make it work again... #66708
  190. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  191. - automated rebuild
  192. * Mon May 13 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-10
  193. - Rebuild
  194. * Thu Feb 21 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-9
  195. - Disable evil patch
  196. * Mon Jan 28 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-8
  197. - Build on more archs (doh)
  198. * Tue Jan 22 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-7
  199. - Make it compile with new compiler (evil workaround)
  200. * Wed Jan 16 2002 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-5
  201. - Rebuild
  202. - Unexclude alpha
  203. * Fri Dec 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-3
  204. - Rebuild
  205. - Don't build on alpha
  206. * Mon Oct 29 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.7.1-2
  207. - "make it work with gcc 3.1" ;)
  208. * Tue Sep 18 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7.1-1
  209. - 0.33.7.1, which is a "make it work with gcc 3" release
  210. * Wed Sep 12 2001 Tim Powers <timp@redhat.com>
  211. - rebuild with new gcc and binutils
  212. * Thu Aug 9 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.33.7-1
  213. - 0.33.7 bugfix release. Requested by the author, it fixes
  214. coredumps in sug-mode and when not using typo-analyses.
  215. It also contains code cleanups so it compiles with -ansi
  216. - should fix coredump on IA64 (#49746)
  217. * Wed Jul 11 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  218. - Add the .la files in the main package - used for dynamic loading
  219. * Sun Jun 3 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  220. - 0.33.6.3, which includes the fix made yesterday
  221. * Sat Jun 2 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  222. - Make it search for directories in the correct location
  223. * Wed May 30 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  224. - No more workarounds at the specfile level
  225. * Tue May 29 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  226. - Use custom ltmain.sh to work around buggy bundled libtool
  227. * Sun May 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  228. - 0.33.6
  229. - use standard %%configure macro - it works now.
  230. * Fri May 11 2001 Bernhard Rosenkraenzer <bero@redhat.com> 0.33.5-2
  231. - Rebuild with new libltdl
  232. * Mon Apr 23 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
  233. - 0.33.5
  234. * Thu Nov 30 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  235. - use new emacs init scheme for Emacs and XEmacs
  236. * Wed Nov 22 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  237. - .32.6
  238. * Sat Aug 19 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  239. - .32.5 bugfix release (also contains improved documentation),
  240. obsolete old patch
  241. - the compatibility scripts are now part of the package itself
  242. - clean up build procedure
  243. - remove manual.aux file from docs (#16424)
  244. * Sun Aug 06 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  245. - .32.1 bugfix release, obsolete old patch
  246. - rename to 0.32.1
  247. - add patch from author to change his email address
  248. - add spell and ispell compatibility scripts
  249. * Fri Aug 04 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  250. - rebuild
  251. * Tue Aug 01 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  252. - remember to obsolete ispell
  253. - build the Canadian and British dictionaries here now,
  254. as part of the main package. Same package names and
  255. descriptions.
  256. * Mon Jul 24 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  257. - .32
  258. - remove old patches, add a patch since namespace isn't
  259. polluted as much anymore (as opposed to older toolchain)
  260. * Wed Jul 19 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  261. - rebuild
  262. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  263. - automatic rebuild
  264. * Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
  265. - Rebuild with new C++
  266. * Fri Jun 30 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  267. - use RPM_OPT_FLAGS, not just -O0
  268. - dont include .la-files
  269. * Fri Jun 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  270. - excludearch ia64
  271. * Fri Jun 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  272. - patch to work around compiler bug(?) wrt. inline functions
  273. - use CFLAGS and CXXFLAGS
  274. - set them to -O0 to work around YACB
  275. - copy libtool files for IA64 support
  276. * Sun Jun 18 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  277. - update to .31.1. My patch was upstreamed and is no longer needed.
  278. - new patch added so DESTDIR works properly
  279. * Fri Jun 16 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  280. - (this entry includes some old ones...)
  281. - update to .31
  282. - added patch to make it compile with a pickier compiler
  283. - include /usr/share/pspell
  284. * Mon May 1 2000 Tim Powers <timp@redhat.com>
  285. - updated to .30.1
  286. - used build fixes from Ryan Weaver's 0.30.1-1 package on sourceforge
  287. - updated URL, download/ftp location
  288. - removed redundant define's at top of spec file
  289. * Thu Jul 8 1999 Tim Powers <timp@redhat.com>
  290. - built for Powertools 6.1
  291. - removed %serial definitions from spec file to make versioning
  292. consistant with the other packages we ship.
  293. - changed build root path
  294. - general spec file cleanups
  295. * Tue Mar 2 1999 Ryan Weaver <ryanw@infohwy.com>
  296. [aspell-.27.2-2]
  297. - Changes from .27.1 to .27.2 (Mar 1, 1999)
  298. - Fixed a major bug that caused aspell to dump core when used
  299. without any arguments
  300. - Fixed another major bug that caused aspell to do nothing when used
  301. in interactive mode.
  302. - Added an option to exit in Aspell's interactive mode.
  303. - Removed some old documentation files from the distribution.
  304. - Minor changes on to the section on using Aspell with egcs.
  305. - Minor changes to remove -Wall warnings.