empathy-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417
  1. %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. ## Minimum required versions of GLib, GTK+, libtelepathy, and Mission-Control,
  3. ## respectively.
  4. %global gtk2_min_version 2.14
  5. %global glib2_min_version 2.18.0
  6. %global tp_mc_min_version 5.3.2
  7. %global tp_glib_min_version 0.7.35
  8. #global enchant_version 1.4.0
  9. %global aspell_version 0.50
  10. %global libcanberra_version 0.4
  11. %global gnome_keyring_version 2.22
  12. %global libnotify_version 0.4.4
  13. Summary: GNOME Instant Messaging Client
  14. Summary(ja): GNOME インスタントメッセージクラアイント
  15. Name: empathy
  16. Version: 2.28.1
  17. Release: 4%{?_dist_release}
  18. Group: Applications/Communications
  19. License: GPLv2+
  20. URL: http://live.gnome.org/Empathy
  21. Source0: http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.28/%{name}-%{version}.tar.bz2
  22. Source1: %{name}-README.ConnectionManagers
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. #BuildRequires: enchant-devel >= %{enchant_version}
  25. BuildRequires: aspell-devel >= %{aspell_version}
  26. BuildRequires: iso-codes
  27. BuildRequires: desktop-file-utils
  28. BuildRequires: evolution-data-server-devel
  29. BuildRequires: GConf2-devel
  30. BuildRequires: gettext
  31. BuildRequires: glib2-devel >= %{glib2_min_version}
  32. BuildRequires: gnome-doc-utils >= 0.17.3
  33. BuildRequires: gnome-panel
  34. BuildRequires: gtk2-devel >= %{gtk2_min_version}
  35. BuildRequires: intltool
  36. BuildRequires: libxml2-devel
  37. BuildRequires: perl(XML::Parser)
  38. BuildRequires: pygtk2-devel
  39. BuildRequires: telepathy-glib-devel >= %{tp_glib_min_version}
  40. BuildRequires: telepathy-mission-control-devel >= %{tp_mc_min_version}
  41. BuildRequires: farsight2-devel
  42. BuildRequires: telepathy-farsight-devel
  43. BuildRequires: libcanberra-devel >= %{libcanberra_version}
  44. BuildRequires: gnome-keyring-devel >= %{gnome_keyring_version}
  45. BuildRequires: unique-devel
  46. BuildRequires: libnotify-devel >= %{libnotify_version}
  47. Requires: %{name}-libs = %{version}-%{release}
  48. Requires: telepathy-filesystem
  49. ## Empathy is useless without a proper Telepathy connection manager installed.
  50. ## We hardcode dependencies on Salut and Gabble to support XMPP on a default
  51. ## install, in both the link-local and Jabber/GoogleTalk incarnations.
  52. ## (RHBZ: 308871 and 334221)
  53. ## TODO: Perhaps we can configure these to be installed "on demand" with
  54. ## PackageKit and friends?
  55. Requires: telepathy-gabble
  56. Requires: telepathy-salut
  57. ## Also hardcode Haze dependency since Empathy is the default IM client in F10+
  58. ## and I'd hate for people to simply disregard it for lack of the "out of the
  59. ## box" protocol support that Pidgin has. (RHBZ: 458935)
  60. Requires: telepathy-haze
  61. # Require this for VOIP support
  62. Requires: telepathy-stream-engine
  63. Requires(pre): GConf2
  64. Requires(post): GConf2
  65. Requires(post): scrollkeeper
  66. Requires(preun): GConf2
  67. Requires(postun): scrollkeeper
  68. ## We're using Empathy's upstreamed profiles for Haze-provided stuff now.
  69. Obsoletes: telepathy-haze-mission-control < 0.2.0-3
  70. Provides: telepathy-haze-mission-control = 0.2.0-3
  71. %description
  72. Empathy provides a powerful multiple protocol instant messaging
  73. client using the Telepathy framework.
  74. %package devel
  75. Summary: Development files for %{name}
  76. Summary(ja): Development files for %{name}
  77. Group: Development/Libraries
  78. Requires: %{name}-libs = %{version}-%{release}
  79. Requires: pkgconfig
  80. ## Needs these for the various #include directives in its headers, as well
  81. ## as pkgconfig dependencies...
  82. Requires: glib2-devel
  83. Requires: telepathy-glib-devel
  84. Requires: telepathy-mission-control-devel
  85. Requires: libxml2-devel
  86. %description devel
  87. The %{name}-devel package contains libraries and header files for
  88. developing applications that use %{name}.
  89. %package libs
  90. Summary: Shared libraries for %{name}
  91. Summary(ja): Shared libraries for %{name}
  92. Group: Development/Libraries
  93. Requires: glib2
  94. Requires: gtk2
  95. Requires: telepathy-glib
  96. Requires: telepathy-mission-control
  97. %description libs
  98. The %{name}-libs package contains shared libraries used by Empathy.
  99. %package python
  100. Summary: Python bindings for libempathy and libempathy-gtk
  101. Summary(ja): Python bindings for libempathy and libempathy-gtk
  102. Group: Development/Languages
  103. Requires: %{name}-libs = %{version}-%{release}
  104. %description python
  105. This package contains the empathy and empathygtk Python modules, which provide
  106. bindings to the libempathy and libempathy-gtk libraries, respectively.
  107. %prep
  108. %setup -q
  109. %build
  110. ## GCC complains about some unused functions, so we forcibly show those as
  111. ## simple warnings instead of build-halting errors.
  112. %configure --with-compile-warnings=yes --disable-static
  113. ## RPATHs are yucky.
  114. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  115. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  116. ##make %{?_smp_mflags}
  117. ## don't use _smp_mflags at empathy-2.18.1
  118. make
  119. install -m 0644 %{SOURCE1} ./README.ConnectionManagers
  120. %install
  121. rm -rf $RPM_BUILD_ROOT
  122. make install DESTDIR=$RPM_BUILD_ROOT
  123. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  124. %find_lang %{name}
  125. desktop-file-install --vendor "" --delete-original \
  126. --dir %{buildroot}%{_datadir}/applications \
  127. %{buildroot}%{_datadir}/applications/%{name}.desktop
  128. %clean
  129. rm -rf %{buildroot}
  130. %pre
  131. if [ "$1" -gt 1 ]; then
  132. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  133. gconftool-2 --makefile-uninstall-rule \
  134. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas \
  135. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  136. fi
  137. %post
  138. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  139. gconftool-2 --makefile-install-rule \
  140. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas \
  141. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  142. scrollkeeper-update -q -o %{_datadir}/omf/%{name} ||:
  143. touch --no-create %{_datadir}/icons/hicolor ||:
  144. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
  145. %post libs -p /sbin/ldconfig
  146. %preun
  147. if [ "$1" -eq 0 ]; then
  148. export GCONF_CONFIG_SOURCE=$(gconftool-2 --get-default-source)
  149. gconftool-2 --makefile-uninstall-rule \
  150. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas \
  151. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null ||:
  152. fi
  153. %postun
  154. scrollkeeper-update -q || :
  155. touch --no-create %{_datadir}/icons/hicolor || :
  156. if [ -x %{_bindir}/gtk-update-icon-cache ]; then
  157. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  158. fi
  159. %postun libs -p /sbin/ldconfig
  160. %files -f %{name}.lang
  161. %defattr(-,root,root,-)
  162. %doc AUTHORS COPYING README README.ConnectionManagers NEWS
  163. %{_sysconfdir}/gconf/schemas/%{name}.schemas
  164. %{_sysconfdir}/gconf/schemas/GNOME_Megaphone_Applet.schemas
  165. %{_bindir}/empathy
  166. %{_bindir}/empathy-logs
  167. %{_datadir}/dbus-1/services/*
  168. %{_datadir}/empathy
  169. %{_datadir}/applications/*.desktop
  170. %{_datadir}/gnome/help/%{name}/
  171. #{_datadir}/omf/%{name}/
  172. %{_datadir}/icons/hicolor/*/apps/%{name}*
  173. #{_datadir}/mission-control/profiles/*.profile
  174. %{_datadir}/telepathy/clients/Empathy.client
  175. %{_libexecdir}/megaphone-applet
  176. %{_libexecdir}/nothere-applet
  177. %{_libdir}/bonobo/servers/GNOME_Megaphone_Applet.server
  178. %{_libdir}/bonobo/servers/GNOME_NotHere_Applet.server
  179. %{_mandir}/man1/empathy*.1.gz
  180. %files libs
  181. %defattr(-,root,root,-)
  182. %{_libdir}/libempathy*.so.*
  183. %files devel
  184. %defattr(-,root,root,-)
  185. %{_includedir}/libempathy*/
  186. %{_libdir}/libempathy*.so
  187. %{_libdir}/pkgconfig/libempathy*.pc
  188. %{_datadir}/gtk-doc/html/libempathy*
  189. %files python
  190. %defattr(-,root,root,-)
  191. %{python_sitearch}/empathy*.so
  192. %changelog
  193. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.28.1-4
  194. - rebuilt with python-2.6.4
  195. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> - 2.28.1-3
  196. - unuse %%{?_smp_mflags} option to make
  197. * Wed Nov 11 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.28.1-2
  198. - add {gnome-keyring,libcanberra,libnotify,unique}-devel to BuildRequires
  199. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.1-1
  200. - new upstream release
  201. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.1-1
  202. - new upstream release
  203. * Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  204. - initial build for Vine Linux
  205. * Tue Sep 9 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.92-1
  206. - Update to 2.23.92
  207. * Thu Sep 4 2008 Matthias Clasen <mclasen@redhat.com> - 2.23.91-1
  208. - Update to 2.23.91
  209. * Sun Aug 24 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-2
  210. - Now that Empathy will be the default IM client in F10+, hardcode a dependency
  211. on telepathy-haze to keep the same protocol functionality across upgrades,
  212. for a much improved "out of the box" experience.
  213. - Reference: bug 458935.
  214. * Fri Aug 22 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.90-1
  215. - Update to new upstream release (2.23.90)
  216. * Fri Aug 15 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-3
  217. - Apply patch from Colin Walters to automagically update profile namings for
  218. the switch to using Empathy's provided profiles.
  219. - Drop the upgrade script (no longer needed since it's automatically done).
  220. - upgrade-haze-profiles.sh
  221. * Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-2
  222. - Use upstream's AIM, ICQ, MSN-Haze, and Yahoo profiles instead of recommending
  223. the telepathy-haze-mission-control package. (The Haze-provided ones have grown
  224. horribly stale...). This makes for better automagic functionality (if Haze is
  225. installed, Empathy/MC will autodetect it) and tracks upstream more closely.
  226. + upgrade-haze-profiles.sh
  227. * Mon Aug 04 2008 Peter Gordon <peter@thecodergeek.com> - 2.23.6-1
  228. - Update to new upstream release (2.23.6)
  229. - Use the in-tarball libtool scripts instead of the system copy to workaround
  230. 'make install' errors.
  231. * Wed Jul 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.4-1
  232. - Update to 0.23.4.
  233. - Update source url.
  234. * Mon Jun 2 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.3-1
  235. - Update to 0.23.3.
  236. - Remove reference to stream-engine in connections managers readme.
  237. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.2-1
  238. - Update to 0.23.2.
  239. - Add man pages.
  240. - Use enchant-devel, instead of aspell-devel.
  241. * Fri May 16 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-3
  242. - Rebuild for new e-d-s.
  243. * Sun May 4 2008 Brian Pepple <bpepple@fedoraproject.org> - 0.23.1-2
  244. - Drop multiple copies of COPYING file.
  245. - Drop BR on gnome-vfs2-devel.
  246. - Require telepathy-stream-engine for VOIP support.
  247. - Add BR on iso-codes-devel, so spell-checking is enabled.
  248. * Wed Apr 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.23.1-1
  249. - Update to new upstream release (0.23.1)
  250. - Drop libtelepathy dependencies; upstream switched fully to telepathy-glib.
  251. * Fri Apr 11 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.1-1
  252. - Update to new upstream release (0.22.1)
  253. * Mon Mar 10 2008 Peter Gordon <peter@thecodergeek.com> - 0.22.0-1
  254. - Update to new upstream release (0.22.0)
  255. * Sun Mar 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.91-1
  256. - Update to new upstream release (0.21.91)
  257. * Fri Feb 22 2008 Peter Gordon <peter@thecodergeek.com> - 0.21.90-1
  258. - Update to new upstream release (0.21.90)
  259. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.21.4-2
  260. - Autorebuild for GCC 4.3
  261. * Mon Dec 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.4-1
  262. - Update to new upstream release (0.21.4)
  263. * Tue Nov 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.21.2-1
  264. - Update to new upstream release (0.21.2)
  265. - Drop backported drag-and-drop patch (fixed upstream):
  266. - svn380-fix-contact-DnD.patch
  267. - Update README.ConnectionManagers: Include Haze package note, remove Galago
  268. note (a feed-only connection manager isn't useful for instant messaging),
  269. and fix some wording.
  270. * Fri Oct 19 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-5
  271. - Backport upstream patch to fixes crashes when using drag-and-drop of a
  272. contact from the buddy list to the current conversation window to initiate a
  273. conversation:
  274. + svn380-fix-contact-DnD.patch
  275. - Resolves: GNOME bug 483168 (crash in Empathy Instant Messenger: I had
  276. dragged a contact ...)
  277. * Tue Oct 16 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-4
  278. - Depend on Salut and Gabble to enable XMPP by default. Otherwise, Empathy
  279. is essentially useless due to the need to install an external connection
  280. manager. Also, add a README.ConnectionManagers to the installed
  281. documentation which lists other possibilities.
  282. - Resolves: bug 308871 (Make empathy dependent at least on telepathy-gabble)
  283. and bug 334221 (Default empathy install is useless).
  284. * Wed Oct 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-3
  285. - Enable VoIP support for those brave enough to test/break/debug it (F9+
  286. only). Though it is functional, it is still deemed rather unstable by
  287. upstream. Use it at your own risk. :)
  288. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-2
  289. - Disable VoIP support at this time, since it is deemed unstable by upstream
  290. for now. (Thanks to Brian Pepple for the notice.)
  291. * Tue Oct 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.14-1
  292. - Update to new upstream release (0.14).
  293. * Sun Sep 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.13-1
  294. - Update to new upstream release (0.13), which adds a panel applet (Megaphone)
  295. and python bindings.
  296. - Split shared libraries into a libs subpackage for easier handling
  297. in multi-lib environments.
  298. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-2
  299. - Add ldconfig invocations to %%post and %%postun scriptlets.
  300. * Fri Aug 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.12-1
  301. - Update to new upstream release (0.12).
  302. - Build against new mission-control stack.
  303. - Update License tag (GPLv2+).
  304. - Alphabetize BuildRequires list (aesthetic-only change).
  305. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 0.8-2
  306. - Rebuild for selinux ppc32 issue.
  307. * Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.11-1
  308. - Update to new upstream release (0.11)
  309. * Fri Jun 22 2007 David Nielsen <david@lovesunix.net> - 0.8-1
  310. - bump to 0.8
  311. - Now with aspell support (deat to teh speeling mistaks)
  312. * Sat Jun 9 2007 David Nielsen <david@lovesunix.net> - 0.7-1
  313. - bump to 0.7
  314. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-3
  315. - Add telepathy-filesystem to Requires
  316. - Move .desktop from autostart to applications
  317. - Nasty hackery to make empathy launch from the menu
  318. * Mon Jun 4 2007 David Nielsen <david@lovesunix.net> - 0.6-2
  319. - Add gettext to BuildRequires
  320. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.6-1
  321. - Bump to 0.6
  322. * Fri Jun 1 2007 David Nielsen <david@lovesunix.net> - 0.5-2
  323. - Let Empathy own the directory and not just the files in it
  324. * Tue May 30 2007 David Nielsen <david@lovesunix.net> - 0.5-1
  325. - Initial package