mod_ruby-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252
  1. %define docroot /home/httpd
  2. %define apxs /usr/sbin/apxs
  3. %define apxs2 /usr/bin/apxs
  4. %define httpdmoddir %(%{apxs} -q LIBEXECDIR)
  5. %define httpdconfdir %(%{apxs} -q SYSCONFDIR)
  6. %define apache2moddir %(%{apxs2} -q LIBEXECDIR)
  7. %define apache2confdir %(%{apxs2} -q SYSCONFDIR)
  8. %define httpdconfmodruby httpd.conf.mod_ruby
  9. %define apache2confmodruby httpd.conf.mod_ruby
  10. %define apachever 1.3.29
  11. %define apache2ver 2.2.9
  12. Summary: A Ruby interpreter for the Apache Web server.
  13. Summary(ja): Apacheサーバ組み込みのRuby言語インタプリタ
  14. Name: mod_ruby
  15. Version: 1.2.6
  16. Release: 1%{?_dist_release}
  17. License: distributable
  18. Group: System Environment/Daemons
  19. Source0: http://www.modruby.net/archive/%{name}-%{version}.tar.gz
  20. Source99: httpd.conf.mod_ruby
  21. Source100: httpd.conf.mod_ruby-apache2
  22. Patch10: mod_ruby-1.2.6-fix-xldflags.patch
  23. URL: http://www.modruby.net/
  24. Prefix: /usr
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. BuildRequires: ruby, ruby-devel
  27. BuildPreReq: apache, apache-devel >= %{apachever}
  28. BuildPreReq: apache2, apache2-devel >= %{apache2ver}
  29. Requires: apache >= %{apachever}, liberuby >= 1.0.5
  30. Requires: ruby >= 1.8
  31. Requires: mod_ruby-common = %{version}-%{release}
  32. %description
  33. mod_ruby embeds the Ruby interpreter into the Apache web server,
  34. allowing Ruby CGI scripts to be executed natively. These scripts
  35. will start up much faster than without mod_ruby.
  36. %description -l ja
  37. mod_rubyはApacheウェブサーバにRubyインタプリタを組み込み、CGIスクリ
  38. プトがネイティブに起動されることを許します。スクリプトはmod_rubyを利
  39. 用しない場合よりも速く起動するでしょう。
  40. %package apache2
  41. Summary: A Ruby interpreter for the Apache2 Web server.
  42. Summary(ja): Apache2サーバ組み込みのRuby言語インタプリタ
  43. Group: System Environment/Daemons
  44. Requires: apache2 >= %{apache2ver}
  45. Requires: ruby >= 1.8
  46. Requires: mod_ruby-common = %{version}-%{release}
  47. %description apache2
  48. mod_ruby embeds the Ruby interpreter into the Apache web server,
  49. allowing Ruby CGI scripts to be executed natively. These scripts
  50. will start up much faster than without mod_ruby.
  51. %description apache2 -l ja
  52. mod_rubyはApache2ウェブサーバにRubyインタプリタを組み込み、CGIスクリ
  53. プトがネイティブに起動されることを許します。スクリプトはmod_rubyを利
  54. 用しない場合よりも速く起動するでしょう。
  55. %package common
  56. Summary: Ruby libraries for mod_ruby
  57. Summary(ja): mod_ruby 用の Ruby ライブラリ
  58. Group: System Environment/Daemons
  59. Requires: ruby >= 1.8
  60. %description common
  61. Ruby libraries for mod_ruby
  62. %description common -l ja
  63. mod_ruby 用の Ruby ライブラリ
  64. %prep
  65. %setup -q -c
  66. %patch10 -p0
  67. %build
  68. ## for apache1
  69. cd %{name}-%{version}
  70. ruby configure.rb --with-apxs=%{apxs}
  71. make
  72. cd ..
  73. %install
  74. rm -rf ${RPM_BUILD_ROOT}
  75. mkdir -p ${RPM_BUILD_ROOT}%{httpdmoddir}
  76. mkdir -p ${RPM_BUILD_ROOT}%{httpdconfdir}
  77. # installing binaries ...
  78. cd %{name}-%{version}
  79. make install DESTDIR=${RPM_BUILD_ROOT}
  80. cd ..
  81. sed -e 's|@@DOCROOT@@|%{docroot}|g' < %{SOURCE99} \
  82. > ${RPM_BUILD_ROOT}/%{httpdconfdir}/%{httpdconfmodruby}
  83. chmod 644 ${RPM_BUILD_ROOT}/%{httpdconfdir}/%{httpdconfmodruby}
  84. ## for apache2
  85. cd %{name}-%{version}
  86. make clean
  87. ruby configure.rb --with-apxs=%{apxs2} --with-apr-includes=/usr/include/apr-1
  88. make
  89. mkdir -p ${RPM_BUILD_ROOT}%{apache2moddir}
  90. mkdir -p ${RPM_BUILD_ROOT}%{apache2confdir}
  91. make install DESTDIR=${RPM_BUILD_ROOT}
  92. sed -e 's|@@DOCROOT@@|%{docroot}|g' < %{SOURCE100} \
  93. > ${RPM_BUILD_ROOT}/%{apache2confdir}/%{apache2confmodruby}
  94. chmod 644 ${RPM_BUILD_ROOT}/%{apache2confdir}/%{apache2confmodruby}
  95. %clean
  96. rm -rf ${RPM_BUILD_ROOT}
  97. rm -f *.files
  98. %files
  99. %defattr(-, root, root)
  100. %doc %{name}-%{version}/README.en
  101. %doc %{name}-%{version}/README.ja
  102. %doc %{name}-%{version}/ChangeLog
  103. %doc %{name}-%{version}/examples/
  104. %config %{httpdconfdir}/%{httpdconfmodruby}
  105. %{_libdir}/apache/*
  106. %files apache2
  107. %defattr(-, root, root)
  108. %doc %{name}-%{version}/README.en
  109. %doc %{name}-%{version}/README.ja
  110. %doc %{name}-%{version}/ChangeLog
  111. %doc %{name}-%{version}/examples/
  112. %config %{apache2confdir}/%{apache2confmodruby}
  113. %{_libdir}/apache2/*
  114. %files common
  115. %defattr(-, root, root)
  116. %doc %{name}-%{version}/README.en
  117. %doc %{name}-%{version}/README.ja
  118. %doc %{name}-%{version}/ChangeLog
  119. %{_libdir}/ruby/1.8/auto-reload.rb
  120. %dir %{_libdir}/ruby/1.8/apache
  121. %{_libdir}/ruby/1.8/apache/*
  122. %changelog
  123. * Mon Sep 22 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.6-1
  124. - new upstream release
  125. - add apache2/common subpackages
  126. * Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.7-1vl5
  127. - applied new versioning policy, spec in utf-8
  128. * Mon Aug 27 2007 Shu KONNO <owa@bg.wakwak.com> 1.0.7-0vl2
  129. - s/Copyright/License/
  130. * Sat Feb 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-0vl1
  131. - new upstream release
  132. - rebuild on apache-1.3.29, ruby-1.8.1
  133. * Thu Aug 22 2002 Satoshi MACHINO <machino@vinelinux.org> 1.0.0-0vl1
  134. - new upstream version.
  135. * Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl2
  136. - updated URL of upstream sources.
  137. * Thu May 30 2002 akira yamada <akira@vinelinux.org> 0.9.8-0vl1
  138. - new upstream version.
  139. * Fri Mar 08 2002 akira yamada <akira@vinelinux.org> 0.9.7-0vl1
  140. - new upstream version.
  141. * Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 0.9.6-0vl1
  142. - new upstream version.
  143. * Mon Oct 17 2001 akira yamada <akira@vinelinux.org> 0.9.4-0vl1
  144. - new upstream version.
  145. * Mon Oct 17 2001 akira yamada <akira@vinelinux.org> 0.9.3-0vl2
  146. - rebuild with apache-1.3.22. Requires: apache = 1.3.22.
  147. - added apache to BuildRequires. (apxs checks /usr/bin/httpd.)
  148. * Mon Sep 03 2001 akira yamada <akira@vinelinux.org> 0.9.3-0vl1
  149. - new upstream release.
  150. * Sat Aug 18 2001 akira yamada <akira@vinelinux.org>
  151. - 0.9.2-0vl1
  152. - new upstream version 0.9.2.
  153. * Wed Aug 08 2001 akira yamada <akira@vinelinux.org>
  154. - 0.9.1-0vl1
  155. - new upstream version 0.9.1.
  156. * Fri Jul 06 2001 akira yamada <akira@vinelinux.org>
  157. - new upstream version 0.9.0.
  158. * Thu Jul 03 2001 akira yamada <akira@vinelinux.org>
  159. - remove liberuby-dev from BuildRequires.
  160. * Thu Jun 28 2001 akira yamada <akira@vinelinux.org>
  161. - new upstream version 0.8.5.
  162. * Thu Jun 21 2001 akira yamada <akira@vinelinux.org>
  163. - new upstream version 0.8.4.
  164. * Mon Jun 06 2001 akira yamada <akira@vinelinux.org>
  165. - new upstream version 0.8.3.
  166. * Mon Jun 04 2001 akira yamada <akira@vinelinux.org>
  167. - new upstream version 0.8.2.
  168. * Thu May 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.0-0vl3
  169. - rebuild with papche-1.3.20
  170. * Thu Apr 13 2001 akira yamada <akira@vinelinux.org>
  171. - new upstream version 0.8.0.
  172. * Thu Mar 15 2001 akira yamada <akira@vinelinux.org>
  173. - rebuild with apache-1.3.19.
  174. * Fri Feb 09 2001 akira yamada <akira@vinelinux.org>
  175. - rebuild with apache-1.3.17.
  176. * Wed Dec 20 2000 akira yamada <akira@vinelinux.org>
  177. - Updated to new upstream version 0.2.2.
  178. * Sun Nov 05 2000 akira yamada <akira@vinelinux.org>
  179. - excute Makefile.RB with --apxs option, because normal user's PATH dose not
  180. include /usr/sbin.
  181. * Thu Oct 19 2000 akira yamada <akira@vinelinux.org>
  182. - Updated to new upstream version 0.2.1.
  183. - BuildPreReq: apache-devel, Requires: apache.
  184. - Build with apache 1.3.14.
  185. * Wed Oct 11 2000 akira yamada <akira@vinelinux.org>
  186. - Removed mod_ruby-0.2.0-egcs-2.91.66.patch, because fixed this probrem in
  187. ruby.
  188. * Thu Oct 03 2000 akira yamada <akira@vinelinux.org>
  189. - Added mod_ruby-0.2.0-egcs-2.91.66.patch to work around for segv.
  190. * Thu Oct 03 2000 akira yamada <akira@vinelinux.org>
  191. - Initial packaging.