mutter-vl.spec 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134
  1. %define pkg_version 2.28.0
  2. %define pkg_release 1%{?_dist_release}
  3. Summary: Window and compositing manager based on Clutter
  4. Name: mutter
  5. Version: %{pkg_version}
  6. Release: %{pkg_release}
  7. Source0: %{name}-%{version}.tar.bz2
  8. License: GPLv2+
  9. Group: User Interface/Desktops
  10. URL: http://git.gnome.org/browse/mutter
  11. Requires(post,postun): scrollkeeper >= 0.1.4
  12. Requires(post,pre,preun): GConf2 >= 2.14
  13. BuildRequires: pkgconfig
  14. BuildRequires: gtk2-devel
  15. BuildRequires: clutter-devel
  16. BuildRequires: libSM-devel
  17. BuildRequires: GConf2-devel
  18. BuildRequires: gir-repository-devel
  19. BuildRequires: python-devel
  20. BuildRequires: startup-notification-devel
  21. BuildRequires: gnome-doc-utils
  22. BuildRequires: desktop-file-utils
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Vendor: Project Vine
  25. Distribution: Vine Linux
  26. Packager: Takemikaduchi
  27. %description
  28. Mutter is a minimal X window manager aimed at nontechnical users and is designed to integrate well with the GNOME desktop. Mutter lacks some features that may be expected by traditional UNIX or other technical users; these users may want to investigate other available window managers for use with GNOME or standalone.
  29. %package devel
  30. Summary: Development files of the mutter library.
  31. Group: Development/Libraries
  32. Requires: %{name} = %{version}-%{release}
  33. Requires: pkgconfig
  34. Requires: gtk-doc
  35. %description devel
  36. Development files of the mutter library.
  37. %prep
  38. %setup -q
  39. %build
  40. %configure --disable-static
  41. %{__make} %{?_smp_mflags}
  42. %install
  43. %{__rm} -rf ${RPM_BUILD_ROOT}
  44. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  45. %find_lang %{name}
  46. %{__rm} -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  47. %clean
  48. %{__rm} -rf ${RPM_BUILD_ROOT}
  49. %post
  50. /sbin/ldconfig
  51. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  52. gconftool-2 --makefile-install-rule \
  53. %{_sysconfdir}/gconf/schemas/mutter.schemas \
  54. > /dev/null || :
  55. /sbin/ldconfig
  56. touch --no-create %{_datadir}/icons/hicolor
  57. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  58. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  59. fi
  60. %pre
  61. if [ "$1" -gt 1 ]; then
  62. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  63. gconftool-2 --makefile-uninstall-rule \
  64. %{_sysconfdir}/gconf/schemas/mutter.schemas \
  65. > /dev/null || :
  66. fi
  67. %preun
  68. if [ "$1" -eq 0 ]; then
  69. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  70. gconftool-2 --makefile-uninstall-rule \
  71. %{_sysconfdir}/gconf/schemas/mutter.schemas \
  72. > /dev/null || :
  73. fi
  74. %postun
  75. scrollkeeper-update -q || :
  76. /sbin/ldconfig
  77. touch --no-create %{_datadir}/icons/hicolor
  78. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  79. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  80. fi
  81. %files -f %{name}.lang
  82. %defattr(-,root,root)
  83. %doc COPYING ChangeLog NEWS README
  84. %{_bindir}/mutter
  85. %{_bindir}/mutter-message
  86. %{_libdir}/lib*.so.*
  87. %{_libdir}/mutter/*
  88. %{_datadir}/applications/*
  89. %{_datadir}/gnome/wm-properties/*
  90. %{_datadir}/mutter/*
  91. %{_sysconfdir}/gconf/schemas/*
  92. %{_mandir}/man1/mutter.1.gz
  93. %{_mandir}/man1/mutter-message.1.gz
  94. %files devel
  95. %defattr(-,root,root,-)
  96. %{_bindir}/mutter-theme-viewer
  97. %{_bindir}/mutter-window-demo
  98. %{_includedir}/mutter/*
  99. %{_libdir}/lib*.so
  100. %{_libdir}/pkgconfig/*
  101. %{_mandir}/man1/mutter-theme-viewer.1.gz
  102. %{_mandir}/man1/mutter-window-demo.1.gz
  103. %changelog
  104. * Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  105. - initial build for Vine Linux