faac-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %define name faac
  2. %define version 1.28
  3. %define release 7%{?_dist_release}
  4. %define enable_libmp4v2_external 1
  5. Summary: Reference encoder and encoding library for MPEG2/4 AAC
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. Source: http://prdownloads.sourceforge.net/faac/faac-%{version}.tar.bz2
  10. Patch0: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
  11. ## this patch is based on http://launchpadlibrarian.net/33120980/mp4v2-strcasestr.diff
  12. Patch1: mp4v2-strcasestr-vine.diff
  13. License: LGPLv2+
  14. Group: Applications/Multimedia
  15. URL: http://www.audiocoding.com/
  16. BuildRequires: nkf
  17. BuildRequires: autoconf, automake, libtool, gcc-c++
  18. %if %{enable_libmp4v2_external}
  19. # *-devel pacages provided by other self-build-* should only be listed
  20. # in self-build-%{name}.spec as PreReq.
  21. # BuildRequires: libmp4v2-devel
  22. %endif
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. %description
  25. FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
  26. COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
  27. multichannel and gapless encoding.
  28. %package devel
  29. Summary: Development libraries of the FAAC AAC encoder
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}
  32. %description devel
  33. FAAC is an AAC audio encoder. It currently supports MPEG-4 LTP, MAIN and LOW
  34. COMPLEXITY object types and MAIN and LOW MPEG-2 object types. It also supports
  35. multichannel and gapless encoding.
  36. This package contains development files and documentation for libfaac.
  37. %if !%{enable_libmp4v2_external}
  38. %package -n libmp4v2
  39. Summary: Library for working with files using the mp4 container format
  40. Group: System Environment/Libraries
  41. %description -n libmp4v2
  42. The libmp4v2 library provides an abstraction layer for working with files
  43. using the mp4 container format. This library is developed by mpeg4ip project
  44. and is an exact copy of the library distributed in the mpeg4ip package.
  45. This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
  46. %package -n libmp4v2-devel
  47. Summary: Development files for the mp4v2 library
  48. Group: Development/Libraries
  49. Requires: libmp4v2 = %{version}-%{release}
  50. %description -n libmp4v2-devel
  51. The libmp4v2 library provides an abstraction layer for working with files
  52. using the mp4 container format. This library is developed by mpeg4ip project
  53. and is an exact copy of the library distributed in the mpeg4ip package.
  54. This package contains development files for libmp4v2.
  55. This package is built with libmp4v2 internal from %{name}-%{version}-%{release}.
  56. %endif
  57. %prep
  58. %setup -q
  59. #find . -type f -print|xargs nkf --unix --overwrite
  60. %if %{enable_libmp4v2_external}
  61. %patch0 -p1 -b .mp4v2
  62. %patch1 -p1 -b .mp4v2
  63. #touch -r configure.in.mp4v2 configure.in
  64. %endif
  65. # # avoid to append the string "2005-02-02" to the tag Requires:
  66. # chmod 644 ChangeLog
  67. # # modify configure.in to escape error
  68. # %__mv configure.in configure.in.org
  69. # %__sed -e 's/^CFLAGS=.*$/CFLAGS="-O2 -Wall"/' configure.in.org > configure.in
  70. %build
  71. sh bootstrap
  72. %configure \
  73. --disable-static \
  74. %if !%{enable_libmp4v2_external}
  75. --with-mp4v2
  76. %endif
  77. %{__make} %{?_smp_mflags}
  78. %install
  79. %{__rm} -rf %{buildroot}
  80. %{__make} install DESTDIR=%{buildroot}
  81. %clean
  82. %{__rm} -rf %{buildroot}
  83. %post
  84. /sbin/ldconfig 2>/dev/null
  85. %postun
  86. /sbin/ldconfig 2>/dev/null
  87. %files
  88. %defattr(-,root,root,-)
  89. %doc AUTHORS COPYING ChangeLog NEWS README TODO docs/*
  90. %{_bindir}/*
  91. %{_libdir}/*.so.*
  92. %{_mandir}/man1/%{name}*
  93. %files devel
  94. %defattr(-,root,root,-)
  95. %exclude %{_libdir}/*.la
  96. %{_libdir}/*.so
  97. %{_includedir}/*.h
  98. %if !%{enable_libmp4v2_external}
  99. %files -n libmp4v2
  100. %defattr(-,root,root,-)
  101. %{_libdir}/libmp4v2.so.*
  102. %files -n libmp4v2-devel
  103. %defattr(-,root,root,-)
  104. %{_libdir}/libmp4v2.so
  105. %{_libdir}/libmp4v2.a
  106. %endif
  107. %changelog
  108. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
  109. - change release to sync with self-build-faac
  110. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
  111. - applied mp4v2-strcasestr.diff from lauchpad
  112. - fixed wrong declaration of strcasestr() in mpeg4ip.h
  113. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
  114. - rebuilt with mp4v2 v1.9.1
  115. - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
  116. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
  117. - change release to sync with self-build-faac
  118. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
  119. - added BuildRequires: nkf
  120. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
  121. - change release to sync with self-build-faac
  122. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
  123. - new upstream release
  124. * Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
  125. - fixed Summary: , %%description
  126. - removed internal mp4v2
  127. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
  128. - new upstream release
  129. - added --disable-static in %%configure
  130. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
  131. - spec in utf8
  132. - remove *.la
  133. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
  134. - apply new versioning policy
  135. * Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
  136. - initial build
  137. ### end of file