self-build-faac-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183
  1. %define pkgname faac
  2. %define name self-build-%{pkgname}
  3. %define version 1.28
  4. %define release 7%{?_dist_release}
  5. %define enable_libmp4v2_external 1
  6. %define sourceurl0 http://prdownloads.sourceforge.net/faac/%{pkgname}-%{version}.tar.bz2
  7. Summary: Package to automatically build %{pkgname} rpm package
  8. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  9. Name: %{name}
  10. Version: %{version}
  11. Release: %{release}
  12. Source0: %{pkgname}-vl.spec
  13. Source10: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/media-libs/faac/files/faac-1.28-external-libmp4v2.patch
  14. Source11: mp4v2-strcasestr-vine.diff
  15. License: LGPLv2+
  16. Group: Restricted Software
  17. Requires(post): self-build-setup >= 0.9.9
  18. # (build)requies of target package.
  19. Requires(post): nkf
  20. Requires(post): autoconf, automake, libtool, gcc-c++
  21. %if %{enable_libmp4v2_external}
  22. Requires(post): self-build-libmp4v2
  23. %endif
  24. BuildArch: noarch
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Packager: munepi
  27. %description
  28. FAAC is an AAC audio encoder. It currently supports MPEG-4
  29. LTP, MAIN and LOW COMPLEXITY object types and MAIN and LOW
  30. MPEG-2 object types. It also supports multichannel and
  31. gapless encoding.
  32. %if !%{enable_libmp4v2_external}
  33. The libmp4v2 library provides an abstraction layer for
  34. working with files using the mp4 container format. This
  35. library is developed by mpeg4ip project and is an exact copy
  36. of the library distributed in the mpeg4ip package.
  37. %endif
  38. If you install this package, it automatically downloads
  39. source code, compile it, and create
  40. rpm packages of %{pkgname}-%{version} and libmp4v2-%{version}.
  41. And the created rpm packages are automatically installed
  42. if installation is executed by apt-get command or synaptic
  43. package manager.
  44. [Note]
  45. This package requires many other packages to compile
  46. targetsoftware. So it consume more disk space than usual.
  47. Also installation takes logner time because of compilation.
  48. (This will take a few minutes to quarter or half of an hour,
  49. depends on building environment)
  50. [About self-build package]
  51. For some kind of software, distributing of binary package
  52. may viorate the patent or law. Therefore we chose self-build
  53. packge, create binary package on your machine, for such kind
  54. of softwares instead of distributing binary package.
  55. Please obey the national law when you use the created binary
  56. packages. And if you want to use the softwares using patented
  57. thechnology, it may be required to get a permission, make an
  58. agreement or purchas a license. Please consider it with your
  59. purpose or way of use and take appropriate action.
  60. %description -l ja
  61. FAAC は AAC オーディオエンコーダーです.現在 MPEG-4 LTP,
  62. Main/Low Complexity object types, Main/LOW MPEG-2 object
  63. types をサポートしています.またマルチチャンネルやギャップ
  64. レスエンコーディングもサポートしています.
  65. %if !%{enable_libmp4v2_external}
  66. libmp4v2 ライブラリは mp4 コンテナフォーマットを用いたファイ
  67. ルで動作するものに対して抽象レイヤーを提供します.このライブ
  68. ラリは mpeg4ip プロジェクトにより開発されており,mpeg4ip パッ
  69. ケージに分散されているライブラリの完全なコピーです.
  70. %endif
  71. このパッケージをインストールすると、自動的にソースコードを
  72. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  73. と libmp4v2-%{version} の rpm パッケージを作成します。
  74. また apt-get コマンドや synaptic パッケージマネージャから実行
  75. した場合は、作成された rpm パッケージのインストールも自動的に
  76. 行います。
  77. [注意]
  78. コンパイルに必要な多くの関連パッケージを要求するので通常より
  79. ディスクの領域を多く消費します。
  80. またインストール時にコンパイルを行うため、通常より時間がかか
  81. る場合があります。(環境にもよりますが数分から数十分程度)
  82. [self-build パッケージについて]
  83. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  84. 違反する可能性があるものがあります。その為、このような問題が
  85. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  86. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  87. ジという方法を採っています。
  88. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  89. アのライセンス、および利用する国の各種法令に従ってください。
  90. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  91. センスの購入などが必要となる場合がありますので、利用する目的
  92. や形態に応じて各自で判断し適切な対応を取ってください。
  93. %prep
  94. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  95. %install
  96. %{__rm} -rf ${RPM_BUILD_ROOT}
  97. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  98. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  99. %{__install} -m 644 %{SOURCE10} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  100. %{__install} -m 644 %{SOURCE11} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  101. %clean
  102. %{__rm} -rf ${RPM_BUILD_ROOT}
  103. %posttrans
  104. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 25000
  105. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  106. %{pkgname}-devel-%{version}-%{release}
  107. %files
  108. %defattr(-,root,root)
  109. %{_datadir}/%{name}
  110. %changelog
  111. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-7
  112. - renamed %%{Source0} to faac-vl.spec
  113. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-6
  114. - applied mp4v2-strcasestr.diff from lauchpad
  115. - fixed wrong declaration of strcasestr() in mpeg4ip.h
  116. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-5
  117. - rebuilt with mp4v2 v1.9.1
  118. - applied faac-1.28-external-libmp4v2.patch from Gentoo Linux
  119. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.28-4
  120. - applied a progress bar to show approximately building time
  121. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-3
  122. - added Requires(post): nkf
  123. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-2
  124. - added BuildArch: noarch
  125. - avoided to execute self-build-rpm.sh on RPM transaction
  126. - moved %%post actions to %%posttrans
  127. * Fri Mar 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.28-1
  128. - new upstream release
  129. * Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-2
  130. - fixed Summary: , %%description
  131. - removed internal mp4v2
  132. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.26-1
  133. - new upstream release
  134. - added PreReq: self-build-libmp4v2
  135. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-2
  136. - spec in utf8
  137. - remove *.la
  138. * Sun May 18 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.25-1
  139. - run pre-allocate-rpm.sh in %%post
  140. - set PreReq: self-build-setup >= 0.8
  141. - apply new versioning policy
  142. * Sat Mar 8 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.25-0vl1
  143. - initial build
  144. ### end of file