self-build-faad2-vl.spec 5.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. %define pkgname faad2
  2. %define name self-build-%{pkgname}
  3. %define version 2.7
  4. %define release 4%{?_dist_release}
  5. %define sourceurl0 http://prdownloads.sourceforge.net/faac/%{pkgname}-%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Obsoletes: faad2 < 2.7, faad2-devel < 2.7
  12. Source0: %{pkgname}-vl.spec
  13. License: GPLv2+
  14. Group: Restricted Software
  15. Requires(post): self-build-setup >= 0.9.9
  16. Requires(post): autoconf, automake, libtool
  17. Requires(post): gcc-c++, zlib-devel, sysfsutils-devel
  18. Requires(post): id3lib-devel, gtk+-devel
  19. %{?_with_xmms:Requires(post): xmms-devel}
  20. BuildArch: noarch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  22. Packager: munepi
  23. %description
  24. FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely
  25. written from scratch.
  26. If you install this package, it automaticaly downloads source
  27. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  28. And the created rpm packages are automatically installed
  29. if installation is executed by apt-get command or synaptic
  30. package manager.
  31. [Note]
  32. This package requires many other packages to compile
  33. targetsoftware. So it consume more disk space than usual.
  34. Also installation takes logner time because of compilation.
  35. (This will take a few minutes to quarter or half of an hour,
  36. depends on building environment)
  37. [About self-build package]
  38. For some kind of software, distributing of binary package
  39. may viorate the patent or law. Therefore we chose self-build
  40. packge, create binary package on your machine, for such kind
  41. of softwares instead of distributing binary package.
  42. Please obey the national law when you use the created binary
  43. packages. And if you want to use the softwares using patented
  44. thechnology, it may be required to get a permission, make an
  45. agreement or purchas a license. Please consider it with your
  46. purpose or way of use and take appropriate action.
  47. %description -l ja
  48. FAAD 2 is a LC, MAIN and LTP profile, MPEG2 and MPEG-4 AAC decoder, completely
  49. written from scratch.
  50. このパッケージをインストールすると、自動的にソースコードを
  51. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  52. パッケージを作成します。
  53. また apt-get コマンドや synaptic パッケージマネージャから実行
  54. した場合は、作成された rpm パッケージのインストールも自動的に
  55. 行います。
  56. [注意]
  57. コンパイルに必要な多くの関連パッケージを要求するので通常より
  58. ディスクの領域を多く消費します。
  59. またインストール時にコンパイルを行うため、通常より時間がかか
  60. る場合があります。(環境にもよりますが数分から数十分程度)
  61. [self-build パッケージについて]
  62. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  63. 違反する可能性があるものがあります。その為、このような問題が
  64. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  65. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  66. ジという方法を採っています。
  67. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  68. アのライセンス、および利用する国の各種法令に従ってください。
  69. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  70. センスの購入などが必要となる場合がありますので、利用する目的
  71. や形態に応じて各自で判断し適切な対応を取ってください。
  72. %prep
  73. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  74. %install
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  77. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %clean
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %posttrans
  81. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 40000
  82. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  83. %{pkgname}-devel-%{version}-%{release}
  84. %files
  85. %defattr(-,root,root)
  86. %{_datadir}/%{name}
  87. %changelog
  88. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-4
  89. - renamed %%{Source0} to faad2-vl.spec
  90. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-3
  91. - applied a progress bar to show approximately building time
  92. * Sat Jan 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-2
  93. - change release to sync with faad2.spec
  94. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2.7-1
  95. - new upstream release
  96. - check version between original spec and self-build spec in %%prep
  97. - added Obsoletes: faad2 < 2.7, faad2-devel < 2.7
  98. - changed so name to libfaad.so.2
  99. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.6.1-3
  100. - added BuildArch: noarch
  101. - avoided to execute self-build-rpm.sh on RPM transaction
  102. - moved %%post actions to %%posttrans
  103. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.6.1-2
  104. - initial bulid for self-build