ffmpeg-mh-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198
  1. %define name ffmpeg-mh
  2. %define version 0.33
  3. %define svndate 051130
  4. %define release 12%{?_dist_release}
  5. %define ffmpeg_mh ffmpeg_%{svndate}
  6. # %define amrnbver 7.1.0.2
  7. # %define amrwbver 7.0.0.3
  8. #% define _with_amr 1
  9. %define _with_x264_mh 1
  10. %define x264_mh x264_051028
  11. Summary: 3GP Converter (Keitai Douga Henkan-kun) for UNIX---FFmpeg Mobile Hack version
  12. Summary(ja): Windows 用携帯動画変換君(3GP Converter)の UNIX 版
  13. Name: %{name}
  14. Version: %{version}
  15. Release: %{release}
  16. Source: http://www.nurs.or.jp/~calcium/3gpp/sources/ffmpeg-%{svndate}-%{version}.tar.gz
  17. # x264_051028.tar.gz: from http://mobilehackerz.jp/contents?plugin=attach&refer=3GPConv%2FSources&openfile=x264_051028.tar.gz
  18. # on http://mobilehackerz.jp/contents/3GPConv/Sources
  19. %if %{_with_x264_mh}
  20. Source1: x264_051028.tar.gz
  21. %endif
  22. # Source1: http://ftp.penguin.cz/pub/users/utx/amr/amrnb-%{amrnbver}.tar.bz2
  23. # Source2: http://ftp.penguin.cz/pub/users/utx/amr/amrwb-%{amrwbver}.tar.bz2
  24. Patch: http://can.homeunix.org/sw/psp/ffmpeg_psp/ffmpeg-mh-unix.patch
  25. #Patch1: ffmpeg-mh-include-amr.patch
  26. Patch2: ffmpeg-mh-0.33-disable-texi2html.patch
  27. License: GPL
  28. Group: Applications/Multimedia
  29. URL: http://www.nurs.or.jp/~calcium/3gpp/
  30. #Requires:
  31. BuildRequires: zlib-devel, SDL-devel, imlib2-devel
  32. #BuildRequires: texi2html
  33. BuildRequires: libogg-devel, libvorbis-devel, libtheora-devel
  34. # *-devel pacages provided by other self-build-* should only be listed
  35. # in self-build-%{name}.spec as PreReq.
  36. #BuildRequires: xvidcore-devel, faac-devel, lame-devel
  37. #BuildRequires: x264-devel, libdca-devel, a52dec-devel, faad2-devel
  38. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  39. %description
  40. FFMpeg is a complete and free Internet live audio and video
  41. broadcasting solution for Linux/Unix. It also includes a digital
  42. VCR. It can encode in real time in many formats including MPEG1 audio
  43. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  44. ffmpeg-mh is a 3GP Converter for UNIX. It is a FFmpeg Mobile Hack version
  45. under unix, is enoughly customized for many mobiles from original sources
  46. of ffmpeg.
  47. %description -l ja
  48. FFMpeg は Linux/Unix に対する完全にフリーなインターネットライブ
  49. オーティオ・ビデオブロードキャスティングソリューションです.
  50. またデジタル VCR を含んでいます.MPEG1 オーディオ・ビデオ,
  51. MPEG4, h263, ac3, asf, avi, real, mjpeg, flash を含む
  52. 多様なフォーマットをリアルタイムにエンコードすることができます.
  53. ffmpeg-mh は Windows 用携帯動画変換君(3GP Converter)の UNIX 版です.
  54. FFmpeg のモバイル端末向けに改良されたバージョンで,オリジナルのソースから
  55. モバイル向けにたくさん調整されています.
  56. %prep
  57. %setup -q -n %{ffmpeg_mh}
  58. %patch -p1
  59. #%patch1 -p1 -b include
  60. # tar jxvf %{SOURCE1}
  61. # tar jxvf %{SOURCE2}
  62. ## use x264 for Mobile Hack version
  63. %if %{_with_x264_mh}
  64. tar zxvf %{SOURCE1}
  65. %endif
  66. %build
  67. # ## build amr
  68. # cd amrnb-%{amrnbver}
  69. # ./configure \
  70. # --prefix=${RPM_BUILD_DIR}/%{ffmpeg_mh} \
  71. # --includedir=${RPM_BUILD_DIR}/%{ffmpeg_mh}/include/amr \
  72. # --enable-static --disable-shared
  73. # %{__make} %{?_smp_mflags} OPT_CFLAGS="$RPM_OPT_FLAGS"
  74. # %{__make} install
  75. # cd ..
  76. # cd amrwb-%{amrwbver}
  77. # ./configure \
  78. # --prefix=${RPM_BUILD_DIR}/%{ffmpeg_mh} \
  79. # --includedir=${RPM_BUILD_DIR}/%{ffmpeg_mh}/include/amr_float \
  80. # --enable-static --disable-shared
  81. # %{__make} %{?_smp_mflags} OPT_CFLAGS="$RPM_OPT_FLAGS"
  82. # %{__make} install
  83. # cd ..
  84. ## build x264 for Mobile Hack version
  85. %if %{_with_x264_mh}
  86. cd %{x264_mh}
  87. ./configure \
  88. --prefix=${RPM_BUILD_DIR}/%{ffmpeg_mh} \
  89. --enable-pthread \
  90. --enable-static \
  91. --disable-shared
  92. %__make
  93. %__make install
  94. cd ..
  95. %endif
  96. ## configure ffmpeg-mh
  97. ./configure \
  98. --prefix=%{_prefix} \
  99. --incdir=%{_includedir}/%{name} \
  100. --libdir=%{_libdir} \
  101. --shlibdir=%{_libdir} \
  102. --mandir=%{_mandir} \
  103. %{?_with_x264_mh:--extra-cflags=-I${RPM_BUILD_DIR}/%{ffmpeg_mh}/include} \
  104. %{?_with_x264_mh:--extra-ldflags=-L${RPM_BUILD_DIR}/%{ffmpeg_mh}/lib} \
  105. %{?_with_x264_mh:--enable-x264} \
  106. --disable-debug \
  107. --enable-mp3lame \
  108. --enable-libogg \
  109. --enable-vorbis \
  110. --enable-faad \
  111. --enable-faac \
  112. --enable-xvid \
  113. --enable-a52 \
  114. %{?_with_amr:--enable-amr_nb --enable-amr_nb-fixed --enable-amr_wb} \
  115. --enable-pp \
  116. --enable-pthreads \
  117. --enable-gpl \
  118. --enable-static \
  119. --disable-shared \
  120. --disable-ffserver \
  121. --disable-ffplay
  122. ## build ffmpeg-mh
  123. %{__make} %{?_smp_mflags}
  124. %install
  125. %{__rm} -rf $RPM_BUILD_ROOT
  126. ## install ffmpeg-mh
  127. install -d -m755 %{buildroot}/%{_bindir}
  128. install -m 755 ffmpeg %{buildroot}/%{_bindir}/%{name}
  129. %clean
  130. %{__rm} -rf $RPM_BUILD_ROOT
  131. %files
  132. %defattr(-,root,root,-)
  133. %{_bindir}/ffmpeg-mh
  134. %changelog
  135. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.33-12
  136. - change release to sync with self-build-ffmpeg-mh
  137. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-11
  138. - rebuild
  139. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-10
  140. - change release to sync with self-build-ffmpeg-mh
  141. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-9
  142. - applied ffmpeg-mh-0.33-disable-texi2html.patch
  143. - dropped BuildRequires: texi2html
  144. * Sun Feb 8 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-8
  145. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  146. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-7
  147. - change release to sync with self-build-ffmpeg-mh
  148. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-6
  149. - added x264_051028 for Mobile Hack version
  150. - dropped BuildRequires: self-build-x264
  151. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-5
  152. - spec in utf8
  153. - droppd BuildRequires: xvidcore-devel, faac-devel, lame-devel
  154. BuildRequires: x264-devel, libdca-devel, a52dec-devel
  155. (*-devel pacages provided by other self-build-*) in ffmpeg-mh.spec
  156. * Thu Apr 10 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-1vl4
  157. - build with new versioning policy
  158. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-0vl2
  159. - [self-build-ffmpeg-mh.spec]
  160. For all pre-required package that is provied by self-build,
  161. changed to its self-build package
  162. * Tue Mar 11 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.33-0vl1
  163. - initial build for Vine Linux 4.2
  164. with ffmpeg-051130-0.33
  165. ### end of file