ffmpeg-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259
  1. #TODO: Build with openjpeg
  2. %define name ffmpeg
  3. %define version 0.5
  4. %define svndate 20100216
  5. %define release 8%{?svndate:.%svndate}%{?_dist_release}
  6. Summary: Digital VCR and streaming server
  7. Name: %{name}
  8. Version: %{version}
  9. Release: %{release}
  10. #Source: %{name}-%{version}.tar.bz2
  11. Source: %{name}-%{?svndate:%svndate}.tar.bz2
  12. Source1: %{name}-snapshot.sh
  13. # pre-built man files
  14. Source90: ffmpeg.1.gz
  15. Source91: ffplay.1.gz
  16. Source92: ffserver.1.gz
  17. # get rid of textrels on x86_64 in yasm code (from RPM Fusion)
  18. #Patch0: %{name}-textrel.patch
  19. License: GPLv2+
  20. Group: Applications/Multimedia
  21. URL: http://ffmpeg.org/
  22. BuildRequires: bzip2-devel
  23. BuildRequires: gsm-devel
  24. BuildRequires: imlib2-devel
  25. BuildRequires: libdc1394-devel
  26. BuildRequires: libraw1394-devel
  27. BuildRequires: libtheora-devel
  28. BuildRequires: libvdpau-devel
  29. BuildRequires: libvorbis-devel
  30. ##BuildRequires: openjpeg-devel
  31. BuildRequires: SDL-devel
  32. BuildRequires: speex-devel
  33. ##BuildRequires: texi2html
  34. BuildRequires: zlib-devel
  35. BuildRequires: libogg-devel
  36. %ifarch %{ix86} x86_64
  37. BuildRequires: yasm
  38. %endif
  39. # *-devel packages provided by other self-build-* should only be listed
  40. # in self-build-%{name}.spec as PreReq.
  41. #BuildRequires: xvidcore-devel, faac-devel, lame-devel
  42. #BuildRequires: x264-devel, libdca-devel, a52dec-devel
  43. #BuildRequires: faad2-devel
  44. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  45. %description
  46. FFMpeg is a complete and free Internet live audio and video
  47. broadcasting solution for Linux/Unix. It also includes a digital
  48. VCR. It can encode in real time in many formats including MPEG1 audio
  49. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  50. %package libs
  51. Group: System Environment/Libraries
  52. Summary: Libraries for %{name}
  53. Group: System Environment/Libraries
  54. %description libs
  55. FFMpeg is a complete and free Internet live audio and video
  56. broadcasting solution for Linux/Unix. It also includes a digital
  57. VCR. It can encode in real time in many formats including MPEG1 audio
  58. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  59. This package contains the libraries for %{name}.
  60. %package devel
  61. Summary: Development package for %{name}
  62. Group: Development/Libraries
  63. Requires: %{name}-libs = %{version}-%{release}
  64. Requires: pkgconfig
  65. %description devel
  66. FFMpeg is a complete and free Internet live audio and video
  67. broadcasting solution for Linux/Unix. It also includes a digital
  68. VCR. It can encode in real time in many formats including MPEG1 audio
  69. and video, MPEG4, h263, ac3, asf, avi, real, mjpeg, and flash.
  70. This package contains development files for %{name}.
  71. %prep
  72. %setup -q -n %{name}-%{svndate}
  73. #% setup -q
  74. #%patch0 -p1 -b .textrel
  75. %build
  76. %ifarch ppc
  77. # compile with -mlongcall on ppc/ppc64 (rf804)
  78. export RPM_OPT_FLAGS="$RPM_OPT_FLAGS -mlongcall"
  79. %endif
  80. ./configure \
  81. --prefix=%{_prefix} \
  82. --incdir=%{_includedir}/%{name} \
  83. --shlibdir=%{_libdir} \
  84. --libdir=%{_libdir} \
  85. --mandir=%{_mandir} \
  86. --arch=%{_target_cpu} \
  87. %ifarch %{ix86}
  88. --cpu=%{_target_cpu} \
  89. %endif
  90. %ifarch ppc
  91. --cpu=g3 \
  92. %endif
  93. --enable-runtime-cpudetect \
  94. --extra-cflags="$RPM_OPT_FLAGS" \
  95. %{?_with_opencore_amr:--enable-libopencore-amrnb --enable-libopencore-amrwb --enable-version3} \
  96. --enable-bzlib \
  97. --enable-libdc1394 \
  98. --enable-libfaac --enable-nonfree \
  99. --enable-libfaad \
  100. --enable-libgsm \
  101. --enable-libmp3lame \
  102. %{?_with_openjpeg:--enable-libopenjpeg} \
  103. --enable-libtheora \
  104. --enable-libvorbis \
  105. --enable-libx264 \
  106. --enable-libxvid \
  107. --enable-x11grab \
  108. --enable-avfilter \
  109. --enable-avfilter-lavf \
  110. --enable-postproc \
  111. --enable-swscale \
  112. --enable-pthreads \
  113. --disable-static \
  114. --enable-shared \
  115. --enable-gpl \
  116. --disable-debug \
  117. --disable-stripping
  118. %{__make} %{?_smp_mflags}
  119. #% {__make}
  120. #%{__make} documentation
  121. %install
  122. %__make install DESTDIR=$RPM_BUILD_ROOT
  123. ## install man
  124. %__mkdir_p $RPM_BUILD_ROOT%{_mandir}/man1/
  125. %__install %{SOURCE90} %{SOURCE91} %{SOURCE92} $RPM_BUILD_ROOT%{_mandir}/man1/
  126. %clean
  127. %{__rm} -rf $RPM_BUILD_ROOT
  128. %post libs -p /sbin/ldconfig
  129. %postun libs -p /sbin/ldconfig
  130. %files
  131. %defattr(-,root,root,-)
  132. %doc COPYING.* CREDITS Changelog README doc/ffserver.conf
  133. %{_bindir}/ffmpeg
  134. %{_bindir}/ffplay
  135. %{_bindir}/ffserver
  136. %{_mandir}/man1/ffmpeg.1*
  137. %{_mandir}/man1/ffplay.1*
  138. %{_mandir}/man1/ffserver.1*
  139. %{_datadir}/ffmpeg
  140. %files libs
  141. %defattr(-,root,root,-)
  142. %{_libdir}/lib*.so.*
  143. %files devel
  144. %defattr(-,root,root,-)
  145. %doc MAINTAINERS doc/APIchanges doc/TODO doc/*.txt
  146. %{_includedir}/ffmpeg
  147. %{_libdir}/pkgconfig/lib*.pc
  148. %{_libdir}/lib*.so
  149. %changelog
  150. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-8.20100216
  151. - change release to sync with self-build-ffmpeg
  152. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.5-7.20100216
  153. - updated source snapshot 20100216
  154. - rebuild with recent x264-devel
  155. - updated pre-built man files: ffmpeg.1 ffplay.1 ffserver.1
  156. - added BuildRequires: libvdpau-devel
  157. * Sat Jun 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-6
  158. - change release to sync with self-build-ffmpeg
  159. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-5
  160. - change release to sync with self-build-ffmpeg
  161. * Wed May 13 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-4
  162. - applied ffmpeg-0.5-disable-texi2html.patch
  163. - dropped BuildRequires: texi2html
  164. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-3
  165. - change release to sync with self-build-ffmpeg
  166. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-2
  167. - corrected release number
  168. * Wed Mar 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5-1
  169. - new upstream release
  170. - added BuildRequires:
  171. - speex-devel
  172. - bzip2-devel
  173. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090227.8
  174. - 20090227 snapshot
  175. * Tue Feb 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.7
  176. - added %%{?_with_amr:%%{_datadir}/%%{name}} in %%files
  177. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.6
  178. - changed to PreReq: self-build-faad2 >= 2.0 from faad2-devel
  179. - dropped Requires: a52dec, faad2 in ffmpeg-libs
  180. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090202.5
  181. - 20090202 snapshot
  182. * Sun Jan 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-20090110.4
  183. - 20090110 snapshot
  184. - dropped some patches
  185. * Thu Nov 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-15488.1
  186. - source updated (r15488)
  187. - fixed License: GPLv2+
  188. - added BuildRequires: gsm-devel libdc1394-devel libraw1394-devel
  189. - added BuildRequires: yasm (only %%ix86)
  190. - applied ffmpeg-cpu.patch (merged from RPM Fusion)
  191. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-11662.3vl4
  192. - spec in utf8
  193. * Tue May 20 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.9-11662.2vl4
  194. - change release to sync with self-build-ffmpeg
  195. * Wed Apr 16 2008 Atsushi SHICHI <ats777@gmail.com> 0.4.9-11662.1vl4
  196. - drop "Patch100: ffmpeg-vine.patch".
  197. * Mon Apr 7 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128.1vl4
  198. - build with new versioning policy
  199. - change to use svn export from svn checkout on post install
  200. - fix ffmpeg-vine.patch for libswscale/swscale.c.rej
  201. * Thu Mar 13 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl2
  202. - [self-build-ffmpeg.spec]
  203. For all pre-required package that is provied by self-build,
  204. changed to its self-build package
  205. * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.9-0.20080128vl1
  206. - initial build for Vine Linux 4.2
  207. - snapshot 2008/01/28 + some Rev.11662 2008/01/29
  208. ### end of file