self-build-ffmpeg2theora-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. %define pkgname ffmpeg2theora
  2. %define name self-build-%{pkgname}
  3. %define version 0.25
  4. %define release 2%{?_dist_release}
  5. %define sourceurl http://www.v2v.cc/~j/ffmpeg2theora/%{pkgname}-%{version}.tar.bz2
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: GPL
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. # (build)requies of target package.
  16. Requires(post): scons
  17. Requires(post): libogg-devel, libtheora-devel, libvorbis-devel
  18. Requires(post): self-build-ffmpeg
  19. BuildArch: noarch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Packager: munepi
  22. %description
  23. ffmpeg2theora is a tool to convert any file that ffmpeg can
  24. decode to theora.
  25. If you install this package, it automaticaly downloads source
  26. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  27. And the created rpm packages are automatically installed
  28. if installation is executed by apt-get command or synaptic
  29. package manager.
  30. [Note]
  31. This package requires many other packages to compile
  32. targetsoftware. So it consume more disk space than usual.
  33. Also installation takes logner time because of compilation.
  34. (This will take a few minutes to quarter or half of an hour,
  35. depends on building environment)
  36. [About self-build package]
  37. For some kind of software, distributing of binary package
  38. may viorate the patent or law. Therefore we chose self-build
  39. packge, create binary package on your machine, for such kind
  40. of softwares instead of distributing binary package.
  41. Please obey the national law when you use the created binary
  42. packages. And if you want to use the softwares using patented
  43. thechnology, it may be required to get a permission, make an
  44. agreement or purchas a license. Please consider it with your
  45. purpose or way of use and take appropriate action.
  46. %description -l ja
  47. ffmpeg2theora は ffmpeg がデコードできるファイルを theora 形式
  48. に変換するツールです。
  49. このパッケージをインストールすると、自動的にソースコードを
  50. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  51. パッケージを作成します。
  52. また apt-get コマンドや synaptic パッケージマネージャから実行
  53. した場合は、作成された rpm パッケージのインストールも自動的に
  54. 行います。
  55. [注意]
  56. コンパイルに必要な多くの関連パッケージを要求するので通常より
  57. ディスクの領域を多く消費します。
  58. またインストール時にコンパイルを行うため、通常より時間がかか
  59. る場合があります。(環境にもよりますが数分から数十分程度)
  60. [self-build パッケージについて]
  61. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  62. 違反する可能性があるものがあります。その為、このような問題が
  63. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  64. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  65. ジという方法を採っています。
  66. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  67. アのライセンス、および利用する国の各種法令に従ってください。
  68. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  69. センスの購入などが必要となる場合がありますので、利用する目的
  70. や形態に応じて各自で判断し適切な対応を取ってください。
  71. %prep
  72. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  73. %install
  74. %{__rm} -rf ${RPM_BUILD_ROOT}
  75. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  76. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  77. %clean
  78. %{__rm} -rf ${RPM_BUILD_ROOT}
  79. %posttrans
  80. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec %{sourceurl} 10000
  81. #/usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release}
  82. %files
  83. %defattr(-,root,root)
  84. %{_datadir}/%{name}
  85. %changelog
  86. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-2
  87. - renamed %%{Source0} to ffmpeg2theora-vl.spec
  88. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.25-1
  89. - new upstream release
  90. - with recent ffmpeg
  91. * Sat Jun 20 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.24-1
  92. - new upstream release
  93. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-2
  94. - added BuildArch: noarch
  95. - avoided to execute self-build-rpm.sh on RPM transaction
  96. - moved %%post actions to %%posttrans
  97. * Wed Feb 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.23-1
  98. - new upstream release
  99. - dropped ffmpeg2theora-0.20-new_ffmpeg.patch
  100. - added PreReq: scons
  101. * Sat May 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.20-2
  102. - spec in utf8
  103. * Sat May 17 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.20-1
  104. - initial build for Vine Linux.