self-build-libquicktime-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150
  1. %define pkgname libquicktime
  2. %define name self-build-%{pkgname}
  3. %define version 1.1.4
  4. %define release 2%{?_dist_release}
  5. %define sourceurl0 http://prdownloads.sourceforge.net/libquicktime/%{pkgname}-%{version}.tar.gz
  6. Summary: Package to automatically build %{pkgname} rpm package
  7. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  8. Name: %{name}
  9. Version: %{version}
  10. Release: %{release}
  11. Source0: %{pkgname}-vl.spec
  12. License: LGPLv2+
  13. Group: Restricted Software
  14. Requires(post): self-build-setup >= 0.9.9
  15. Requires(post): libvorbis-devel
  16. Requires(post): libpng-devel
  17. Requires(post): libjpeg-devel
  18. Requires(post): gtk2-devel
  19. Requires(post): libdv-devel
  20. Requires(post): libraw1394-devel
  21. Requires(post): libavc1394-devel
  22. Requires(post): alsa-lib-devel
  23. Requires(post): zlib-devel
  24. Requires(post): gettext-devel
  25. Requires(post): mesa-libGL-devel
  26. Requires(post): libX11-devel
  27. Requires(post): libICE-devel
  28. Requires(post): libSM-devel
  29. Requires(post): libXext-devel
  30. Requires(post): libXmu-devel
  31. Requires(post): libXpm-devel
  32. Requires(post): libXt-devel
  33. Requires(post): libXaw-devel >= 1.0.5
  34. Requires(post): libXv-devel
  35. Requires(post): self-build-ffmpeg
  36. Requires(post): self-build-lame
  37. Requires(post): self-build-faad2
  38. Requires(post): self-build-faac
  39. Requires(post): self-build-x264
  40. BuildArch: noarch
  41. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  42. Packager: munepi
  43. %description
  44. Libquicktime is a library for reading and writing QuickTime files
  45. on UNIX systems. Video CODECs supported by this library are OpenDivX, MJPA,
  46. JPEG Photo, PNG, RGB, YUV 4:2:2, and YUV 4:2:0 compression. Supported
  47. audio CODECs are Ogg Vorbis, IMA4, ulaw, and any linear PCM format.
  48. Libquicktime is based on the quicktime4linux library. Libquicktime add
  49. features such as a GNU build tools-based build process and dynamically
  50. loadable CODECs.
  51. If you install this package, it automaticaly downloads source
  52. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  53. And the created rpm packages are automatically installed
  54. if installation is executed by apt-get command or synaptic
  55. package manager.
  56. [Note]
  57. This package requires many other packages to compile
  58. targetsoftware. So it consume more disk space than usual.
  59. Also installation takes logner time because of compilation.
  60. (This will take a few minutes to quarter or half of an hour,
  61. depends on building environment)
  62. [About self-build package]
  63. For some kind of software, distributing of binary package
  64. may viorate the patent or law. Therefore we chose self-build
  65. packge, create binary package on your machine, for such kind
  66. of softwares instead of distributing binary package.
  67. Please obey the national law when you use the created binary
  68. packages. And if you want to use the softwares using patented
  69. thechnology, it may be required to get a permission, make an
  70. agreement or purchas a license. Please consider it with your
  71. purpose or way of use and take appropriate action.
  72. %description -l ja
  73. libquicktimeはUNIX 系のシステムでQuickTimeファイルを読み書きするための
  74. ライブラリです.ビデオエンコード:OpenDivX、MJPA、JPEG Photo、PNG、RGB、
  75. YUV 4:2:2、YUV 4:2:0、オーディオエンコード:Ogg Vorbis、IMA4、ulaw、そ
  76. の他線型PCM形式をサポートします.
  77. このパッケージをインストールすると、自動的にソースコードを
  78. ダウンロードしてコンパイルし、%{pkgname}-%{version} の rpm
  79. パッケージを作成します。
  80. また apt-get コマンドや synaptic パッケージマネージャから実行
  81. した場合は、作成された rpm パッケージのインストールも自動的に
  82. 行います。
  83. [注意]
  84. コンパイルに必要な多くの関連パッケージを要求するので通常より
  85. ディスクの領域を多く消費します。
  86. またインストール時にコンパイルを行うため、通常より時間がかか
  87. る場合があります。(環境にもよりますが数分から数十分程度)
  88. [self-build パッケージについて]
  89. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  90. 違反する可能性があるものがあります。その為、このような問題が
  91. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  92. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  93. ジという方法を採っています。
  94. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  95. アのライセンス、および利用する国の各種法令に従ってください。
  96. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  97. センスの購入などが必要となる場合がありますので、利用する目的
  98. や形態に応じて各自で判断し適切な対応を取ってください。
  99. %prep
  100. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  101. %install
  102. %{__rm} -rf ${RPM_BUILD_ROOT}
  103. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  104. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  105. %clean
  106. %{__rm} -rf ${RPM_BUILD_ROOT}
  107. %posttrans
  108. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec "%{sourceurl0}" 185000
  109. /usr/lib/rpm/pre-allocate-rpm.sh %{pkgname}-%{version}-%{release} \
  110. %{pkgname}-devel-%{version}-%{release}
  111. %files
  112. %defattr(-,root,root)
  113. %{_datadir}/%{name}
  114. %changelog
  115. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-2
  116. - renamed %%{Source0} to libquicktime-vl.spec
  117. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.4-1
  118. - new upstream release
  119. * Sun Jun 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.1.2-1
  120. - initial bulid