wl-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origname wl
  4. %define origver 2.14.0
  5. # if the package is not prerelease, set %%{prever} to %{nil}
  6. %define prever %{nill}
  7. %define emacsen_pkgdir /usr/lib/emacsen-common/packages
  8. Summary: IMAP-capable mail/news reader for emacsen
  9. Summary(ja): (X)Emacs 用IMAP に対応したメール/ニュースリーダ
  10. Name: %{origname}
  11. Version: %{origver}
  12. Release: 3%{?_dist_release}
  13. Source0: ftp://ftp.gohome.org/%{origname}/stable/%{origname}-%{origver}.tar.gz
  14. Source1: %{origname}-install.sh
  15. Source2: %{origname}-remove.sh
  16. Source3: %{origname}-init.el
  17. Source4: vine-default-%{origname}.el
  18. Patch1: wl-2.14.0-wl-news.patch
  19. Patch10: wl-2.8.1-texi-ja.diff
  20. Patch11: wl-2.8.1-install-utils.diff
  21. License: GPL2
  22. Group: Applications/Editors/Emacs
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildArch: noarch
  25. Obsoletes: wl-el, Wanderlust, Wanderlust-xemacs
  26. PreReq: emacsen
  27. %prereq_ge emacsen-common
  28. %prereq_ge semi
  29. %prereq_ge w3m-el
  30. BuildRequires: emacsen-common, semi, w3m-el
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. Packager: MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  34. %description
  35. Wanderlust is a mail/news reader supporting IMAP for emacsen.
  36. Overall impression resembles to Mew, but Wanderlust have nifty
  37. features like IMAP support, threading display, and so on.
  38. #(eigo wakannai)
  39. #After installation, you must modify your ~/.emacs file to contain
  40. #at least:
  41. #
  42. # (load "mime-setup")
  43. #
  44. # (autoload 'wl "wl" "Wanderlust t)
  45. # (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
  46. Other detailed information can be available at:
  47. http://www.gohome.org/wl/index-e.html
  48. (sorry, much detailed info is currently available only in Japanese)
  49. %description -l ja
  50. Wanderlust は、elisp のみで実装された IMAP 対応のメール/ニュースリーダです。
  51. 使用感は Mew に近く、加えてスレッド表示や未読管理などにも対応しています。
  52. 主な特徴(Wanderlust web ページより抜粋)
  53. - elisp のみによる実装
  54. - IMAPrev1, NNTP, POP, MH 形式のサポート
  55. - Mew っぽい Folder Specification に基づくメッセージへの
  56. 統一的アクセス
  57. - Mew っぽいキーバインドとマーク処理
  58. - インタラクティブなスレッド表示
  59. - 未読管理
  60. - 購読フォルダの一覧を表示するフォルダモード
  61. - メッセージキャッシュ、オフライン処理 (IMAP4)
  62. - MIME 対応 (by SEMI or tm)
  63. #インストール後、~/.emacs に最低でも以下の記述を追加して下さい:
  64. #
  65. # (load "mime-setup")
  66. #
  67. # (autoload 'wl "wl" "Wanderlust t)
  68. # (autoload 'wl-draft "wl" "Write draft with Wanderlust." t)
  69. # Emacs/XEmacs 起動時に以下の設定ファイルを読み込みます。
  70. # M-x wl で起動します。
  71. # /etc/emacs-??.?/site-start.d/55wl-init.el
  72. # /etc/xemacs-??.?.??/site-start.d/55wl-init.el
  73. アカウント毎の設定は、
  74. %{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.wl
  75. %{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.folders
  76. %{_defaultdocdir}/%{name}-%{origver}/samples/ja/dot.addresses
  77. をベースに、
  78. ~/.wl
  79. ~/.folders
  80. ~/.address
  81. を作成下さい。
  82. 詳しくは、Wanderlust の web ページ
  83. http://www.gohome.org/wl/
  84. を見て下さい。
  85. %prep
  86. rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
  87. %setup -q -n %{origname}-%{origver}
  88. %patch1 -p1
  89. #%patch10 -p1
  90. %patch11 -p1
  91. touch doc/*.texi
  92. %install
  93. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  94. [ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
  95. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc
  96. #mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/install
  97. #mkdir -p ${RPM_BUILD_ROOT}%{_libdir}/emacsen-common/packages/remove
  98. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/install
  99. mkdir -p ${RPM_BUILD_ROOT}%{emacsen_pkgdir}/remove
  100. mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
  101. #
  102. # install el files
  103. #
  104. cp -a WL-* Makefile wl %{SOURCE3} %{SOURCE4} \
  105. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  106. cp -a utils elmo \
  107. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  108. cp -a etc/icons \
  109. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}/etc/.
  110. # 2004.12.13 add Irokawa
  111. cp -a NEWS* \
  112. ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
  113. #
  114. # build & install info
  115. #
  116. make EMACS=emacs info
  117. make EMACS=emacs INFODIR=${RPM_BUILD_ROOT}%{_infodir} install-info
  118. #
  119. # install script( bytecompile el and install elc , remove )
  120. #
  121. %_installemacsenscript %{origname} %{SOURCE1}
  122. %_removeemacsenscript %{origname} %{SOURCE2}
  123. %post
  124. #
  125. # bytecompile and install
  126. #
  127. if [ "$1" = 2 ]; then
  128. %_emacsenPackageRemove %{origname}
  129. fi
  130. %_addemacsenlist %{origname}
  131. %_emacsenPackageInstall %{origname}
  132. /sbin/install-info %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
  133. --section="Message User Agent"
  134. /sbin/install-info %{_infodir}/wl.info.gz %{_infodir}/dir \
  135. --section="Message User Agent"
  136. %preun
  137. if [ "$1" = 0 ]; then
  138. %_emacsenPackageRemove %{origname}
  139. %_removeemacsenlist %{origname}
  140. /sbin/install-info --delete %{_infodir}/wl-ja.info.gz %{_infodir}/dir \
  141. --section="Message User Agent"
  142. /sbin/install-info --delete %{_infodir}/wl.info.gz %{_infodir}/dir \
  143. --section="Message User Agent"
  144. fi
  145. %clean
  146. [ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
  147. %files
  148. %defattr(-,root,root)
  149. %doc BUGS* COPYING* ChangeLog*
  150. %doc INSTALL* NEWS* README*
  151. %doc doc etc samples tests
  152. %{_datadir}/emacs/site-lisp/%{origname}/
  153. #%{_libdir}/emacsen-common/packages/install/%{origname}
  154. #%{_libdir}/emacsen-common/packages/remove/%{origname}
  155. %{emacsen_pkgdir}/install/%{origname}
  156. %{emacsen_pkgdir}/remove/%{origname}
  157. %{_infodir}/wl*.info*
  158. %changelog
  159. * Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-3
  160. - fixed wl-init.el
  161. * Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.14.0-2
  162. - added vine-default-wl.el
  163. - updated wl-install.sh for vine-default-wl.el
  164. * Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 2.14.0-1vl5
  165. - applied new versioning policy, spec in utf-8
  166. - added macro %%emacsen_pkgdir
  167. * Fri Dec 7 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl5
  168. - rebuild
  169. * Wed Jan 10 2007 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.14.0-0vl4
  170. - rebuild
  171. * Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl3
  172. - changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
  173. * Fri Sep 30 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl2
  174. - added Patch1 (wl-news.elc was not generated with emacs22)
  175. * Fri Apr 15 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.0-0vl1
  176. - updated to new upstream release 2.14.0
  177. * Sun Dec 26 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl1
  178. - updated to new upstream release 2.12.1
  179. * Mon Dec 13 2004 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.12.0-0vl0.pre
  180. - updated to new release canditate 2.12.0pre
  181. * Wed Dec 24 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.1-0vl2
  182. - increased release number for the new flim/semi release
  183. * Tue Jul 8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 2.10.1-0vl1
  184. - updated to new upstream release 2.10.1
  185. * Mon Jun 09 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl2
  186. - increased release number for the new apel release
  187. * Wed Dec 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl1
  188. - updated to new upstream release 2.10.0
  189. * Sat Dec 07 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl0.1
  190. - updated to new release canditate 2.10.0pre4
  191. * Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl3
  192. - Obsoletes: wl-el now, instead of Conflicts:
  193. - added %%triggerpostun -- wl-el
  194. * Fri Jan 11 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl2
  195. - added PreReq: w3m-el, for shimbun-guys will be happy :)
  196. * Fri Dec 28 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.8.1-0vl1
  197. - updated to new upstream release
  198. * Thu Dec 27 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl5
  199. - modified wl-install.sh to put pixmaps in a proper place even with emacs21
  200. * Sat Dec 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl4
  201. - modified wl-install.sh to put xemacs pixmaps in a proper place (AGAIN)
  202. * Fri Dec 07 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl3
  203. - spec file cleaned-up too much now
  204. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl2
  205. - modified wl-install.sh to put xemacs pixmaps in a proper place
  206. * Thu Dec 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.6.1-0vl1
  207. - updated to 2.6.1 stable release
  208. - the changelog was incorrect. now merged from original Wanderlust spec file
  209. * Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  210. - emacsenize
  211. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  212. - 2.6.0-0vl2
  213. - added patch to fix recursive load problem
  214. (see wl:07309, wl:07812)
  215. * Wed Jul 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  216. - 2.6.0-0vl1
  217. - updated to 2.6.0 stable release
  218. * Wed Feb 14 2001 MATSUBAYASHI 'Shaolin' Kohji
  219. - 2.4.1-0vl1
  220. - updated to 2.4.1 stable release
  221. - merge emacs/xemacs package again into one source rpm :-)
  222. * Fri Dec 01 2000 MATSUBAYASHI 'Shaolin' Kohji
  223. - 2.4.0-0vl1
  224. - updated to 2.4.0 stable release
  225. * Thu Nov 23 2000 MATSUBAYASHI 'Shaolin' Kohji
  226. - 2.4.0-0.3vl1
  227. - updated to 2.4.0pre3 release canditate
  228. * Wed Nov 15 2000 MATSUBAYASHI 'Shaolin' Kohji
  229. - 2.4.0-0.2vl1
  230. - updated to 2.4.0pre2 release canditate
  231. * Sun Nov 12 2000 MATSUBAYASHI 'Shaolin' Kohji
  232. - 2.4.0-0.1vl1
  233. - updated to 2.4.0pre release canditate
  234. * Fri Aug 25 2000 MATSUBAYASHI 'Shaolin' Kohji
  235. - 1.1.1-0vl3
  236. - modified %files section to handle compressed man page(s)
  237. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  238. - 1.1.1-0vl2
  239. - included a patch to fix Maildir-related problem
  240. (Thanks Teranishi-kun!)
  241. * Wed May 10 2000 MATSUBAYASHI 'Shaolin' Kohji
  242. - 1.1.1-0vl1
  243. - updated to 1.1.1 release
  244. * Mon Mar 27 2000 MATSUBAYASHI 'Shaolin' Kohji
  245. - 1.1.0-1vl2
  246. - added small patch by Mr. Yuuichi Teranishi himself :-)
  247. * Fri Mar 24 2000 MATSUBAYASHI 'Shaolin' Kohji
  248. - 1.1.0-1vl1
  249. - updated to 1.1.0 release
  250. - added a patch (see wl:04506)
  251. * Thu Mar 09 2000 MATSUBAYASHI 'Shaolin' Kohji
  252. - 1.1.0-0.3vl1
  253. - updated to 1.1.0pre3 release canditate
  254. * Fri Mar 03 2000 MATSUBAYASHI 'Shaolin' Kohji
  255. - 1.1.0-0.1vl1, 1.1.0-0.1vl2
  256. - updated to 1.1.0pre1 release canditate
  257. - added patches (see wl:04218, wl:04281)
  258. * Mon Feb 21 2000 MATSUBAYASHI 'Shaolin' Kohji
  259. - 2.2.18-1
  260. - updated to 2.2.18 beta release
  261. * Wed Jan 12 2000 MATSUBAYASHI 'Shaolin' Kohji
  262. - 2.2.15-1
  263. - updated to 2.2.15 beta release
  264. - included patches (see wl:03792, wl:03793)
  265. * Sat Jan 08 2000 MATSUBAYASHI 'Shaolin' Kohji
  266. - 2.2.14-1
  267. - updated to 2.2.14 beta release
  268. - included patches (see wl:03746, wl:03751)
  269. * Thu Jan 06 2000 MATSUBAYASHI 'Shaolin' Kohji
  270. - 2.2.13-2
  271. - included patches (see wl:03604, wl:03709, wl:03713, wl:03722)
  272. - fixed %install section to get wl be installed in proper directory
  273. * Tue Dec 28 1999 MATSUBAYASHI 'Shaolin' Kohji
  274. - 2.2.13-1
  275. - updated to 2.2.13 beta release
  276. - now utils are also installed
  277. - included a patch (see wl:03684)
  278. * Tue Dec 21 1999 MATSUBAYASHI 'Shaolin' Kohji
  279. - 2.2.12-3
  280. - included patches (see wl:03595, wl:03620, wl:03637, wl:03651)
  281. * Tue Dec 7 1999 MATSUBAYASHI 'Shaolin' Kohji
  282. - 2.2.12-2
  283. - updated to 2.2.12 beta release
  284. - included paches (see wl:03357, wl:03564)
  285. * Mon Dec 6 1999 MATSUBAYASHI 'Shaolin' Kohji
  286. - 2.2.11-1
  287. - updated to 2.2.11 beta release
  288. - included patches (see wl:03526, wl:03528)
  289. * Sat Dec 4 1999 MATSUBAYASHI 'Shaolin' Kohji
  290. - 2.2.10-2
  291. - included patches (see wl:03489, wl:03491)
  292. * Fri Dec 3 1999 MATSUBAYASHI 'Shaolin' Kohji
  293. - 2.2.10-1
  294. - udpated to 2.2.10 beta release
  295. - included patches (see wl:03480, wl:03484)
  296. * Mon Nov 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  297. - 2.2.8-1
  298. - udpated to 2.2.8 beta release for semi-1.13.7
  299. - included patches (see wl:03171, wl:03182)
  300. * Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji
  301. - 1.0.3-4
  302. - Obsolete: Wanderlust-mule added
  303. - %post and %preun section modified
  304. * Fri Oct 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  305. - 1.0.3-3
  306. - %post and %preun section added for install-info
  307. * Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji
  308. - 1.0.3-2
  309. - package name changed from Wanderlust-emacs to Wanderlust
  310. * Wed Sep 15 1999 MATSUBAYASHI 'Shaolin' Kohji
  311. - 1.0.3-1
  312. - first release for FSF Emacs 20.4