xsp-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. %define mono_dir %(/usr/bin/monodir)
  2. Summary: Small Web Server Hosting ASP.NET
  3. Summary(ja): ASP.NET を提供する小さなウェブサーバ
  4. Name: xsp
  5. URL: http://go-mono.com/
  6. License: GNU General Public License (GPL)
  7. Group: Applications/Internet
  8. #Autoreqprov: on
  9. Version: 2.6
  10. Release: 1%{?_dist_release}
  11. Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildArch: noarch
  14. BuildRequires: mono-devel mono-web
  15. BuildRequires: mono-data-sqlite mono-data-oracle mono-jscript mono-extras mono-nunit
  16. BuildRequires: pkgconfig
  17. # One of the test runs requires this
  18. BuildRequires: sqlite
  19. # This must be manually entered according to xsp's protocol version
  20. # Since this package is currently noarch, and mod_mono's name is different
  21. # on different distros, we can't use this... yet
  22. #Requires: mod_mono >= %{version}
  23. %description
  24. The XSP server is a small Web server that hosts the Mono System.Web
  25. classes for running what is commonly known as ASP.NET.
  26. %prep
  27. %setup -q
  28. %build
  29. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  30. # Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
  31. ./configure \
  32. --prefix=%{_prefix} \
  33. --libexecdir=%{_prefix}/lib \
  34. --libdir=%{_prefix}/lib \
  35. --mandir=%{_prefix}/share/man \
  36. --infodir=%{_prefix}/share/info \
  37. --sysconfdir=%{_sysconfdir}
  38. make
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
  42. make install DESTDIR=$RPM_BUILD_ROOT
  43. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
  44. mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
  45. %clean
  46. rm -rf $RPM_BUILD_ROOT
  47. %files
  48. %defattr(-,root,root)
  49. %doc NEWS README
  50. %{_bindir}/*
  51. %{_prefix}/lib/xsp
  52. %{mono_dir}/gac/Mono.WebServer
  53. %{mono_dir}/1.0/Mono.WebServer.dll
  54. %{mono_dir}/gac/Mono.WebServer2
  55. %{mono_dir}/2.0/Mono.WebServer2.dll
  56. %{mono_dir}/gac/xsp
  57. %{mono_dir}/1.0/xsp.exe
  58. %{mono_dir}/gac/xsp2
  59. %{mono_dir}/2.0/xsp2.exe
  60. %{mono_dir}/gac/mod-mono-server
  61. %{mono_dir}/1.0/mod-mono-server.exe
  62. %{mono_dir}/gac/mod-mono-server2
  63. %{mono_dir}/2.0/mod-mono-server2.exe
  64. %{mono_dir}/gac/fastcgi-mono-server
  65. %{mono_dir}/1.0/fastcgi-mono-server.exe
  66. %{mono_dir}/gac/fastcgi-mono-server2
  67. %{mono_dir}/2.0/fastcgi-mono-server2.exe
  68. %{_datadir}/pkgconfig/*
  69. %{_mandir}/*/*
  70. %changelog
  71. * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
  72. - updated to 2.6
  73. - rebuilt with new toolchain
  74. * Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
  75. - updated to 2.4.3
  76. * Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
  77. - changed Group to Applications/Internet
  78. * Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
  79. - updated to 2.4
  80. * Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
  81. - initial build for VineSeed
  82. - updated xsp to 2.0
  83. - added japanese summary
  84. - applied vine versioning policy
  85. - spec in utf-8
  86. * Tue Apr 22 2008 wberrier@suse.de
  87. - update to 1.9.1 (bugfix release)
  88. - Output date header (instead of asp.net doing it)
  89. * Tue Mar 25 2008 wberrier@suse.de
  90. - update to 1.9
  91. - minor test updates
  92. - BaseRequestBroker fix: Check if the request ID is valid inside
  93. the lock.
  94. * Mon Jan 14 2008 wberrier@suse.de
  95. - update to 1.2.6
  96. - FastCGI support
  97. * Thu Aug 30 2007 wberrier@suse.de
  98. - xsp_1.2.5_p5_final.patch: Fix for regression in the request
  99. broker
  100. * Fri Aug 17 2007 wberrier@suse.de
  101. - xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
  102. - bugs: 81699, 81906, 82379, 82057
  103. - fixes ability to handle large (GB) uploads (needed for iFolder)
  104. * Fri Aug 3 2007 wberrier@suse.de
  105. - Update to 1.2.5
  106. - More robust exception handling
  107. - Fixed permissions bits for non executable scripts
  108. - virtual host support
  109. - New Documentation for Mono.WebServer
  110. - Improved event handling
  111. * Tue Jun 5 2007 wberrier@novell.com
  112. - Remove unnecessary path defines (prefix, sysconfdir)
  113. - Update to 1.2.4
  114. - fix some race conditions and crashes
  115. - add tracing support
  116. * Fri Apr 13 2007 wberrier@novell.com
  117. - add %%debug_package so debug packages get created
  118. * Wed Apr 11 2007 wberrier@novell.com
  119. - Add mono dep/req for older distros
  120. * Thu Mar 1 2007 wberrier@suse.de
  121. - Update Update to 1.2.3
  122. - Bug fix #80230 (prevents possible nullref)
  123. - Support for response header encoding
  124. * Mon Jan 22 2007 ro@suse.de
  125. - drop requires for gnome-filesystem
  126. * Sat Dec 2 2006 wberrier@suse.de
  127. - Update to 1.2.1 (Fate #301111)
  128. - Bugfixes:
  129. - close the connection if there's an error reading the headers
  130. (including assembly loading exceptions due to a bad installation).
  131. - kill the warning that everyone is worried about.
  132. * Fri Oct 20 2006 wberrier@suse.de
  133. - Update to 1.1.18
  134. - 2.0 updates
  135. * Thu Oct 19 2006 wberrier@suse.de
  136. - Add mono-devel to fix bnc #213576 (missing provides)
  137. * Tue Sep 5 2006 wberrier@suse.de
  138. - Update to 1.1.17.1 bugfix release
  139. - Read from the stream, not the socket as the socket data is
  140. encrypted when using SSL.
  141. * Wed Aug 30 2006 wberrier@suse.de
  142. - Update to 1.1.17
  143. - Added support for X.509 client certificates
  144. - Update to handle newly created AppDomains
  145. * Mon Jul 31 2006 wberrier@suse.de
  146. - update to 1.1.16.1
  147. - better connection handling
  148. - fixes bugs: 77698,78034,78621
  149. * Tue Apr 25 2006 wberrier@suse.de
  150. - Security update (remove all the duplicated slashes
  151. and don't do an extra Replace on non-windows.) and minor fix for
  152. [#78034].
  153. * Wed Jan 25 2006 mls@suse.de
  154. - converted neededforbuild to BuildRequires
  155. * Fri Jan 6 2006 wberrier@suse.de
  156. - Update to 1.1.13, clean up deps
  157. * Thu Nov 10 2005 wberrier@suse.de
  158. - Update to 1.1.10, set libdir to lib/
  159. * Fri Oct 7 2005 wberrier@suse.de
  160. - Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
  161. libexec, so I disabled the patch)
  162. * Tue Jul 19 2005 sbrabec@suse.cz
  163. - Build as noarch (#81109).
  164. * Fri Jul 15 2005 sbrabec@suse.cz
  165. - Updated to version 1.0.9 (#96776).
  166. * Mon Feb 21 2005 clahey@suse.de
  167. - Updated to 1.0.6.
  168. * Sun Feb 6 2005 ro@suse.de
  169. - use /usr/lib/mono
  170. * Mon Dec 13 2004 clahey@suse.de
  171. - New package.