unixODBC-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. Name: unixODBC
  2. Version: 2.3.7
  3. Release: 1%{?_dist_release}
  4. Summary: A complete ODBC Driver Manager for Linux
  5. Summary(ja): Linux 用 ODBC ドライバマネージャー
  6. Group: System Environment/Libraries
  7. # Programs are GPL, libraries are LGPL, except News Server library is GPL.
  8. License: GPLv2+ and LGPLv2+
  9. URL: http://www.unixODBC.org/
  10. Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
  11. Source1: odbcinst.ini
  12. Source4: conffile.h
  13. Source5: README.dist
  14. Patch8: so-version-bump.patch
  15. Patch9: keep-typedefs.patch
  16. Conflicts: iodbc
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
  19. BuildRequires: readline-devel
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. Install unixODBC if you want to access databases through ODBC.
  24. You will also need the mysql-connector-odbc package if you want to access
  25. a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
  26. %package devel
  27. Summary: Development files for programs which will use the unixODBC library.
  28. Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The unixODBC package can be used to access databases through ODBC
  33. drivers. If you want to develop programs that will access data through
  34. ODBC, you need to install this package.
  35. %prep
  36. %setup -q
  37. %patch8 -p1
  38. %patch9 -p1
  39. chmod 0644 Drivers/MiniSQL/*.c
  40. chmod 0644 Drivers/nn/*.c
  41. chmod 0644 Drivers/template/*.c
  42. chmod 0644 doc/ProgrammerManual/Tutorial/*.html
  43. chmod 0644 doc/lst/*
  44. chmod 0644 include/odbcinst.h
  45. %build
  46. autoreconf -ivf
  47. # unixODBC 2.2.14 is not aliasing-safe
  48. CFLAGS="%{optflags} -fno-strict-aliasing"
  49. CXXFLAGS="$CFLAGS"
  50. export CFLAGS CXXFLAGS
  51. %configure --with-gnu-ld=yes --enable-threads=yes \
  52. --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
  53. # Get rid of the rpaths
  54. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  55. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  56. make all
  57. %install
  58. rm -rf $RPM_BUILD_ROOT
  59. make DESTDIR=$RPM_BUILD_ROOT install
  60. install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
  61. # multilib header hacks
  62. # we only apply this to known Red Hat multilib arches, per bug #181335
  63. case `uname -i` in
  64. i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
  65. mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
  66. rm -f unixodbc_conf.h
  67. sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
  68. install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
  69. ;;
  70. *)
  71. ;;
  72. esac
  73. # add some explanatory documentation
  74. cp %{SOURCE5} README.dist
  75. # remove obsolete Postgres drivers from the package (but not the setup code)
  76. rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
  77. # copy text driver documentation into main doc directory
  78. # currently disabled because upstream no longer includes text driver
  79. # mkdir -p doc/Drivers/txt
  80. # cp -pr Drivers/txt/doc/* doc/Drivers/txt
  81. # don't want to install doc Makefiles as docs
  82. find doc -name 'Makefile*' | xargs rm
  83. # we do not want to ship static libraries
  84. rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
  85. # remove unpackaged files from the buildroot
  86. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
  88. rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
  89. # initialize lists of .so files
  90. find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
  91. find $RPM_BUILD_ROOT%{_libdir} -name "*.so" | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
  92. # move these to main package, they're often dlopened...
  93. for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
  94. do
  95. echo "%{_libdir}/$lib" >> base-so-list
  96. grep -v "/$lib$" devel-so-list > devel-so-list.x
  97. mv -f devel-so-list.x devel-so-list
  98. done
  99. %clean
  100. rm -rf $RPM_BUILD_ROOT
  101. %post -p /sbin/ldconfig
  102. %postun -p /sbin/ldconfig
  103. %files -f base-so-list
  104. %doc README COPYING AUTHORS ChangeLog NEWS doc
  105. %doc README.dist
  106. %config(noreplace) %{_sysconfdir}/odbc*
  107. %{_bindir}/odbcinst
  108. %{_bindir}/isql
  109. %{_bindir}/dltest
  110. %{_bindir}/iusql
  111. %{_bindir}/odbc_config
  112. %{_bindir}/slencheck
  113. %{_mandir}/man*/*
  114. %files devel -f devel-so-list
  115. %{_includedir}/*
  116. %{_libdir}/pkgconfig/*.pc
  117. %changelog
  118. * Wed Dec 12 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.7-1
  119. - new upstream release.
  120. - dropped Patch6: fixed in upstream.
  121. * Sat Jan 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.5-1
  122. - new upstream release.
  123. * Tue Jan 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
  124. - new upstream release.
  125. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
  126. - rebuilt with readline 6.3
  127. - removed kde-subpackage-related BuildRequires
  128. - added Japanese summary
  129. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
  130. - new upstream release.
  131. - gui was discontinued in upstream.
  132. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
  133. - rebuild with VineSeed environment
  134. * Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
  135. - add --with-qt-includes option for configure
  136. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
  137. - updated to 2.2.14
  138. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
  139. - applied new versioning policy
  140. - removed *.la files from devel package
  141. * Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
  142. - updated to 2.2.12
  143. - rebuilt with new toolchain
  144. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
  145. - use installed libltdl
  146. - added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
  147. * Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
  148. - rebuilt with readline 5.1
  149. * Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
  150. - updated to 2.2.11
  151. - not libtoolize
  152. * Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
  153. - added Patch100 to fix typo in doc/Makefile.am from failure on compiling
  154. * Fri Jun 6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
  155. - source upgrade
  156. - remove patch (no need)
  157. - run libtoolize etc for VineSeed
  158. * Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
  159. - enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
  160. * Sun Feb 9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
  161. - source upgrade
  162. - change spec to build both VineSeed and Vine2.5/2.6
  163. - add patch from rawhide 2.2.3-6
  164. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
  165. - Requires: libjpeg (not libjpeg-6b)
  166. * Sun Oct 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
  167. - source upgrade
  168. - add BuildPrereq: autoconf253 automake15
  169. - add PreReq: ldconfig
  170. - fix %files section and clean up spec
  171. - for unixODBC-kde package
  172. - add Requires: unixODBC = %{version}
  173. - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
  174. - delete .desktop files
  175. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
  176. - rebuild with KDE3
  177. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
  178. - updated unixODBC-2.2.0
  179. - fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
  180. * Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
  181. - remove -kde package on alpha
  182. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
  183. - Rebuild for Vine.
  184. * Sun Jun 24 2001 Than Ngo <than@redhat.com>
  185. - rebuild against qt-2.3.1, kde-2.1.x
  186. * Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
  187. - Better default odbcinst.ini
  188. - Minor cleanups
  189. * Wed Jun 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
  190. - 2.0.7
  191. * Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
  192. - Fix for isql segfault on EOF/ctrl-d exit
  193. * Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  194. - 2.0.6
  195. - add patch for 64 bit archs (dword shouldn't be "long int")
  196. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  197. - rebuild
  198. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  199. - 1.8.13
  200. * Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
  201. - enable GUI now that we have KDE compiled with the standard
  202. compiler
  203. - move the applnk entries to the KDE package
  204. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  205. - add the missing shared libs to the non-devel package
  206. * Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
  207. - 1.8.12 fixes problems with the postgresql driver
  208. * Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
  209. - disable KDE subpackage to avoid the mess that is C++ binary
  210. compatibility
  211. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  212. - automatic rebuild
  213. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
  214. - improved QTDIR detection
  215. * Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  216. - 1.8.10
  217. - use %%{_tmppath}
  218. - update URL
  219. - including two missing libraries
  220. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  221. - 1.8.9
  222. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  223. - adopted for Winston, changed to Red Hat packaging standards
  224. * Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
  225. - added a unixODBC-devel RPM to the group, added KDE links and icons to system
  226. - all of which came from recommendations from Fredrick Meunier
  227. - <Fredrick.Meunier@computershare.com.au>
  228. * Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
  229. - unixODBC-1.8.7
  230. - moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.