thunderbird-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661
  1. # do not include minor version number in MOZILLA_FIVE_HOME
  2. %define tbmajor 2.0
  3. %define tbversion %{tbmajor}.0.23
  4. %define tbdir %{_libdir}/thunderbird-%{tbmajor}
  5. %define build_vineseed 0
  6. %define build_vine4 0
  7. %define build_vine3 0
  8. %if "%{?_dist_release}" == "vl5"
  9. %define build_vineseed 1
  10. %endif
  11. %if "%{?_dist_release}" == "vl4"
  12. %define build_vine4 1
  13. %endif
  14. %if "%{?_dist_release}" == "vl3"
  15. %define build_vine3 1
  16. %endif
  17. %define tbrelease 1%{?_dist_release}
  18. # Temporary until this works again
  19. ExcludeArch: ppc64
  20. %define desktop_file_utils_version 0.6
  21. %define cairo_version 1.0
  22. %define nspr_version 4.6.7
  23. %define nss_version 3.11.5
  24. Summary: Thunderbird Community Edition, Mail/newsgroup client
  25. Summary(ja): Thunderbirdコミュニティエディション, メール・ニュースクライアント
  26. Name: thunderbird
  27. Version: %{tbversion}
  28. Release: %{tbrelease}
  29. URL: http://www.mozilla.org/projects/thunderbird/
  30. License: MPL
  31. Group: Applications/Internet
  32. Source0: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/%{tbversion}/source/thunderbird-%{version}-source.tar.bz2
  33. Source1010: mozconfig-thunderbird-vine3
  34. Source1020: mozconfig-thunderbird-vine4
  35. Source1030: mozconfig-thunderbird-vine5
  36. Source12: thunderbird-vine-default-prefs.js
  37. Source20: thunderbird.desktop
  38. Source21: thunderbird.vine.sh.in
  39. Source22: thunderbird.png
  40. Source30: thunderbird-open-browser.sh
  41. Source100: find-external-requires
  42. # locale sources
  43. %define MOZ_BUILD_LOCALES "ja"
  44. Source1000: thunderbird-2.0.0.0-ja.tar.bz2
  45. # upstream patch
  46. # build patches
  47. Patch1: firefox-2.0-link-layout.patch
  48. # customization patches
  49. Patch22: firefox-1.0-psfonts.patch
  50. Patch24: thunderbird-2.0-default-applications.patch
  51. Patch25: thunderbird-1.1-software-update.patch
  52. Patch26: firefox-1.5-default-a4-paper.patch
  53. # font system fixes
  54. #Patch81: firefox-nopangoxft.patch
  55. ## Vine patch
  56. # http://bugzilla.mozilla.org/show_bug.cgi?id=179248
  57. Patch1000: firefox-1.5-sjisalias.patch
  58. # use /proc/net/netstat for random seed instead of netstat command.
  59. #Patch1010: firefox-nss-no_netstat.patch
  60. # workaround gcc visibility hidden bugs (see gcc#26905)
  61. Patch1020: firefox-2.0.0.3-visibility.patch
  62. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  63. %if !%{build_vine3}
  64. BuildRequires: pango-devel
  65. BuildRequires: cairo-devel >= %{cairo_version}
  66. %if !%{build_vine4}
  67. BuildRequires: nspr-devel >= %{nspr_version}
  68. BuildRequires: nss-devel >= %{nss_version}
  69. BuildRequires: pixman-devel
  70. %endif
  71. %endif
  72. BuildRequires: libpng-devel, libjpeg-devel, gtk2-devel
  73. BuildRequires: zlib-devel, gzip, zip, unzip
  74. BuildRequires: libIDL-devel
  75. BuildRequires: tcsh
  76. BuildRequires: freetype2-devel
  77. Prereq: desktop-file-utils >= %{desktop_file_utils_version}
  78. %if %{build_vineseed}
  79. Requires: nspr >= %{nspr_version}
  80. Requires: nss >= %{nss_version}
  81. %endif
  82. Obsoletes: MozillaThunderbird
  83. Provides: MozillaThunderbird = %{version}
  84. Packager: daisuke, ryoichi, kazutaka
  85. AutoProv: 0
  86. %define _use_internal_dependency_generator 0
  87. %define __find_requires %{SOURCE100}
  88. %description
  89. Thunderbird is a standalone mail and newsgroup client.
  90. %description -l ja
  91. Thunderbird はスタンドアローンのメールおよびニュースクライアントです。
  92. #===============================================================================
  93. %prep
  94. %setup -q -n %{name}-%{version} -c -b 1000
  95. cd mozilla
  96. %patch1 -p1 -b .link-layout
  97. %patch22 -p1
  98. %patch24 -p1
  99. #%patch25 -p0
  100. %patch26 -p1
  101. #%if !%{build_vine3}
  102. #%patch81 -p1
  103. #%endif
  104. %patch1000 -p0
  105. #%patch1010 -p1
  106. #patch1020 -p1
  107. %{__rm} -f .mozconfig
  108. %if %{build_vine3}
  109. %{__cp} %{SOURCE1010} .mozconfig
  110. %endif
  111. %if %{build_vine4}
  112. %{__cp} %{SOURCE1020} .mozconfig
  113. %endif
  114. %if %{build_vineseed}
  115. %{__cp} %{SOURCE1030} .mozconfig
  116. %endif
  117. #===============================================================================
  118. %build
  119. cd mozilla
  120. autoconf-2.13
  121. #MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-O2/-Os/' -e 's/-Wall//')
  122. MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %__sed -e 's/-Wall//')
  123. export RPM_OPT_FLAGS=$MOZ_OPT_FLAGS
  124. export CFLAGS="$RPM_OPT_FLAGS"
  125. export CXXFLAGS="$CFLAGS"
  126. export BUILD_OFFICIAL=1
  127. export MOZILLA_OFFICIAL=1
  128. %ifarch ppc ppc64 s390 s390x
  129. %define moz_mflags -j1
  130. %else
  131. %define moz_mflags %{?_smp_mflags}
  132. %endif
  133. export LDFLAGS="-Wl,-rpath,%{ffdir}"
  134. export MAKE="gmake %{moz_mflags}"
  135. %__make -f client.mk build
  136. # build locales
  137. LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
  138. sed -e 's|\./\(.*\)/locales/.*|\1|g'`
  139. for dir in $LOCALEDIRS
  140. do
  141. for lang in %{MOZ_BUILD_LOCALES} ; do
  142. make -C $dir/locales AB_CD=$lang
  143. done
  144. done
  145. #===============================================================================
  146. %install
  147. cd mozilla
  148. %{__rm} -rf $RPM_BUILD_ROOT
  149. cd xpinstall/packager/
  150. %{__make} STRIP=/bin/true
  151. cd -
  152. %{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
  153. %{__tar} -C $RPM_BUILD_ROOT%{_libdir}/ -xzf dist/%{name}-*linux*.tar.gz
  154. %{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name} $RPM_BUILD_ROOT%{tbdir}
  155. %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}-*linux*.tar
  156. %{__install} -p -D %{SOURCE22} $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{name}.png
  157. desktop-file-install --vendor vine \
  158. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  159. --add-category Application \
  160. --add-category Network \
  161. %{SOURCE20}
  162. # set up the thunderbird start script
  163. %{__cat} %{SOURCE21} | %{__sed} -e 's,TBDIR,%{tbdir},g' > \
  164. $RPM_BUILD_ROOT%{_bindir}/thunderbird
  165. %{__chmod} 755 $RPM_BUILD_ROOT/%{_bindir}/thunderbird
  166. install -m755 %{SOURCE30} $RPM_BUILD_ROOT/%{tbdir}/open-browser.sh
  167. perl -pi -e 's|LIBDIR|%{_libdir}|g' $RPM_BUILD_ROOT/%{tbdir}/open-browser.sh
  168. %{__cat} %{SOURCE12} | %{__sed} -e 's,THUNDERBIRD_RPM_VR,%{version}-%{release},g' \
  169. -e 's,COMMAND,%{tbdir}/open-browser.sh,g' > \
  170. $RPM_BUILD_ROOT/vine-default-prefs
  171. %{__cp} $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{tbdir}/greprefs/all-vine.js
  172. %{__cp} $RPM_BUILD_ROOT/vine-default-prefs $RPM_BUILD_ROOT/%{tbdir}/defaults/pref/all-vine.js
  173. %{__rm} $RPM_BUILD_ROOT/vine-default-prefs
  174. # own mozilla plugin dir (#135050)
  175. %{__mkdir_p} $RPM_BUILD_ROOT%{_libdir}/mozilla/plugins
  176. %{__rm} -f $RPM_BUILD_ROOT%{tbdir}/thunderbird-config
  177. cd $RPM_BUILD_ROOT%{tbdir}/chrome
  178. find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf \{\} \;
  179. cd -
  180. # install locales
  181. for lang in %{MOZ_BUILD_LOCALES} ; do
  182. %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT%{tbdir}/chrome/
  183. done
  184. # install default icons
  185. # refer https://bugzilla.redhat.com/show_bug.cgi?id=177823
  186. %{__mkdir_p} $RPM_BUILD_ROOT%{tbdir}/chrome/icons/default
  187. install -m644 dist/thunderbird/chrome/icons/default/* \
  188. $RPM_BUILD_ROOT%{tbdir}/chrome/icons/default/
  189. %clean
  190. %{__rm} -rf $RPM_BUILD_ROOT
  191. %post
  192. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  193. %postun
  194. update-desktop-database %{_datadir}/applications >& /dev/null ||:
  195. %files
  196. %defattr(-,root,root,-)
  197. %attr(755,root,root) %{_bindir}/thunderbird
  198. %attr(644,root,root) %{_datadir}/applications/vine-thunderbird.desktop
  199. %attr(644,root,root) %{_datadir}/pixmaps/thunderbird.png
  200. %{tbdir}
  201. #===============================================================================
  202. %changelog
  203. * Sun Aug 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.23-1
  204. - new upstream release
  205. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.22-1
  206. - new upstream release
  207. * Wed May 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.21-3
  208. - don't install official branding logos
  209. * Mon May 04 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-2
  210. - add necessary icons in %%{tbdir}/chrome/icons/default
  211. - add Packager tag
  212. * Fri Mar 20 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.21-1
  213. - new upstream release
  214. * Sun Jan 25 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.0.0.19-1
  215. - new upstream release
  216. * Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.18-1
  217. - new upstream release
  218. * Wed Apr 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.14-1
  219. - new upstream release
  220. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl2
  221. - rebuilt for VineSeed
  222. * Sun Aug 5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.6-0vl1
  223. - new upstream release
  224. * Sat Jul 21 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0.5-0vl1
  225. - new upstream release
  226. - built for Vine Linux 4.x
  227. - dropped Patch1020 (merged into upstream)
  228. * Sun May 20 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0.0-0vl4
  229. - added Patch1020 for workaround gcc visibility hidden bugs
  230. * Sat May 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl3
  231. - build with new environment/toolchain
  232. - add build options to build with external nss/nspr libraries
  233. ac_add_options --with-system-nspr
  234. ac_add_options --with-system-nss
  235. * Mon Apr 23 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0.0-0vl2
  236. - new upstream release
  237. * Mon Oct 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.7-0vl2
  238. - new upstream release
  239. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.5-0vl2
  240. - new upstream release
  241. * Fri Jun 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.4-0vl1
  242. - new upstream release
  243. * Fri Apr 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.0.2-0vl1
  244. - new upstream release
  245. - merge changes from firefox
  246. - use thunderbird-1.5 for MOZILLA_FIVE_HOME instead of thunderbird-1.5.0.2
  247. * Tue Mar 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl2
  248. - new upstream release
  249. - build en-US locale
  250. - merge changes from firefox
  251. - add upstream patches
  252. - disable pango rendering by default
  253. (workaround fix slow rendering in some page)
  254. * Thu Dec 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-0vl0.rc2
  255. - initial build for Vine Linux based on FC package
  256. - update to 1.5RC2
  257. * Mon Nov 28 2005 Christopher Aillon <caillon@redhat.com> - 1.5-0.5.1.rc1
  258. - Fix issue with popup dialogs and other actions causing lockups
  259. * Sat Nov 5 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.rc1
  260. - Update to 1.5 rc1
  261. * Sat Oct 8 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta2
  262. - Update to 1.5 beta2
  263. * Wed Sep 28 2005 Christopher Aillon <caillon@redhat.com> 1.5-0.5.0.beta1
  264. - Update to 1.5 beta1
  265. - Bring the install phase of the spec file up to speed
  266. * Sun Aug 14 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-4
  267. - Rebuild
  268. * Sat Aug 6 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-3
  269. - Add patch to make file chooser dialog modal
  270. * Fri Jul 22 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-2
  271. - Update to 1.0.6
  272. * Mon Jul 18 2005 Christopher Aillon <caillon@redhat.com> 1.0.6-0.1.fc5
  273. - 1.0.6 Release Candidate
  274. * Fri Jul 15 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-8
  275. - Use system NSPR
  276. - Fix crash on 64bit platforms (#160330)
  277. * Thu Jun 23 2005 Kristian H淡gsberg <krh@redhat.com> 1.0.2-7
  278. - Add firefox-1.0-pango-cairo.patch to get rid of the last few Xft
  279. references, fixing the "no fonts" problem.
  280. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-6
  281. - Change the Exec line in the desktop file to `thunderbird`
  282. * Fri May 13 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-5
  283. - Update pango patche, MOZ_DISABLE_PANGO now works as advertised.
  284. * Mon May 9 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-4
  285. - Add temporary workaround to not create files in the user's $HOME (#149664)
  286. * Wed May 4 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-3
  287. - Don't have downloads "disappear" when downloading to desktop (#139015)
  288. - Fix for some more cursor issues in textareas (149991, 150002, 152089)
  289. - Add upstream patch to fix bidi justification of pango
  290. - Add patch to fix launching of helper applications
  291. - Add patch to properly link against libgfxshared_s.a
  292. - Fix multilib conflicts
  293. * Wed Apr 27 2005 Warren Togami <wtogami@redhat.com>
  294. - correct confusing PANGO vars in startup script
  295. * Wed Mar 23 2005 Christopher Aillon <caillon@redhat.com> 1.0.2-1
  296. - Thunderbird 1.0.2
  297. * Tue Mar 8 2005 Christopher Aillon <caillon@redhat.com> 1.0-5
  298. - Add patch to compile against new fortified glibc macros
  299. * Sat Mar 5 2005 Christopher Aillon <caillon@redhat.com> 1.0-4
  300. - Rebuild against GCC 4.0
  301. - Add execshield patches
  302. - Minor specfile cleanup
  303. * Mon Dec 20 2004 Christopher Aillon <caillon@redhat.com> 1.0-3
  304. - Rebuild
  305. * Thu Dec 16 2004 Christopher Aillon <caillon@redhat.com> 1.0-2
  306. - Add RPM version to useragent
  307. * Thu Dec 16 2004 Christopher Blizzard <blizzard@redhat.com>
  308. - Port over pango patches from firefox
  309. * Wed Dec 8 2004 Christopher Aillon <caillon@redhat.com> 1.0-1
  310. - Thunderbird 1.0
  311. * Mon Dec 6 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.1
  312. - Fix advanced prefs
  313. * Fri Dec 3 2004 Christopher Aillon <caillon@redhat.com>
  314. - Make this run on s390(x) now for real
  315. * Wed Dec 1 2004 Christopher Aillon <caillon@redhat.com> 1.0-0.rc1.0
  316. - Update to 1.0 rc1
  317. * Fri Nov 19 2004 Christopher Aillon <caillon@redhat.com>
  318. - Add patches to build and run on s390(x)
  319. * Thu Nov 11 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-2
  320. - Rebuild to fix file chooser
  321. * Fri Nov 5 2004 Christopher Aillon <caillon@redhat.com> 0.9.0-1
  322. - Update to 0.9
  323. * Fri Oct 22 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-10
  324. - Prevent inlining of stack direction detection (#135255)
  325. * Tue Oct 19 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-9
  326. - More file chooser fixes (same as in firefox)
  327. - Fix for upstream 28327.
  328. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  329. - Update the pango patch
  330. * Mon Oct 18 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-8
  331. - Pull over patches from firefox build:
  332. - disable default application dialog
  333. - don't include software update since it doesn't work
  334. - make external app support work
  335. * Thu Oct 14 2004 Christopher Blizzard <blizzard@redhat.com> 0.8.0-7
  336. - Use pango for rendering
  337. * Tue Oct 12 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-6
  338. - Fix for 64 bit crash at startup (b.m.o #256603)
  339. * Sat Oct 9 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-5
  340. - Add patches to fix xremote (#135036)
  341. * Fri Oct 8 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-4
  342. - Add patch to fix button focus issues (#133507)
  343. - Add patch for fix IMAP race issues (bmo #246439)
  344. * Fri Oct 1 2004 Bill Nottingham <notting@redhat.com> 0.8.0-3
  345. - filter out library Provides: and internal Requires:
  346. * Tue Sep 28 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-2
  347. - Backport the GTK+ File Chooser.
  348. - Add fix for JS math on x86_64 systems
  349. - Add pkgconfig patch
  350. * Thu Sep 16 2004 Christopher Aillon <caillon@redhat.com> 0.8.0-1
  351. - Update to 0.8.0
  352. - Remove enigmail
  353. - Update BuildRequires
  354. - Remove gcc34 and extension manager patches -- they are upstreamed.
  355. - Fix for gnome-vfs2 error at component registration
  356. * Fri Sep 03 2004 Christopher Aillon <caillon@redhat.com> 0.7.3-5
  357. - Build with --disable-xprint
  358. * Wed Sep 01 2004 David Hill <djh[at]ii.net> 0.7.3-4
  359. - remove all Xvfb-related hacks
  360. * Wed Sep 01 2004 Warren Togami <wtogami@redhat.com>
  361. - actually apply psfonts
  362. - add mozilla gnome-uriloader patch to prevent build failure
  363. * Tue Aug 31 2004 Warren Togami <wtogami@redhat.com> 0.7.3-3
  364. - rawhide import
  365. - apply NetBSD's freetype 2.1.8 patch
  366. - apply psfonts patch
  367. - remove BR on /usr/bin/ex, breaks beehive
  368. * Tue Aug 31 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.2
  369. - oops, fix %%install
  370. * Thu Aug 26 2004 David Hill <djh[at]ii.net> 0.7.3-0.fdr.1
  371. - update to Thunderbird 0.7.3 and Enigmail 0.85.0
  372. - remove XUL.mfasl on startup, add Debian enigmail patches
  373. - add Xvfb hack for -install-global-extension
  374. * Wed Jul 14 2004 David Hill <djh[at]ii.net> 0.7.2-0.fdr.0
  375. - update to 0.7.2, just because it's there
  376. - update gcc-3.4 patch (Kaj Niemi)
  377. - add EM registration patch and remove instdir hack
  378. * Sun Jul 04 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.1
  379. - re-add Enigmime 1.0.7, omit Enigmail until the Mozilla EM problems are fixed
  380. * Wed Jun 30 2004 David Hill <djh[at]ii.net> 0.7.1-0.fdr.0
  381. - update to 0.7.1
  382. - remove Enigmail
  383. * Mon Jun 28 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.1
  384. - re-enable Enigmail 0.84.1
  385. - add gcc-3.4 patch (Kaj Niemi)
  386. - use official branding (with permission)
  387. * Fri Jun 18 2004 David Hill <djh[at]ii.net> 0.7-0.fdr.0
  388. - update to 0.7
  389. - temporarily disable Enigmail 0.84.1, make ftp links work (#1634)
  390. - specify libdir, change BR for apt (V. Skytt辰, #1617)
  391. * Tue May 18 2004 Warren Togami <wtogami@redhat.com> 0.6-0.fdr.5
  392. - temporary workaround for enigmail skin "modern" bug
  393. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.4
  394. - update to Enigmail 0.84.0
  395. - update launch script
  396. * Mon May 10 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.3
  397. - installation directory now versioned
  398. - allow root to run the program (for installing extensions)
  399. - remove unnecessary %%pre and %%post
  400. - remove separators, update mozconfig and launch script (M. Schwendt, #1460)
  401. * Wed May 05 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.2
  402. - include Enigmail, re-add release notes
  403. - delete %{_libdir}/thunderbird in %%pre
  404. * Mon May 03 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.1
  405. - update to Thunderbird 0.6
  406. * Fri Apr 30 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.rc1
  407. - update to Thunderbird 0.6 RC1
  408. - add new icon, remove release notes
  409. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.6-0.fdr.0.20040415
  410. - update to latest CVS, update mozconfig and %%build accordingly
  411. - update to Enigmail 0.83.6
  412. - remove x-remote and x86_64 patches
  413. - build with -Os
  414. * Thu Apr 15 2004 David Hill <djh[at]ii.net> 0.5-0.fdr.12
  415. - update x-remote patch
  416. - more startup script fixes
  417. * Tue Apr 06 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.11
  418. - startup script fixes, and a minor cleanup
  419. * Sun Apr 04 2004 Warren Togami <wtogami@redhat.com> 0:0.5-0.fdr.10
  420. - Minor cleanups
  421. * Sun Apr 04 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.8
  422. - minor improvements to open-browser.sh and startup script
  423. - update to latest version of Blizzard's x-remote patch
  424. * Thu Mar 25 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.7
  425. - update open-browser.sh, startup script, and BuildRequires
  426. * Sun Mar 14 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.6
  427. - update open-browser script, modify BuildRequires (Warren)
  428. - add Blizzard's x-remote patch
  429. - initial attempt at x-remote-enabled startup script
  430. * Sun Mar 07 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.5
  431. - refuse to run with excessive privileges
  432. * Fri Feb 27 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.4
  433. - add Mozilla x86_64 patch (Oliver Sontag)
  434. - Enigmail source filenames now include the version
  435. - modify BuildRoot
  436. * Thu Feb 26 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.3
  437. - use the updated official tarball
  438. * Wed Feb 18 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.2
  439. - fix %%prep script
  440. * Mon Feb 16 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.1
  441. - update Enigmail to 0.83.3
  442. - use official source tarball (after removing the CRLFs)
  443. - package renamed to thunderbird
  444. * Mon Feb 09 2004 David Hill <djh[at]ii.net> 0:0.5-0.fdr.0
  445. - update to 0.5
  446. - check for lockfile before launching
  447. * Fri Feb 06 2004 David Hill <djh[at]ii.net>
  448. - update to latest cvs
  449. - update to Enigmail 0.83.2
  450. * Thu Jan 29 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.5
  451. - update to Enigmail 0.83.1
  452. - removed Mozilla/Firebird script patching
  453. * Sat Jan 03 2004 David Hill <djh[at]ii.net> 0:0.4-0.fdr.4
  454. - add startup notification to .desktop file
  455. * Thu Dec 25 2003 Warren Togami <warren@togami.com> 0:0.4-0.fdr.3
  456. - open-browser.sh release 3
  457. - patch broken /usr/bin/mozilla script during install
  458. - dir ownership
  459. - XXX: Source fails build on x86_64... fix later
  460. * Tue Dec 23 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.2
  461. - update to Enigmail 0.82.5
  462. - add Warren's open-browser.sh (#1113)
  463. * Tue Dec 09 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.1
  464. - use Thunderbird's mozilla-xremote-client to launch browser
  465. * Sun Dec 07 2003 David Hill <djh[at]ii.net> 0:0.4-0.fdr.0
  466. - update to 0.4
  467. - make hyperlinks work (with recent versions of Firebird/Mozilla)
  468. * Thu Dec 04 2003 David Hill <djh[at]ii.net>
  469. - update to 0.4rc2
  470. * Wed Dec 03 2003 David Hill <djh[at]ii.net>
  471. - update to 0.4rc1 and Enigmail 0.82.4
  472. * Thu Nov 27 2003 David Hill <djh[at]ii.net>
  473. - update to latest CVS and Enigmail 0.82.3
  474. * Sun Nov 16 2003 David Hill <djh[at]ii.net>
  475. - update to latest CVS (0.4a)
  476. - update Enigmail to 0.82.2
  477. - alter mozconfig for new build requirements
  478. - add missing BuildReq (#987)
  479. * Thu Oct 16 2003 David Hill <djh[at]ii.net> 0:0.3-0.fdr.0
  480. - update to 0.3
  481. * Sun Oct 12 2003 David Hill <djh[at]ii.net> 0:0.3rc3-0.fdr.0
  482. - update to 0.3rc3
  483. - update Enigmail to 0.81.7
  484. * Thu Oct 02 2003 David Hill <djh[at]ii.net> 0:0.3rc2-0.fdr.0
  485. - update to 0.3rc2
  486. * Wed Sep 17 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.2
  487. - simplify startup script
  488. * Wed Sep 10 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.1
  489. - add GPG support (Enigmail 0.81.6)
  490. - specfile fixes (#679)
  491. * Thu Sep 04 2003 David Hill <djh[at]ii.net> 0:0.2-0.fdr.0
  492. - update to 0.2
  493. * Mon Sep 01 2003 David Hill <djh[at]ii.net>
  494. - initial RPM
  495. (based on the fedora MozillaFirebird-0.6.1 specfile)