totem-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.24.0
  5. %define _gtk_ver 2.20.0
  6. %define _gnomeicon_ver 2.30.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.2.24
  9. %define _gst_ver 0.10.29
  10. %define _gstpb_ver 0.10.29
  11. %define _gstpg_ver 0.10.22
  12. %define _xulrunner_ver 1.9
  13. %define _nautilus_ver 2.26.0
  14. %define _shared_mime_info_ver 0.17
  15. %define _unique_ver 1.0
  16. %define _vala_ver 0.7.5
  17. %define _totem_pl_parser_ver 2.30.0
  18. %define _libgdata_ver 0.6.4
  19. %define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
  20. %define mozplug_dir %{_libdir}/mozilla/plugins
  21. Summary: Movie player for GNOME 2
  22. Summary(ja): GNOME2 用動画プレイヤー
  23. Name: totem
  24. Version: 2.30.1
  25. Release: 3%{?_dist_release}
  26. License: GPL
  27. Group: Applications/Multimedia
  28. URL: http://www.gnome.org/projects/totem/
  29. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/2.30/totem-%{version}.tar.bz2
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. BuildRequires: gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  34. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  35. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  36. BuildRequires: dbus-devel >= %{_dbus_ver}
  37. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  38. BuildRequires: gettext, scrollkeeper
  39. BuildRequires: perl-XML-Parser
  40. BuildRequires: iso-codes
  41. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  42. BuildRequires: bluez-libs-devel >= 4.15
  43. BuildRequires: lirc
  44. BuildRequires: unique-devel >= %{_unique_ver}
  45. BuildRequires: vala-devel >= %{_vala_ver}
  46. BuildRequires: python-devel
  47. BuildRequires: pygtk2-devel
  48. BuildRequires: libgdata-devel >= %{_libgdata_ver}
  49. BuildRequires: gstreamer-devel >= %{_gst_ver}
  50. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb_ver}
  51. BuildRequires: gstreamer-plugins-good >= %{_gstpg_ver}
  52. %if %{build_plugin}
  53. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  54. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  55. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  56. %endif
  57. Requires: gstreamer >= %{_gst_ver}
  58. Requires: gstreamer-plugins-base >= %{_gstpb_ver}
  59. Requires: gstreamer-plugins-good >= %{_gstpg_ver}
  60. Requires: iso-codes
  61. # for opensubtitles plugin
  62. Requires: pyxdg
  63. # for python plugins
  64. Requires: pygtk2
  65. # for coherence plugins
  66. Requires: python-Coherence >= 0.6.6.2
  67. Obsoletes: nautilus-media
  68. Obsoletes: %{name}-gstreamer < 2.30.1-2
  69. Obsoletes: %{name}-xine < 2.30.1-2
  70. Obsoletes: %{name}-common < 2.30.1-3
  71. Provides: nautilus-media
  72. Provides: %{name}-common = %{version}-%{release}
  73. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  74. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils
  75. Requires(preun): GConf2
  76. %description
  77. Totem is simple movie player for the Gnome desktop. It features a
  78. simple playlist, a full-screen mode, seek and volume controls, as well as
  79. a pretty complete keyboard navigation.
  80. %if %{build_plugin}
  81. %package mozilla
  82. Summary: Totem movie plugin for Mozilla
  83. Summary(ja): Mozilla 用 Totem 動画プラグイン
  84. Group: Applications/Internet
  85. Requires: %{name} = %{version}-%{release}
  86. Obsoletes: %{name}-mozilla-common
  87. Obsoletes: %{name}-mozilla-gstreamer
  88. Obsoletes: %{name}-mozilla-xine
  89. %description mozilla
  90. Totem is simple movie player for the Gnome desktop. It features a
  91. simple playlist, a full-screen mode, seek and volume controls, as well as
  92. a pretty complete keyboard navigation.
  93. This package contains a Totem video plugin for Mozilla. It allows Totem
  94. movie player to be embedded into a web browser.
  95. %endif
  96. %prep
  97. %setup -q
  98. %build
  99. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
  100. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  101. %configure \
  102. --disable-schemas-install \
  103. --disable-scrollkeeper \
  104. --enable-python \
  105. --enable-nautilus \
  106. --enable-gmp-plugin \
  107. --enable-narrowspace-plugin \
  108. --enable-mully-plugin \
  109. %if %{build_plugin}
  110. --enable-browser-plugins
  111. %else
  112. --disable-browser-plugins
  113. %endif
  114. make %{?_smp_mflags}
  115. %install
  116. rm -rf $RPM_BUILD_ROOT
  117. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  118. make install DESTDIR=$RPM_BUILD_ROOT
  119. # remove unneeded files
  120. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  121. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  122. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  123. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  124. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  125. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  126. %find_lang %{name} --with-gnome
  127. # save space by linking identical images in translated docs
  128. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  129. for f in $helpdir/C/figures/*.png; do
  130. b="$(basename $f)"
  131. for d in $helpdir/*; do
  132. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  133. g="$d/figures/$b"
  134. if [ -f "$g" ]; then
  135. if cmp -s $f $g; then
  136. rm "$g"; ln -s "../../C/figures/$b" "$g"
  137. fi
  138. fi
  139. fi
  140. done
  141. done
  142. %clean
  143. %__rm -rf %{buildroot}
  144. %post
  145. %{_bindir}/scrollkeeper-update -q
  146. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  147. export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
  148. gconftool-2 --makefile-install-rule \
  149. %{_sysconfdir}/gconf/schemas/totem.schemas \
  150. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  151. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  152. >& /dev/null || :
  153. touch %{_datadir}/icons/hicolor
  154. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  155. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  156. fi
  157. %pre
  158. if [ "$1" -gt 1 ]; then
  159. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  160. gconftool-2 --makefile-uninstall-rule \
  161. %{_sysconfdir}/gconf/schemas/totem.schemas \
  162. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  163. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  164. >& /dev/null || :
  165. fi
  166. %preun
  167. if [ "$1" -eq 0 ]; then
  168. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  169. gconftool-2 --makefile-uninstall-rule \
  170. %{_sysconfdir}/gconf/schemas/totem.schemas \
  171. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  172. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  173. >& /dev/null || :
  174. fi
  175. %postun
  176. %{_bindir}/scrollkeeper-update -q
  177. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  178. touch %{_datadir}/icons/hicolor
  179. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  180. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  181. fi
  182. %files -f %{name}.lang
  183. %defattr(-,root,root,-)
  184. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  185. %config %{_sysconfdir}/gconf/schemas/*.schemas
  186. %{_bindir}/totem
  187. %{_bindir}/totem-audio-preview
  188. %{_bindir}/totem-video-indexer
  189. %{_bindir}/totem-video-thumbnailer
  190. %{_datadir}/applications/%{name}.desktop
  191. %{_datadir}/icons/*/*/apps/*
  192. %{_datadir}/icons/*/*/devices/*
  193. %{_datadir}/%{name}
  194. %{_datadir}/gtk-doc/html/totem
  195. %dir %{_libdir}/totem
  196. %dir %{_libdir}/totem/plugins
  197. %{_libdir}/totem/plugins/brasero-disc-recorder
  198. %{_libdir}/totem/plugins/coherence_upnp
  199. %{_libdir}/totem/plugins/dbus
  200. %{_libdir}/totem/plugins/gromit
  201. %{_libdir}/totem/plugins/iplayer
  202. %{_libdir}/totem/plugins/jamendo
  203. %{_libdir}/totem/plugins/lirc
  204. %{_libdir}/totem/plugins/media-player-keys
  205. %{_libdir}/totem/plugins/ontop
  206. %{_libdir}/totem/plugins/opensubtitles
  207. %{_libdir}/totem/plugins/properties
  208. %{_libdir}/totem/plugins/pythonconsole
  209. %{_libdir}/totem/plugins/sample-vala
  210. %{_libdir}/totem/plugins/screensaver
  211. %{_libdir}/totem/plugins/screenshot
  212. %{_libdir}/totem/plugins/skipto
  213. %{_libdir}/totem/plugins/thumbnail
  214. %{_libdir}/totem/plugins/youtube
  215. %{_libdir}/totem/plugins/totem
  216. %if %{build_plugin}
  217. %{_libdir}/nautilus/extensions-2.0/*.so*
  218. %endif
  219. %{_libexecdir}/%{name}/totem-bugreport.py
  220. %{_mandir}/man1/*
  221. %if %{build_plugin}
  222. %files mozilla
  223. %defattr(-,root,root,-)
  224. %{mozplug_dir}/*
  225. %{_libexecdir}/totem-plugin-viewer
  226. %endif
  227. %changelog
  228. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  229. - clean up spec file
  230. - remove totem-common and merged to totem main package.
  231. - add Obsoletes: totem-common
  232. - remove unneeded BR: and R:
  233. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  234. - libmusicbrainz, alternatives
  235. - remove explicit dependency
  236. - gtk2, glib2, dbus
  237. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  238. - add R: gstreamer-plugins-good
  239. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  240. - rebuild with libgdata (add youtube plugin)
  241. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  242. - add Obsolete: totem-gstreamer, totem-xine)
  243. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  244. - new upstream release
  245. - chagnge _gst_ver from 0.10.19 to 0.10.29
  246. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  247. - new upstream release
  248. - drop totem-tracker package
  249. - add BuildRequires: unique-devel
  250. - remove BuildRequires: hal-devel
  251. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  252. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  253. - remove unneeded autoreconf
  254. - add BR: lirc
  255. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  256. - new upstream release
  257. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  258. - remove bemused plugin
  259. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  260. - new upstream release
  261. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  262. - added tracker video search sub-package
  263. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  264. - new upstream release
  265. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  266. - new upstream release
  267. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  268. - remove libxine dependency from totem-common
  269. - build xine backend with minimum dependency
  270. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  271. - add BR: bluez-libs-devel >= 4.15
  272. - fix typo in %%postun xine
  273. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  274. - rebuild with bluez-libs-devel-4.15
  275. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  276. - new upstream release
  277. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  278. - new upstream release
  279. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  280. - new upstream release
  281. - add patch1 to build with xulrunner-1.9
  282. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  283. - new upstream release
  284. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  285. - new upstream release
  286. - disabled devel package (replaced by totem-pl-parser-devel)
  287. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  288. - new upstream release
  289. - update version macros
  290. - enable browser plugins on x86_64
  291. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  292. - new upstream release
  293. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  294. - upstream release
  295. - drop obsolete ja.po.patch (patch0)
  296. - revert change of 1.4.4-0vl2
  297. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  298. - upstream release
  299. - enable browser plugins (exclude x86_64 arch)
  300. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  301. - upstream release
  302. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  303. - update configure options
  304. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  305. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  306. - fix mistranslation (patch0)
  307. - add icon symlink
  308. - add BuildRequires: gstreamer-plugins-good
  309. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  310. - upstream release
  311. - update %%_glib_ver, %%_xine_ver
  312. - add BuildRequires: hal
  313. - update %%configure options
  314. - update %%files
  315. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  316. - upstream release
  317. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  318. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  319. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  320. - upstream release
  321. - drop obsolete patch0
  322. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  323. - upstream release
  324. - add patch0 to build with intltool-0.35
  325. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  326. - upstream release
  327. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  328. - upstream release
  329. - update alternatives entry
  330. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  331. - upstream release
  332. - drop fix-sort-function.patch (was merged to upstream, #331426)
  333. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  334. - rebuild with gnome-2.14rc
  335. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  336. - upstream release
  337. - add macros
  338. - _gtk_ver, _glib_ver
  339. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  340. - _dbus_ver
  341. - _gst_ver, gstpb_ver, _xine_ver
  342. - add fix-sort-function.patch to build with glib < 2.9.1
  343. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  344. - upstream release
  345. - add BuildRequires:
  346. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  347. - gnome-vfs2-devel >= 2.9.92
  348. - dbus-devel >= 0.35
  349. - use gstreamer-0.10 as backend for totem-gstreamer
  350. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  351. - use gstreamer08 instead of gstreamer
  352. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  353. - upstream release
  354. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  355. - fix missing links
  356. - update file list
  357. - update update-alternatives scripts
  358. - fix totem-gstreamer's %%postun script
  359. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  360. - upstream release
  361. - add BuildRequires: iso-codes, libmusicbrainz-devel
  362. - add Requires: iso-codes, libmusicbrains to -common package
  363. - remove BuildRequires: nautilus-cd-burner
  364. - remove Requires: nautilus-cd-burner from -common package
  365. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  366. - totem-gstreamer obsoletes nautilus-media
  367. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  368. - upstream release
  369. - add Requires(post,postun): alternatives for gstreamer,xine
  370. - add Requires(postun,triggers): alternatives for common
  371. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  372. - upstream release
  373. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  374. - build xine backend
  375. - move common files to common package
  376. - move GStreamer related files to gstreamer package
  377. - install xine related files to xine package
  378. - fix scripts
  379. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  380. - upstream release
  381. - update URL
  382. - move *.{a,la} to devel package
  383. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  384. - fix %%{post,preun} script (video-thumbnail.schemas)
  385. - sync with Fedora Core's 1.0.1-1
  386. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  387. - Update to upstream version 1.0.1
  388. - Break out devel package
  389. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  390. - add %%{post,pre}un script
  391. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  392. - initial build for Vine Linux
  393. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  394. - fix %%post
  395. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  396. - Obsolete nautilus-media
  397. - Install property page and thumbnailer
  398. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  399. - Update to 0.101
  400. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  401. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  402. missing menu entry (144088)
  403. - Remove workaround for desktop file being misinstalled, fixed
  404. by above patch
  405. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  406. - New upstream version 0.100
  407. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  408. - update to 0.99.22
  409. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  410. - Add patch to remove removed items from package from help
  411. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  412. - New upstream 0.99.19
  413. - Fixes crasher with CD playback (see NEWS)
  414. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  415. - Call update-desktop-database in post
  416. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  417. - update to 0.99.18
  418. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  419. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>