elfutils-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773
  1. %define eu_version 0.161
  2. %define eu_release 1
  3. %global nocheck true
  4. Summary: A collection of utilities and DSOs to handle compiled objects
  5. Summary(ja): コンパイル済みオブジェクトを扱うためのユーティリティ集
  6. Name: elfutils
  7. Version: %{eu_version}
  8. Release: %{eu_release}%{?_dist_release}
  9. License: GPLv3+ and (GPLv2+ or LGPLv3+)
  10. Group: Development/Tools
  11. URL: https://fedorahosted.org/elfutils/
  12. Source: http://fedorahosted.org/releases/e/l/elfutils/%{name}-%{version}.tar.bz2
  13. #Patch1: elfutils-robustify.patch
  14. #Patch2: elfutils-portability.patch
  15. Patch1: elfutils-portability-%{version}.patch
  16. Patch2: elfutils-0.161-ar-long-name.patch
  17. # libdw: fix offset for sig8 lookup in dwarf_formref_die
  18. Patch3: elfutils-0.161-formref-type.patch
  19. # rhbz#1189928 - Consider sh_addralign 0 as 1
  20. Patch4: elfutils-0.161-addralign.patch
  21. ##VINE##
  22. Patch10: elfutils-0.131-readelf_c.patch
  23. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  24. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  26. BuildRequires: bison >= 1.875
  27. BuildRequires: flex >= 2.5.4a
  28. BuildRequires: bzip2
  29. BuildRequires: bzip2-devel
  30. BuildRequires: zlib-devel
  31. BuildRequires: xz-devel
  32. BuildRequires: gettext
  33. BuildRequires: m4
  34. BuildRequires: gcc >= 3.4
  35. # Need <byteswap.h> that gives unsigned bswap_16 etc.
  36. BuildRequires: glibc-headers >= 2.3.4-11
  37. %define _gnu %{nil}
  38. %define _program_prefix eu-
  39. %description
  40. Elfutils is a collection of utilities, including ld (a linker),
  41. nm (for listing symbols from object files), size (for listing the
  42. section sizes of an object or archive file), strip (for discarding
  43. symbols), readelf (to see the raw ELF file structures), and elflint
  44. (to check for well-formed ELF files).
  45. %package libs
  46. Summary: Libraries to handle compiled objects
  47. Summary(ja): コンパイル済オブジェクトを扱うためのライブラリ
  48. License: GPLv2+ or LGPLv3+
  49. Group: System Environment/Libraries
  50. Provides: elfutils-libs-%{_arch} = %{version}-%{release}
  51. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  52. Conflicts: elfutils < %{version}-%{release}
  53. Conflicts: elfutils > %{version}-%{release}
  54. Conflicts: elfutils-devel < %{version}-%{release}
  55. Conflicts: elfutils-devel > %{version}-%{release}
  56. %description libs
  57. The elfutils-libs package contains libraries which implement DWARF, ELF,
  58. and machine-specific ELF handling. These libraries are used by the programs
  59. in the elfutils package. The elfutils-devel package enables building
  60. other programs using these libraries.
  61. %package devel
  62. Summary: Development libraries to handle compiled objects
  63. Summary(ja): コンパイル済オブジェクトを扱うための開発用ライブラリ
  64. License: GPLv2+ or LGPLv3+
  65. Group: Development/Libraries
  66. Provides: elfutils-devel-%{_arch} = %{version}-%{release}
  67. Requires: elfutils-libs-%{_arch} = %{version}-%{release}
  68. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  69. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  70. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  71. %description devel
  72. The elfutils-devel package contains the libraries to create
  73. applications for handling compiled objects. libebl provides some
  74. higher-level ELF access functionality. libdw provides access to
  75. the DWARF debugging information. libasm provides a programmable
  76. assembler interface.
  77. %package devel-static
  78. Summary: Static archives to handle compiled objects
  79. Summary(ja): コンパイル済オブジェクトを扱うための静的ライブラリ
  80. License: GPLv2+ or LGPLv3+
  81. Group: Development/Libraries
  82. Provides: elfutils-devel-static-%{_arch} = %{version}-%{release}
  83. Requires: elfutils-devel-%{_arch} = %{version}-%{release}
  84. Requires: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  85. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  86. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  87. %description devel-static
  88. The elfutils-devel-static package contains the static archives
  89. with the code to handle compiled objects.
  90. %package libelf
  91. Summary: Library to read and write ELF files
  92. Summary(ja): ELF ファイルを読み書きするためのライブラリ
  93. License: GPLv2+ or LGPLv3+
  94. Group: System Environment/Libraries
  95. Provides: libelf = %{version}-%{release}
  96. Obsoletes: libelf <= 0.8.2-2
  97. Provides: elfutils-libelf-%{_arch} = %{version}-%{release}
  98. Conflicts: elfutils < %{version}-%{release}
  99. Conflicts: elfutils > %{version}-%{release}
  100. Conflicts: elfutils-libs < %{version}-%{release}
  101. Conflicts: elfutils-libs > %{version}-%{release}
  102. Conflicts: elfutils-libelf-devel < %{version}-%{release}
  103. Conflicts: elfutils-libelf-devel > %{version}-%{release}
  104. %description libelf
  105. The elfutils-libelf package provides a DSO which allows reading and
  106. writing ELF files on a high level. Third party programs depend on
  107. this package to read internals of ELF files. The programs of the
  108. elfutils package use it also to generate new ELF files.
  109. %package libelf-devel
  110. Summary: Development support for libelf
  111. Summary(ja): libelf の開発用ライブラリ
  112. License: GPLv2+ or LGPLv3+
  113. Group: Development/Libraries
  114. Provides: libelf-devel = %{version}-%{release}
  115. Obsoletes: libelf-devel <= 0.8.2-2
  116. Provides: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  117. Requires: elfutils-libelf-%{_arch} = %{version}-%{release}
  118. Conflicts: libelf-devel < %{version}-%{release}
  119. %description libelf-devel
  120. The elfutils-libelf-devel package contains the libraries to create
  121. applications for handling compiled objects. libelf allows you to
  122. access the internals of the ELF object file format, so you can see the
  123. different sections of an ELF file.
  124. %package libelf-devel-static
  125. Summary: Static archive of libelf
  126. Summary(ja): libelf の静的ライブラリ
  127. License: GPLv2+ or LGPLv3+
  128. Group: Development/Libraries
  129. Provides: elfutils-libelf-devel-static-%{_arch} = %{version}-%{release}
  130. Requires: elfutils-libelf-devel-%{_arch} = %{version}-%{release}
  131. %description libelf-devel-static
  132. The elfutils-libelf-static package contains the static archive
  133. for libelf.
  134. %prep
  135. %setup -q
  136. #patch1 -p1 -b .robustify
  137. %patch1 -p1 -b .portability
  138. %patch2 -p1 -b .ar_long_name
  139. %patch3 -p1 -b .formref_type
  140. %patch4 -p1 -b .addralign
  141. %patch10 -p0 -b .readelf_c
  142. find . -name \*.sh ! -perm -0100 -print | xargs chmod +x
  143. %build
  144. # Remove -Wall from default flags. The makefiles enable enough warnings
  145. # themselves, and they use -Werror. Appending -Wall defeats the cases where
  146. # the makefiles disable some specific warnings for specific code.
  147. RPM_OPT_FLAGS=${RPM_OPT_FLAGS/-Wall/}
  148. %configure CFLAGS="$RPM_OPT_FLAGS -fexceptions"
  149. make -s %{?_smp_mflags}
  150. %install
  151. rm -rf ${RPM_BUILD_ROOT}
  152. make -s install DESTDIR=${RPM_BUILD_ROOT}
  153. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/lib*.so*
  154. chmod +x ${RPM_BUILD_ROOT}%{_prefix}/%{_lib}/elfutils/lib*.so*
  155. %find_lang %{name}
  156. # XXX Nuke unpackaged files
  157. { cd ${RPM_BUILD_ROOT}
  158. rm -f .%{_bindir}/eu-ld
  159. }
  160. %check
  161. make -s %{?_smp_mflags} check || (cat tests/test-suite.log; %{nocheck})
  162. %clean
  163. rm -rf ${RPM_BUILD_ROOT}
  164. %post libs -p /sbin/ldconfig
  165. %postun libs -p /sbin/ldconfig
  166. %post libelf -p /sbin/ldconfig
  167. %postun libelf -p /sbin/ldconfig
  168. %files -f %{name}.lang
  169. %defattr(-,root,root)
  170. %doc README TODO
  171. %{_bindir}/eu-addr2line
  172. %{_bindir}/eu-ar
  173. %{_bindir}/eu-elfcmp
  174. %{_bindir}/eu-elflint
  175. %{_bindir}/eu-findtextrel
  176. %{_bindir}/eu-nm
  177. %{_bindir}/eu-objdump
  178. %{_bindir}/eu-ranlib
  179. %{_bindir}/eu-readelf
  180. %{_bindir}/eu-size
  181. %{_bindir}/eu-stack
  182. %{_bindir}/eu-strings
  183. %{_bindir}/eu-strip
  184. #%{_bindir}/eu-ld
  185. %{_bindir}/eu-unstrip
  186. %{_bindir}/eu-make-debug-archive
  187. %files libs
  188. %defattr(-,root,root)
  189. %{_libdir}/libasm-%{version}.so
  190. %{_libdir}/libasm.so.*
  191. %{_libdir}/libdw-%{version}.so
  192. %{_libdir}/libdw.so.*
  193. %dir %{_libdir}/elfutils
  194. %{_libdir}/elfutils/lib*.so
  195. %files devel
  196. %defattr(-,root,root)
  197. %{_includedir}/dwarf.h
  198. %dir %{_includedir}/elfutils
  199. %{_includedir}/elfutils/elf-knowledge.h
  200. %{_includedir}/elfutils/libasm.h
  201. %{_includedir}/elfutils/libebl.h
  202. %{_includedir}/elfutils/libdw.h
  203. %{_includedir}/elfutils/libdwelf.h
  204. %{_includedir}/elfutils/libdwfl.h
  205. %{_includedir}/elfutils/version.h
  206. %{_libdir}/libebl.a
  207. %{_libdir}/libasm.so
  208. %{_libdir}/libdw.so
  209. %files devel-static
  210. %defattr(-,root,root)
  211. %{_libdir}/libasm.a
  212. %{_libdir}/libdw.a
  213. %files libelf
  214. %defattr(-,root,root)
  215. %{_libdir}/libelf-%{version}.so
  216. %{_libdir}/libelf.so.*
  217. %files libelf-devel
  218. %defattr(-,root,root)
  219. %{_includedir}/libelf.h
  220. %{_includedir}/gelf.h
  221. %{_includedir}/nlist.h
  222. %{_libdir}/libelf.so
  223. %files libelf-devel-static
  224. %defattr(-,root,root)
  225. %{_libdir}/libelf.a
  226. %changelog
  227. * Fri Feb 20 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.161-1
  228. - update to 0.161
  229. - added Japanese summary
  230. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 0.157-1
  231. - update to 0.157
  232. * Wed Apr 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-2
  233. - add BR: zlib-devel, bzip2-devel, xz-devel, m4, gettext
  234. * Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.152-1
  235. - update to 0.152
  236. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.135-2
  237. - elfutils-libs: changed Group to System Environment/Libraries
  238. - elfutils-libelf: changed Group to System Environment/Libraries
  239. - elfutils-devel: changed Group to Development/Libraries
  240. - elfutils-devel-static: changed Group to Development/Libraries
  241. - elfutils-libelf-devel: changed Group to Development/Libraries
  242. - elfutils-libelf-devel-static: changed Group to Development/Libraries
  243. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.135-1
  244. - merged with Fedora 9 0.135-1
  245. - Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.131-1vl5
  246. - applied new versioning policy
  247. - added elfutils-0.131-readelf_c.patch
  248. - Thu Nov 29 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.131-0vl1
  249. - new upstream release
  250. - move libelf/libelf-devel obsoletes tag (<BTS:0568>)
  251. - remove Obsoletes: libelf, libelf-devel from elfutils
  252. - add Obsoletes: libelf to elfutils-libelf
  253. - add Obsoletes: libelf-devel to elfutils-libelf-devel
  254. * Mon May 12 2008 Roland McGrath <roland@redhat.com> - 0.135-1
  255. - Update to 0.135
  256. - libdwfl: bug fixes
  257. - eu-strip: changed handling of ET_REL files wrt symbol tables and relocs
  258. * Wed Apr 9 2008 Roland McGrath <roland@redhat.com> - 0.134-1
  259. - Update to 0.134
  260. - elflint: backend improvements for sparc, alpha (#204170)
  261. - libdwfl, libelf: bug fixes (#439344, #438867, #438263, #438190)
  262. - Remove Conflicts: libelf-devel from elfutils-libelf-devel. (#435742)
  263. * Sun Mar 2 2008 Roland McGrath <roland@redhat.com> - 0.133-2
  264. - Update to 0.133
  265. - readelf, elflint, libebl: SHT_GNU_ATTRIBUTE section handling (readelf -A)
  266. - readelf: core note handling for NT_386_TLS, NT_PPC_SPE, Alpha NT_AUXV
  267. - libdwfl: bug fixes and optimization in relocation handling
  268. - elfcmp: bug fix for non-allocated section handling
  269. - ld: implement newer features of binutils linker.
  270. - Install eu-objdump and libasm, now has limited disassembler support.
  271. * Mon Jan 21 2008 Roland McGrath <roland@redhat.com> - 0.132-3
  272. - Update to 0.132
  273. - libelf: Use loff_t instead of off64_t in libelf.h header. (#377241)
  274. - eu-readelf: Fix handling of ET_REL files in archives.
  275. - libcpu: Implement x86 and x86-64 disassembler.
  276. - libasm: Add interface for disassembler.
  277. - all programs: add debugging of branch prediction.
  278. - libelf: new function elf_scnshndx.
  279. * Sun Nov 11 2007 Roland McGrath <roland@redhat.com> - 0.131-1
  280. - Update to 0.131
  281. - libdw: DW_FORM_ref_addr support; dwarf_formref entry point now deprecated;
  282. bug fixes for oddly-formatted DWARF
  283. - libdwfl: bug fixes in offline archive support, symbol table handling;
  284. apply partial relocations for dwfl_module_address_section on ET_REL
  285. - libebl: powerpc backend support for Altivec registers
  286. * Wed Oct 17 2007 Roland McGrath <roland@redhat.com> - 0.130-3
  287. - Fix ET_REL support.
  288. - Fix odd indentation in eu-readelf -x output.
  289. * Tue Oct 16 2007 Roland McGrath <roland@redhat.com> - 0.130-1
  290. - Update to 0.130
  291. - eu-readelf -p option can take an argument like -x for one section
  292. - eu-readelf --archive-index (or -c)
  293. - eu-readelf -n improved output for core dumps
  294. - eu-readelf: handle SHT_NOTE sections without requiring phdrs (#249467)
  295. - eu-elflint: ditto
  296. - eu-elflint: stricter checks on debug sections
  297. - eu-unstrip: new options, --list (or -n), --relocate (or -R)
  298. - libelf: new function elf_getdata_rawchunk, replaces gelf_rawchunk;
  299. new functions gelf_getnote, gelf_getauxv, gelf_update_auxv
  300. - libebl: backend improvements (#324031)
  301. - libdwfl: build_id support, new functions for it
  302. - libdwfl: dwfl_module_addrsym fixes (#268761, #268981)
  303. - libdwfl offline archive support, new script eu-make-debug-archive
  304. * Mon Aug 20 2007 Roland McGrath <roland@redhat.com> - 0.129-2
  305. - Fix false-positive eu-elflint failure on ppc -mbss-plt binaries.
  306. * Tue Aug 14 2007 Roland McGrath <roland@redhat.com> - 0.129-1
  307. - Update to 0.129
  308. - readelf: new options --hex-dump (or -x), --strings (or -p) (#250973)
  309. - addr2line: new option --symbols (or -S)
  310. - libdw: dwarf_getscopes fixes (#230235)
  311. - libdwfl: dwfl_module_addrsym fixes (#249490)
  312. * Fri Jun 8 2007 Roland McGrath <roland@redhat.com> - 0.128-2
  313. - Update to 0.128
  314. - new program: unstrip
  315. - elfcmp: new option --hash-inexact
  316. - Replace Conflicts: with Provides/Requires using -arch
  317. * Wed Apr 18 2007 Roland McGrath <roland@redhat.com> - 0.127-1
  318. - Update to 0.127
  319. - libdw: new function dwarf_getsrcdirs
  320. - libdwfl: new functions dwfl_module_addrsym, dwfl_report_begin_add,
  321. dwfl_module_address_section
  322. * Mon Feb 5 2007 Roland McGrath <roland@redhat.com> - 0.126-1
  323. - Update to 0.126
  324. - New program eu-ar.
  325. - libdw: fix missing dwarf_getelf (#227206)
  326. - libdwfl: dwfl_module_addrname for st_size=0 symbols (#227167, #227231)
  327. - Resolves: RHBZ #227206, RHBZ #227167, RHBZ #227231
  328. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-3
  329. - Fix overeager warn_unused_result build failures.
  330. * Wed Jan 10 2007 Roland McGrath <roland@redhat.com> - 0.125-1
  331. - Update to 0.125
  332. - elflint: Compare DT_GNU_HASH tests.
  333. - move archives into -static RPMs
  334. - libelf, elflint: better support for core file handling
  335. - Really fix libdwfl sorting of modules with 64-bit addresses (#220817).
  336. - Resolves: RHBZ #220817, RHBZ #213792
  337. * Tue Oct 10 2006 Roland McGrath <roland@redhat.com> - 0.124-1
  338. - eu-strip -f: copy symtab into debuginfo file when relocs use it (#203000)
  339. - Update to 0.124
  340. - libebl: fix ia64 reloc support (#206981)
  341. - libebl: sparc backend support for return value location
  342. - libebl, libdwfl: backend register name support extended with more info
  343. - libelf, libdw: bug fixes for unaligned accesses on machines that care
  344. - readelf, elflint: trivial bugs fixed
  345. * Mon Aug 14 2006 Roland McGrath <roland@redhat.com> 0.123-1
  346. - Update to 0.123
  347. - libebl: Backend build fixes, thanks to Stepan Kasal.
  348. - libebl: ia64 backend support for register names, return value location
  349. - libdwfl: Handle truncated linux kernel module section names.
  350. - libdwfl: Look for linux kernel vmlinux files with .debug suffix.
  351. - elflint: Fix checks to permit --hash-style=gnu format.
  352. * Mon Jul 17 2006 Roland McGrath <roland@redhat.com> - 0.122-4
  353. - Fix warnings in elflint compilation.
  354. * Wed Jul 12 2006 Roland McGrath <roland@redhat.com> - 0.122-3
  355. - Update to 0.122
  356. - Fix libdwfl sorting of modules with 64-bit addresses (#198225).
  357. - libebl: add function to test for relative relocation
  358. - elflint: fix and extend DT_RELCOUNT/DT_RELACOUNT checks
  359. - elflint, readelf: add support for DT_GNU_HASH
  360. - libelf: add elf_gnu_hash
  361. - elflint, readelf: add support for 64-bit SysV-style hash tables
  362. - libdwfl: new functions dwfl_module_getsymtab, dwfl_module_getsym.
  363. * Thu Jun 15 2006 Roland McGrath <roland@redhat.com> - 0.121-1
  364. - Update to 0.121
  365. - libelf: bug fixes for rewriting existing files when using mmap (#187618).
  366. - make all installed headers usable in C++ code (#193153).
  367. - eu-readelf: better output format.
  368. - eu-elflint: fix tests of dynamic section content.
  369. - libdw, libdwfl: handle files without aranges info.
  370. * Thu May 25 2006 Jeremy Katz <katzj@redhat.com> - 0.120-3
  371. - rebuild to pick up -devel deps
  372. * Tue Apr 4 2006 Roland McGrath <roland@redhat.com> - 0.120-2
  373. - Update to 0.120
  374. - License changed to GPL, with some exceptions for using
  375. the libelf, libebl, libdw, and libdwfl library interfaces.
  376. Red Hat elfutils is an included package of the Open Invention Network.
  377. - dwarf.h updated for DWARF 3.0 final specification.
  378. - libelf: Fix corruption in ELF_C_RDWR uses (#187618).
  379. - libdwfl: New function dwfl_version; fixes for offline.
  380. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2.1
  381. - bump again for double-long bug on ppc(64)
  382. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.119-1.2
  383. - rebuilt for new gcc4.1 snapshot and glibc changes
  384. * Fri Jan 13 2006 Roland McGrath <roland@redhat.com> - 0.119-1
  385. - update to 0.119
  386. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  387. - rebuilt
  388. * Sun Nov 27 2005 Roland McGrath <roland@redhat.com> - 0.118-1
  389. - update to 0.118
  390. - elflint: more tests.
  391. - libdwfl: New function dwfl_module_register_names.
  392. - libebl: New backend hook for register names.
  393. - Make sure -fexceptions is always in CFLAGS.
  394. * Tue Nov 22 2005 Roland McGrath <roland@redhat.com> - 0.117-2
  395. - update to 0.117
  396. - libdwfl: New function dwfl_module_return_value_location (#166118)
  397. - libebl: Backend improvements for several CPUs
  398. * Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.116-1
  399. - update to 0.116
  400. - libdw fixes, API changes and additions
  401. - libdwfl fixes (#169672)
  402. - eu-strip/libelf fix to preserve setuid/setgid permission bits (#167745)
  403. * Fri Sep 9 2005 Roland McGrath <roland@redhat.com> - 0.115-3
  404. - Update requires/conflicts for better biarch update behavior.
  405. * Mon Sep 5 2005 Roland McGrath <roland@redhat.com> - 0.115-2
  406. - update to 0.115
  407. - New program eu-strings.
  408. - libdw: New function dwarf_getscopes_die.
  409. - libelf: speed-ups of non-mmap reading.
  410. - Implement --enable-gcov option for configure.
  411. * Wed Aug 24 2005 Roland McGrath <roland@redhat.com> - 0.114-1
  412. - update to 0.114
  413. - new program eu-ranlib
  414. - libdw: new calls for inlines
  415. - libdwfl: new calls for offline modules
  416. * Sat Aug 13 2005 Roland McGrath <roland@redhat.com> - 0.113-2
  417. - update to 0.113
  418. - elflint: relax a bit. Allow version definitions for defined symbols
  419. against DSO versions also for symbols in nobits sections.
  420. Allow .rodata section to have STRINGS and MERGE flag set.
  421. - strip: add some more compatibility with binutils.
  422. - libdwfl: bug fixes.
  423. - Separate libdw et al into elfutils-libs subpackage.
  424. * Sat Aug 6 2005 Roland McGrath <roland@redhat.com> - 0.112-1
  425. - update to 0.112
  426. - elfcmp: some more relaxation.
  427. - elflint: many more tests, especially regarding to symbol versioning.
  428. - libelf: Add elfXX_offscn and gelf_offscn.
  429. - libasm: asm_begin interface changes.
  430. - libebl: Add three new interfaces to directly access machine, class,
  431. and data encoding information.
  432. * Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.111-2
  433. - update portability patch
  434. * Thu Jul 28 2005 Roland McGrath <roland@redhat.com> - 0.111-1
  435. - update to 0.111
  436. - libdwfl library now merged into libdw
  437. * Sun Jul 24 2005 Roland McGrath <roland@redhat.com> - 0.110-1
  438. - update to 0.110
  439. * Fri Jul 22 2005 Roland McGrath <roland@redhat.com> - 0.109-2
  440. - update to 0.109
  441. - verify that libebl modules are from the same build
  442. - new eu-elflint checks on copy relocations
  443. - new program eu-elfcmp
  444. - new experimental libdwfl library
  445. * Thu Jun 9 2005 Roland McGrath <roland@redhat.com> - 0.108-5
  446. - robustification of eu-strip and eu-readelf
  447. * Wed May 25 2005 Roland McGrath <roland@redhat.com> - 0.108-3
  448. - more robustification
  449. * Mon May 16 2005 Roland McGrath <roland@redhat.com> - 0.108-2
  450. - robustification
  451. * Mon May 9 2005 Roland McGrath <roland@redhat.com> - 0.108-1
  452. - update to 0.108
  453. - merge strip fixes
  454. - sort records in dwarf_getsrclines, fix dwarf_getsrc_die searching
  455. - update elf.h from glibc
  456. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-2
  457. - fix strip -f byte-swapping bug
  458. * Sun May 8 2005 Roland McGrath <roland@redhat.com> - 0.107-1
  459. - update to 0.107
  460. - readelf: improve DWARF output format
  461. - elflint: -d option to support checking separate debuginfo files
  462. - strip: fix ET_REL debuginfo files (#156341)
  463. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-3
  464. - fix some bugs in new code, reenable make check
  465. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-2
  466. - disable make check for most arches, for now
  467. * Mon Apr 4 2005 Roland McGrath <roland@redhat.com> - 0.106-1
  468. - update to 0.106
  469. * Mon Mar 28 2005 Roland McGrath <roland@redhat.com> - 0.104-2
  470. - update to 0.104
  471. * Wed Mar 23 2005 Jakub Jelinek <jakub@redhat.com> 0.103-2
  472. - update to 0.103
  473. * Wed Feb 16 2005 Jakub Jelinek <jakub@redhat.com> 0.101-2
  474. - update to 0.101.
  475. - use %%configure macro to get CFLAGS etc. right
  476. * Sat Feb 5 2005 Jeff Johnson <jbj@redhat.com> 0.99-2
  477. - upgrade to 0.99.
  478. * Sun Sep 26 2004 Jeff Johnson <jbj@redhat.com> 0.97-3
  479. - upgrade to 0.97.
  480. * Tue Aug 17 2004 Jakub Jelinek <jakub@redhat.com> 0.95-5
  481. - upgrade to 0.96.
  482. * Mon Jul 5 2004 Jakub Jelinek <jakub@redhat.com> 0.95-4
  483. - rebuilt with GCC 3.4.x, workaround VLA + alloca mixing
  484. warning
  485. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  486. - rebuilt
  487. * Fri Apr 2 2004 Jeff Johnson <jbj@redhat.com> 0.95-2
  488. - upgrade to 0.95.
  489. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  490. - rebuilt
  491. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  492. - rebuilt
  493. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.94-1
  494. - upgrade to 0.94
  495. * Fri Jan 16 2004 Jakub Jelinek <jakub@redhat.com> 0.93-1
  496. - upgrade to 0.93
  497. * Thu Jan 8 2004 Jakub Jelinek <jakub@redhat.com> 0.92-1
  498. - full version
  499. - macroized spec file for GPL or OSL builds
  500. - include only libelf under GPL plus wrapper scripts
  501. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-2
  502. - macroized spec file for GPL or OSL builds
  503. * Wed Jan 7 2004 Ulrich Drepper <drepper@redhat.com>
  504. - split elfutils-devel into two packages.
  505. * Wed Jan 7 2004 Jakub Jelinek <jakub@redhat.com> 0.91-1
  506. - include only libelf under GPL plus wrapper scripts
  507. * Tue Dec 23 2003 Jeff Johnson <jbj@redhat.com> 0.89-3
  508. - readelf, not readline, in %%description (#111214).
  509. * Fri Sep 26 2003 Bill Nottingham <notting@redhat.com> 0.89-1
  510. - update to 0.89 (fix eu-strip)
  511. * Tue Sep 23 2003 Jakub Jelinek <jakub@redhat.com> 0.86-3
  512. - update to 0.86 (fix eu-strip on s390x/alpha)
  513. - libebl is an archive now; remove references to DSO
  514. * Mon Jul 14 2003 Jeff Johnson <jbj@redhat.com> 0.84-3
  515. - upgrade to 0.84 (readelf/elflint improvements, rawhide bugs fixed).
  516. * Fri Jul 11 2003 Jeff Johnson <jbj@redhat.com> 0.83-3
  517. - upgrade to 0.83 (fix invalid ELf handle on *.so strip, more).
  518. * Wed Jul 9 2003 Jeff Johnson <jbj@redhat.com> 0.82-3
  519. - upgrade to 0.82 (strip tests fixed on big-endian).
  520. * Tue Jul 8 2003 Jeff Johnson <jbj@redhat.com> 0.81-3
  521. - upgrade to 0.81 (strip excludes unused symtable entries, test borked).
  522. * Thu Jun 26 2003 Jeff Johnson <jbj@redhat.com> 0.80-3
  523. - upgrade to 0.80 (debugedit changes for kernel in progress).
  524. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  525. - rebuilt
  526. * Wed May 21 2003 Jeff Johnson <jbj@redhat.com> 0.79-2
  527. - upgrade to 0.79 (correct formats for size_t, more of libdw "works").
  528. * Mon May 19 2003 Jeff Johnson <jbj@redhat.com> 0.78-2
  529. - upgrade to 0.78 (libdwarf bugfix, libdw additions).
  530. * Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
  531. - debuginfo rebuild
  532. * Thu Feb 20 2003 Jeff Johnson <jbj@redhat.com> 0.76-2
  533. - use the correct way of identifying the section via the sh_info link.
  534. * Sat Feb 15 2003 Jakub Jelinek <jakub@redhat.com> 0.75-2
  535. - update to 0.75 (eu-strip -g fix)
  536. * Tue Feb 11 2003 Jakub Jelinek <jakub@redhat.com> 0.74-2
  537. - update to 0.74 (fix for writing with some non-dirty sections)
  538. * Thu Feb 6 2003 Jeff Johnson <jbj@redhat.com> 0.73-3
  539. - another -0.73 update (with sparc fixes).
  540. - do "make check" in %%check, not %%install, section.
  541. * Mon Jan 27 2003 Jeff Johnson <jbj@redhat.com> 0.73-2
  542. - update to 0.73 (with s390 fixes).
  543. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  544. - rebuilt
  545. * Wed Jan 22 2003 Jakub Jelinek <jakub@redhat.com> 0.72-4
  546. - fix arguments to gelf_getsymshndx and elf_getshstrndx
  547. - fix other warnings
  548. - reenable checks on s390x
  549. * Sat Jan 11 2003 Karsten Hopp <karsten@redhat.de> 0.72-3
  550. - temporarily disable checks on s390x, until someone has
  551. time to look at it
  552. * Thu Dec 12 2002 Jakub Jelinek <jakub@redhat.com> 0.72-2
  553. - update to 0.72
  554. * Wed Dec 11 2002 Jakub Jelinek <jakub@redhat.com> 0.71-2
  555. - update to 0.71
  556. * Wed Dec 11 2002 Jeff Johnson <jbj@redhat.com> 0.69-4
  557. - update to 0.69.
  558. - add "make check" and segfault avoidance patch.
  559. - elfutils-libelf needs to run ldconfig.
  560. * Tue Dec 10 2002 Jeff Johnson <jbj@redhat.com> 0.68-2
  561. - update to 0.68.
  562. * Fri Dec 6 2002 Jeff Johnson <jbj@redhat.com> 0.67-2
  563. - update to 0.67.
  564. * Tue Dec 3 2002 Jeff Johnson <jbj@redhat.com> 0.65-2
  565. - update to 0.65.
  566. * Mon Dec 2 2002 Jeff Johnson <jbj@redhat.com> 0.64-2
  567. - update to 0.64.
  568. * Sun Dec 1 2002 Ulrich Drepper <drepper@redhat.com> 0.64
  569. - split packages further into elfutils-libelf
  570. * Sat Nov 30 2002 Jeff Johnson <jbj@redhat.com> 0.63-2
  571. - update to 0.63.
  572. * Fri Nov 29 2002 Ulrich Drepper <drepper@redhat.com> 0.62
  573. - Adjust for dropping libtool
  574. * Sun Nov 24 2002 Jeff Johnson <jbj@redhat.com> 0.59-2
  575. - update to 0.59
  576. * Thu Nov 14 2002 Jeff Johnson <jbj@redhat.com> 0.56-2
  577. - update to 0.56
  578. * Thu Nov 7 2002 Jeff Johnson <jbj@redhat.com> 0.54-2
  579. - update to 0.54
  580. * Sun Oct 27 2002 Jeff Johnson <jbj@redhat.com> 0.53-2
  581. - update to 0.53
  582. - drop x86_64 hack, ICE fixed in gcc-3.2-11.
  583. * Sat Oct 26 2002 Jeff Johnson <jbj@redhat.com> 0.52-3
  584. - get beehive to punch a rhpkg generated package.
  585. * Wed Oct 23 2002 Jeff Johnson <jbj@redhat.com> 0.52-2
  586. - build in 8.0.1.
  587. - x86_64: avoid gcc-3.2 ICE on x86_64 for now.
  588. * Tue Oct 22 2002 Ulrich Drepper <drepper@redhat.com> 0.52
  589. - Add libelf-devel to conflicts for elfutils-devel
  590. * Mon Oct 21 2002 Ulrich Drepper <drepper@redhat.com> 0.50
  591. - Split into runtime and devel package
  592. * Fri Oct 18 2002 Ulrich Drepper <drepper@redhat.com> 0.49
  593. - integrate into official sources
  594. * Wed Oct 16 2002 Jeff Johnson <jbj@redhat.com> 0.46-1
  595. - Swaddle.