gprolog-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. Summary: GNU Prolog is a free Prolog compiler with constraint solving over Finite Domains
  2. Summary(ja): GNU Prolog: 有限領域の制約解決に適したフリーな Prolog コンパイラ
  3. Name: gprolog
  4. Version: 1.3.1
  5. Release: 2%{?_dist_release}
  6. License: GPLv2
  7. Group: Development/Languages
  8. URL: http://gprolog.inria.fr/
  9. Source: ftp://ftp.inria.fr/Projects/loco/%{name}/%{name}-%{version}.tar.gz
  10. Buildroot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: sed
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: inagaki
  15. %description
  16. GNU Prolog is a native Prolog compiler with constraint solving over finite
  17. domains (FD) developed by Daniel Diaz (http://loco.inria.fr/~diaz).
  18. GNU Prolog is a very efficient native compiler producing (small) stand-alone
  19. executables. GNU-Prolog also offers a classical top-level+debugger.
  20. GNU Prolog conforms to the ISO standard for Prolog but also includes a lot
  21. of extensions (global variables, DCG, sockets, OS interface,...).
  22. GNU Prolog also includes a powerful constraint solver over finite domains
  23. with many predefined constraints+heuristics.
  24. More information can be found at http://www.gnu.org/software/prolog
  25. or better at http://gprolog.inria.fr.
  26. %description -l ja
  27. GNU Prolog は有限領域 (FD) の制約解決に適したネイティブ Prolog コンパイラで、
  28. Daniel Diaz (http://loco.inria.fr/~diaz) によって開発されました。
  29. GNU Prolog は (小さな) スタンドアロンの実行可能形式を生成する、非常に効率の
  30. 良いネイティブコンパイラです。
  31. GNU Prolog は Prolog の ISO 規格に準拠しているだけでなく、多くの拡張
  32. (グローバル変数、DCG、ソケット、OS インタフェース、……) も含んでいます。
  33. GNU Prolog は多くの定義済の制約条件と発見的手法を用いて、有限領域の問題に
  34. 対して強力な制約解決機能も提供します。
  35. 詳しい情報は http://www.gnu.org/software/prolog や http://gprolog.inria.fr
  36. (こちらの方が良い)で見つけることができます。
  37. %prep
  38. %setup -q
  39. %build
  40. cd src
  41. # gprolog only acccept -O0 and don't like -fomit-frame-pointer
  42. CFLG="$(echo $RPM_OPT_FLAGS | sed -s "s/\-O2/-O1/g" \
  43. | sed -e "s/\-fomit-frame-pointer//")"
  44. # Based on a gentoo ebuild (??)
  45. CFLG="$CFLG -funsigned-char"
  46. ./configure \
  47. --with-install-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version} \
  48. --without-links-dir \
  49. --with-examples-dir=$RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/examples \
  50. --with-doc-dir=dist-doc \
  51. --with-c-flags="$CFLG"
  52. make
  53. %check
  54. cd src
  55. #
  56. export PATH=$RPM_BUILD_ROOT%{_bindir}:$PATH
  57. #
  58. make check
  59. %install
  60. rm -rf $RPM_BUILD_ROOT
  61. rm -rf dist-doc
  62. pushd src
  63. make install-strip
  64. popd
  65. mkdir $RPM_BUILD_ROOT%{_bindir}
  66. pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/bin
  67. for i in *; do
  68. ln -s ../lib/%{name}-%{version}/bin/$i $RPM_BUILD_ROOT%{_bindir}/$i
  69. done
  70. #rm -rf docs_to_install
  71. #mkdir -p docs_to_install
  72. #mv $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/doc/* docs_to_install
  73. #rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}-%{version}/{COPYING,ChangeLog,NEWS,VERSION}
  74. rm -f dist-doc/*.{chm,dvi,ps}
  75. rm -f dist-doc/compil-scheme.pdf
  76. rm -f dist-doc/debug-box.pdf
  77. for file in ChangeLog COPYING NEWS VERSION
  78. do
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/gprolog-%{version}/$file
  80. done
  81. popd
  82. %clean
  83. rm -rf $RPM_BUILD_ROOT
  84. %files
  85. %defattr(-,root,root)
  86. %doc README COPYING ChangeLog NEWS PROBLEMS VERSION
  87. %doc src/dist-doc/*
  88. %{_bindir}/*
  89. %{_libdir}/%{name}-%{version}/bin
  90. %{_libdir}/%{name}-%{version}/examples
  91. %{_libdir}/%{name}-%{version}/include
  92. %{_libdir}/%{name}-%{version}/lib
  93. %changelog
  94. * Sun May 1 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-2
  95. - rebuilt with current VineSeed
  96. - fixed compile option
  97. * Wed Mar 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-1
  98. - updated to 1.3.1
  99. - applied new versioning policy
  100. - spec in UTF-8
  101. * Tue Aug 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl3
  102. - rebuild for VinePlus/3.0 and VineSeedPlus
  103. - updated Japanese Summary and description
  104. - merged VinePlus/2.5 spec file
  105. * Fri Jul 23 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.16-1vl2
  106. - Added Summary(ja) and %%description -l ja.
  107. * Sat Feb 14 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl2
  108. - merged VinePlus spec file
  109. * Thu Feb 12 2004 by IKEDA Katsumi <ikedak@rg8.so-net.ne.jp>
  110. - 1.2.161vl1
  111. - Modified %Vendor, %Buildroot and %build.
  112. - Add %Distribution.
  113. - Remove %Packager and %Prefix.
  114. - added --with-examples-dir to ./configure
  115. - fixed %files section to exclude %{_libdir}/%{name}-%{version}/doc
  116. * Fri Feb 13 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.17-0vl1
  117. - rebuild for Vine Linux
  118. - s/Copyright/License/
  119. - use more rpm macros
  120. * Tue Jul 25 2000 Daniel Diaz <Daniel.Diaz@inria.fr>
  121. - initial specfile