123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334 |
- %global api_ver 0.14
- Summary: A modern programming language for GNOME
- Summary: GNOME 用のモダンなプログラミング言語
- Name: vala
- Version: 0.14.1
- Release: 1%{?_dist_release}
- Group: Development/Languages
- # Most files are LGPLv2.1+, curses.vapi is 2-clause BSD
- License: LGPLv2+ and BSD
- URL: http://live.gnome.org/Vala
- Source0: http://download.gnome.org/sources/vala/0.14/vala-%{version}.tar.xz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: glib2-devel
- BuildRequires: flex
- BuildRequires: bison
- BuildRequires: libxslt
- Vendor: Project Vine
- Distribution: Vine Linux
- %description
- Vala is a new programming language that aims to bring modern programming
- language features to GNOME developers without imposing any additional
- runtime requirements and without using a different ABI compared to
- applications and libraries written in C.
- valac, the Vala compiler, is a self-hosting compiler that translates
- Vala source code into C source and header files. It uses the GObject
- type system to create classes and interfaces declared in the Vala source
- code. It's also planned to generate GIDL files when gobject-
- introspection is ready.
- The syntax of Vala is similar to C#, modified to better fit the GObject
- type system.
- %package devel
- Summary: Development files for %{name}
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: pkgconfig
- %description devel
- Vala is a new programming language that aims to bring modern programming
- language features to GNOME developers without imposing any additional
- runtime requirements and without using a different ABI compared to
- applications and libraries written in C.
- This package contains development files for %{name}. This is not necessary for
- using the %{name} compiler.
- %package tools
- Summary: Tools for creating projects and bindings for %{name}
- Group: Development/Languages
- License: LGPLv2+
- Requires: %{name} = %{version}-%{release}
- Requires: gnome-common intltool libtool
- Provides: %{name}-vapigen = %{version}-%{release}
- Obsoletes: %{name}-vapigen < %{version}-%{release}
- %description tools
- Vala is a new programming language that aims to bring modern programming
- language features to GNOME developers without imposing any additional
- runtime requirements and without using a different ABI compared to
- applications and libraries written in C.
- This package contains tools to generate Vala projects, as well as API bindings
- from existing C libraries, allowing access from Vala programs.
- %package doc
- Summary: Documentation for %{name}
- Group: Documentation
- License: LGPLv2+
- BuildArch: noarch
- Requires: %{name} = %{version}-%{release}
- Requires: devhelp
- Provides: %{name}-docs = %{version}-%{release}
- Obsoletes: %{name}-docs < %{version}-%{release}
- %description doc
- Vala is a new programming language that aims to bring modern programming
- language features to GNOME developers without imposing any additional
- runtime requirements and without using a different ABI compared to
- applications and libraries written in C.
- This package contains documentation in a devhelp HTML book.
- %prep
- %setup -q
- %build
- %configure --enable-vapigen
- # Don't use rpath!
- sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
- sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
- make %{?_smp_mflags}
- # checks currently utilize installed Vala, not the one being compiled
- #%check
- #make check
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR=$RPM_BUILD_ROOT
- rm $RPM_BUILD_ROOT%{_libdir}/libvala-%{api_ver}.la
- %clean
- rm -rf $RPM_BUILD_ROOT
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %files
- %defattr(-,root,root,-)
- %doc AUTHORS ChangeLog COPYING INSTALL MAINTAINERS NEWS README THANKS
- %{_bindir}/vala
- %{_bindir}/valac
- %{_bindir}/vala-%{api_ver}
- %{_bindir}/valac-%{api_ver}
- %{_datadir}/vala-%{api_ver}
- %{_libdir}/libvala-%{api_ver}.so.*
- %{_mandir}/*/valac*
- %files devel
- %defattr(-,root,root,-)
- %{_includedir}/vala-%{api_ver}
- %{_libdir}/libvala-%{api_ver}.so
- %{_libdir}/pkgconfig/libvala-%{api_ver}.pc
- %{_datadir}/aclocal/vala.m4
- %files tools
- %defattr(-,root,root,-)
- %{_bindir}/vala-gen-introspect
- %{_bindir}/vapicheck
- %{_bindir}/vapigen
- %{_bindir}/vala-gen-introspect-%{api_ver}
- %{_bindir}/vapicheck-%{api_ver}
- %{_bindir}/vapigen-%{api_ver}
- %{_libdir}/vala-%{api_ver}
- %{_mandir}/*/*gen*
- %files doc
- %defattr(-,root,root,-)
- %{_datadir}/devhelp/books/vala-%{api_ver}
- %changelog
- * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.1-1
- - new upstream release
- * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.14.0-1
- - new upstream release
- - remove BuildRequires: gtk2-devel, xulrunner-devel
- - add BuildRequires: glib2-devel, libxslt
- * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.12.1-1
- - new upstream release
- - remove BuildRequires: devhelp
- * Mon Jan 3 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.2-1
- - new upstream release
- * Thu Oct 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
- - new upstream release
- * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.10.0-1
- - new upstream release
- * Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 0.9.8-2
- - rebuilt with rpm-4.8.1 for pkg-config
- * Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.8-1
- - new upstream release
- - made -doc subpackage noarch
- * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.7-1
- - new upstream release
- * Wed Aug 11 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.5-1
- - new upstream release
- * Fri Aug 6 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.9.4-1
- - new upstream release
- * Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.8.1-1
- - new upstream release
- * Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.0-1
- - new upstream release
- - change BuildRequires: gecko-libs -> xulrunner-devel
- * Wed Feb 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.10-1
- - new upstream release
- * Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.7.9-1
- - new upstream release
- * Tue Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.7-1
- - new upstream release
- * Mon Oct 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.5-1
- - initial build for Vine Linux
- * Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.5-1
- - Update to 0.7.5
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Tue Jul 14 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-2
- - Patch broken ModuleInit attribute (upstream bug 587444)
- * Tue Jul 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.7.4-1
- - Update to 0.7.4
- * Wed Jun 3 2009 Peter Robinson <pbrobinson@gmail.com> - 0.7.3-1
- - Update to 0.7.3
- * Sat Apr 18 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
- - Update to 0.6.1
- * Mon Feb 23 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.7-1
- - Update to 0.5.7
- * Tue Jan 27 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.6-1
- - Update to 0.5.6
- * Tue Dec 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.3-1
- - Update to 0.5.3
- * Mon Dec 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-3
- - Fix bug in Emacs version detection
- * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-2
- - Use buildsystem variables to determine available Emacs version
- - BR on gecko-devel >= 1.9, since older version is also in RHEL repo
- * Sat Dec 13 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.2-1
- - Update to 0.5.2
- * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
- - Update to 0.5.1
- * Fri Aug 22 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.5-1
- - Update to 0.3.5
- * Tue Jul 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.4-2
- - Add vala-mode for editing Vala code in Emacs
- * Tue Jul 1 2008 Lennart Poettering <lpoetter@redhat.com> - 0.3.4-1
- - Update to 0.3.4
- * Wed Jun 4 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.3-1
- - Update to 0.3.3
- * Fri May 16 2008 Michel Salim <salimma@fedoraproject.org> - 0.3.2-1
- - Update to 0.3.2
- * Thu Apr 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.2.0-1
- - Update to 0.2.0
- * Wed Mar 5 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.7-1
- - Update to 0.1.7
- - -tool subpackage now requires gnome-common, intltool and libtoolize
- for out-of-the-box vala-gen-project support
- * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.1.6-2
- - Autorebuild for GCC 4.3
- * Sat Jan 19 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
- - Update to 0.1.6
- - Revert vapi addition, needed declarations have been inlined (r846)
- - Rename -docs subpackage to -doc, to comply with guidelines
- * Tue Jan 15 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.5-5
- - Manually add Gee vapi file to package (bz #428692)
- * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-4
- - Backport patch to autodetect location of automake shared files
- * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-3
- - Add build dependency on gtk2-devel
- * Tue Dec 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-2
- - Enable project generator tool
- * Tue Nov 27 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.5-1
- - Update to 0.1.5
- * Sun Nov 11 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-2
- - Add build dependency on devhelp
- * Fri Oct 19 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.4-1
- - Update to 0.1.4
- - Put newly-added documentation in its own subpackage (depends on devhelp)
- * Mon Sep 17 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-5
- - vapigen subpackage: add missing Require: on perl-XML-Twig
- * Sat Sep 8 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-4
- - Split -vapigen subpackage. It is functionally self-contained and the license
- is more restricted
- - Updated license declarations
- * Wed Sep 5 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-3
- - Licensing and URL updates
- * Tue Sep 4 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-2
- - Enable binding generation tools
- * Sun Sep 2 2007 Michel Salim <salimma@fedoraproject.org> - 0.1.3-1
- - Update to 0.1.3
- * Sun Mar 25 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.8-1
- - Update to 0.0.8
- * Wed Mar 7 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.7-1
- - Update to 0.0.7
- * Wed Feb 28 2007 Michel Salim <salimma@fedoraproject.org> - 0.0.6-1
- - Update to 0.0.6
- * Mon Nov 6 2006 Michel Salim <salimma@fedoraproject.org> - 0.0.5-1
- - Initial package
|