chromium-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539
  1. # Thanks to malcolmlewis for help with this script
  2. # Thanks to Tom "spot" Callaway for much of the patchwork
  3. # Thanks to jhaygood for most of the icu patch
  4. # norootforbuild
  5. %if %{?_dist_release} == "vl6"
  6. #% define with_system_icu 1
  7. %endif
  8. %define svn_rev 47263
  9. Name: chromium
  10. Summary: Google's opens source browser project
  11. Summary(ja): Googleのオープンソースウェブブラウザ
  12. #'
  13. Version: 6.0.405.0
  14. Release: 1%{?_dist_release}
  15. License: BSD
  16. Group: Applications/Internet
  17. Source0: %{name}.%{version}.svn%{svn_rev}.tar.lzma
  18. ## The following are included for source reasons only
  19. # Custom build tools for chromium, hammer is a fancy front-end for scons
  20. Source1: http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz
  21. %{?nosrc:NoSource: 0}
  22. %{?nosrc:NoSource: 1}
  23. # Script used to create the tar.lzma archive from the daily tarball downloadable at http://build.chromium.org/buildbot/archives/
  24. Source2: repack_chromium_archive.sh
  25. # Script used to create the tar.lzma archive from a checked out source
  26. #Source3: pack_chromium_source.sh
  27. Source3: pack_chromium_source-vine.sh
  28. #Source10: chromium.desktop
  29. Source10: chromium-vine.desktop
  30. # Patch template which adds vendor to user agent
  31. ##!!Source20: chromium-vendor.patch.in
  32. Source20: chromium-vendor-vine.patch.in
  33. ##!!Source30: master_preferences
  34. Source30: master_preferences.vine
  35. #Source31: default_bookmarks.html
  36. #Source31: default_bookmarks.html.vine
  37. # icu-4.2.1 contained in chromium.5.0.353.0.svn41449 (for Vine Linux 5.X)
  38. Source100: icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2
  39. Provides: chromium-browser = %{version}
  40. #Obsoletes: chromium-browser < %{version}
  41. ## Start Patches
  42. # Many changes to the gyp system so we can use system libraries
  43. # My first ever patch set. I hope I did well.
  44. Patch3: chromium-gyp-system-02-icu.patch
  45. Patch4: chromium-no-sqlite-debug.patch
  46. Patch5: chromium-gyp-system-04-nss-nspr.patch
  47. Patch7: chromium-codechanges-nss-nspr.patch
  48. Patch8: chromium-codechanges-zlib.patch
  49. #Patch9: chromium-drop-sse.patch
  50. Patch10: chromium-fix-wrapper.patch
  51. Patch12: chromium-no-test-sources.patch
  52. Patch13: chromium-no-courgette.patch
  53. Patch14: chromium-master-prefs-path.patch
  54. #Patch15: chromium-media-probe.patch
  55. Patch16: chromium-icu-code-changes.patch
  56. Patch17: chromium-system-glew.patch
  57. Patch18: chromium-system-expat.patch
  58. Patch19: chromium-system-zlib.patch
  59. Patch20: chromium-noffmpeg.patch
  60. Patch21: chromium-system-old-ffmpeg-way.patch
  61. Patch23: chromium-disable-mmx.patch
  62. Patch24: chromium-fix-yuv_row_posix-shared.patch
  63. Patch25: tcmalloc-factory.patch
  64. # Vine
  65. #Patch40: chromium-5.0.353-no-ffmpeg-vine.patch
  66. ## Gentoo patches
  67. # Allow use of MP3/MPEG-4 audio/video tags with our system ffmpeg
  68. #Patch50: http://sources.gentoo.org/viewcvs.py/*checkout*/gentoo-x86/www-client/chromium/files/chromium-20100122-ubuntu-html5-video-mimetypes.patch
  69. BuildRequires: gcc gcc-c++
  70. %if %{?_dist_release} == "vl5"
  71. BuildRequires: libstdc++34 libstdc++34-devel
  72. %elseif %{?_dist_release} == "vl6"
  73. BuildRequires: libstdc++ libstdc++-devel
  74. %endif
  75. BuildRequires: libevent
  76. ##!!BuildRequires: pkg-config
  77. BuildRequires: python
  78. ##!!BuildRequires: python-xml
  79. BuildRequires: python-pyxml
  80. BuildRequires: perl bison flex gperf
  81. ##!!BuildRequires: wdiff
  82. ##!!BuildRequires: update-desktop-files
  83. BuildRequires: desktop-file-utils
  84. BuildRequires: lzma
  85. ##!!BuildRequires: mozilla-nss-devel
  86. BuildRequires: nss-devel
  87. ##!!BuildRequires: alsa-devel
  88. BuildRequires: alsa-lib-devel
  89. BuildRequires: gtk2-devel
  90. BuildRequires: glib2-devel
  91. BuildRequires: cairo-devel >= 1.6
  92. ##!!BuildRequires: mozilla-nspr-devel
  93. BuildRequires: nspr-devel
  94. ##!!BuildRequires: gconf2-devel
  95. BuildRequires: GConf2-devel
  96. BuildRequires: freetype2-devel
  97. ##!!BuildRequires: dbus-1-devel
  98. BuildRequires: dbus-devel
  99. BuildRequires: libxslt-devel
  100. BuildRequires: libxml2-devel
  101. BuildRequires: libjpeg-devel
  102. BuildRequires: zlib-devel
  103. BuildRequires: libpng-devel
  104. ##!!BuildRequires: libbz2-devel
  105. BuildRequires: bzip2-devel
  106. %if %{?_dist_release} == "vl6"
  107. BuildRequires: fdupes
  108. %endif
  109. ##!!BuildRequires: libexpat-devel
  110. BuildRequires: expat-devel
  111. BuildRequires: glew-devel
  112. ##!!BuildRequires: Mesa-devel
  113. BuildRequires: mesa-libGLU-devel
  114. %{?with_system_icu:BuildRequires: libicu-devel >= 4.0}
  115. BuildRequires: libevent-devel
  116. ##Vine Linux
  117. BuildRequires: libXScrnSaver-devel
  118. #BuildRequires: gle-devel
  119. #BuildRequires: webkit-gtk-devel
  120. #BuildRequires: scons
  121. %ifarch x86_64
  122. Requires: nspluginwrapper
  123. %endif
  124. ##!!Requires: alsa
  125. Requires: alsa-lib
  126. # shouldn't be required to name all dependencies
  127. # Requires: mozilla-nss mozilla-nspr gtk2 glib2 cairo >= 1.6 freetype2 dbus-1 alsa v8 >= 1.3.15
  128. ## Recommends the ffmpeg libraries (available from packman)
  129. #Recommends: libavcodec52 libavformat52 libavutil50
  130. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  131. %description
  132. Chromium is the open-source project behind Google Chrome.
  133. We invite you to join us in our effort to help build a safer, faster,
  134. and more stable way for all Internet users to experience the web,
  135. and to create a powerful platform for developing a new generation of
  136. web applications.
  137. %description -l ja
  138. Chromium は Google Chrome の後方にあるオープンソースプロジェクトです。
  139. 私たちは、ウェブを体験しているすべてのインターネットユーザに対して
  140. より安全で、より速くて、より安定した方法を築き上げるのを助けるために、
  141. ウェブアプリケーションの新しい世代を発展させるように
  142. 強力なプラットホームを作成するために、
  143. 私たちの取り組みで私たちに加わるようにあなたを誘います。
  144. %prep
  145. [ -d %{name} ] && %__rm -rf %{name}
  146. lzma -cd %{SOURCE0} | tar xf -
  147. %setup -D -T -n %{name}
  148. # use static libicu
  149. #%if %{?_dist_release} == "vl5"
  150. cd src/third_party || exit 1
  151. %__rm -rf icu || exit 1
  152. tar jxvf %{SOURCE100} || exit 1
  153. %__mv icu-4.2.1-chromium.5.0.353.0.svn41449 icu || exit 1
  154. cd - || exit 1
  155. #%endif
  156. # use system libicu only if >= 4.0
  157. %{?with_system_icu:%patch3 -p1}
  158. %patch4 -p1
  159. %patch5 -p1
  160. %patch7 -p1
  161. %patch8 -p1
  162. #%patch9 -p1
  163. %patch10 -p1
  164. #%patch11 -p1
  165. %patch12 -p1
  166. %patch13 -p1
  167. %patch14 -p1
  168. #%patch15 -p0
  169. %{?with_system_icu:%patch16 -p1}
  170. %patch17 -p1
  171. %patch18 -p1
  172. %patch19 -p1
  173. %patch20 -p1
  174. %patch21 -p1
  175. #%patch22 -p1
  176. %patch25 -p1
  177. %ifarch %ix86
  178. %patch23 -p1
  179. %endif
  180. %patch24 -p1
  181. # apply vendor patch after substitution
  182. %__sed "s:RPM_VERSION:%{version}-%{release}:" %{SOURCE20} | patch -p0
  183. %build
  184. ## create make files
  185. PARSED_OPT_FLAGS=`echo \'$RPM_OPT_FLAGS -DUSE_SYSTEM_LIBEVENT -fPIC -fno-strict-aliasing \' | %__sed "s/ /',/g" | %__sed "s/',/', '/g"`
  186. for i in src/build/common.gypi; do
  187. %__sed -i "s|'-march=pentium4',||g" $i
  188. %__sed -i "s|'-msse2',||g" $i
  189. %__sed -i "s|'-mfpmath=sse',||g" $i
  190. %__sed -i "s|'-O<(debug_optimize)',||g" $i
  191. %__sed -i "s|'-m32',||g" $i
  192. %__sed -i "s|'-fno-exceptions',|$PARSED_OPT_FLAGS|g" $i
  193. %__sed -i "s|'-Werror'|'-Wno-error'|g" $i
  194. done
  195. # '
  196. pushd src
  197. ./build/gyp_chromium -f make build/all.gyp \
  198. -Duse_system_ffmpeg=1 \
  199. -Duse_system_zlib=1 \
  200. -Duse_system_libpng=1 \
  201. -Duse_system_bzip2=1 \
  202. -Duse_system_libjpeg=1 \
  203. -Duse_system_libxml=1 \
  204. -Duse_system_libxslt=1 \
  205. -Duse_system_libevent=1 \
  206. -Dproprietary_codes=1 \
  207. -Dlinux_fpic=1 \
  208. %{?with_system_icu:-Duse_system_icu=1} \
  209. %{!?with_system_icu:-Duse_system_icu=0} \
  210. %ifarch %{ix86}
  211. -Dtarget_arch=ia32 \
  212. -Ddisable_sse2=1 \
  213. %endif
  214. %ifarch x86_64
  215. -Dtarget_arch=x64 \
  216. %endif
  217. %if %{?_dist_release} == "vl6"
  218. -Dno_strict_aliasing=1 -Dgcc_version=44 \
  219. %endif
  220. -Drelease_extra_cflags=-fPIC \
  221. ;
  222. #make -r %{?jobs:-j%jobs} chrome BUILDTYPE=Release
  223. #%__make -r -j5 chrome BUILDTYPE=Release
  224. %__make %{?_smp_mflags} chrome BUILDTYPE=Release
  225. popd
  226. %install
  227. %{__rm} -rf %{buildroot}
  228. ## Create install directories
  229. %{__mkdir_p} %{buildroot}%{_libdir}/%{name}
  230. %{__mkdir_p} %{buildroot}%{_bindir}
  231. %{__mkdir_p} %{buildroot}%{_datadir}/applications
  232. %{__mkdir_p} %{buildroot}%{_datadir}/pixmaps
  233. %{__mkdir_p} %{buildroot}%{_mandir}/man1
  234. %{__mkdir_p} %{buildroot}%{_sysconfdir}/%{name}
  235. # chromium 'make' deposits us back at the top level build directory
  236. pushd src/out/Release
  237. ls -l
  238. # clean somechromium-codechanges-zlib.patch
  239. # clean debug junk
  240. %{__rm} -rf obj/ mksnapshot obj.target obj.host
  241. find ./ -type f -name '*.d' | while read i; do %__rm -f $i; done
  242. # clean NaCl stuff... maybe NaCl will be in its own package in the future.
  243. %{__rm} -f ncdecode_table ncdecode_tablegen
  244. # clean other temporary binaries used in the compilation of chromium
  245. %{__rm} -f protoc xdg-settings
  246. %{__cp} -rf * %{buildroot}%{_libdir}/%{name}/
  247. # Man page
  248. [ ! -f %{name}.1 ] && %{__mv} chrome.1 %{name}.1
  249. %__install -m 0644 %{name}.1 %{buildroot}%{_mandir}/man1
  250. # Add startup file with plugins enabled
  251. %{__cat} > %{buildroot}%{_bindir}/%{name} <<EOF
  252. #!/bin/bash
  253. %{_libdir}/%{name}/chrome-wrapper --enable-plugins --enable-user-scripts --enable-extensions --enable-sync --enable-geolocation --enable-webgl "\$@"
  254. EOF
  255. # # link to browser plugin path. Plugin patch doesn't work. Why?
  256. # %{__mkdir_p} %{buildroot}%{_libdir}/browser-plugins
  257. # pushd %{buildroot}%{_libdir}/%{name}
  258. # %{__ln_s} %{_libdir}/browser-plugins plugins
  259. # popd
  260. pushd %{buildroot}%{_libdir}/%{name}
  261. %ifarch x86_64
  262. %{__ln_s} %{_libdir}/mozilla/plugins-wrapped plugins
  263. %else
  264. %{__ln_s} %{_libdir}/mozilla/plugins plugins
  265. %endif
  266. #touch %{buildroot}%{_libdir}/libavcodec.so.52
  267. #%{__ln_s} %{_libdir}/libavcodec.so.52 libavcodec.so.52
  268. #touch %{buildroot}%{_libdir}/libavformat.so.52
  269. #%{__ln_s} %{_libdir}/libavformat.so.52 libavformat.so.52
  270. #touch %{buildroot}%{_libdir}/libavutil.so.50
  271. #%{__ln_s} %{_libdir}/libavutil.so.50 libavutil.so.50
  272. popd
  273. # Install desktop-related files
  274. %__install -m 0644 %{SOURCE10} %{buildroot}%{_datadir}/applications/%{name}.desktop
  275. %__install -m 0644 product_logo_48.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
  276. desktop-file-install --vendor Vine \
  277. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  278. --delete-original \
  279. --mode 644 \
  280. $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
  281. # Install the master_preferences file
  282. #%__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}
  283. %__install -m 0644 %{SOURCE30} %{buildroot}%{_sysconfdir}/%{name}/$(basename %{SOURCE30} .vine)
  284. ## install o3d plugin
  285. #pushd src/o3d/build/out/Release
  286. #%{__cp} -rf * %{buildroot}%{_libdir}/browser-plugins
  287. %clean
  288. %{__rm} -rf %{buildroot}
  289. %files
  290. %defattr(-,root,root)
  291. %doc src/AUTHORS src/LICENSE
  292. %dir %{_libdir}/%{name}
  293. %attr(0755,root,root) %{_bindir}/%{name}
  294. %{_mandir}/man1/*
  295. %{_datadir}/applications/*%{name}.desktop
  296. %{_datadir}/pixmaps/%{name}.png
  297. %{_libdir}/%{name}/*
  298. %config %{_sysconfdir}/%{name}
  299. #%{_libdir}/browser-plugins/*
  300. #%exclude %{_libdir}/libavcodec.so.52
  301. #%exclude %{_libdir}/libavutil.so.50
  302. #%exclude %{_libdir}/libavformat.so.52
  303. %changelog
  304. * Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 6.0.405.0-1
  305. - updated to snapshot 6.0.405.0 r47263
  306. * Fri Apr 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-2
  307. - unused with_system_icu (for vl6)
  308. - used icu-4.2.1-chromium.5.0.353.0.svn41449 (for vl6)
  309. * Wed Apr 14 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.378.0-1
  310. - updated to snapshot 5.0.378.0 r44472
  311. - used with_system_icu (for vl6)
  312. - added icu-4.2.1-chromium.5.0.353.0.svn41449.tar.bz2 (for vl5)
  313. * Sat Apr 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.372.0-1
  314. - updated to snapshot 5.0.372.0 r43947
  315. - added BuildRequires: glew-devel
  316. - changed Group tag to Applications/Internet
  317. - added Summary(ja) and %%description -l ja
  318. * Mon Apr 05 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.365.0-1
  319. - updated to snapshot 5.0.365.0 r42966
  320. - merged 5.0.353.0-4vl5
  321. * Fri Apr 2 2010 IWAI, Masaharu <iwai@alib.jp> 5.0.353.0-4vl5
  322. - build on Vine Linux 5.1
  323. - add BuildRequires: libstdc++34 libstdc++34-devel for Vine5
  324. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.364.0-1
  325. - updated to snapshot 5.0.364.0 r42779
  326. * Sun Mar 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.359.0-1
  327. - updated to snapshot 5.0.359.0 r42116
  328. - dropped chromium-20100122-ubuntu-html5-video-mimetypes.patch
  329. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-4
  330. - fixed master_preferences.vine, little
  331. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-3
  332. - fixed to install master_preferences
  333. - dropped chromium-5.0.353-no-ffmpeg-vine.patch
  334. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-2
  335. - applied chromium-5.0.353-no-ffmpeg-vine.patch
  336. * Tue Mar 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.353.0-1
  337. - updated to snapshot 5.0.353.0 r41449
  338. * Wed Mar 10 2010 bgmerrell@novell.com
  339. - Add master_preferences source file and install it to /etc/chromium.
  340. - Create a new patch (chromium-master-prefs-path.patch) which tells
  341. chromium to look in /etc/chromium for the master_preferences file
  342. (instead of looking in the default directory, which is the same
  343. directory as the 'chrome' binary).
  344. * Sun Feb 21 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.335.0-1
  345. - updated to snapshot 5.0.335.0 r39556
  346. * Sat Feb 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-2
  347. - applied chromium-20100122-ubuntu-html5-video-mimetypes.patch from Gentoo
  348. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.330.0-1
  349. - updated to snapshot 5.0.330.0 r39074
  350. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-5
  351. - use_system_ffmpeg
  352. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-4
  353. - added Requires: nspluginwrapper
  354. - fixed a symbolic link of plugins directory with nspluginwrapper
  355. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-3
  356. - replaced %%{SOUECE20} to chromium-vendor-vine.patch.in
  357. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-2
  358. - added BuildRequires: mesa-libGLU-devel
  359. - added BuildRequires: libstdc++34 libstdc++34-devel for vl5
  360. * Tue Feb 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 5.0.329.0-1
  361. - built based on chromium-5.0.329.0-167.1.src.rpm of OpenSuse
  362. * Sun Nov 29 2009 - tittiatcoke@gmail.com - 4.0.260.0
  363. - Update to 4.0.260
  364. * Fri Nov 27 2009 - tittiatcoke@gmail.com - 4.0.259.0
  365. - Update to 4.0.259
  366. * Thu Nov 26 2009 - tittiatcoke@gmail.com - 4.0.258.0
  367. - Update to 4.0.258
  368. * Tue Nov 24 2009 - tittatcoke@gmai.com - 4.0.257.0
  369. - In order to complete prevent the wrong v8 version to be used, the Chromium build has been
  370. changed to having an built-in v8
  371. * Tue Nov 24 2009 - dbuck@example.com - 4.0.257.0
  372. - Re-base patches. Fixed a few patch errors. Rename some patches to better correspond with function. Removed some patches.
  373. - Minor SPEC changes. I changed the v8 requirement to be exact, instead of greater than a specific version.
  374. * Sat Oct 24 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.223.5
  375. - don't create desktop files in wrapper, fix LD_LIBRARY_PATH (chromium-fix-wrapper.patch)
  376. * Tue Oct 20 2009 - Raymond Wooninck >tittiatcoke@gmail.com> - 4.0.223.5
  377. - update to newer svn snapshot
  378. + Obsoletes fwrite patch (included upstream)
  379. * Fri Oct 16 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.223.2
  380. - update to newer svn snapshot
  381. + Requires newer version of v8
  382. * Thu Oct 15 2009 - Pavol Rusnak <prusnak@suse.cz> - 4.0.222.6
  383. - do not force SSE on x86 (drop-sse.patch)
  384. * Tue Oct 13 2009 - Raymond Wooninck <tittiatcoke@gmail.com> - 4.0.222.6
  385. - Update to newer svn snapshot
  386. - Fixed spec file in order to build
  387. - Included patch to build with system zlib
  388. * Mon Oct 12 2009 - Pavol Rusnak <prusnak@suse.cz> 4.0.222.2
  389. - package renamed to chromium
  390. - cleaned up spec file
  391. * Tue Oct 6 2009 - dbuck <dbuck@example.com> - 4.0.222.2
  392. - v8 is now built as a separate package, and is required
  393. - included many patches to use system libraries: v8, icu, libxml2, libxslt, libjpeg, libpng, libevent, bzip2, zlib, nspr, nss
  394. * Sun Oct 1 2009 - dbuck <dbuck@example.com> - 4.0.221.1
  395. - included a newer DEP than is in svn, native_client@823. So things should compile cleanly now
  396. * Sun Aug 31 2009 - dbuck <dbuck@example.com> - 4.0.204.0
  397. - initial build
  398. #% changelog
  399. * Sun Jan 24 2010 prusnak@suse.cz
  400. - added vendor to user agent (chromium-vendor.patch.in)
  401. * Sun Nov 29 2009 prusnak@suse.cz
  402. - added --enable-sync to wrapper to enable bookmark sync
  403. * Fri Nov 13 2009 tittiatcoke@gmail.com
  404. - update to 247.0 svn 31928
  405. * Fri Oct 30 2009 tittiatcoke@gmail.com
  406. - update to 229.0 svn 30454
  407. + Fix regression where popups and app frames lost their titlebars.
  408. + Makes it so that when a folder is open on the bookmark bar
  409. and the mouse moves over another folder, the menu for that
  410. folder is shown.
  411. + Lazily create the find bar.
  412. + Polish to the gmail checker sample.
  413. * New, crisper icons that are exactly 19x19
  414. * Add a loading animation at the beginning before Gmail
  415. responds.
  416. * Fix a bug where we sometimes don't update the UI after a
  417. logout/login cycle.
  418. + Refactor widget methods to support desktop notifications,
  419. including GTK stubs.
  420. + Find-in-page should not ding while deleting characters.
  421. + Add SSL wrapper for linux and mac. This allows notifier to
  422. use chrome's SSL layer instead of OpenSSL.
  423. + Add three of the six extensions to PAC that Internet Explorer supports.
  424. + WebSocket support in chromium. (Run with --enable-web-sockets
  425. enables WebSocket features.)
  426. + Do not allow GTK File Chooser dialogs to return directories.
  427. + Fix the notifier SSL layer to make notifications work for
  428. Linux Bookmark sync.
  429. + linux: don't override mouse selection behavior in omnibox
  430. * Sun Oct 25 2009 tittiatcoke@gmail.com
  431. - Update to 224.4 svn 30027
  432. + First cut at new page and browser action docs based
  433. on new API. Deleted old stuff.
  434. + Add suppression for new memory leak caused by WebKit merge 49830:49844
  435. + Cleanup: change PIDs to base::ProcessId (or pid_t, as appropriate)
  436. + Minimize dependency of user scripts
  437. + Fixup the flip_framer eof-handling semantics now that we have
  438. the FIN bit in place
  439. + app depends on x11 because of active_window_watcher_x
  440. + Adding two images for the new Extension managment UI
  441. + Removing hard-coded Chrome Frame output path
  442. + Rearrange clipboard code
  443. + Fix crash bug when attempting to download a url with unsupported scheme,
  444. e.g. 'data:', by 'Alt + Click'
  445. + GTK: Change text for extension download UI
  446. + Ignore invalid urls on command line
  447. + Make dropped tabs animate from where they were dropped.
  448. + Make room for the full width of the tab placeholder.
  449. + Make tab dragging as smooth as glass.
  450. + Remove an annoying NOTIMPLEMNETED
  451. + Extensions: guarantee removal of BROWSER_WINDOW_READY registration
  452. + If we're in the middle of a drag, don't allow the user to middle
  453. click to close or right click for the context menu
  454. + "Fix" a NOTIMPLEMENTED on Linux by using the default password store
  455. + Remove +x bit from files that shouldn't have it
  456. + Fold first 3 channels of multichannel instead of 5. Use fixed point
  457. + Adding new image needed for the managment UI
  458. + Fix a race bug where content scripts would not apply to the first page load
  459. + Make escape remove a bookmark if it's just been added (but not if it already existed)
  460. + Fix bubbles deactivating the opaque frame
  461. + Allow ESC to cancel ALT+SHIFT+T in Toolbar
  462. + ake all pepper plugins default to windowless and transparent
  463. + Add styles for printing
  464. + Implement the new extension management UI
  465. + Add support for to automation interface load install and load extensions
  466. + GTK: theme the info bar border
  467. + Update V8 to version 1.3.16.1
  468. + Introduce WebSecurityPolicy for security related methods
  469. + New button scheme...borders are separate from the inner contents so
  470. that they can be highlighted / depressed independently
  471. + When opening Chrome maximized with an application window already
  472. running, the Chrome window was not activated
  473. + Fix compatibility problems with FileZilla FTP Server
  474. + Remove the extension shelf on Linux
  475. + Fix the proxy host and port string to start with http:// if it does not already
  476. + Enable HTML5 databases for all extension renderer processes