telnet-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326
  1. %define telnet_version 0.17
  2. Summary: The client program for the telnet remote login protocol.
  3. Summary(ja): リモートログインプロトコル telnet のクライアントプログラム
  4. Name: telnet
  5. Version: %{telnet_version}.x
  6. Release: 33%{?_dist_release}
  7. License: BSD
  8. Group: Applications/Internet
  9. URL: http://web.archive.org/web/20070819111735/www.hcs.harvard.edu/~dholland/computers/old-netkit.html
  10. Source0: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-%{telnet_version}.tar.gz
  11. Source2: telnet-client.tar.gz
  12. Source3: telnet-xinetd
  13. Source4: telnet.wmconfig
  14. Patch1: telnet-client-cvs.patch
  15. Patch5: telnetd-0.17.diff
  16. Patch6: telnet-0.17-env.patch
  17. Patch7: telnet-0.17-issue.patch
  18. Patch8: telnet-0.17-sa-01-49.patch
  19. Patch9: telnet-0.17-env-5x.patch
  20. Patch10: telnet-0.17-pek.patch
  21. Patch11: telnet-0.17-8bit.patch
  22. Patch12: telnet-0.17-argv.patch
  23. Patch13: telnet-0.17-conf.patch
  24. Patch14: telnet-0.17-cleanup_race.patch
  25. Patch15: telnetd-0.17-pty_read.patch
  26. Patch16: telnet-0.17-CAN-2005-468_469.patch
  27. Patch18: telnet-gethostbyname.patch
  28. Patch19: netkit-telnet-0.17-ipv6.diff
  29. Patch20: netkit-telnet-0.17-nodns.patch
  30. Patch21: telnet-0.17-errno_test_sys_bsd.patch
  31. Patch22: netkit-telnet-0.17-reallynodns.patch
  32. Buildroot: %{_tmppath}/%{name}-%{version}-root
  33. BuildRequires: ncurses-devel
  34. %description
  35. Telnet is a popular protocol for logging into remote systems over the
  36. Internet. The telnet package provides a command line telnet client.
  37. Install the telnet package if you want to telnet to remote machines.
  38. This version has support for IPv6.
  39. %description -l ja
  40. Telnet はインターネット越しにリモートシステムへログインするための非常に
  41. ポピュラーなプロトコルです。telnet パッケージは telnet のコマンドライン
  42. クライアントを提供しています。
  43. リモートマシンへ telnet したい場合は telnet パッケージをインストールして
  44. ください。
  45. このバージョンは IPv6 をサポートしています。
  46. %package server
  47. Summary: The server program for the telnet remote login protocol.
  48. Summary(ja): リモートログインプロトコル telnet サーバトプログラム
  49. Requires: xinetd
  50. Group: System Environment/Daemons
  51. %description server
  52. Telnet is a popular protocol for logging into remote systems over the
  53. Internet. The telnet-server package a telnet daemon, which will
  54. support remote logins into the host machine. The telnet daemon is
  55. enabled by default. You may disable the telnet daemon by editing
  56. /etc/xinet.d/telnet
  57. Install the telnet-server package if you want to support remote logins
  58. to your own machine.
  59. %description -l ja server
  60. Telnet はインターネット越しにリモートシステムへログインするための非常に
  61. ポピュラーなプロトコルです。telnet-server パッケージにはホストマシンにリ
  62. モートログインの機能を提供する telnet デーモンが含まれています。
  63. xinetd または inetd の設定を編集することで telnet デーモンを停止すること
  64. ができます。
  65. あなたのマシンに外部から telnet でリモートログインできるようにするために
  66. は telnet-server パッケージをインストールしてください。
  67. %prep
  68. %setup -q -n netkit-telnet-%{telnet_version}
  69. mv telnet telnet-NETKIT
  70. %setup -T -D -q -a 2 -n netkit-telnet-%{telnet_version}
  71. %patch1 -p0 -b .cvs
  72. %patch5 -p0 -b .fix
  73. %patch6 -p1 -b .env
  74. %patch10 -p0 -b .pek
  75. %patch7 -p1 -b .issue
  76. %patch8 -p1 -b .sa-01-49
  77. %patch11 -p1 -b .8bit
  78. %patch12 -p1 -b .argv
  79. %patch13 -p1 -b .confverb
  80. %patch14 -p1 -b .cleanup_race
  81. %patch15 -p0 -b .pty_read
  82. %patch16 -p1 -b .CAN-2005-468_469
  83. #%patch17 -p1 -b .linemode
  84. %patch18 -p1 -b .gethost
  85. %patch19 -p1 -b .gethost2
  86. %patch20 -p1 -b .nodns
  87. %patch21 -p1 -b .errnosysbsd
  88. %patch22 -p1 -b .reallynodns
  89. %build
  90. sh configure --with-c-compiler=gcc
  91. perl -pi -e '
  92. s,^CC=.*$,CC=cc,;
  93. s,-O2,\$(RPM_OPT_FLAGS),;
  94. s,^BINDIR=.*$,BINDIR=%{_bindir},;
  95. s,^MANDIR=.*$,MANDIR=%{_mandir},;
  96. s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
  97. ' MCONFIG
  98. make
  99. %install
  100. rm -rf ${RPM_BUILD_ROOT}
  101. mkdir -p ${RPM_BUILD_ROOT}%{_bindir}
  102. mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
  103. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
  104. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man5
  105. mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  106. make INSTALLROOT=${RPM_BUILD_ROOT} install
  107. mkdir -p ${RPM_BUILD_ROOT}/etc/xinetd.d
  108. install -m644 %SOURCE3 ${RPM_BUILD_ROOT}/etc/xinetd.d/telnet
  109. %clean
  110. rm -rf ${RPM_BUILD_ROOT}
  111. %files
  112. %defattr(-,root,root)
  113. %doc README
  114. %{_bindir}/telnet
  115. %{_mandir}/man1/telnet.1*
  116. %{!?b5x:%files server}
  117. %defattr(-,root,root)
  118. %config(noreplace) /etc/xinetd.d/telnet
  119. %{_sbindir}/in.telnetd
  120. %{_mandir}/man5/issue.net.5*
  121. %{_mandir}/man8/in.telnetd.8*
  122. %{_mandir}/man8/telnetd.8*
  123. %changelog
  124. * Sat Jul 05 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.17.x-33
  125. - rebuilt current environment
  126. * Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.x-32
  127. - rebuilt with current VineSeed
  128. - used BuildRequires instead of BuildPrereq
  129. - added Patch 14, 15, 18-22 from Fedora
  130. * Wed Sep 02 2009 Adam Tkac <atkac redhat com> 1:0.17-45
  131. - add new option -N to disable DNS lookups (#490242)
  132. * Tue Sep 25 2007 Adam Tkac <atkac redhat com> 1:0.17-41
  133. - rebased "nodns" patch with patch from Bryn M. Reeves
  134. * Fri Jul 14 2006 Harald Hoyer <harald@redhat.com> - 1:0.17-37
  135. - added netkit-telnet-0.17-ipv6.diff from Marek Grác,
  136. which adds IPv6 support to telnetd
  137. * Mon May 08 2006 Harald Hoyer <harald@redhat.com> - 1:0.17-36
  138. - patch to remove gethostbyname() (bug #190296)
  139. * Fri Jan 21 2005 Harald Hoyer <harald@redhat.com> - 1:0.17-33
  140. - added patch telnetd-0.17-pty_read.patch, which fixes 145636
  141. * Thu Jan 13 2005 Jason Vas Dias <jvdias@redhat.com> - 1:0.17-31
  142. - bug 143929 / 145004 : fix race condition in telnetd on wtmp lock
  143. - when cleanup() is entered from main process and in signal
  144. - handler
  145. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-31
  146. - Requires: xinetd instead of inetd
  147. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 0.17.x-30vl5
  148. - applied new versioning policy, spec in utf-8
  149. * Thu Jul 06 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17.x-30vl2
  150. - rebuilt for VineSeed
  151. * Fri Apr 01 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.17.x-30vl1.1
  152. - added a security patch for CAN-2005-0468 and CAN-2005-0469 from Fedora.
  153. * Sat Oct 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.x-30vl1
  154. - import patches from Fedora package
  155. - add Japanese summaries and desctiptions.
  156. - add xinetd config files.
  157. - remove old applnk files.
  158. * Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.6x-23vl1
  159. - merged with redhat package (patch10 for errata)
  160. * Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
  161. - 0.17.6x-18vl1: from RedHat updates
  162. * Tue Jul 31 2001 Harald Hoyer <harald@redhat.de>
  163. - fixed security issues (#50335)
  164. - patched the patches to fit the 5x version
  165. - one world -> one spec file for all versions ;)
  166. * Sat Jul 21 2001 Tim Powers <timp@redhat.com>
  167. - no applnk file, it's clutrtering the menus
  168. * Wed Jul 17 2001 Bill Nottingham <notting@redhat.com>
  169. - apply the patch, duh (and fix it while we're here)
  170. * Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
  171. - make /etc/issue.net parsing match the various gettys
  172. * Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
  173. - merged Jakubs and Pekka's patches
  174. * Wed Apr 4 2001 Jakub Jelinek <jakub@redhat.com>
  175. - don't let configure to guess compiler, it can pick up egcs
  176. * Fri Mar 9 2001 Pekka Savola <pekkas@netcore.fi>
  177. - update to 0.17
  178. - apply latest changes from CVS to telnet client, enable IPv6
  179. - BuildPreReq ncurses-devel
  180. * Mon Jan 22 2001 Helge Deller <hdeller@redhat.com>
  181. - added swedish & german translation to .desktop-file (#15332)
  182. * Sat Dec 30 2000 Nalin Dahyabhai <nalin@redhat.com>
  183. - mark the xinetd config file as config(noreplace)
  184. * Fri Dec 01 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  185. - make sure the server is turned off by default
  186. * Tue Jul 18 2000 Bill Nottingham <notting@redhat.com>
  187. - add description & default to xinetd file
  188. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  189. - automatic rebuild
  190. * Mon Jun 19 2000 Jeff Johnson <jbj@redhat.com>
  191. - FHS packaging.
  192. - update to 0.17-pre20000412.
  193. * Tue May 23 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  194. - moved the xinet entry to the server
  195. * Mon May 22 2000 Trond Eivind Glomsr藷?<teg@redhat.com>
  196. - add an entry to /etc/xinetd.d
  197. * Tue May 16 2000 Jeff Johnson <jbj@redhat.com>
  198. - permit telnet queries only for exported variables.
  199. * Fri Mar 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  200. - 0.17
  201. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  202. - rebuild for sparc baud rates > 38400.
  203. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  204. - fix description
  205. * Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
  206. - wmconfig gone
  207. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  208. - man pages are compressed
  209. - fix description
  210. * Tue Jan 4 2000 Bill Nottingham <notting@redhat.com>
  211. - split client and server
  212. * Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
  213. - update to 0.16.
  214. * Sun Oct 10 1999 Matt Wilson <msw@redhat.com>
  215. - corrected the Terminal setting of the .desktop (needs to be 'true' not '1')
  216. * Sat Sep 24 1999 Preston Brown <pbrown@redhat.com>
  217. - red hat .desktop entry
  218. * Sat Aug 21 1999 Jeff Johnson <jbj@redhat.com>
  219. - rebuild for 6.1.
  220. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  221. - don't trust random TERM variables in telnetd (#4560)
  222. * Wed Jun 2 1999 Jeff Johnson <jbj@redhat.com>
  223. - fix (#3098).
  224. * Thu May 27 1999 Antti Andreimann <Antti.Andreimann@mail.ee>
  225. - fixed the problem with escape character (it could not be disabled)
  226. - changed the spec file to use %setup macro for unpacking telnet-client
  227. * Thu Apr 15 1999 Jeff Johnson <jbj@redhat.com>
  228. - use glibc utmp routines.
  229. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  230. - fix the fix (wrong way memcpy).
  231. * Wed Apr 7 1999 Jeff Johnson <jbj@redhat.com>
  232. - fix "telnet localhost" bus error on sparc64 (alpha?).
  233. * Tue Apr 6 1999 Jeff Johnson <jbj@redhat.com>
  234. - use OpenBSD telnet client (and fix minor core dump with .telnetrc #247)
  235. * Thu Mar 25 1999 Erik Troan <ewt@redhat.com>
  236. - use openpty in telnetd
  237. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  238. - auto rebuild in the new build environment (release 22)
  239. * Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
  240. - compile for 6.0.
  241. * Fri Apr 24 1998 Prospector System <bugs@redhat.com>
  242. - translations modified for de, fr, tr
  243. * Fri Apr 24 1998 Cristian Gafton <gafton@redhat.com>
  244. - compile C++ code using egcs
  245. * Tue Apr 14 1998 Erik Troan <ewt@redhat.com>
  246. - built against new ncurses
  247. * Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
  248. - added wmconfig entry
  249. * Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
  250. - initial build