cdparanoia-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: cdparanoia
  3. Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
  4. Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
  5. Version: 10.2
  6. Release: 5%{?_dist_release}
  7. Group: system,multimedia
  8. License: GPLv2 and LGPLv2
  9. URL: http://www.xiph.org/paranoia/index.html
  10. Source: http://www.xiph.org/paranoia/download/%{name}-III-%{version}.src.tgz
  11. # Patch from upstream to fix cdda_interface.h C++ incompatibility ("private")
  12. # https://trac.xiph.org/changeset/15338
  13. # https://bugzilla.redhat.com/show_bug.cgi?id=463009
  14. Patch0: cdparanoia-10.2-#463009.patch
  15. # #466659
  16. Patch1: cdparanoia-10.2-endian.patch
  17. Patch2: cdparanoia-10.2-install.patch
  18. Patch3: cdparanoia-10.2-format-security.patch
  19. Patch4: cdparanoia-use-proper-gnu-config-files.patch
  20. Patch5: cdparanoia-10.2-ldflags.patch
  21. # https://svn.xiph.org/trunk/cdparanoia@17289
  22. Patch6: cdparanoia-10.2-add-pkgconfig.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. %description
  25. Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
  26. writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
  27. PCM format. Cdparanoia doesn't contain any extra features (like the ones
  28. included in the cdda2wav sampling utility). Instead, cdparanoia's strength
  29. lies in its ability to handle a variety of hardware, including inexpensive
  30. drives prone to misalignment, frame jitter and loss of streaming during
  31. atomic reads. Cdparanoia is also good at reading and repairing data from
  32. damaged CDs.
  33. %package devel
  34. Summary: Development tools for libcdda_paranoia (Paranoia III).
  35. Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
  36. Group: programming
  37. License: LGPLv2
  38. Requires: %{name} = %{version}-%{release}
  39. %description devel
  40. The cdparanoia-devel package contains the static libraries and header
  41. files needed for developing applications to read CD Digital Audio disks.
  42. # compat32
  43. %package -n compat32-%{name}
  44. Summary: A Compact Disc Digital Audio (CDDA) extraction tool (or ripper).
  45. Summary(ja): 音楽 CD (CDDA) 用の抽出ツール
  46. Group: system,legacy
  47. Requires: %{name} = %{version}-%{release}
  48. %description -n compat32-%{name}
  49. Cdparanoia (Paranoia III) reads digital audio directly from a CD, then
  50. writes the data to a file or pipe in WAV, AIFC or raw 16 bit linear
  51. PCM format. Cdparanoia doesn't contain any extra features (like the ones
  52. included in the cdda2wav sampling utility). Instead, cdparanoia's strength
  53. lies in its ability to handle a variety of hardware, including inexpensive
  54. drives prone to misalignment, frame jitter and loss of streaming during
  55. atomic reads. Cdparanoia is also good at reading and repairing data from
  56. damaged CDs.
  57. %package -n compat32-%{name}-devel
  58. Summary: Development tools for libcdda_paranoia (Paranoia III).
  59. Summary(ja): libcdda_paranoia (Paranoia III) の開発用ファイル
  60. Group: programming,legacy
  61. Requires: compat32-%{name} = %{version}-%{release}
  62. Requires: %{name}-devel = %{version}-%{release}
  63. %description -n compat32-%{name}-devel
  64. The cdparanoia-devel package contains the static libraries and header
  65. files needed for developing applications to read CD Digital Audio disks.
  66. %debug_package
  67. %prep
  68. %setup -q -n %{name}-III-%{version}
  69. %patch0 -p3 -b .#463009
  70. %patch1 -p1 -b .endian
  71. %patch2 -p1 -b .install
  72. %patch3 -p1 -b .fmt-sec
  73. %patch4 -p1 -b .config
  74. %patch5 -p1 -b .ldflags
  75. %patch6 -p1 -b .pkgconfig
  76. %build
  77. autoreconf -ifv
  78. %configure --includedir=%{_includedir}/cdda
  79. # Using -O0 is mandatory, the build fails otherwise...
  80. # Also remove many warnings which we are aware of
  81. # Lastly, don't use _smp_mflags since it also makes the build fail
  82. make OPT="$RPM_OPT_FLAGS -Wno-pointer-sign -Wno-unused" LDFLAGS="%{?__global_ldflags}"
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make install DESTDIR=$RPM_BUILD_ROOT
  86. mkdir -p %{buildroot}%{_mandir}/ja/man1
  87. install -m644 cdparanoia.1.jp %{buildroot}%{_mandir}/ja/man1/cdparanoia.1
  88. %clean
  89. [ "$RPM_BUILD_ROOT" != "/" -a -d "$RPM_BUILD_ROOT" ] && rm -rf "$RPM_BUILD_ROOT"
  90. %files
  91. %defattr(-,root,root)
  92. %doc README COPYING-GPL COPYING-LGPL
  93. %{_bindir}/*
  94. %{_libdir}/lib*.so.*
  95. %{_mandir}/man1/*
  96. %{_mandir}/ja/man1/*
  97. %files devel
  98. %defattr(-,root,root)
  99. %{_includedir}/cdda
  100. %{_libdir}/lib*.so
  101. %{_libdir}/*.a
  102. %{_libdir}/pkgconfig/cdparanoia-3.pc
  103. # compat32
  104. %if %{build_compat32}
  105. %files -n compat32-%{name}
  106. %defattr(-, root, root)
  107. %{_libdir}/*.so.*
  108. %files -n compat32-%{name}-devel
  109. %defattr(-, root, root)
  110. %{_libdir}/*.so
  111. %endif
  112. %changelog
  113. * Fri Apr 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-5
  114. - rebuilt with current environment.
  115. - dropped ldconfig scriptlets.
  116. - imported Patch4-6 from rawhide.
  117. * Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.2-4
  118. - imported Patch1-3 from rawhide.
  119. * Wed Jan 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 10.2-3
  120. - create compat32 sub packages
  121. * Sun Apr 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-2
  122. - rebuilt with new toolchain
  123. - added Japanese summary
  124. * Sun Aug 9 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 10.2-1
  125. - new upstream release
  126. - added Requires: cdparanoia to devel package
  127. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> alpha9.8-9vl5
  128. - applied new versioning policy
  129. * Tue Jul 3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> alpha9.8-8vl6
  130. - add Patch1
  131. * Tue Oct 17 2006 NAKAMURA Kenta <kenta@vinelinux.org> alpha9.8-8vl5
  132. - added fPIC.patch fix a problem on x86_64 archtecture
  133. * Fri Dec 26 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> alpha9.8-8vl4
  134. - rebuild with new toolchain
  135. * Sun Mar 16 2003 IWAI Masaharu <iwai@alib.jp> alpha9.8-8vl3
  136. - rebuild with new toolchain
  137. * Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  138. - alpha9.8-8vl2
  139. - rebuild on VineSeed
  140. * Tue Apr 24 2001 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  141. - alpha9.8-8vl1
  142. - included japanese manual
  143. * Tue Feb 27 2001 Karsten Hopp <karsten@redhat.de>
  144. - fix spelling error in description
  145. * Thu Dec 7 2000 Crutcher Dunnavant <crutcher@redhat.com>
  146. - rebuild for new tree
  147. * Fri Jul 21 2000 Trond Eivind Glomsrød <teg@redhat.com>
  148. - use %%{_tmppath}
  149. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  150. - automatic rebuild
  151. * Tue Jun 06 2000 Preston Brown <pbrown@redhat.com>
  152. - revert name change
  153. - use new rpm macro paths
  154. * Wed Apr 19 2000 Trond Eivind Glomsrød <teg@redhat.com>
  155. - Switched spec file from the one used in Red Hat Linux 6.2, which
  156. also changes the name
  157. - gzip man page
  158. * Thu Dec 23 1999 Peter Jones <pjones@redhat.com>
  159. - update package to provide cdparanoia-alpha9.7-2.*.rpm and
  160. cdparanoia-devel-alpha9.7-2.*.rpm. Also, URLs point at xiph.org
  161. like they should.
  162. * Wed Dec 22 1999 Peter Jones <pjones@redhat.com>
  163. - updated package for alpha9.7, based on input from:
  164. Monty <xiphmont@xiph.org>
  165. David Philippi <david@torangan.saar.de>
  166. * Mon Apr 12 1999 Michael Maher <mike@redhat.com>
  167. - updated pacakge
  168. * Tue Oct 06 1998 Michael Maher <mike@redhat.com>
  169. - updated package
  170. * Mon Jun 29 1998 Michael Maher <mike@redhat.com>
  171. - built package