baloo-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147
  1. Name: baloo
  2. Summary: The file indexing and file search framework for KDE.
  3. Summary(ja): ファイルのインデックス作成及び検索のフレームワーク
  4. Version: 4.14.3
  5. Release: 2%{?_dist_release}
  6. License: GPLv2
  7. Group: System Environment/Libraries
  8. URL: https://community.kde.org/Baloo
  9. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/%{name}-%{version}.tar.xz
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: kdelibs-devel
  12. BuildRequires: kdepimlibs-devel
  13. BuildRequires: qjson-devel
  14. BuildRequires: kfilemetadata-devel
  15. BuildRequires: xapian-core-devel
  16. BuildRequires: akonadi-devel
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: Takemikaduchi
  20. %description
  21. Baloo is the file indexing and file search framework for KDE.
  22. Baloo focuses on providing a very small memory footprint along with
  23. with extremely fast searching. It internally uses a mixture of sqlite
  24. along with Xapian to store the file index.
  25. %package libs
  26. Summary: %{name} runtime libraries
  27. Summary(ja): %{name} のラインタイムライブラリ
  28. Group: System Environment/Libraries
  29. Requires: kdelibs >= %{version}
  30. %description libs
  31. %{summary}.
  32. %package devel
  33. Summary: Development files for kdepim
  34. Summary(ja): %{name} の開発用ファイル
  35. Group: Development/Libraries
  36. Requires: %{name}-libs = %{version}-%{release}
  37. Requires: kdelibs-devel
  38. %description devel
  39. Development files for %{name}.
  40. Install %{name}-devel if you want to write or compile %{name} plugins.
  41. %package akonadi
  42. Summary: Akonadi runtime support for %{name}
  43. Summary(ja): %{name} の Akonadi サポート
  44. Group: System Environment/Libraries
  45. Requires: %{name} = %{version}-%{release}
  46. Requires: akonadi
  47. %description akonadi
  48. %{summary}.
  49. %prep
  50. %setup -q
  51. %build
  52. mkdir -p %{_target_platform}
  53. pushd %{_target_platform}
  54. %cmake \
  55. -DCMAKE_BUILD_TYPE=release \
  56. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  57. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  58. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  59. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  60. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  61. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  62. -DKDEPIM_BUILD_MOBILE:BOOL=OFF \
  63. ..
  64. popd
  65. make %{?_smp_mflags} -C %{_target_platform}
  66. %install
  67. rm -rf $RPM_BUILD_ROOT
  68. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  69. %post
  70. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  71. %posttrans
  72. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  73. %postun
  74. if [ $1 -eq 0 ] ; then
  75. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  76. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  77. fi
  78. %post libs -p /sbin/ldconfig
  79. %postun libs -p /sbin/ldconfig
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %files
  83. %defattr(-,root,root,-)
  84. %doc COPYING COPYING.LIB
  85. %config %{_sysconfdir}/dbus-1/system.d/org.kde.baloo.filewatch.conf
  86. %{_bindir}/baloo_file
  87. %{_bindir}/baloo_file_cleaner
  88. %{_bindir}/baloo_file_extractor
  89. %{_bindir}/balooctl
  90. %{_bindir}/baloosearch
  91. %{_bindir}/balooshow
  92. %{_libdir}/kde4/*.so
  93. %{_libexecdir}/kde4/kde_baloo_filewatch_raiselimit
  94. %{_datadir}/autostart/baloo_file.desktop
  95. %{_datadir}/dbus-1/interfaces/org.kde.baloo.file.indexer.xml
  96. %{_datadir}/dbus-1/system-services/org.kde.baloo.filewatch.service
  97. %{_datadir}/icons/hicolor/*/*/*
  98. %{_datadir}/kde4/services/*
  99. %{_datadir}/kde4/servicetypes/*
  100. %{_datadir}/polkit-1/actions/*.policy
  101. %files libs
  102. %defattr(-,root,root,-)
  103. %{_libdir}/lib*.so.*
  104. %files devel
  105. %defattr(-,root,root,-)
  106. %{_includedir}/kde4/%{name}
  107. %{_libdir}/lib*.so
  108. %{_libdir}/cmake/Baloo/*.cmake
  109. %files akonadi
  110. %defattr(-,root,root,-)
  111. %{_bindir}/akonadi_baloo_indexer
  112. %{_libdir}/kde4/akonadi/akonadi_baloo_searchplugin.so
  113. %{_libdir}/kde4/akonadi/akonadibaloosearchplugin.desktop
  114. %{_datadir}/akonadi/agents/akonadibalooindexingagent.desktop
  115. %changelog
  116. * Mon Jul 04 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-2
  117. - rebuild with gcc-5.4.0
  118. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.14.3-1
  119. - initial build